KE-Hilfe

Friedrich-Loeffler Institut
Bundesforschungsinstitut für Tiergesundheit
Institut für Epidemiologie
Südufer 10, 17493 Greifswald, Insel Riems

Was ist neu?

Karten-Explorer
ist ein intuitives Werkzeug zum Visualisieren und Analysieren von Vektor- und Rasterkarten.

Er wurde ursprünglich als eine Komponente des Tierseuchennachrichten-Systems (TSN) entwickelt und ist seit 2003 als separate Applikation verfügbar. Die Version 2.2 (2022) bietet zahlreiche Verbesserungen.

Die nicht kommerzielle Nutzung dieser Software ist ohne Entrichtung von Lizenzgebühren möglich. Bitte beachten Sie, dass der Einsatz auf eigene Gefahr erfolgt und somit die Haftung für Schäden, die durch Einsatz dieser Software entstehen, durch das FLI ausgeschlossen ist.

© FLI Stand 06.07.2022


Benutzung der Hilfe

Das vorliegende Hilfe- und Dokumentationssystem basiert auf einem Hypertext-System (HTML) und verwendet die Technologie eines Web-Browsers für das Internet.

Aufbau des Hilfefensters

Das HTML-Hilfe-System verwendet ein dreigeteiltes Fenster mit

Schalterbereich (Symbolleiste)
Navigationsbereich (linker Fensterbereich)
Inhaltsbereich (rechter Fensterbereich)

Der Navigationsbereich kann bei Bedarf ein- und ausgeblendet werden. Das Größenverhältnis zwischen Navigations- und Inhaltsbereich kann jederzeit verändert werden, indem der Trennbalken zwischen Inhalts- und Navigationsbereich bei gedrückter linker Maustaste verschoben wird. Alle Stati (Größe, Position etc.) werden beim Schließen des Hilfefensters gespeichert und beim erneuten Öffnen wiederhergestellt.

Schalterbereich (Symbolleiste)

Ausblenden der Navigationsleiste | Blendet den Navigationsbereich (linken Fensterbereich) aus
Einblenden der Navigationsleiste | Blendet den Navigationsbereich ein
Seite zurück | Blättert zurück zu vorher angezeigten Seiten
Seite vorwärts | Blättert vorwärts
Gehe zur Startseite | Aufruf der Startseite des Hilfesystems
Drucken | Ausdruck der im Inhaltsbereich angezeigten Seite
Optionen | Abbrechen: Laden einer (Internet-)Seite abbrechen Aktualisieren: (Internet-)Seite neu laden Internetoptionen: Aufruf des Windows-Systemdialogs zur Einstellung der systemweiten Internetoptionen Suchbegriffhervorhebung de-/aktivieren [image] Registerkarte Suchen
 | ruft die Internet-Seite des Karten-Explorers auf [image] Karten-Explorer-Webseite
 | Aktiviert eine Info mit Kontakt- und Supportinformationen

Navigationsbereich

Der Navigationsbereich umfasst vier Registerkarten zur Navigation und Informationssuche.

Registerkarte Inhalt

... zeigt das Inhaltsverzeichnis des Hilfesystems an. Bei geöffneter Registerkarte "Inhalt" werden Inhaltsverzeichnis und Inhaltsbereich automatisch synchronisiert. Die Überschriften repräsentieren i.d.R. selbst ein Hilfethema.

Mit der rechten Maustaste kann ein Menü aktiviert werden, das das Öffnen und Schließen aller Überschriftenkapitel ("Alle öffnen" bzw. "Alle schließen") und den Druck des markierten Überschriftthemas ("Drucken") und dem fortgeschrittenen Anwender die direkte Anwahl beliebiger URL ("Zu URL springen") ermöglicht.

Registerkarte Suchen

... erlaubt die Volltextsuche über alle in der Hilfedatei vorhandenen Seiten. Das zu suchende Schlüsselwort ist anzugeben und mit der Eingabetaste oder der Schaltfläche "Themenliste" zu bestätigen. Im Anschluss wird bei erfolgreicher Suche eine Liste der gefundenen Themen angezeigt, die durch Mausdoppelklick auf das Thema im Inhaltsbereich angezeigt werden.

Die Hervorhebung des Suchbegriffes (der Suchbegriffe) kann über das Menü "Optionen" mit dem Menüpunkt "Suchbegriffhervorhebung (de)aktivieren" ein- bzw. ausgeschaltet werden.

Erweiterte Suchfunktionen

Registerkarte Favoriten

... gestattet es, eine jederzeit editierbare Auswahlliste bevorzugter Hilfeseiten anzulegen, die den schnellen Zugriff auf diese Favoriten durch Mausdoppelklick auf den entsprechende Eintrag in der Themenliste ermöglicht.

Favoriten verwalten

Inhaltsbereich

Im Inhaltsbereich ist durch Betätigen der rechten Maustaste ein Kontextmenü verfügbar, welches folgende Möglichkeiten bietet:

Menüpunkt | Erklärung
Zurück | blättert zurück zu vorher angezeigten Seiten
Vorwärts | blättert vorwärts
Alles auswählen | markiert den gesamten Seiteninhalt Markierter Text kann durch erneutes Drücken der rechten Maustaste in die Windows-Zwischenablage kopiert oder gedruckt werden
Quelle anzeigen | zeigt den Seitenquelltext (HTML-Code)
Drucken | druckt die aktuelle Seite
Aktualisieren | liest den Inhalt der angezeigten Seite neu ein (dies ist ggf. für Seiten aus dem Internet erforderlich)

Erweiterte Suchfunktionen

Bei der Angabe von Schlüsselbegriffen im Eingabefeld "Zu suchendes Schlüsselwort" auf der Registerkarte "Suchen" können logische Verknüpfungen benutzt werden, um die Treffermenge gezielt einzuschränken.

Ver- knüpfung | Beispiel | Erklärung
and | Alpha and Beta | ...alle Seiten, die sowohl Alpha als auch Beta enthalten
or | Alpha or Beta | ...alle Seiten, die Alpha oder Beta (oder beides) enthalten
not | Alpha not Beta | ... alle Seite, die Alpha und nicht Beta enthalten
near | Alpha near Beta | ... alle Seiten, auf denen Alpha und Beta nahe beieinander vorkommen

Favoriten verwalten

Favoriten anzeigen

  • Mausdoppelklick auf gewünschtes Thema oder
  • Thema mit rechte Maustaste markieren und Menüpunkt "Anzeigen" wählen oder
  • Thema markieren und Schaltfläche "Anzeigen" betätigen

Favoriten hinzufügen

  • Der Titel des aktuell im Inhaltsbereich angezeigten Themas wird auf der Registerkarte "Favoriten" im Eingabefeld "Aktuelles Thema" angezeigt (der Titel kann bei Bedarf umbenannt werden). Durch Betätigen der Schaltfläche "Hinzufügen" wird das Thema in die Liste der Favoriten aufgenommen.

  • Alternativ kann der Titel des aktuellen Themas durch Betätigen der rechten Maustaste Menüpunkt "Hinzufügen" in die Favoritenliste aufgenommen werden

Favoriten entfernen

  • Thema mit rechte Maustaste markieren und Menüpunkt "Löschen" wählen oder
  • Thema markieren und Schaltfläche "Entfernen" betätigen

Favoriten umbenennen

  • einfacher Mausklick auf bereits gewähltes Thema oder
  • Thema mit rechte Maustaste markieren und Menüpunkt "Umbenennen" wählen


Kurzvorstellung

Aufbau

Das Fenster des Karten-Explorers gliedert sich in einen Kartenbereich auf der rechten Fensterseite und einen Kontrollbereich auf der linken Fensterseite, der die Layer-Kontrolle, den Maßstab und das Übersichtsfenster enthält.
Die [image] Layer-Kontrolle ist das zentrale Element zur Verwaltung aller geladenen Karten (Layer). Die Sichtbarkeit, Einfärbung und Darstellungsreihenfolge der Layer wird über sie gesteuert.

Die [image] Maßstabsanzeige zeigt für den aktuellen Kartenausschnitt (Karteneinheiten wahlweise Meter oder Grad) den exakten Maßstab an. Per Mausdoppelklick auf die Maßstabsanzeige kann ein gewünschter Maßstab manuell eingegeben werden.
Die Übersichtskarte erlaubt es, einen beliebigen Layer in vollständiger Größe in einem gesonderten Fenster anzuzeigen. Diese korrespondiert mit den geladenen Karten im Karten-Element. Ein rotes Rechteck in der Übersichtskarte zeigt an, welcher Bereich im Karten-Element sichtbar ist. Zudem ist das Zoomen und Scrollen im Übersichtsfenster möglich.
Im Karten-Element werden alle Layer (Karten) entsprechend ihrer Spezifikation (Einfärbung, Reihenfolge, Sichtbarkeit) in der Layer-Kontrolle angezeigt. Es kann beliebig gezoomt und gescrollt werden. Geo-Objekte können per Maus identifiziert werden usw.

Einfärben

Vektordaten (Shape-Dateien) können auf vielfältige Weise eingefärbt werden. Der Dialog zum [image] Einfärben kann am einfachsten über einen Mausdoppelklick auf den gewünschten Layer in der Layer-Kontrolle aktiviert werden.
Folgende Optionen stehen zur Verfügung:

  1. einfaches Symbol
    alle Geo-Objekte werden einheitlich eingefärbt (einheitliche Farbe, Größe, Stil).

  2. Klassen
    Geo-Objekte werden in Abhängigkeit eines numerischen Merkmals abgestuft eingefärbt, Klassenbereiche können automatisch oder manuell festgelegt werden.

  3. Einzelwert
    Geo-Objekte werden in Abhängigkeit eines diskreten Wertes (Einzelwertes) eines Merkmals eingefärbt (z.B. braun für Wert "Ackerland", grün für Wert "Wald" usw.).

  4. Punkthäufigkeiten
    Flächen werden mit Punkthäufigkeiten in Abhängigkeit eines zu wählenden numerischen Merkmals eingefärbt. Diese Option ist nur für Polygone (nicht für Linien und Punkte) möglich.
  5. Beschriftung
    Geo-Objekte werden mit den Werten eines wählbaren Merkmals beschriftet.

Suchen und Identifizieren

Die mit den Geo-Objekten von Vektordaten (Polygone, Linien, Punkte, Multipoint) assoziierten Attribute eines Layers können angezeigt oder gesucht werden.

  1. Info-Feld
    Aus den Attributen eines Layers kann ein beliebiges Feld ausgewählt werden. Ist der Layer aktiv, wird im Karten-Element diese Information zum an der Mausposition befindlichen Geo-Objekt als Tooltipp (Quick-Info) angezeigt.

  2. Info-Fenster
    Während beim Info-Feld nur ein Feld angezeigt wird, kann mit dem Info-Fenster ein Überblick über alle Felder des ausgewählten Geo-Objektes angezeigt werden. Die Attribute der angeklickten Geo-Objekte können dabei direkt bearbeitet werden.

  3. Suchen
    Geo-Objekte können gezielt auf der Karte gesucht und hervorgehoben werden. Dabei kann in einem oder mehreren Layern gleichzeitig nach Zeichenketten gesucht werden.

Zeichnen und Selektieren

Per Mausklick können Punkte, Linien und Polygone (Polygone, Rechtecke, Kreise) gezeichnet werden. Diese werden wahlweise in neuen oder vorhandenen Shape-Dateien abgelegt. Die so gezeichneten Geo-Objekte können unter anderem zum räumlichen Selektieren verwendet werden.

Der Karten-Explorer erlaubt es, aus Layern mit Vektordaten Geo-Objekte zu selektieren und als neue Shape-Datei zu speichern. Dabei werden verschiedene Selektionsmöglichkeiten unterschieden:

  1. räumlich
    Anhand der Geo-Objekte eines "Selektion-Layers" (der z.B. mit der Zeichenfunktion erstellt worden ist) werden Geo-Objekte aus einem anderen Layer selektiert.

  2. manuell
    Aus Attributen eines Layers wird eine Auswahlliste erzeugt, über die die gewünschten Geo-Objekte selektiert werden können.

  3. Abfrage
    Über eine frei definierbare SQL-Abfrage auf die Attribut-Tabelle eines Layers können Geo-Objekte selektiert werden.

  4. per Mausklick
    Geo-Objekte können (aus mehreren Layern gleichen Typs) per Mausklick selektiert werden.

Karte drucken und exportieren

Der Inhalt des Karten-Elements kann gedruckt oder exportiert werden. Dabei kann der Ausdruck wahlweise auch mit Kartentitel, Legende, Maßstab und Nordpfeil erfolgen.

Alternativ zum Ausdruck kann die Karte in eine Datei oder die Zwischenablage (BMP oder WMF) exportiert werden. Auch die Legende kann in die Windows-Zwischenablage exportiert werden, so dass Karten und Legenden z.B. einfach in Office-Produkten (Word, Excel) weiter verarbeitet werden können.

Karten können mit Einfärbungen und Attributen in KML ausgegeben werden und direkt im Internet-Browser (FLI-Maps) oder in Google Earth (Google Maps) angezeigt werden.

Export BMP | Export KML (FLI-Maps) | Export KML (Google Earth)

Daten importieren, exportieren, konvertieren

  • Das Werkzeug [image] Shape-Konverter ermöglicht das flexible Importieren, Exportieren, Transformieren und Duplizieren von Shape-Dateien (Ändern der Projektion, Manipulation der Attribute und komfortable Filterfunktionen).

  • Das KML-Format wird bidirektional unterstützt.

    • Beliebig viele Layer können als KML-Datei mit allen Geo-Objekten, Einfärbungen und Attributen exportiert werden.

    • Analog können KML-Dateien mit beliebig vielen Layern (so genannten Foldern) mit allen Attributen und Einfärbungen importiert und zu Shape-Dateien konvertiert werden.

  • Das von GPS-Empfänger bekannte Datenaustauschformat GPX steht sowohl für den Import als auch den Export von Layern zur Verfügung.

  • Über Textdateien bzw. die Zwischenablage können Daten mit anderen Anwendungen ausgetauscht werden.

    • Koordinaten und Attribute können in die Zwischenablage kopiert bzw. in Excel geöffnet werden.

    • CSV-Dateien oder (in die Zwischenablage kopierte) Excel-Tabellen können eingefügt werden.

Geokodierung und Routenberechnung

Das BKG stellt verschiedene Web-Services zur Geokodierung (Adressen zu Koordinaten) und rekursiver Geokodierung (über Koordinaten werden Adressen ermittelt) zur Verfügung.

Im Karten-Explorer können Adressen manuell (Benutzereingabe der Adresse) oder automatisch (Tabelle mit Adressen) geokodiert, also mit Koordinaten versehen und/oder als Karte dargestellt werden.

Über ALT+W oder das Kontextmenü (rechte Maustaste) können Adressen und Orte an der aktuellen Position ermittelt werden.

Eine Routenberechnungen ermittelt den schnellsten oder kürzesten Weg von "A nach B" für LKW, PKW, Radfahrer und Fußgänger inklusive möglicher Zwischenziele. Die Route kann als Tabelle mit Wegbeschreibungen und/oder Karte ausgegeben werden.

Dateiformate

Der Karten-Explorer unterstützt folgende Formate:

  • Shape-Dateien (*.shp)
  • Bilddateien
    • Multi-Resolution Seamless Image Database, MrSID (*.sid)
    • Tagged Image File Format, inklusive GeoTiff (*.tif, *.tff, *.tiff)
    • Windows-Bitmap (*.bmp)
    • JPEG (*.jpg, *.jpeg)
    • Band interleaved by line multiband images (*bil)
    • Band interleaved by pixel multiband images (*.bip)
    • Band sequential multiband images (*.bsq)
    • Sun rasterfiles (*.sun, *rs, *.ras)
    • Run-length compressed files (*.rlc)

Dateien dieser Typen können auf folgende Arten geöffnet werden:

  • mit der Schaltfläche [image] "Layer hinzufügen"
  • über das Menü Layer
  • per Drag & Drop auf das Karten-Element
  • über Kommandozeilen-Parameter
    Tipp: Sie können den Karten-Explorer als Standard-Programm für das Öffnen aller unterstützten Dateitypen verwenden, so dass diese Formate per Mausdoppelklick unter Windows automatisch mit dem Karten-Explorer geladen werden.

Projekte

Alle Einstellungen (geladene Layer, Einfärbung, Info-Feld usw.) werden auf Wunsch in einer Karten-Explorer-Datei (*.kep) gespeichert und können somit per Knopfdruck wieder hergestellt werden.

Um die Archivierung von Projekten und den Datenaustausch via Internet/Email zu erleichtern, können alle Shape-Dateien inklusive der Informationen zu ihrer Einfärbung als ein so genanntes Online-Projekt in ein Zip-Archiv exportiert werden (*.kez für Karten-Explorer-Zip).

Dateien der Typen *.kep und *.kez können über das Menü "Datei", Drag & Drop auf das Karten-Element und als Kommandozeilen-Parameter geöffnet werden.

Sonstige Funktionen

  • Georeferenzieren
    Punkt-Informationen können über den Karten-Explorer georeferenziert werden. Dabei kann eine beliebige Struktur der Attribut-Datei festgelegt und editiert werden.
  • Entfernung bestimmen
  • Attribute manipulieren
    • Struktur der mit der Shape-Datei assoziierten Attribut-Datei (*.dbf) ändern
    • Attribute einer Shape-Datei editieren und berechnen
    • Attribute in Datei oder Zwischenablage exportieren
  • Layer erstellen
    • aus dBase-Dateien
    • aus KML- und GPX-Dateien
    • aus CSV-Dateien

    • aus der Zwischenablage (Text, Excel-Tabellen)

    • Puffer um Punkte
    • "Grid-Zellen" und Punktdichten
    • Hexagone
  • Verknüpfen von Layern
    • "Join" über Attribute oder räumliche Beziehungen

Koordinatentransformationen

Shape-Dateien können für folgende Koordinatensysteme und geodätische Bezugsdaten (ggf. unter Angabe von Meridianstreifen) frei konvertiert werden:

  • Koordinatensysteme
    • geografisch
    • Gauß-Krüger (3°)
    • UTM (6-,7-,8-stellig)
    • LAEA
  • geodätisches Bezugsdatum
    • Potsdam Datum (DHDN)
    • System 42/83
    • WGS84 und WGS72
    • ETRS89

Koordinatentransformationen erfolgen unter Nutzung der Software GEODLL32 der Firma C. Killet Softwareentwicklung GbR mit der 7-Parameter-Methode nach Helmert.

Der Karten-Explorer verfügt über eine Funktion zum Verwalten der Projektion von Projekten, mit der alle Layer (Shape-Dateien) eines Projektes einfach transformiert werden können (Menüpunkt "Datei - Projektion verwalten" oder Doppelklick auf die Info zur Projektion in der Statuszeile).

Hinweise für TSN-Nutzer

Der Karten-Explorer bietet den Mitarbeitern aus Veterinärbehörden, die zur so genannten TSN-Benutzergruppe gehören, viele Einsatzmöglichkeiten:

  • Die Dateiformate '*.kep' (Karten-Explorer-Projekt) und '*.kez' (Online-Projekt bzw. Karten-Explorer-Zip) sind 100%ig kompatibel zu denen von TSN.

  • Die unter TSN verwendeten Polygon-Dateien zur Verarbeitung von Restriktionsgebieten (*.plg) können sowohl geladen als auch bearbeitet werden. Der von TSN bekannte [image] Polygon-Editor wurde in da Programm integriert.

  • Unter "Extras - Einstellungen" im Hauptfenster können auf der Registerkarte "TSN-Kompatibilität" die Zugriffspfade, Zugang zum Web-Service und der Typ der TSN-spezifischen Rasterkarten eingestellt werden.

    • Die Zugriffspfade für Karten und Projekte können auf die entsprechenden Zugriffspfade von TSN gesetzt werden, um Projekte und Karten simultan zu nutzen.

    • Die Karten für Staatsgrenzen (Bundesländer, Regierungspräsidien, Kreise) können über einen Web-Service herunter geladen werden.

    • Insbesondere steht der TSN-Benutzergruppe die DTK25 und die DTK200 bzw. DTK500 (Übersichtskarte BRD) für den Menüpunkt "Layer - Rasterkarten hinterlegen" zur Verfügung und die Funktionen arbeiten dann auch unter dem Karten-Explorer mit dem gewünschten Resultat.
      Beachten Sie bei der Weitergabe und Nutzung der DTK25 die Vereinbahrungen mit Ihrem Landesvermessungsamt und bei der Nutzung der DTK500 die Copyright-Hinweise!

  • Mitglieder der TSN-Benutzergruppe können die Tierseuchenlage für wählbare Tierseuchen direkt im Karten-Explorer über den Menüpunkt [image] "Erstellen - Abfrage ZTSDB" abfragen und als Layer einbinden.

Tipp: Wenn Sie unter Windows den Dateityp 'kez' mit dem Karten-Explorer verknüpfen, können Sie kartografische Online-Abfragen der Zentralen Tierseuchendatenbank "direkt vom Server öffnen" ohne sie explizit auf der Festplatte speichern zu müssen.


Hauptfenster

Hauptfenster der Anwendung

Das Hauptfenster der Software "Karten-Explorer" bietet folgende Optionen:

Explorer
 | Explorer startet einen neuen [image] Karten-Explorer zur Anzeige und Analyse von Karten.
 | Beenden schließt die Anwendung.
Extras
 | Einstellungen erlaubt es, Zugriffspfade, Adressen, Projektion, Standardprojekt usw. zu konfigurieren. Einstellungen
 | Shape-Datei transformieren erlaubt es, die Projektion von Shape-Dateien sowie die Dateistruktur der Attribute-Datei zu ändern und Filter anzuwenden. Die ausgewählte Datei wird überschrieben! Shape-Datei konvertieren
 | Shape-Datei exportieren erstellt eine Kopie einer Shape-Datei und erlaubt es, die Projektion der Shape-Dateien sowie die Dateistruktur der Attribute-Datei zu ändern und Filter anzuwenden. Die Ursprungsdatei wird nicht modifiziert! Shape-Datei konvertieren
 | Koordinaten umrechnen aktiviert eine Programmfunktion, die das manuelle Umrechnen von Koordinaten (Koordinatensystem, Bezugssystem und Streifen) erlaubt. Koordinaten umrechnen
 | Polygon-Editor ist ein Werkzeug für Veterinärbehörden zur Erstellung und Bearbeitung spezieller Polygone zur Darstellung von Sperr- und Beobachtungsgebieten. Polygon-Editor
 | dBase-Datei bearbeiten gestattet das Öffnen und Bearbeiten von dBase-Dateien. dBase-Datei bearbeiten
 | Archiv-Manager erlaubt es, Zip-Archive (Dateikomprimierung) zu erstellen, Dateien zu diesen hinzuzufügen, aus diesen zu löschen bzw. aus diesen zu extrahieren. Archiv-Manager
 | Karten-Explorer-Homepage startet den Standard-Internetbrowser und öffnet die Webseite des Karten-Explorers, auf der die neusten Programmversionen und verschiedene Karten (Online-Projekte) zum Download publiziert werden. https://kartenexplorer.fli.de
Hilfe
 | Hilfe oder F1 ruft die lokale Hilfedatei im aktuellen Kontext auf. Sollte es Probleme beim Zugriff auf diese Hilfe geben, kann alternativ die (identische) Hilfe im Web aufgerufen werden.
 | Hilfe im Web oder Strg+F1 erlaubt es, die Hilfe als Webseite aufzurufen. Dazu wird der Standard-Webbrowser verwendet. Da der Zugriff auf die lokale Hilfe (ke.chm) durch lokale Sicherheitseinstellungen blockiert sein kann, steht damit eine alternative Plattform zum Zugriff auf die benötigten Hilfeseiten zur Verfügung.
 | Freischaltung anfordern ruft das Standard-Mailprogramm auf und erlaubt es, die notwendigen Informationen (angemeldeter Benutzer und Domäne) zum Supportteam des Karten-Explorers zu übertragen, um eine Freischaltung zu den Diensten des BKG (Geokodierung, Routenberechnung) zu erstellen.


Was ist neu?

Dieser Abschnitt gibt Auskunft über wichtige Neuerungen und Erweiterungen der Version KE 2.21 im Vergleich zur Vorversion.

  • Export von Karten in Dateien
    Jetzt können mit dem Menüpunkt "Export - Karte in Datei" (F3) neben Bitmap und Enhanced Metafile auch TIFF (verschiedene Kompressionsmethoden), JPEG und PNG exportiert werden. Außerdem können die Bilddateien jetzt über optionale World-Dateien georeferenziert werden. Damit können mit dem Karten-Explorer Rasterkarten für GIS-Anwendungen (QGIS, ArcGIS, Karten-Explorer) erstellt werden. Karte als Datei exportieren

  • verschiedene Optimierungen und Fehlerbereinigungen, u.a.

    • Das Lesen und Konvertieren von Shape-Dateien mit sehr großen Polygonen wurde deutlich beschleunigt.

    • Ein Fehler beim Importieren (Konvertieren) von Shape-Dateien (Typ Punkt) mit NULL-Shapes wurde gefixt.

Dieser Abschnitt gibt Auskunft über wichtige Neuerungen und Erweiterungen der Version KE 2.2 im Vergleich zur Vorversion.

Karten-Explorer hier

Einfärbung

  • Einfärben mit Klassen
    Das Einfärben von numerischen Attributen mit [image] individuellen Klassen sowie die Darstellung von Symbolen in Legenden wurde komplett überarbeitet. Insbesondere für Layer mit vielen Geo-Objekten und die geplanten Entwicklungen im Bereich Risikobewertungen (z.B. Grid-Layer mit relevanten Attributen für ganz Deutschland) steht jetzt ein intuitives und leistungsfähiges Werkzeug zur Verfügung.
    • Der [image] Klassen-Designer erlaubt das flexible Einfärben von Layern nach numerischen Attributen mit bis zu 100 Klassen.
    • Klassen können interaktiv eingefügt, gelöscht, eingefärbt und visualisiert werden.
    • Klassengrenzen und Farbverläufe können auf alle Klassen oder wählbare Teilbereiche angewendet werden.
  • Farbschema zuweisen [image] hier
    • eine Bibliothek hinterlegter Farbverläufe, die bei Bedarf durch selbst erstellte Farbverläufe erweitert werden kann
    • nützlich für einheitliche Einfärbungen für Sachdaten, Risikokulissen, Heat-Maps usw.
    • verfügbar beim Einfärben nach individuellen Klassen und Einzelwerten
  • Vorlagenbibliothek ® Vordefinierte und benutzerdefinierte Vorlagen können über das Menü „Layer – Layer-Vorlagen-Vorlagenbibliothek“ aktiviert werden
    • Vordefiniert
      • DLM (Standard, Vegetation, Wald)
      • Tierarten (Klauentier-, Schweine-, Rinder-, Geflügeldichte)
    • Eigene Vorlagen
      • Eigene Vorlagen können in die Vorlagenbibliothek integriert werden, wenn eine KEL-Datei (Layer-Vorlage) in das „Vorlagen-Verzeichnis“ kopiert wird.

        • Unterhalb des bei den Einstellungen vom Karten-Explorer hinterlegten Karten-Verzeichnisses ist ein Ordner /KEL anzulegen.

        • In diesen Ordner können KEL-Dateien u.a. aufgenommen werden, indem die aktuelle Einfärbung eines Layers über das Kontextmenü (rechter Mausklick auf Layer) mit dem Menüpunkt „Layer-Vorlage - Exportieren“ gespeichert wird.

Shape-Konverter - Einheitliches Werkzeug zur Konvertierung von Shape-Dateien hier

Der Datenaustausch zwischen dem Karten-Explorer und dem "externen GIS-Umfeld" über Shape-Dateien hat in den zurückliegenden Krisenmonaten enorm zugenommen und zu vielen Problemen bei abweichender Projektion, UTF-Zeichensätzen, inkompatiblen Formaten (Z- und M-Shapes, Null-Shapes) und nicht unterstützten Feldtypen (Float) geführt. Ein einziges Werkzeug sollte alle Probleme simultan und intuitiv lösen und kommt zum einen in neuen Programmfunktionen zur Anwendung und ersetzt bisherige Programmfunktionen.

  • neue Programmfunktionen
    • Import mit Menüpunkt "Layer – Importieren" (Alt+I) oder
      Drag & Drop einer Shape-Datei aus einem Windows-Explorer in den "Konverter"
    • Duplizieren mit Menüpunkt "Layer – Duplizieren – benutzerdefinierte Kopie"(↑+D) oder
      Drag & Drop eines Layers aus der Layer-Kontrolle in den "Konverter"
  • Ersetzt folgende Programmfunktionen
    • Transformieren mit Menüpunkt "Layer – Transformieren"(Strg+T) oder
      mit rechter Maustaste auf Layer klicken (Kontextmenüpunkt: Transformieren)
    • Exportieren mit Menüpunkt "Layer – Exportieren"oder
      mit rechter Maustaste auf Layer klicken (Kontextmenüpunkt: Exportieren)
      • Tipp: beim Exportieren kann die Shape-Datei über das Kontrollkästchen [image] automatisch in ein Zip-Archiv komprimiert werden.
  • Komfortable Modifikation der Dateistruktur mit Voransicht
    • Namen und Typen von Feldern können ohne Datenverlust geändert werden
    • Neue Felder, Löschen von Feldern, Reihenfolge ändern
    • Statistikfunktion untersucht vorhandene Daten auf Feldlänge (Zeichenkette) und Wertebereich (numerische Felder), um die Feldlängen zu optimieren (unnötig lange Felder kosten viel Platz)
    • Konvertierung von UTF-8, ANSI und OEM mit Anzeige in der Voransicht
  • Unterstützung von Voransicht mit Tabellenfiltern erlaubt die Selektion von Daten für neue Layer
    • Probleme mit Umlauten sind sofort zu identifizieren
    • Tabellenfilter erlauben das Filtern von Zeilen
      • Selektion (Erstellen eines neuen Layers mit bestimmten Attributen (nur Wald etc.) oder Bereinigen/Löschen nicht benötigter Objekte)
      • gezielter Export in [image] Zwischenablage oder [image] Anzeige in Excel

      • Zählen von Zeilen die eine Bedingung erfüllen

  • Einfügen über Drag & Drop aus Layer-Kontrolle und externen Windows-Explorer-Fenstern
  • Umrechnen von Koordinaten
    • Voransicht auf Karte (Wo würde der Layer bei den eingestellten Parametern auf der aktuellen Karte liegen?)
    • Unterstützung von PRJ-Dateien → Projektion von "fremden" Shape-Dateien wird jetzt i.d.R. automatisch erkannt (sofern PRJ vorhanden)
    • Relevante EPSG-Codes sind auswählbar [image] hier
  • M- und -Z-Werte von entsprechenden Shape-Dateien werden genauso automatisch entfernt wie auch Null-Shapes (Einträge ohne Geometrie).
  • Beim Exportieren werden jetzt Zeichensatz (CPG-Datei) und Projektion (PRJ-Datei) automatisch erstellt.

KML

  • KML-Export wurde erweitert [image] hier
    • Integration einer Schnittstelle zu „FLI-Maps“

      • KML-Dateien können jetzt direkt über einen Karten-Service des FLI im Internet-Browser angezeigt werden.
        Vorteile

        • Mit einer Vielzahl von Hintergrund-Karten kombinierbar (BKG, Google, OpenStreetMap usw.)

        • Keine Übertragung von sensiblen Daten auf Server privater Unternehmen

        • Karten können mit einer Lebensdauer versehen werden.

        • Per weitergeleitetem Link kann Dritten Zugriff auf die Karten erlaubt werden.

    • Bei Ausgabe als Karte auf FLI-Maps kann eine Lebensdauer angegeben werden (Voraussetzung ist Anmeldung bei TSN-Online).
      • Verwaltung eigener publizierter Karten über TSN-Online für den Benutzer möglich
    • "Extended Data" implementiert, was die effektive Übergabe von Attributen (Sachdaten) erlaubt
  • KML-Import integriert [image] hier
    • universeller nationaler und internationaler Datenaustausch
      • Restriktionszonen
      • Lagedarstellungen
    • KML-Dateien einlesen über
      • Menüpunkt "Erstellen - aus KML-Datei"
      • Drag&Drop von KML-Dateien in Karten-Explorer
      • Einfügen aus Zwischenablage (Dateien oder Text)
    • Karten-Austausch mit TSN-Online über KML-Format
    • Einfärbungen (Styles) editierbar
    • Struktur der übergebenen Attribute (Datentypen etc.) bei "Extended Data"editierbar

Datenaustausch mit GPS-Geräten

  • Importieren von GPX-Dateien [image] hier
    • Einlesen von Tracks (aufgezeichneten, tatsächlich zurückgelegten Wegstrecken), Routen (geplante Wegstrecken) und Wegepunkte als Karten-Layer
    • Abgelaufene Wegstrecken können für die Erstellung von Restriktionszonen genutzt werden.
      • Dabei können mit einer neuen Funktion im Selektieren-Fenster Linien markiert und zu einem Polygon umgewandelt werden.
    • Die Suchpfade von Jägern oder Personen bei der Kadaversuche können dargestellt werden.
    • Fundstellen von Kadavern können als Wegepunkte importiert werden.
  • Exportieren von GPX-Dateien [image] hier
    • Linien-Layern oder Polygon-Layern als Routen
      • Wegstrecken können vorgegeben werden, um z.B. die Kadaversuche zu optimieren.
    • Punkte-Layer als Wegepunkte
      • Betriebe, Fundstellen von Tieren usw. können auf ein GPS-Gerät übergeben werden.

Integration von Web-Services des BKG

  • Geokodierung [image] hier
    • deutschlandweite Ermittlung von Koordinaten aus Adressen
    • Suche nach PLZ, Orten, Straßen, Hausnummern und geografischen Namen
    • Automatische Georeferenzierung von Adressen (z.B. Excel-Tabellen über Einfügen aus Zwischenablage)
    • Exportieren der gefundenen Objekte in die Zwischenablage
    • Anzeigen der Objekte auf Karte
  • Umgebungssuche (Reverse Geokodierung) [image] hier
    • Für gegebene Koordinaten können im beliebigen Umkreis Adressen (Häuser), Straßen, Orte und geografische Namen gesucht werden.
    • Bis zu 1000 Objekte werden als Vorschlagsliste ermittelt und können sofort als Karten-Layer angezeigt werden
    • Koordinaten können aus Zwischenablage und per Klick in die Karte ermittelt werden
      • Kontextmenü "Was ist hier?"→ Umgebungssuche an geklickter Position
      • ALT+W (Was ist hier?) → führt Umgebungssuche an Mausposition aus
      • ALT + linke Maustaste identifiziert die Adresse an der geklickten Position
  • Routenberechnung [image] hier
    • Integration eines Webservice des BKG zur Berechnung von Routen
    • Startpunkt … (Zwischenziele) … Endpunkt (Max. 50 Punkte pro Route)
      • Einfügen aus Zwischenablage, Geokodierung von Adressen oder Umgebungssuche
    • Optionen
      • Auto, Schwerlast usw.
      • Schnellste, Kürzeste Route
    • Darstellung auf Karte
    • Anweisungen als Excel-Tabelle exportierbar
    • Künftig können weitere Routing-Optionen (Fahrzeuggrößen, Gesamt-Achslasten) und zu umfahrende Flächen (Restriktionsgebiete) implementiert werden.
      • z.B. ein TKB-Fahrzeug mit 40t Achslast soll von A nach B unter Umgehung von Sperrzonen fahren

Hinweise zum Zugriff auf diese Funktionalitäten finden Sie in den [image] Nutzungsbedingungen!

Attribute bearbeiten und exportieren

  • Bearbeiten von Attributen [image] hier
    Die Programmfunktion zum Bearbeiten von Attributen eines Layers oder einer separaten dBase-Datei wurde erweitert:
    • Hinzufügen und Löschen von Zeilen für dBase-Dateien

    • Kopieren von Daten (wählbare Zeilen/Spalten) in Zwischenablage (ALT+C) und optionale Anzeige in Excel

    • Erstellen von Shape-Dateien erweitert
      • Das Erstellen einer Shape-Datei aus einer dBase-Datei über Spalten mit Koordinaten ist jetzt auch möglich, wenn die Tabelle noch Zeilen ohne Koordinaten enthält, indem die Shape-Datei aus einer Kopie der bisher georeferenzierten Zeilen erstellt wird.
    • Markierungsmodus zum Kopieren, Löschen, Georeferenzieren und Berechnen/Ersetzen von Attributen
    • Die Funktion "Geografische Eigenschaften berechnen" wurde um die Möglichkeit erweitert, Attribute in Bezug zur Fläche zu setzen (Bsp.: Ersetze Feld Strecke durch Strecke je 100ha) [image] hier
  • Ermittlung von Koordinaten
    Die Möglichkeiten zur Ermittlung von Koordinaten beim Bearbeiten von dBase-Dateien und Attributen von Shape-Dateien wurden optimiert.
    • Geokodierung von Adressen per Web-Service integriert
      • Manuell (STRG+H)
      • Automatisch (alle selektierten Zeilen werden geokodiert)
    • Koordinaten und/oder Adressen können jetzt direkt per Menüpunkt oder ALT+V aus der Zwischenablage in das "Bearbeiten-Fenster" eingefügt werden.
      • Geografische Koordinaten aus Google Maps (dezimal oder in Grad) werden korrekt separiert und in das aktuell eingestellte Koordinatensystem umgerechnet.
      • Adressen aus Google Maps, die in die Zwischenablage kopiert wurden, können direkt eingefügt werden.
    • Menüpunkte für [image] Umgebungssuche (STRG+U) und manuelle Eingabe von Koordinaten sind hinzugefügt worden.
    • Wird eine Adresse in der manuellen Geokodierung, Umgebungssuche oder Georeferenzierung ausgewählt (geändert), dann werden auch die Adressangaben im "Bearbeiten-Fenster" aktualisiert.
    • manuelles Georeferenzieren per Mausklick in Karte [image] hier
      • Geokodierung integriert
      • Umgebungssuche – Was ist hier? (Alt + W) → für Suche in konfigurierbarem Radius an aktueller Mausposition
      • Alt + linke Maustaste identifiziert Adresse an geklickerter Position über Web-Service.
  • Attribute bearbeiten – Struktur ändern [image] hier
    • Das Ändern der Dateistruktur wurde komplett überarbeitet und an das Konvertierungswerkzeug für Shape-Dateien angelehnt.
    • Feldname und -typ können ohne Datenverlust geändert werden.
    • Statistikfunktion untersucht vorhandene Daten auf Feldlänge (Zeichenkette) und Wertebereich (numerische Felder), um die Feldlängen zu optimieren
    • Zeichensatzkonvertierung
    • Voransicht

Drag & Drop

Folgende Möglichkeiten bestehen, Dateien oder Layer per Drag&Drop (Ziehen mit gedrückter Maustaste und "Fallenlassen") zu verarbeiten:

  • Drag & Drop von Dateien aus einem Windows-Explorer in den Karten-Explorer oder Einfügen aus Zwischenablage mit Strg + V
    • *.KEP → Laden eines Karten-Explorer-Projekts
    • *.KMZ, *.ZIP → Laden eines Online-Projektes
      • Ausnahme: enthält das Zip-Archiv genau eine CSV-Datei, wird ein Export aus der ZTSDB (TSN-Online) angenommen und versucht, einen Layer aus der Textdatei zu erstellen!
    • *.SHP → Laden einer oder mehrerer Layer
      • Ausnahme: Wird genau einer SHP-Datei mit gedrückter linker Maustaste eingefügt, wird die Shape-Datei importiert [image] Shape-Konverter
    • *.JPG, *.JPEG, *.BMP, *.TIF, *.TFF, *.TIFF, *.SID → Laden einer oder mehrerer Layer
    • *.PLG → Erstellen eines Layers aus einer Polygon-Datei
    • *.CSV/*.TXT → Erstellen eines Layers oder einer dBase-Datei
    • *.KML → Erstellen eines Layers aus KML
    • *.GPX → Erstellen eines Layers aus GPX (GPS-Geräte)
    • *.DBF → Erstellen eines Layers oder Bearbeiten einer dBASE-Datei
    • *.KEL → verwendet die Einfärbung einer KEL-Datei (Layer-Vorlage) für den aktiven Layer
  • Drag & Drop von Layern aus der Layer-Kontrolle
    • In die Übersichtskarte des eigenen Karten-Explorers ® verwendet den Layer als Übersichtsfenster
      Hinweis: ist keine Übersichtskarte sichtbar, kann der Layer in die Statuszeile gezogen werden.
    • in das Selektieren-Fenster des eigenen Karten-Explorers (siehe Erläuterungen im nächsten Absatz)
    • in ein anderes Karten-Explorer-Fenster ® öffnet den Layer im anderen Karten-Explorer
    • in das Anwendungsfenster (innerhalb der Anwendung, aber außerhalb eines Karten-Explorer-Fensters)
      ®       öffnet den Layer in einem neuen Karten-Explorer-Fenster
    • in ein Fenster zur Routenberechnung ® übernimmt die Koordinaten eines Punkte-Layers als Wegepunkte zur Routenberechnung

    • in das Karten-Element des eigenen Karten-Explorers ® erstellt eine benutzerdefinierte Kopie des Layers [image] Shape-Konverter

    • auf den Windows-Desktop (aus dem Anwendungsfenster heraus) ® exportiert den Layer [image] Shape-Konverter
  • Drag & Drop von Dateien in das [image] Selektieren-Fenster
    • *.SHP oder *.PLG aus dem Windows-Explorer → Einfügen der Geo-Objekte einer oder mehrerer Shape- oder Polygon-Dateien
    • Layer aus der Layer-Kontrolle
      →       Einfügen der Geo-Objekte des Layers
      • Sonderfall: bei gedrückter STRG- oder ↑-Taste) ® Geo-Objekte im Selektieren-Fenster anhand des Layers markieren:
        ... STRG + Drop & Drop ® Geo-Objekte markieren, die sich vollständig innerhalb des Layers befinden.
        ...↑ + Drop & Drop ® Geo-Objekte markieren, die sich innerhalb des Layers befinden oder von ihm geschnitten werden.

Tastatur und Maus

Die Möglichkeiten, den Karten-Explorer mit Tastatur und Maus intuitiv bedienen zu können, wurden an vielen Stellen erweitert. Einen Überblick finden Sie unter [image] Tastatur und Maus.

Zwischenablage

  • Kopieren in Zwischenablage
    • Karte in Zwischenablage (STRG + C) kopiert die Karte als BMP in die Zwischenablage.
    • Attribute in Zwischenablage kopieren (↑ + C) erlaubt jetzt das direkte Öffnen in Excel. Des Weiteren kann die Feldbeschreibung in der Kopfzeile (z.B. GEM_SCHL,C,8) wahlweise mit ausgegeben werden. Hinweis: Als Trennzeichen wird der Tabulator verwendet.

  • Einfügen aus Zwischenablage mit STRG + V

    • Befinden sich Dateien in der Zwischenablage, werden sie exakt so verarbeitet, als würden Sie per Drag & Drop in den Karten-Explorer gezogen worden (siehe Punkt 1 Drag & Drop)
    • Befindet sich Text in der Zwischenablage, wird dieser analysiert:
      • Werden Adressen und/oder Koordinaten erkannt werden diese automatisch kartografisch dargestellt [image] Adressen und Koordinaten in Zwischenablage
        • Werden GPS-Koordinaten erkannt, erfolgt automatisch eine Transformation auf die im Karten-Explorer verwendete Projektion.
      • Wird eine sonstige Tabellestruktur (durch Tabulator, Semikolon, | oder Komma getrennte Werte) erkannt, wird die Programmfunktion [image] „Erstellen aus Zwischenablage“ aktiviert und eine Voransicht der Daten angezeigt.

        • Damit lassen sich sehr leicht Daten aus Excel etc. in den Karten-Explorer integrieren, indem diese in die Zwischenablage kopiert werden – ein Umweg über die Erstellung von Dateien ist nicht mehr erforderlich.

      • Wird der Text in der Zwischenablage als KML oder GPX identifiziert, wird die entsprechende Importfunktion gestartet.

Verknüpfen

  • „Join über Schlüsselfeld“ wurde erweitert:
    • Die Attribute eines Layers können jetzt direkt über ein gemeinsames Schlüsselfeld mit Werten aus der Zwischenablage verknüpft werden.
      • Beispiele
        • Die Attribute eines Gemeinde-Layers werden in die Zwischenablage kopiert und in Excel bearbeitet. Anschließend werden sie wieder in die Zwischenablage kopiert und über das Schlüsselfeld GEM_SCHL mit den Gemeinden des Layers verknüpft.
        • In einem Kreis wird ein 3-Km-Grid zur Risikoanalyse erstellt. Das FLI stellt eine Tabelle mit einer Grid-ID und Informationen für Anteil von Wald, Wasser, Höhe, Temperatur usw. zur Verfügung. Die benötigten Informationen werden in die Zwischenablage kopiert und über die ID mit dem Grid verknüpft.
  • „Punkt-Flächen-Verknüpfung“ wurde erweitert:
    • Summieren und/oder Zählen (gleichzeitig) möglich, z.B.:
      • Summe der Rinder = Anzahl der Tiere je Gemeinde
      • Zählen von Einträgen mit Rindern = Anzahl der Betriebe je Gemeinde
    • Wahlweise Berechnung je km2 ® Problem Viehdichtekarte auf Kreisebene damit schnell lösbar
  • „Punkt-Grid-Verknüpfung“ wurde erweitert
    • Das Einpassen des Grid-Layers kann anhand jedes geladenen Layer erfolgen.
    • Die Gridzellen werden automatisch auf einen Referenzpunkt bezogen (siehe oben).
    • Summieren und/oder Zählen (gleichzeitig) möglich
    • Wahlweise Berechnung je km2

Selektieren

  • Menü "Selektieren" in Karten-Explorer hinzugefügt
    • Räumlich, Abfrage, Liste und per Mausklick
    • Schnelles Selektieren mit Kreis, Rechteck und Polygon
      • Tipp: Kurztasten, z.B. Alt + SK → Selektieren mit Kreis

  • Selektieren per Mausklick
    Das [image] Selektieren-Fenster wurde komplett überarbeitet und bietet eine deutlich erweiterte Funktionalität.

    • Konfigurierbare Info-Felder ® Anzeige der Attribute an der Mausposition zur Identifizierung von Objekten
    • Drag & Drop in das Selektieren –Fenster
      • Von Layern aus der Layer-Kontrolle
      • Von (mehreren) PLG-Dateien
      • Von (mehreren) SHP-Dateien
    • Markieren von Geo-Objekten im Selektieren-Fenster
      • Geo-Objekte können markiert werden, um sie zu löschen oder sie zusammen zu fassen usw.
      • Markierung kann jetzt einfach für alle Objekte gesetzt, umgekehrt oder entfernt werden.
      • Layer aus der Layer-Kontrolle können zur Markierung von Geo-Objekten (analog zum räumlichen Selektieren) verwendet werden.
        • Menüpunkt „Markieren - mit Layer markieren“ erlaubt die Auswahl des Layers und der Methode (z.B. Vollständig enthalten)
        • Alternativ können Layer zum Markieren aus der Layer-Kontrolle in das Selektieren-Fenster gezogen werden:
          • STRG + Drop & Drop ® Geo-Objekte markieren, die sich vollständig innerhalb des Layers befinden.
          • ↑ + Drop & Drop ® Geo-Objekte markieren, die sich innerhalb des Layers befinden oder von ihm geschnitten werden.
    • Selektieren per Mausklick bei überlappenden bzw. angrenzenden Objekten ist jetzt komfortabel
      • Werden mehrere Objekte beim Mausklick gefunden, kann man sie jetzt getrennt identifizieren und für jedes Objekt entscheiden, ob es in das Auswahlfenster übernommen werden soll.
      • Analog kann man im Auswahlfenster übereinander liegende Objekte separat zur Löschung markieren usw.
    • Neue Tasten- und Mausfunktionen
      • STRG + Mausrad zum Vergrößern und Verkleinern
      • Mit gedrückter linker Maustaste kann die Karte jederzeit verschoben werden, sofern eine beliebige Steuerungstaste (STRG, ↑, ALT) betätigt wird.

Legende hier

  • Legende anzeigen und positionieren
    Mit dem Menüpunkt „Ansicht – Legende auf Karte anzeigen“ [image] kann die Legende direkt in der Karte angezeigt, gedruckt und exportiert werden. Die Legende wird automatisch an der oberen linken Position der Karte angezeigt. Um die Position der Legende zu verändern, ist der Menüpunkt "Ansicht - Legende positionieren" zu nutzen. Mit gedrückter linker Maustaste ist ein Rahmen für die neue Position der Legende im Karten-Element von links oben nach rechts unten zu ziehen.
    Hinweis: Um Platz für die Legende zu schaffen, sollte ggf. die Karte verschoben werden. Manchmal empfiehlt es sich, den Teilungsbalken zwischen Karte und Layer-Kontrolle zu verschieben, um die Größe des Karten-Elements der anzuzeigenden Karte anzupassen.
    • Layer in Legende ausblenden
      In der Layer-Kontrolle können über das Plus-Minus-Symbol einzelne Layer zusammengeklappt werden. Diese erscheinen fortan nicht mehr in der Legende (sowohl beim Drucken als auch bei der Anzeige von Legenden in der Karte).
  • Feldbezeichnungen in Legende ausgeben
    Mit dem Menüpunkt "Ansicht - Feldbezeichnungen in Legende ausgeben" kann entschieden werden, ob bei der Einfärbung von Layern nach einem Attribut die Feldbezeichnung des verwendeten Attributs mit in der angezeigten, gedruckten oder exportierten Legende ausgegeben wird. Insbesondere bei Verwendung von Beschriftungen kann damit die Länge der Legende minimiert werden.
  • Legende auf der Karte skalieren
    Mit dem Menüpunkt "Ansicht - Legendengröße skalieren" kann die Legende im Karten-Element im Vergleich zur Standardgröße zwischen 25% und 500% skaliert werden.
  • Die Legende kann jetzt mit einem Hintergrund versehen werden.
  • Die Bedienung der Legendenfunktionen kann jetzt mit der Tastatur erfolgen:
    • Legende Ein/Aus STRG + L
    • Positionieren ↑+ L
    • In separatem Fenster ALT + L
    • Hintergrund ↑+ STRG + L

Grid und Hexagon hier

  • Bei der Erstellung eines Grids wird jetzt standardmäßig nicht mehr die linke untere Ecke der aktuellen Karte für den Ursprung des Grids und die Zählung der IDs verwendet, sondern es wird ein Referenzpunkt benutzt. Dieser wird durch die linke, untere Koordinate der verwendeten Rasterkarten bestimmt (GK3, U32, U33, LAEA).
    • Grids (gleicher Kantenlänge) passen aneinander (z.B. separat erstellte Grids benachbarter Kreise).
    • Die IDs (bei gleicher Kantenlänge) sind deutschlandweit homogen. Damit kann man für 1-km-, 3-km- und 5-km-Grids „Risiko-Grids“ im FLI vorbereiten (Höhe, Temperatur, Anteile Wald, Wasser usw.) und über die IDs deren Informationen separat erstellten Grids zuordnen ( [image] Verknüpfen über Schlüsselfeld).

  • Alternativ zu quadratischen Grids können Hexagone (Waben, regelmäßigen Sechsecken) beliebiger Kantenlänge mit dem Menü "Erstellen -Hexagon" erzeugt werden. hier

Layer ersetzen

Der Karten-Explorer bietet viele Möglichkeiten zur Manipulation von Layer (Projizieren, Selektieren, Attribute ändern, geometrische Operationen usw.). Häufig entstehen als Ergebnis von Operationen neue Layer, die den Benutzer schnell den Überblick verlieren lassen. Prinzipiell ist es zweckmäßig, Ergebnisse in neuen Layern abzubilden und nicht ungewollt (und ggf. unwiederbringlich) wertvolle Daten zu überschreiben. Häufig macht es aber Sinn, nach Evaluierung des neu entstandenen Layers die Ursprungsdaten durch ihn zu ersetzen. Dies ist jetzt sehr viel einfacher und intuitiver möglich:

  • Beim allen Selektieren-Funktionen (räumlich, Liste, Abfrage, manuell) verfügbar

  • Mit dem Menüpunkt „Layer – anderen Layer ersetzen“ kann ein neuer Layer jeden anderen Layer desselben Typs (Punkt, Linie, Polygon) ersetzen. Dabei kann gewählt werden, ob die Einfärbung beibehalten oder die des ersetzen Layers verwendet werden soll.
    • Tipp: (Original-)Layer sollten/könnten dupliziert werden, bevor man an ihnen größere Manipulationen vornimmt (Transformieren (Projizieren) ohne genau Kenntnis der Quellprojektion, komplexere Änderungen der Attribute usw.)

Layer aus Abfrage der ZTSDB erstellen hier

Mit dem Menüpunkt "Erstellen - Abfrage ZTSDB" bzw. der Schaltfläche [image] kann die Zentrale Tierseuchendatenbank für einzelne Tierseuchen und Tierkrankheiten für beliebige Zeiträume abgefragt werden.

  • Bisher war es nur möglich, explizit georeferenzierte Fälle (Ausbrüche und Verdachtsfälle) darzustellen. Das Verhalten wurde geändert. Exakt georeferenzierte und näherungsweise georeferenzierte Fälle werden in der Tabelle optisch unterschiedlich dargestellt. Über die Option "nicht exakt georeferenzierte Fälle ausblenden" können die Fälle, deren Koordinaten nur näherungsweise (Zufallspunkt in der Nähe des Ortsmittelpunkts oder innerhalb Gemeinde) vorhanden sind, wahlweise ein- oder ausgeblendet werden. Damit ist es jetzt möglich, Karten von allen Ausbrüchen zu erzeugen, auch wenn diese nicht vollständig georeferenziert wurden.

    • exakt georeferenziert (Typ 1)
    • Zufallspunkt in Ausbruchsnähe (Typ 2: in Nähe des angegebenen Ortsmittelpunktes, Typ 3: innerhalb der angegebenen Gemeinde)
  • Über die Option "Verdachtsmeldungen ausblenden" werden nur noch Ausbrüche in der Tabelle und Karte angezeigt.
  • Die Programmfunktion unterstützt jetzt die Mehrfachauswahl für die Anzeige von Ausbrüchen auf Karten, sowie die Ausgabe in Zwischenablage und Anzeige in Excel.

Sonstiges

  • Integration neuer Rasterkarten
    Mit der „TopPlusOpen“ stellt das Bundesamt für Kartografie und Geodäsie neue, frei zugängliche Rasterkarten für verschiedene Maßstäbe zur Verfügung. Folgende Rasterkarten werden für die Nutzung mit TSN (UTM Zone 32) angepasst und angeboten:

    • Top100.SID steht als neue Übersichtskarte zur Verfügung, welche nicht nur Deutschland abdeckt, sondern tief in die benachbarten Länder reicht. Wird UTM Zone 32 als Koordinatensystem verwendet, sucht die Programmfunktion „Raster – Übersichtskarte hinterlegen“ (STRG + Ü) des Karten-Explorers automatisch zuerst nach dieser Karte.

    • Die Karte TOP100 steht neben der gesamtdeutschen Übersichtskarte auch in Form der von TSN etablierten Kacheln zur Verfügung. Außerdem wird derzeit eine Karte TOP17 (Maßstab 1:17.500) mit integrierter Benamung von Straßen als Alternative zu den Rasterkarten DTK 1:25.000 aufbereitet und ist in Kürze als Download verfügbar. Die Rasterkarten TOP100 und TOP17 können ohne Einschränkung heruntergeladen und genutzt werden – die Beschränkung auf ein Bundesland ist hier nicht vorhanden.
    • Bei Verwendung der Programmfunktion „Raster - Rasterkarten hinterlegen“ (STRG + R) des Karten-Explorers kann jetzt zwischen den unterstützen Maßstäben gewählt werden.
  • Koordinaten und Projektion
    • LAEA (Lambert azimuthal equal-area) als Koordinatensystem integriert
      • europaweite Darstellungen möglich
      • Hintergrundkarten für ganz Europa verfügbar
    • Anzeige des aktuellen Koordinatensystems in Statuszeile
      • Doppelklick auf diese Anzeige öffnet die Programmfunktion [image] Projektion verwalten
    • Beim Öffnen des ersten Layers wird die Projektion des Projektes bei Bedarf automatisch angepasst
    • Alle Funktionen zum Erstellen von Layern (Grid, KML etc.) erzeugen jetzt Koordinaten entsprechend der aktuell eingestellten Projektion

  • Layer auf der Karte finden

    • „Layer finden“ (Kontextmenü oder STRG + F) identifiziert den markierten Layer auf der Karte, indem er ihn aufblinken lässt oder ggf. die Karte verschiebt, um ihn sichtbar zu machen.

  • Zeichnen-Funktionen erstellen geometrische Attribute [image] hier
    Werden im Menü "Extras- Zeichnenmodus" Objekte erstellt, werden automatisch folgende Attribute zum Geo-Objekt berechnet und gespeichert:

    • Kreis

      • X- und Y-Koordinate des Mittelpunktes

      • Radius

    • Rechteck

      • Länge und Breite

      • Koordinaten für Links (X), Oben (Y), Rechts (X), Unten (Y)

    • Polygon

      • Fläche und Umfang

    • Puffer

      • X- und Y-Koordinate des Mittelpunktes

      • Radius

    • Linie

      • Länge

    • Punkt

      • X- und Y-Koordinate

  • Mit der neuen Schriftart TSN-Symbole.ttf wurden die Standard-Symbole erweitert (z.B. Bienen)
  • ALT + C kopiert Koordinaten an Mausposition in die Zwischenablage, ↑ + ALT + C fügt Koordinaten an Mausposition zur Zwischenablage hinzu (STRG + V erzeugt daraus sofort einen Punkte-Layer)
  • Der Menüpunkt "Layer – Exportieren" erlaubt es, eine Kopie der mit dem Layer assoziierte Shape-Datei in ein beliebiges Laufwerk/Verzeichnis zu kopieren und dabei optional die Projektion zu ändern. Dies erleichtert den Datenaustausch mit externen Einrichtungen. hier
  • Beim Speichern eines neuen Projektes können Titel und Beschreibung angegeben werden.
  • Tipps ...vollständige Liste für Tastatur und Maus [image] hier

    • STRG + Drag&Drop genau einer Shape-Datei in den Karten-Explorer öffnet den Shape-Konverter zum Importieren der Shape-Datei

    • Mausfunktionstasten in Karten-Explorer (sowie Polygon-Editor und beim Georeferenzieren) erweitert:

      • Mausrad↑ = Karte nach oben verschieben

      • ↑ + Mausrad↑ = Karte nach links verschieben

      • Mausrad↓ = Karte nach unten verschieben

      • ↑ + Mausrad↓ = Karte nach rechts verschieben

      • Maustaste↓ (Daumentaste unten) = Vorheriger Kartenausschnitt

      • Maustaste↑ (Daumentaste oben) = nächster Kartenausschnitt

Polygon-Editor hier

Der Polygon-Editor wurde komplett neu programmiert und funktional erweitert. Insbesondere erfolgt das Darstellen von Punkten auf der Karte jetzt direkt aus dem Speicher und damit deutlich schneller (die Geschwindigkeit wird vor allem durch die Anzeige der Rasterkarten limitiert). Relevante Größenbeschränkungen für Polygone (Anzahl von Punkten) wurden aufgehoben. Die Exportmöglichkeiten wurden deutlich erweitert und erleichtern jetzt auch das Digitalisieren von

  • integriertes Fenster - alle Werkzeuge jetzt in einem Fenster vereint

    • Editier-Kontrolle (Steuerung des Zeichnens, Infos zum Polygon und Kontexthilfe)

    • Layer-Kontrolle (Verwaltung der geladenen Karten)

    • optionale Übersichtskarte

  • Layer-Kontrolle
    • Laden, Entfernen, Einpassen, Einfärben von Layern; Anzeigen von Attributen; Laden von Rasterkarten usw.
  • Drag & Drop von Polygon- und Shape-Dateien ins Fenster
  • Markieren, Löschen, Messen und Exportieren von Segmenten (Linien)
    • Tipp: Im Karten-Explorer können jetzt neben Polygonen auch Linien mit der rechten Maustaste angeklickt und in den Polygon-Editor geladen werden!
  • Exportieren von Polygonen und Segmenten (Linien)

    • als Shape-, KML-, GPX- oder WKT-Datei (Well known text)

      • KML-Dateien können zur Weitergabe von Restriktionszonen an externe Einrichtungen, Nachbarstaaten verwendet werden, da es ein standardisiertes Format ist
      • GPX-Dateien können

    • bei Aktivierung des Polygon-Editors über den Karten-Explorer (Menüpunkt "Extras - Polygon-Editor" oder Alt+P) kann das Exportieren als "neuer Layer" oder "zu bestehendem Layer hinzufügen" erfolgen, womit sich komplexe Strukturen wie Zaunabschnitte relativ einfach und in Etappen digitalisieren lassen

    • Export in die Zwischenablage als KML, GPX, Punkte und WKT
      • KML, GPX und Punkte können über den Menüpunkt "Erstellen - aus Zwischenablage" (Strg+V) im Karten-Explorer eingefügt werden.
  • Import bei Multipolygonen
    Bei Polygonen, die aus mehreren Teilen bestehen (z.B. Inseln, Exklaven), wird jetzt bei der Import-Funktion (und auch per rechtem Mausklick im Karten-Explorer) der angeklickte Teil separiert und importiert.
  • Schnappschuss-Funktion [image] hier
    • einfaches Sichern/Reaktivieren von Zwischenständen
    • Schnappschüsse werden als Polygon-Datei mit fortlaufendem Index gespeichert und können im Polygon-Editor simultan zum bearbeiteten Polygon angezeigt werden bzw. es ersetzen

Hilfesystem

  • Alternatives Hilfesystem
    Sollte der Zugriff auf das Hilfesystem vom Karten-Explorer(z.B. durch Systemeinstellungen bei Citrix-Umgebungen) blockiert sein, kann jetzt auf eine Webseite zugegriffen werden, die eine identische Hilfe enthält. Alternativ kann mit STRG+F1 die Hilfe jederzeit als Webseite aufgerufen werden.

    • Hinweis: Jede Tastenkombination mit gedrückter STRG-Taste ist möglich (ALT+STRG+F1, ↑+STRG+F1), was hilfreich ist, wenn STRG+F1 bei einer Umgebung bereits anderweitig verwendet wird.

  • Initialisierungsdatei [image] hier
    Die Initialisierungsdatei jetzt folgende Parameter in der Sektion [Optionen]:

    • Internetbrowser=…
      Es kann ein Browser angegeben werden, der bei Aufrufen von Internetadressen (KE-Online, Internethilfe, FLI-Maps) verwendet wird. Wird die angegebene Ressource nicht gefunden, wird weiterhin der beim Betriebssystem hinterlegte Standard-Internetbrowser verwendet.

    • Internethilfe=0/1

      • Internethilfe=0 (Beim Betätigen von F1 wird die lokale Hilfe (ke.chm) aufgerufen, STRG+F1 ruft die Internethilfe auf.)

      • Internethilfe=1 (Beim Betätigen von F1 wird die Internethilfe aufgerufen, STRG+F1 ruft die lokale Hilfe (ke.chm) auf.)

    • InternethilfeUrl=…
      Wird hier eine Internetadresse angeben, wird die HTML-Seite für die Kontexthilfe mit der angegeben URL aufgerufen. Damit ist es möglich, die Internethilfe auf ein alternatives Web umzulenken.


Nutzungsbedingungen

Nutzungsbedingungen des Karten-Explorers

Gegenstand des Vertrages:
Gegenstand des Vertrages ist das Computerprogramm Karten-Explorer sowie die Programmbeschreibung. Das FLI (Friedrich-Loeffler-Institut, https://www.fli.de) macht darauf aufmerksam, dass es nach dem Stand der Technik nicht möglich ist, Computer-Software so zu erstellen, dass sie in allen Anwendungen und Kombinationen fehlerfrei arbeitet. Gegenstand des Vertrages ist daher nur eine Software, die im Sinne der Programmbeschreibung und der Benutzungsanleitung grundsätzlich brauchbar ist.

Umfang der Benutzung:
Die FLI gewährt das uneingeschränkte Recht zur Nutzung zur wissenschaftlichen, behördlichen oder privaten Nutzung der Software. Eine weitergehende Nutzung (insbesondere kommerzielle) ist nicht zulässig.

Der Zugriff auf die Plattform des Tierseuchennachrichten-Systems TSN ist nur den Veterinärbehörden Deutschlands gestattet.

Die entsprechenden Zugangsdaten sind Dritten gegenüber geheim zu halten. Die auf der Plattform bereitgestellten Karten, insbesondere die Deutsche Topografische Karte 1:25.000 (DTK25) und Vektordaten für administrative Grenzen sind ausschließlich für die Tierseuchenbekämpfung bestimmt. Die Nutzung herunter geladener Karten zu anderen Zwecken ist nur erlaubt, wenn dies durch die Nutzungsverträge der jeweiligen Behörde mit dem zugehörigen Landesvermessungsamt gedeckt ist.

Die Dienste des BKG zur Geokodierung und Routenberechnung sind bei Verwendung des Karten-Explorers innerhalb der Domäne des FLI automatisch verfügbar. Alternativ können diese Dienste für die Dauer der Sitzung des Karten-Explorers über die Eingabe der Zugangsdaten zu TSN freigeschaltet werden. Zusätzlich ist es möglich, einen individuellen Freischaltcode vom Support des Karten-Explorers zu erhalten. Nutzen Sie dazu den Menüpunkt "Hilfe - Freischaltung anfordern" im Hauptfenster der Anwendung.

Dauer des Vertrages:
Der Vertrag läuft auf unbestimmte Zeit.

Schadensersatz bei Vertragsverletzung:
Die FLI macht darauf aufmerksam, dass Sie als Lizenznehmer für alle Schäden aufgrund von Urheberrechtsverletzungen haften, die dem FLI sowie weiteren Urhebern aus einer Verletzung dieser Vertragsbestimmungen durch Sie entstehen.

Gewährleistung und Haftung des FLI:
Die FLI übernimmt keine Gewähr dafür, dass die Software mit anderen von Lizenznehmer ausgewählten Programmen und Daten (GIS-Daten) zusammenarbeitet. Die Benutzung der Software erfolgt auf eigene Gefahr. Für Schäden oder Nachteile, die aus der Benutzung der Software resultieren, haftet der Lizenznehmer uneingeschränkt. Dies schließt eventuell durch die Manipulation von Karten und Daten mit dem Karten-Explorer (z.B. Koordinatentransformation oder das Bearbeiten von Attributen) verursachte Beschädigungen derselben ausdrücklich ein.

Bei der Nutzung des Karten-Explorers in Verbindung mit Softwareprodukten anderer Hersteller wie z.B. Google Earth oder Google Maps ist der Benutzer für die Einhaltung von Lizenzbedingungen der jeweiligen Hersteller und die Beachtung der Datenschutzbestimmungen der Behörden selbst verantwortlich. Dies gilt im Besonderen auch für die Einhaltung des Bundesdatenschutzgesetzes.


Karten-Explorer

Bildschirm anzeigen

Der Karten-Explorer ist ein komplexes und intuitives Werkzeug zum Visualisieren und Abfragen von kartografischen Informationen. Funktionalitäten Karten-Explorer. Falls Sie vorab einige Begriffe zum Karten-Explorer erläutert haben wollen, klicken Sie [image] hier. Nützliche Hinweise zu Tastatur, Maus sowie Drag&Drop finden Sie [image] hier.

Aufbau des Karten-Explorers

Menüleiste

Layer- Kontrolle Karten-Element
Maßstabs-
anzeige
Übersichts-
karte
Statusleiste

Die Abbildung zeigt schematisch die Untergliederung des Karten- Explorers in sechs Bereiche. Maßstabsanzeige und Übersichtsfenster können dabei optional aktiviert werden. Benutzen Sie die Hyperlinks, um direkt zu den Informationen zum jeweiligen Bereich zu gelangen.

Layer-Kontrolle

Ein Layer stellt eine geladene Karte dar. Es können beliebig viele Layer (Karten) geladen werden. Dabei steuert die Layer-Kontrolle deren

  • Sichtbarkeit,

  • Reihenfolge und

  • Eigenschaften (Einfärbung, Info-Feld)

... weitere Informationen zur Layer-Kontrolle finden Sie [image] hier

Maßstabsanzeige

Die Maßstabsanzeige kann mit Maßstab anzeigen ein- bzw. ausgeschaltet werden. Bei einem Doppelklick mit der Maus auf die Maßstabsanzeige wird ein Menü zur Auswahl von Maßstäben angezeigt. Alternativ dazu kann das Kontext-Menü (rechte Maustaste) der Maßstabsanzeige zur Auswahl von Maßstäben genutzt werden.

Übersichtskarte

Die Übersichtskarte erlaubt es, eine beliebige Karte in vollständiger Größe in einem gesonderten Fenster anzuzeigen. Diese korrespondiert mit den geladenen Karten im Karten-Element. Ein rotes Rechteck in der Übersichtskarte zeigt an, welcher Bereich im Karten-Element sichtbar ist. Dies ist insbesondere bei "gezoomter" Darstellung hilfreich.

Um eine Übersichtskarte zu aktivieren, klicken Sie mit der rechten Maustaste auf den gewünschten Layer in der Layer-Kontrolle und wählen Sie die Option "als Übersichtsfenster" aus dem angezeigten Kontext-Menü. Alternativ kann ein Layer per Drag&Drop aus der Layer-Kontrolle in die Übersichtskarte (bzw. bei nicht aktiver Übersichtskarte auf die Statusleiste) gezogen werden, um ihn als Übersichtskarte zu aktivieren. Um die Übersichtskarte zu deaktivieren, ist der Menüpunkt "Ansicht - Übersichtsfenster zurücksetzen" auszuwählen oder die rechte Maustaste im Übersichtsfenster zu betätigen (Menüpunkt "Übersichtsfenster zurücksetzen" im Kontextmenü).

Zoomen und Verschieben

Der sichtbare Kartenausschnitt des Karten-Elements kann über das Übersichtsfenster beliebig gezoomt oder verschoben werden. Zum Zoomen ist mit gedrückter linker Maustaste der gewünschte Bereich im Übersichtsfenster zu markieren.
Um den Kartenausschnitt zu verschieben, ist im Übersichtsfenster das Mausrad an der gewünschten Stelle zu drücken, ein Doppelklick mit der Maus an der gewünschten Stelle zu machen oder die rechte Maustaste (Menüpunkt "Ausschnitt hierher verschieben" im Kontextmenü) zu betätigen. Tipps & Tricks

Statusleiste

Die Statusleiste zeigt folgende Informationen:

  • aktiver Layer und Info-Feld
    Der aktive Layer ist der aktuell gewählte (hervorgehobene) Layer in der Layer-Kontrolle. Ist für den Layer ein Info-Feld gewählt, erscheint es in Klammern hinter dem Layer-Namen.

  • Skalierbereich für Rasterkarten
    Ist die Rasterkartenskalierung aktiviert (Rasterkarten werden nur innerhalb eines bestimmten Maßstabsbereiches eingeblendet), wird hier der Skalierbereich, innerhalb dessen die Karten sichtbar sind, eingeblendet.

  • TR, wenn im Menü "Ansicht" der Modus für transparente Rasterkarten aktiviert worden ist. Dieser Modus stellt eine wählbare Farbe von Rasterkarten transparent dar, um störende Überlappungen von Kartenblättern (so genannte Blattschnitte) zu eliminieren.

  • Kat, wenn über das Menü "Raster" ein [image] Raster-Katalog geöffnet worden ist.

  • "DG", wenn im Menü "Ansicht" die Karteneinheit Dezimalgrad ausgewählt worden ist.

  • Anzeige des gewählten Drucklayoutmodus
    Drucklayoutmodus ist nicht aktiv
    Hochformat
    Querformat
    Karte mit separater Legende, Nordpfeil und Maßstabsanzeige (nur Querformat)

  • Projektion
    Die aktuell eingestellte Projektion (z.B. "UTM, Zone 32") wird angezeigt.

  • Rechtswert und Hochwert

Ein Mausdoppelklick auf Bereiche der Statusleiste erlaubt den Zugriff auf folgende Optionen:

  • im Bereich aktiver Layer à Info-Felder ändern
  • im Bereich Skalierbereich à Einstellungen Skalierbereich für Rasterkarten ändern
  • im Bereich KAT à Einstellungen Rasterkatalog ändern
  • im Bereich Drucklayoutmodus à Drucklayoutmodus aktivieren und Drucker einrichten

Karten-Element

Im Kartenelement werden alle sichtbaren, geladenen Layer angezeigt. Dabei ist zu beachten, dass die Karten entsprechend ihrer Reihenfolge in der Layer-Kontrolle erscheinen, d.h., der oben befindliche Layer wird zuletzt gezeichnet. Rasterkarten werden bei aktiver Rasterkartenskalierung nur angezeigt, wenn sich der aktuelle Maßstab im eingestellten "Skalierbereich" befindet.

Mausfunktionen

  • linke Maustaste
    Die Funktion der linken Maustaste hängt vom im Menü Karte eingestellten Modus ab und wird durch folgende Mauskursor symbolisiert:
    Vergrößern (mit gedrückter linker Maustaste Rechteck in Karte ziehen),
    Verschieben, (mit gedrückter linker Maustaste Karte verschieben),
    Identifizieren (zu identifizierendes Geo-Objekt des aktiven Layers anklicken),
    Entfernung (Streckenpunkte in Karte „klicken“),
    Selektieren (zu selektierendes Geo-Objekt des aktiven Layers anklicken),
    Zeichnen (Klicken/Ziehen des Objektes abhängig vom Modus),
    Hyperlink (Mausklick öffnet einen mit Geo-Objekt verknüpften Hyperlink).

  • ↑ + linke Maustaste
    Diese Kombination erlaubt jederzeit das Verschieben der Karte mit gedrückter linker Maustaste.

  • Strg + linke Maustaste
    Diese Kombination erlaubt jederzeit das Verschieben der Karte mit gedrückter linker Maustaste.
    Ausnahme    : Im Modus "Georeferenzieren" gestattet diese Kombination das Georeferenzieren von Punkt-Objekten über sog. Basis-Dateien.
    Georeferenzieren von Punkten

  • Alt + linke Maustaste
    Führt eine Suche nach der Hausadresse (per Web-Service) an der geklickten Position aus und zeigt sie als Quickinfo an.
    Ausnahme: Im Zeichnenmodus (die Schaltfläche mit dem Stift ist in der Menüleiste aktiviert) wird das Zeichnen eines Geo-Objektes gestartet.
    Zeichnenmodus

  • Mausrad drehen

    • nach oben drehen = Karte nach oben verschieben

    • nach unten drehen = Karte nach unten verschieben

  • ↑ + Mausrad drehen

    • nach oben drehen = Karte nach links verschieben

    • nach unten drehen = Karte nach rechts verschieben

  • Strg + Mausrad drehen

    • nach oben drehen = Vergrößern

    • nach unten drehen = Verkleinern

  • Mausdoppelklick
    erlaubt das Selektieren mit der Maus von Geo-Objekten des aktiven Layers.

  • rechte Maustaste (Kontextmenü)
    Siehe unten!

Kontextmenü

  • Was ist hier? (Alt + W) führt eine [image] Umgebungssuche für die geklickte Mausposition aus.

  • vorheriger Kartenausschnitt (F9) bzw. nächster Kartenausschnitt (Strg + F9) bewirkt das "Blättern" innerhalb der Kartenausschnitte, die vor den letzten Zoom- oder Verschiebeaktionen angezeigt wurden.

  • Favoriten anzeigen (F8) aktiviert ein Auswahlmenü mit vordefinierten Kartenpositionen

  • Einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Karten-Elements.

  • Einpassen auf aktiven Layer bewirkt das optimale Einpassen des markierten (aktiven) Layers im Karten-Element.

  • mit Einpassen auf Geo-Objekt wird der Kartenausschnitt auf die Ausdehnung des an der Mausposition befindlichen Geo-Objektes (Polygon, Linie) des aktiven Layers eingepasst.

  • mit Karte hier zentrieren wird der Kartenausschnitt so eingepasst, dass sich die geklickte Mausposition in der Mitte befindet.

  • 2 x Vergrößern vergrößert die Karte zweifach an der geklickten Mausposition.

  • 2 x Verkleinern verkleinert die Karte zweifach.

  • 1:50.000, 1:25.000, 1:10.000 etc. zentriert die Karte an der Mausposition und zoomt sie auf den gewählten Maßstab; "Maßstab ..." erlaubt die Angabe eines beliebigen Maßstabes

  • Koordinaten umrechnen öffnet den Koordinaten-Rechner und initialisiert ihn mit den Koordinaten der geklickten Mausposition [image] Koordinaten umrechnen

  • in Zwischenablage kopieren (Alt + C) kopiert die Koordinaten an der geklickten Position in die Zwischenablage, von wo aus sie in andere Anwendungen (z.B. per Strg + V in Excel) eingefügt werden können.

  • zur Zwischenablage hinzufügen (↑ + Alt + C) fügt die Koordinaten an der geklickten Position zur Zwischenablage hinzu, so dass eine Liste von Koordinaten erstellt werden kann, die mit Strg + V in andere Anwendungen oder direkt im Karten-Explorer als neuer Layer eingefügt werden kann.

  • in Polygon-Editor laden startet den [image] Polygon-Editor und lädt das an der Mausposition befindliche Polygon des markierten (aktiven) Layers im Karten-Element.

  • Hyperlink aufrufen aktiviert einen eventuell vorhandenen Hyperlink zum an der Mausposition geklickten Geo-Objekt des aktiven Layers. Hyperlink aufrufen

Menüfunktionen

Datei (Alt + D)
Neuer Karten-Explorer (Alt + N) startet einen neuen Karten-Explorer.
Öffnen-Dialog anzeigen

Öffnen erlaubt es eine der folgenden Optionen zu aktivieren:

  • Neues Projekt (↑ + N),
  • Standard-Projekt (↑ + S),
  • Projekt öffnen (↑ + Ö),
  • Online-Abfrage (↑ + O) bzw.
  • Administrative Grenzen (↑ + A)
  • Öffnen-Dialog (Strg + Ö) zur Projektauswahl [image] hier
aktuelle Projekt-Einstellungen speichern | Speichern Projekt (F2) speichert alle aktuellen Einstellungen im aktuellen Projekt.
Speichern unter speichert alle Einstellungen als neues Projekt.
Schließen Projekt schließt das Projekt.
Drucker einrichten erlaubt die Auswahl von Drucker, Papierformat und Druckmodus mit bzw. ohne Legende. Drucker einrichten
Drucken | Drucken gibt die Karte auf dem Drucker aus. Karte drucken
Projektinformationen (Strg + P) gibt einen Überblick verschiedene Parameter des Projektes wie Titel, Dateiname, Zugriffspfade und Typen der geladenen Layer, Erstellungs- und Änderungsdatum usw. Projektinformationen
Projektion verwalten (↑ + P) erlaubt das Zuweisen und Ändern der Projektion (Koordinatensystem, Bezugssystem und Streifen) einzelner Layer bzw. des gesamten Projektes [image] Projektion verwalten
Beenden | Beenden schließt den Karten-Explorer.

Export (Alt + T) [image] Infos zum Exportieren
Karte in Zwischenablage kopieren | Karte in Zwischenablage (BMP) (Strg + C) übernimmt den Inhalt des Karten-Elements in die Zwischenablage. Das Format ( Bitmap) ist insbesondere Bilddaten (Rasterkarten) geeignet.
Karte in Zwischenablage (EMF) übernimmt den Inhalt des Karten-Elements in die Zwischenablage. Das Format (Enhanced Metafile) ist insbesondere Vektordaten (Punkte, Linien, Polygone) geeignet.
Tipp: Der Inhalt der Zwischenablage kann z.B. in Microsoft Word über "Bearbeiten - Inhalte einfügen" in Dokumente eingefügt werden.
Kartengröße in Zwischenablage skalieren erlaubt es, die Größe der in die Zwischenablage exportierten Karten von 50 bis 500% in Bezug zur Originalgröße zu skalieren.
Karte in Datei erlaubt die Ausgabe des Inhalts des Karten-Elements in eine Datei (Bitmap oder Metafile). Dabei kann die Bildgröße über einen Zoomfaktor variiert werden.
Tipp: Sollte der Ausdruck einer Karte mit der Druck-Funktion des Karten-Explorers nicht wie gewünscht funktionieren, kann die Karte ggf. als Datei exportiert und mit anderen Programmen ausgedruckt werden.
Legende in Zwischenablage (BMP) exportiert die Legende als Bitmap in die Zwischenablage.
Legende in Zwischenablage (EMF) exportiert die Legende als Windows Metadatei (Enhanced Metafile) in die Zwischenablage.
Tipp: Der Inhalt der Zwischenablage kann z.B. in Microsoft Word über "Bearbeiten - Inhalte einfügen" in Dokumente eingefügt werden. Des weiteren kann dieses Format nachträglich (z.B. mit Word) bearbeitet werden.
Koordinaten in Zwischenablage

  • in Zwischenablage kopieren (Alt + C) kopiert die Koordinaten an der Mausposition in die Zwischenablage, von wo aus sie in andere Anwendungen (z.B. per Strg + V in Excel oder im Karten-Explorer) eingefügt werden können.

  • zur Zwischenablage hinzufügen (↑ + Alt + C) fügt die Koordinaten an Mausposition zur Zwischenablage hinzu, so dass eine Liste von Koordinaten erstellt werden kann, die mit Strg + V in andere Anwendungen oder direkt im Karten-Explorer eingefügt werden kann.
GPX (GPS-Geräte) (Strg + X) ermöglicht es, geladene Shape-Dateien in das GPX-Format umzuwandeln, welches insbesondere von GPS-Geräten verarbeitet werden kann. GPX exportieren
KML (FLI-Maps) (Strg + K) gestattet die Ausgabe von Layern mit Einfärbungen und Attributen als KML-Datei zur Anzeige mit GIS-Anwendungen wie FLI-Maps, Google Earth und Google Maps, sowie das Speichern einer KML-Datei zur Weitergabe an externe Applikationen.
KML exportieren
Online-Projekt exportieren KEZ (Online-Projekt) (Strg + O) komprimiert geladenen Shape-Dateien in ein Online-Projekt (spezifisches Zip-Archiv), welches mit dem Karten-Explorer geöffnet werden kann.
Online-Projekt exportieren

Ansicht (Alt + A)
Drucklayoutmodus ein/aus | Drucklayoutmodus schaltet die Formatierung des Karten-Elements für die Ausgabe auf einen Drucker ein bzw. aus. Der Druck von Karten ist nur bei aktivem Drucklayoutmodus möglich. Karte drucken
Druckmaßstab festlegen passt den Maßstab im Karten-Element dahingehend an, dass beim Ausdruck ein exakt wählbarer Maßstab auf der Karte ausgedruckt wird. Druckmaßstab
Hintergrundfarbe erlaubt es, die Farbe des Hintergrundes im Karten-Element zu ändern.
Maßstab anzeigen (↑ + M) schaltet die Maßstabsanzeige ein bzw. aus.

Karteneinheit stellt das Koordinatensystem der geladenen Karten ein.

  • Meter
  • Dezimalgrad
Legende auf Karte anzeigen (Strg + L) zeigt eine Legende direkt auf der Karte an.
Legende
Legende positionieren (↑ + L) erlaubt es, mit gedrückter linker Maustaste eine neue Position der Legende im Karten-Element zu ziehen.
Legendengröße skalieren ermöglicht es, die Größe der Legende auf der Karte im Bereich von 25 bis 500% zu skalieren.
Feldbezeichnungen in Legende ausgeben entscheidet, ob bei der Einfärbung von Layern nach einem Attribut die Feldbezeichnung des verwendeten Attributs mit in der angezeigten, gedruckten oder exportierten Legende ausgegeben wird. Insbesondere bei Verwendung von Beschriftungen kann damit die Länge der Legende minimiert werden.
Legende mit Hintergrund (Strg + ↑ + L) schaltet Rahmen und Hintergrund für die Legende ein bzw. aus.
Legende in Fenster anzeigen (Alt + L) aktiviert ein separates Fenster, in dem eine Legende für alle geladenen Layer angezeigt wird.
Legende

Legende sortieren sortiert die Layer in der Layer-Kontrolle und Legende nach

  • Name (nur Vektordaten)
  • Typ (nur Vektordaten werden in der Reihenfolge Punkt, Linie, Polygon sortiert)
  • Name (alle Layer)
  • Typ (Reihenfolge Punkt, Linie, Polygon, Bilddateien)
Übersichtsfenster zurücksetzen (Strg + ↑ + Ü) entfernt die Übersichtskarte aus dem Karten-Explorer.
alle Karten ein schaltet alle Karten "sichtbar".
Hinweis: Rasterkarten werden bei aktiver Rasterkartenskalierung nur angezeigt, wenn sich der aktuelle Maßstab im eingestellten Skalierbereich befindet.
alle Karten aus schaltet alle Karten "nicht sichtbar".
alle Rasterkarten aus schaltet alle Rasterkarten "nicht sichtbar".
Entfernen aller Layer beseitigt alle Layer aus der Layer-Kontrolle.
Aktualisieren (F5) bewirkt einen Neuaufbau der Karten im Karten-Element. Dies ist i.d.R. erforderlich, wenn das Zeichnen der Karten mit der Esc-Taste abgebrochen worden ist.

Layer (Alt + Y)
vorhandenen Layer hinzufügen (Shapedatei, Coverage, Rasterkarte | .Hinzufügen (Strg + H) lädt existierende Shape-Dateien oder Bilddateien (Rasterkarten) und fügt sie der Layer-Kontrolle zu. Hierbei können per Mehrfachauswahl mit Strg+Mausklick im Dateiauswahl-Dialog gleichzeitig beliebig viele Dateien der unterstützten Formate geöffnet werden. Layer hinzufügen

Duplizieren erstellt ein Duplikat eines Layers, der auf einer Shape-Datei beruht.

  • Erneut laden lädt die Shape-Datei des markierten Layers erneut. Dies bietet sich an, wenn ein bereits geladener, der z.B. nach Klassen eingefärbt ist, zusätzlich beschriftet werden soll.
  • Kopie laden (Strg + D) erstellt eine Kopie der markierten Shape-Datei und lädt diese. Dies ist z.B. von Nutzen, wenn die Attribut-Tabelle eines Layers geändert werden soll, ohne das Original der Shape-Datei zu zerstören.
  • benutzerdefinierte Kopie (↑ + D) erstellt mit dem Shape-Konverter einen neuen Layer aus dem markierten Layer und gestattet es unter anderem die Struktur der Attributs-Datei zu modifizieren oder gezielt Geo-Objekte nach Attributen zu filtern. Shape-Datei konvertieren

Importieren (Alt + I) erstellt eine anpassbare Kopie einer externen Shape-Datei und lädt sie zur Nutzung im Karten-Explorer. Bei Bedarf wird die Shape-Datei in die momentan eingestellt Projektion überführt, inkompatible Feldnamen und Feldtypen werden umwandelt und wenn notwendig der Zeichensatz konvertiert. Shape-Datei konvertieren

Umbenennen (Strg + U) ändert den Namen eines Layers in der Layer-Kontrolle.
Tipp: Die Funktion kann auch mit einem einfachen Mausklick auf den Layer-Namen aktiviert werden.
Entfernen (Entf) beseitigt den markierten (aktiven) Layer aus der Layer-Kontrolle.
Speichern unter (Strg + ↑ + S) erlaubt das Abspeichern temporärer Layer unter einem wählbaren Namen als Shape-Datei. temporäre Layer
anderen Layer ersetzen (Strg + ↑ + E) erlaubt es, dass ein neuer (temporären Layer) einen anderen Layer des selben Typs (Punkt, Linie, Polygon) ersetzt. Damit ist es möglich, dass durch Verarbeitungsprozesse (z.B. Selektion, geometrische Operationen, Verknüpfen usw.) entstandene Layer, andere Layer überschreiben und dabei wahlweise die Einfärbung behalten oder die des ersetzten Layers übernehmen.
Exportieren ermöglicht es, die Shape-Datei eines Layers mit dem Shape-Konverter in ein anderes Laufwerk/Verzeichnis zu kopieren und dabei optional Projektion, Struktur und Zeichensatz zu ändern. Dies erlaubt die einfache Weitergabe von Daten an andere GIS-Anwendungen. Shape-Datei konvertieren
Einpassen auf aktiven Layer | Einpassen auf aktiven Layer bewirkt das optimale Einpassen des markierten (aktiven) Layers im Karten-Element.
Layer finden (Strg + F) identifiziert den markierten Layer auf der Karte, indem er ihn aufblinken lässt oder ggf. die Karte verschiebt, um ihn sichtbar zu machen.
Anfang (Alt + Pos1) bewegt den markierten Layer an die oberste Position in der Layer-Kontrolle.
Hoch (Alt + Nach-Oben) bewegt den markierten Layer in der Layer-Kontrolle nach oben
Tief (Alt + Nach-Unten) bewegt den markierten Layer in der Layer-Kontrolle nach unten.
Ende (Alt + Ende) bewegt den markierten Layer an die unterste Position in der Layer-Kontrolle.
als Übersichtsfenster (↑ + Ü) bewirkt die Anzeige des markierten Layers als Übersichtskarte.
Attribute bearbeiten

Attribute bietet die Möglichkeit,

  • (Strg + A) die Attribute des Layers anzuzeigen [image] Anzeigen

  • Attribute bearbeiten (Strg + B) die Attribute des Layers zu editieren [image] Bearbeiten

  • die Struktur der Attribut-Datei des Layers zu ändern [image] Struktur ändern
  • die Attribute zur Bearbeitung mit anderen Programmen zu exportieren. Exportieren
  • (↑ + C) die Attribute in die Zwischenablage zu exportieren [image] in Zwischenablage exportieren
T ransformieren (Strg + T) erlaubt es, die Projektion des Layers (Koordinatensystem, Bezugsdatum, Zentralmeridian) zu ändern sowie Struktur und Zeichensatz bei Bedarf anzupassen. Dies ist eventuell notwendig, um die Projektion von Shape-Dateien den verwendeten Rasterkarten anzupassen. Shape-Datei konvertieren
Layer-Statistik | Layer-Statistik (Alt + S) zeigt ein Fenster mit detaillierten Informationen zum markierten Layer und dessen Merkmalsdatei (bei Vektordaten). Layer-Statistik
Layer-Vorlage lädt oder erstellt Vorlagen (Schablonen), die Informationen zur Einfärbung von Layern enthalten. Layer-Vorlage
  • Laden einer Layer-Vorlage
  • aktuelle Einstellungen des Layers as Layer-Vorlage speichern
  • Importieren einer Layer-Vorlage
  • Exportieren einer Layer-Vorlage
  • (↑ + V) Vorlagen-Bibliothek aufrufen [image] Vorlagenbibliothek
Anzeigebereich erlaubt es, jedem Layer einen individuellen Maßstabsbereich zuzuordnen, innerhalb dessen er angezeigt werden soll. Anzeigebereich
Info-Felder | Info-Feld (Strg + I) aktiviert bis zu drei beliebiges Felder der Attribut-Datei eines Layers dergestalt, dass für das an der Mausposition befindliche Geo-Objekt die gewählten Informationen als Tooltipp (Quick-Info) angezeigt werden, sofern der Layer in der Layer-Kontrolle markiert ist. Info-Felder auswählen
Eigenschaften für Einfärbung Einfärbung (Strg + E) aktiviert den Dialog zum Einfärben des Layers, mit dem das Erscheinungsbild (Farben, Klassifizierungen, Beschriftungen usw.) des Layers geändert werden können. Eigenschaften für Einfärbung
Tipp: Die Funktion kann auch durch Doppelklick auf den jeweilige Layer-Namen in der Layer-Kontrolle aktiviert werden.

Karte (Alt + K)
gesamte Karte einpassen | Karte einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Kartenelements.
Vorheriger Kartenausschnitt (F9 oder Maustaste↓ (Daumentaste unten)) bewirkt die Anzeige des Kartenausschnittes, der vor der letzen Zoom- oder Verschiebeaktion angezeigt wurde (Zurückblättern).
Nächster Kartenausschnitt (Strg + F9 oder Maustaste↑ (Daumentaste oben)) bewirkt die Anzeige des nächsten Kartenausschnittes nach dem "Zurückblättern".
Vergrößern | Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.
2x Vergrößern (+ auf Zehnertastatur) vergrößert den Kartenausschnitt zweifach.
Verkleinern | 2xVerkleinern (- auf Zehnertastatur) reduziert die Größe der Karte zweifach.
Karte verschieben Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen.
Tipp: Mit Strg + gedrückter linker Maustaste kann die Karte jederzeit verschoben werden.
Geo-Objekt identifizieren | Identifizieren (↑ + I) zeigt alle in der Merkmalsdatei vorhandenen Informationen zum mit der linken Maustaste angeklickten Geo-Objekt an. Geo-Objekte identifizieren, [image] Suchen und Identifizieren
Geo-Objekte suchen | Suchen (Strg + S) startet einen Dialog, mit dem Geo-Objekte in den Merkmalsdateien der Layer gesucht und auf der Karte gezeigt werden. Damit ist z.B. die gezielte Suche nach Betrieben möglich. Geo-Objekte suchen, [image] Suchen und Identifizieren

Selektieren (Alt + S) [image] Geo-Objekte selektieren
Mausklick (Strg + M) öffnet das Selektieren-Fenster und erlaubt es, Geo-Objekte des aktiven Layers per Mausklick zu selektieren und in einem neuen Layer zu speichern. Selektieren per Mausklick
Räumlich ermöglicht es, Geo-Objekte eines Layers anhand räumlicher Bedingungen, zu extrahieren und in einem neuen Layer zu speichern. Räumlich
Liste ermöglicht es, Geo-Objekte eines Layers durch Auswahl aus einer Liste (Attribute-Datei) zu extrahieren und in einem neuen Layer zu speichern. Liste
Abfrage ermöglicht es, Geo-Objekte eines Layers per SQL-Abfrage zu extrahieren und in einem neuen Layer zu speichern. Abfrage

mit Rechteck aktiviert den Zeichnenmodus zum Ziehen eines Rechtecks mit gedrückter Maustaste (links oben nach rechts unten). Alle Geo-Objekte des aktiven Layers werden im Anschluss selektiert, sofern sie dem Suchmodus (gewählten Menüpunkt im Untermenü) entsprechen:

  • innerhalb oder geschnitten → selektiert alle Geo-Objekte die im Rechteck sind oder von ihm geschnitten werden!

  • innerhalb → selektiert alle Geo-Objekte, die vollständig im Rechteck enthalten sind!
  • geschnitten → selektiert alle Geo-Objekte, die vom Rechteck geschnitten werden!

mit Kreis aktiviert den Zeichnenmodus zum Ziehen eines Kreises (Mausklick auf Mittelpunkt und Radius mit gedrückter Maustaste ziehen). Alle Geo-Objekte des aktiven Layers werden im Anschluss selektiert, sofern sie dem Suchmodus (gewählten Menüpunkt im Untermenü) entsprechen:

  • innerhalb oder geschnitten → selektiert alle Geo-Objekte die im Kreis sind oder von ihm geschnitten werden!

  • innerhalb → selektiert alle Geo-Objekte, die vollständig im Kreis enthalten sind!
  • geschnitten → selektiert alle Geo-Objekte, die vom Kreisbogen geschnitten werden!

mit Polygon aktiviert den Zeichnenmodus zum Ziehen eines Polygons (Mausklick auf jeden gewünschten Punkt, Doppelklick auf den letzten Eckpunkt beendet das Zeichnen). Alle Geo-Objekte des aktiven Layers werden im Anschluss selektiert, sofern sie dem Suchmodus (gewählten Menüpunkt im Untermenü) entsprechen:

  • innerhalb oder geschnitten → selektiert alle Geo-Objekte die im Polygon sind oder von ihm geschnitten werden!

  • innerhalb → selektiert alle Geo-Objekte, die vollständig im Polygon enthalten sind!
  • geschnitten → selektiert alle Geo-Objekte, die vom Polygon geschnitten werden!Alternativ köännen

Erstellen (Alt + E) [image] Infos zum Erstellen von Layern
Abfrage ZTSDB (↑ + Z) erstellt Layer aus einer Online-Abfrage der Zentralen Tierseuchendatenbank über einen Web-Service.
Layer durch Abfrage der ZTSDB erstellen
Grid (↑ + G) erlaubt die Erstellung eines Layers mit Zellen wählbarer Kantenlänge.
Grid erstellen
Hexagon (↑ + H) erlaubt die Erstellung eines Layers mit regelmäßigen Sechsecken wählbarer Kantenlänge.
Hexagon erstellen
Punktdichte erstellt einen Multipoint-Layer mit zufällig verteilten Punkten auf Grundlage eines geladenen Polygon-Layers.
Punktdichte erstellen
aus Zwischenablage (Strg + V)
Der Karten-Explorer kann einen neuen Layer oder eine dBase-Datei aus einer Tabelle zu erzeugen, die sich in der Zwischenablage befindet.
 aus Zwischenablage erstellen
aus dBase-Datei
Der Karten-Explorer kann aus jeder dBase-Datei, die Spalten mit Koordinaten enthält (Rechtswert, Hochwert) einen Layer erstellen und anzeigen. Damit können z.B. externe Programme beliebige Abfragen in Form von dBase-Dateien erstellen und zur Anzeige auf Karten an den Karten-Explorer übergeben. Layer aus dBase-Datei erstellen
aus Text-Datei / CSV (↑ + T)
Der Karten-Explorer kann Text-Dateien (CSV-Datei mit Trennzeichen für Spalten wie Tabulator, Semikolon oder Komma) einlesen und über Spalten mit Koordinaten (Rechtswert, Hochwert) einen Layer erstellen und anzeigen. aus Textdatei erstellen
aus GPX-Datei (↑ + X)
Der Karten-Explorer kann GPX-Dateien (z.B. von GPS-Empfängern) einlesen und als Layer erstellen und anzeigen. aus GPX-Datei erstellen
aus KML-Datei (↑ + K)
Der Karten-Explorer kann KML-Dateien einlesen und als Layer erstellen und anzeigen. aus KML-Datei erstellen

aus Polygondatei erstellt Layer aus Polygondateien, die mit dem Polygon-Editor gezeichnet wurden. Alternativ können Polygondateien per Drag&Drop in das Fenster des Karten-Explorers geladen werden.

Raster [image] Infos zu Rasterkarten hinterlegen
Raster hinterlegen (Strg + R) lädt genau die topografischen Karten, die für den "aktuellen Bildschirmausschnitt" erforderlich sind. Rasterkarten hinterlegen

Übersichtskarte hinterlegen (Strg + Ü) lädt eine topografische Übersichtskarte (gesamte Bundesrepublik im Maßstab 1:200.000 bzw. 1:500:000), die zur Orientierung bei größeren Gebieten (Betrachtungsabständen) dient.

Rasterkartenskalierung (Strg + ↑ + R) aktiviert bzw. deaktiviert die Anzeige von Rasterkarten in Abhängigkeit vom aktuellen Maßstab. Damit werden die Rasterkarten (bei aktivierter Funktion) nur angezeigt, wenn der aktuelle Maßstab innerhalb des eingestellten Skalierbereiches ist. Standardmäßig ist die Rasterkartenskalierung aktiviert!
Skalierbereich stellt den Maßstabbereich ein, innerhalb dessen die Rasterkarten bei aktiver Rasterkartenskalierung angezeigt werden. Der als Vorgabe eingestellte Bereich ist 1:5.000 bis 1:50.000.
transparente Rasterkarten stellt eine wählbare Farbe von Rasterkarten (Bilddateien) transparent dar. Diese Funktion sollte ausschließlich bei Rasterkarten mit Rändern (Blattschnitt) aktiviert werden, um störende Randstreifen (Überlappungen) zu vermeiden.
Transparenzfarbe festlegen gibt an, welche Farbe bei der transparenten Darstellung von Rasterkarten nicht dargestellt werden soll (i.d.R ist es weiß oder schwarz).
Entfernen aller Rasterkarten (↑ + R) entfernt alle Rasterkarten aus der Layer-Kontrolle

Raster-Katalog erlaubt das

  • Öffnen,
  • Schließen und
  • Erstellen/Bearbeiten von Raster-Katalogen.

Raster-Katalog

Aktualisieren (F11) bewirkt das automatische Hinterlegen des aktuellen Kartenausschnitts mit Rasterkarten aus dem geöffneten Raster-Katalog.

Extras
Entfernung bestimmen | Entfernung bestimmen (↑ + E) aktiviert das Messen von Entfernungen. Per Mausklick wird der Anfangspunkt festgelegt, Zwischenpunkte können durch weitere Mausklicks gesetzt werden. Die Funktion wird durch Doppelklick mit der Maus beendet und die Streckenlänge sowie die Luftlinie zwischen Anfangs- und Endpunkt angezeigt.
Zeichnenmodus Zeichnen
Es wird der Modus zum Zeichnen geometrischer Objekte aktiviert. Unter Zeichnenmodus wird festgelegt, ob ein Kreis, ein Rechteck, ein Polygon usw. gezeichnet werden soll. Zeichnenmodus
Verknüpfen erlaubt die Erstellung neuer Layer unter Verknüpfung vorhandener Layer bzw. externer dBase-Dateien [image] Verknüpfen

Attribute ( [image] Attribute manipulieren) bietet die Möglichkeit,

  • die Attribute einer Shape-Datei zu editieren [image] Bearbeiten
  • die Struktur der Attribute-Datei einer Shape-Datei zu ändern [image] Struktur ändern
  • Attribute zur Bearbeitung mit anderen Programmen zu exportieren. Exportieren
  • Attribute in die Zwischenablage zu exportieren [image] in Zwischenablage exportieren
Georeferenzieren erlaubt das Georeferenzieren von Punkt-Objekten über sog. Basis-Dateien. Georeferenzieren von Punkten
Mit Öffnen Basisdatei wird eine vorhandene Basisdatei geöffnet. Koordinaten können mit der Kombination Umschalten + linke Maustaste digitalisiert werden. Über Erstellen Basisdatei kann eine neue Basisdatei generiert werden. Shape-Datei erzeugen wandelt eine Basisdatei in eine Shape-Datei um, die z.B. über den Menüpunkt "Layer - Layer hinzufügen" geladen werden kann.
Polygon-Editor (Alt + P) aktiviert das Zeichenwerkzeug zum Erstellen bzw. Editieren von Polygonen (Sperrgebieten), die in sog. Polygon-Dateien (*.plg) abgelegt werden. Polygon-Editor
Shape-Datei transformieren erlaubt es, die Projektion von Shape-Dateien (Koordinatensystem, Bezugsdatum, Zentralmeridian) und/oder die Struktur der Attributs-Datei zu ändern. Shape-Datei konvertieren
Koordinaten umrechnen (↑ + U) aktiviert eine Programmfunktion, die das manuelle Umrechnen von Koordinaten (Koordinatensystem, Bezugsdatum, Zentralmeridian) erlaubt. Des weiteren diese Programmfunktion über die rechte Maustaste im Karten-Element (Kontextmenü) aktiviert werden. Dabei werden die geklickten Koordinaten automatisch in den Koordinatenrechner übernommen.
Koordinaten umrechnen
dBase-Datei bearbeiten gestattet das Öffnen und Bearbeiten von dBase-Dateien.
dBase-Datei bearbeiten
Geometrische Operationen stellt Funktionen zur Verfügung, um Geo-Objekte zu puffern, zusammenzufassen, aufzulösen (Überlappungen entfernen) oder auszuschneiden. Geometrische Operationen

Punkte puffern erlaubt es, um die Geo-Objekte eines wählbaren Punkte-Layers Radien (Puffer) zu bilden und in einem separaten Layer abzuspeichern. Puffer erstellen

Analyse - Flächenanteile erlaubt es durch Verschneidung von zwei Layern Berechnungen von Flächenanteilen wie Wald-, Wiesen-, Ackerfläche je Gemeinde etc. durchzuführen. Flächenanteile, Längenanteile
Geokodierung (Alt + G) gestattet es, über Geokodierung von Adressangaben Koordinaten zu ermitteln. Geokodierung
Umgebungssuche (Alt + U) führt eine [image] Umgebungssuche für Koordinaten aus. Mit Alt + W (Was ist hier?) geschieht dies für die aktuelle Mausposition auf der Karte.
Routenberechnung (Alt + B) erlaubt die Berechnung von Routen zwischen Wegepunkten. Routenberechnung
Maßstab justieren kalibriert die Maßstabsanzeige des Karten-Explorers für die aktuelle Bildschirmgröße.
Windows-Explorer anzeigen (Strg + W) öffnet den Windows-Explorer (Startverzeichnis ist das voreingestellte Verzeichnis für Projekte).

Favoriten
zu Favoriten hinzufügen (F7) speichert die aktuelle Kartenposition in der Liste der Favoriten ab.
Favoriten verwalten erlaubt es, Favoriten zu löschen bzw. umzubenennen. Favoriten
Favoriten anzeigen (F8) aktiviert ein Auswahlmenü mit vordefinierten Kartenpositionen.


Begriffe - Karten-Explorer

Projekt (Karten-Projekt)
Ein Karten-Projekt umfasst alle Informationen zu geladenen Layern, deren Einfärbung, Sichtbarkeit und Reihenfolge. Diese können in einer Datei (*.kep für "Karten-Explorer-Projekt") gespeichert und komplett wieder hergestellt werden.

Online-Projekt
Ein Online-Projekt speichert alle geladenen Layer (nur Shape-Dateien) und alle Einfärbungsoptionen in einer einzigen komprimierten Datei (*.kez für "Karten-Explorer-Zip"), die mit dem Karten-Explorer geladen werden kann. Dies ist der effizienteste Weg zur elektronischen Übertragung (Email) und Archivierung von Vektordaten.

Layer - aktiver Layer
Ein Layer stellt eine geladene Karte (eine Shape-Datei, eine ARC/INFO-Datei oder eine Rasterkarte) dar. Diese erscheinen in der [image] Layer-Kontrolle. Der in der Layer-Kontrolle markierte Eintrag ist der aktive Layer.

Geo-Objekt
Ein Geo-Objekt stellt abhängig vom Typ des Layers einen Punkt, eine Linie oder eine Fläche dar.

Info-Feld
Zu einem Layer, der Vektordaten enthält (Punkte, Linien, Polygone), existiert eine Merkmalsdatei, die für jedes Geo-Objekt Informationen speichert. Aus dieser Merkmalsdatei kann ein beliebiges Feld ausgewählt werden. Ist der Layer aktiv, wird im Karten-Element diese Information zum an der Mausposition befindlichen Geo-Objekt als Tooltipp (Quick-Info) angezeigt.

Rasterkartenskalierung - Skalierbereich
Rasterkarten werden (bei aktivierter Funktion) nur angezeigt, wenn der aktuelle Maßstab innerhalb des eingestellten Skalierbereiches ist. Damit kann der Aufbau von Karten bei höherem Maßstab (großer Betrachtungsentfernung) erheblich beschleunigt werden. Rasterkarten werden nur beim "Hineinzoomen" in die Karte eingeblendet.

Der Skalierbereich stellt den Maßstabbereich ein, innerhalb dessen die Rasterkarten bei aktiver Rasterkartenskalierung angezeigt werden. Der voreingestellte Bereich ist 1:5.000 bis 1:50.000.


Karten-Explorer - Tastatur und Maus

Tastatur und Maus

Tastenfunktionen

Aktion | Taste | Aktion | Taste
Attribute |  | Layer
Anzeigen | Strg + A | Ersetzen | ↑ + Strg + E
Bearbeiten | Strg + B | Finden | Strg + F
in die Zwischenablage | ↑ + C | Hinzufügen | Strg+H / Einfg
Erstellen von Layern |  | Importieren | Alt + I
aus GPX-Datei | ↑ + X | Info-Feld | Strg + I
Grid | ↑ + G | Speichern | ↑ + Strg + S
Hexagon | ↑ + H | Transformieren | Strg + T
aus KML-Datei | ↑ + K | Umbenennen | Strg + U
aus Textdatei (CSV) | ↑ + T | Vorlage für Einfärbung | ↑ + V
Abfrage ZTSDB | ↑ + Z | Entfernen | Entf
aus Zwischenablage | Strg + V | Legende
Fenster |  | Ein/Aus | Strg + L
Entfernung messen | ↑ + E | Positionieren | ↑ + L
Geokodierung | Alt + G | in separatem Fenster | Alt + L
Identifizieren | ↑ + I | mit Hintergrund | ↑ + Strg + L
Koordinaten umrechnen | ↑ + U | Projekt
neuer Karten-Explorer | Alt + N | Admin. Grenzen laden | ↑ + A
Polygon-Editor | Alt + P | Standard-Projekt laden | ↑ + S
Routenberechnung | Alt + B | Neues (leeres) Projekt | ↑ + N
Selektieren Mausklick | Strg + M | Online-Projekt laden | ↑ + O
Suchen | Strg + S | Öffnen-Dialog | Strg + Ö
Umgebungssuche | Alt + U | Projekt öffnen | ↑ + Ö
Was ist hier? | Alt + W | Projektinformation | Strg + P
Windows-Explorer | Strg + W | Projektion verwalten | ↑ + P
Export |  | Speichern | F2
GPX (GPS-Geräte) | Strg + X | Raster
Karte in Zwischenablage | Strg + C | Entfernen | ↑ + R
KEZ (Online-Projekt) | Strg + O | Hinterlegen | Strg + R
KML (z.B. FLI-Maps) | Strg + K | Rasterkartenskalierung | ↑ + Strg + R
Koordinaten in Zwischenablage | Alt + C | Übersichtskarte | Strg + Ü
Layer |  | Maßstab und Übersicht
Duplizieren (einfache Kopie) | Strg + D | Maßstab ein/aus | ↑ + M
Duplizieren (Shape-Konverter) | ↑ + D | als Übersichtsfenster | ↑ + Ü
Einfärben | Strg+E / Enter | Übersicht schließen | ↑ + Strg + Ü

Sichtbarkeit und Reihenfolge mit Tastatur und Maus

Aktion | Taste / Maus
aktiven Layer hoch | Alt + Pfeil↑
aktiven Layer tief | Alt + Pfeil↓
aktiven Layer an Anfang | Alt + Pos1
aktiven Layer ans Ende | Alt + Ende
Alle Layer sichtbar | Strg + Mausklick auf
Alle Layer nicht sichtbar | Strg + Mausklick auf
Nur diesen Layer sichtbar | ↑ + Strg + Mausklick auf [image] oder
Karte aktualisieren | F5
Zeichnen der Karte abbrechen | ESC

Vergrößern und Verkleinern mit Tastatur und Maus

Aktion | Taste / Maus
Karte vergrößern | Zehnertastatur+ oder Strg + Mausrad↑
Karte verkleinern | Zehnertastatur+ oder Strg + Mausrad↓
Einpassen auf aktiven Layer | Strg + Zehnertastatur+
Maßstab 1: 25.000 | ↑ + Zehnertastatur+
Einpassen der gesamten Karte | Strg + Zehnertastatur-
Karte aktualisieren | F5
Zeichnen der Karte abbrechen | ESC

Verschieben der Karte

Aktion | Taste / Maus
Karte nach oben verschieben | Mausrad↑
Karte nach links verschieben | ↑ + Mausrad↑ oder Mausrad←
Karte nach unten verschieben | Mausrad↓
Karte nach rechts verschieben | ↑ + Mausrad↓ oder Mausrad→
Karte verschieben | ↑ + linke Maustaste oder Strg + linke Maustaste
Vorheriger Kartenausschnitt | F9 oder Maustaste↓ (Daumentaste unten)
Nächster Kartenausschnitt | F10 oder Maustaste↑ (Daumentaste oben)

Drag & Drop

Folgende Möglichkeiten bestehen, Dateien oder Layer per Drag&Drop (Ziehen mit gedrückter Maustaste und "Fallenlassen") zu verarbeiten:

  • Drag & Drop von Dateien aus einem Windows-Explorer in den Karten-Explorer oder Einfügen aus Zwischenablage mit Strg + V
    • *.KEP → Laden eines Karten-Explorer-Projekts
    • *.KMZ, *.ZIP → Laden eines Online-Projektes
      • Ausnahme: enthält das Zip-Archiv genau eine CSV-Datei, wird ein Export aus der ZTSDB (TSN-Online) angenommen und versucht, einen Layer aus der Textdatei zu erstellen!
    • *.SHP → Laden einer oder mehrerer Layer
      • Ausnahme: Wird genau einer SHP-Datei mit gedrückter linker Maustaste eingefügt, wird die Shape-Datei importiert [image] Shape-Konverter
    • *.JPG, *.JPEG, *.BMP, *.TIF, *.TFF, *.TIFF, *.SID → Laden einer oder mehrerer Layer
    • *.PLG → Erstellen eines Layers aus einer Polygon-Datei
    • *.CSV/*.TXT → Erstellen eines Layers oder einer dBase-Datei
    • *.KML → Erstellen eines Layers aus KML
    • *.GPX → Erstellen eines Layers aus GPX (GPS-Geräte)
    • *.DBF → Erstellen eines Layers oder Bearbeiten einer dBASE-Datei
    • *.KEL → verwendet die Einfärbung einer KEL-Datei (Layer-Vorlage) für den aktiven Layer
  • Drag & Drop von Dateien in das [image] Selektieren-Fenster
    • *.SHP oder *.PLG aus dem Windows-Explorer → Einfügen der Geo-Objekte einer oder mehrerer Shape- oder Polygon-Dateien
    • Layer aus der Layer-Kontrolle
      →       Einfügen der Geo-Objekte des Layers
      • Sonderfall: bei gedrückter STRG- oder ↑-Taste) ® Geo-Objekte im Selektieren-Fenster anhand des Layers markieren:
        STRG + Drop & Drop
        ®         Geo-Objekte markieren, die sich vollständig innerhalb des Layers befinden.
        ↑ + Drop & Drop
        ®         Geo-Objekte markieren, die sich innerhalb des Layers befinden oder von ihm geschnitten werden.
  • Drag & Drop von Layern aus der Layer-Kontrolle
    • In die Übersichtskarte des eigenen Karten-Explorers ® verwendet den Layer als Übersichtsfenster
      Hinweis: ist keine Übersichtskarte sichtbar, kann der Layer in die Statuszeile gezogen werden.
    • in das Selektieren-Fenster des eigenen Karten-Explorers (siehe Erläuterungen im vorherigen Absatz)
    • in ein anderes Karten-Explorer-Fenster ® öffnet den Layer im anderen Karten-Explorer
    • in das Anwendungsfenster (innerhalb der Anwendung, aber außerhalb eines Karten-Explorer-Fensters)
      ®       öffnet den Layer in einem neuen Karten-Explorer-Fenster
    • in ein Fenster zur Routenberechnung ® übernimmt die Koordinaten eines Punkte-Layers als Wegepunkte zur Routenberechnung

    • in das Karten-Element des eigenen Karten-Explorers ® erstellt eine benutzerdefinierte Kopie des Layers [image] Shape-Konverter

    • auf den Windows-Desktop (aus dem Anwendungsfenster heraus) ® exportiert den Layer [image] Shape-Konverter


Projektauswahl - Karten-Explorer

Öffnen-Dialog (Projektauswahl)

Bildschirm zeigen

Das Fenster zur Projektauswahl bietet verschiedene Möglichkeiten zum Öffnen eines Projektes an, die auch unter den Menüpunkten unter "Datei - Öffnen" des Karten-Explorers verfügbar sind. Der Aufruf der Projektauswahl ist im Karten-Explorer über die Schaltfläche [image] oder die Tastenkombination Strg + Ö möglich.

Durch Anklicken eines der folgenden Symbole sind folgende Optionen verfügbar:

Standard Projekt (Alt + S, Strg + S oder ↑ + S)
Betätigen Sie diese Option, wenn Sie Ihr Standardprojekt laden wollen!
Unter dem Menüpunkt "Einstellungen - Standardprojekt" im Hauptfenster werden alle Karten "angemeldet", die standardmäßig geladen werden sollen. Dies sind für Kreisämter i.d.R. die Gemeindegrenzen und die topografischen Karten für das Kreisgebiet. Mit der Schaltfläche Einstellungen kann die Programmfunktion [image] Einstellungen - Standardprojekt direkt im Fenster der Projektauswahl aufgerufen werden.

zuletzt geöffnete Projekte

Der Karten-Explorer ist in der Lage, alle Einstellungen zu Projekten wie geladene Layer, deren Einfärbung usw. in Dateien vom Typ *.kep für Karten-Explorer-Projekt zu speichern.
Die Liste der zehn zuletzt geöffneten Projekte des Mandanten wird im Listenelement "zuletzt geöffnete Projekte" angezeigt. Ein Projekt aus der Liste kann auf Knopfdruck (Eingabetaste oder Doppelklick mit der Maus) geöffnet werden. Über ein Kontextmenü (Klick mit der rechten Maustaste in die Liste) kann ein Eintrag oder die gesamte Liste gelöscht werden.

neues Projekt (Alt + N, Strg + N oder ↑ + N)
Es wird mit einem neuen Projekt begonnen, es sind keine Layer geladen.

bestehendes Projekt öffnen (Alt + B, Strg + B oder ↑ + B)
Bestehende Projekte (*.kep) können mit dieser Schaltfläche geladen werden.

Online-Projekt laden (Alt + O, Strg + O oder ↑ + O)
Diese Funktion lädt spezielle Zip-Archive, die mit dem Menüpunkt [image] "Export - Online-Projekt" des Karten-Explorers erstellt werden (*.kez für Karten-Explorer-Zip), mit denen auf einfache Weise Karten (Shape-Dateien) archiviert oder an andere Einrichtungen per Email zwecks Weiterverarbeitung mit dem Karten-Explorer übergeben werden können. Online-Projekt exportieren

Administrative Grenzen laden (Alt + A, Strg + A oder ↑ + A)
Die administrativen Grenzen der Bundesrepublik (Länder, Regierungsbezirke, Kreise) werden mit dieser Funktion geladen. Außerdem kann das anfängliche Erscheinungsbild der durch diese Funktion geladenen Karten generell über den Menüpunkt "Einstellungen - TSN-Kompatibilität" im Hauptfenster festgelegt werden. Einstellungen - TSN


Layer-Kontrolle - Karten-Explorer

Layer-Kontrolle

Die Layer-Kontrolle enthält alle geladenen Karten und erlaubt es, deren Sichtbarkeit, Reihenfolge und Einfärbung zu steuern.

a ) Vektordateien (Shape-Datei)
Vektordaten (Punkte, Linien, Flächen) werden in der Layer-Kontrolle mit fettem Layer-Namen und mit ihrer Einfärbung (Symbologie) dargestellt, wobei die Art des Layers an der dargestellten Symbologie erkennbar ist, z.B. Rechtecke für Flächen-Layer. Die Symbologie kann über die Schaltflächen [image] / [image] auf- bzw. zugeklappt werden.

Der aktive Layer ist der selektierte Layer (hier: Betriebe im Sperrgebiet)

grüner Rand = für den betreffenden Layer wurde (mindestens) ein Info-Feld definiert
roter Punkt = Layer wurde neu erstellt und bisher nicht gespeichert [image] temporäre Layer
Layer ist "sichtbar" geschaltet
Layer ist "nicht sichtbar" geschaltet
Layer ist "sichtbar" geschaltet, befindet sich aber nicht im definierten Anzeigebereich des Layers

Per Mausklick auf diese Schaltflächen kann die Symbologie eines Layers auf- und zugeklappt werden
Mit Strg + Mausklick auf diese Schaltflächen wird die Symbologie aller Layer auf- bzw. zugeklappt.

b) Bilddatei-Formate (MrSID, Tiff-Datei, Bitmap usw.)
Bilddateien (auch Rasterkarten) sind am nicht fett dargestelltem Layer-Namen und der fehlenden Symbologie (keine Schaltflächen [image] / [image]) erkennbar. Der Status der Sichtbarkeit ist wie bei Vektordateien über [image], [image], [image] erkennbar.

weißes Rechteck = der betreffenden Layer wurde über einen Raster-Katalog geladen

Sichtbarkeit und Reihenfolge

Sichtbarkeit
Die Sichtbarkeit von einzelnen Layern wird über das Kontrollkästchen [image] / [image] neben dem Layer gesteuert. Dieses Kontrollkästchen kann per Mausklick oder die Leertaste umgeschaltet werden.

Soll die Sichtbarkeit von mehreren Layern gleichzeitig geändert werden (alle ein, alle aus, alle Rasterkarten aus), kann dies über das Menü "Ansicht" oder ein Kontext-Menü der Layer-Kontrolle erfolgen. Dabei wird der wiederholte Neuaufbau der Karte vermieden. Alternativ können alle Layer über Strg-Mausklick auf ein [image] ausgeschaltet und per Strg-Mausklick auf ein [image] eingeschaltet werden.

Aktion läuft

Bei aktivierter Rasterkartenskalierung Rasterkarten nur innerhalb Skalierbereich einblenden werden die geladene Bilddateien (Rasterkarten) nur innerhalb des eingestellten Skalierbereiches (wird in Statusleiste angezeigt) angezeigt, auch wenn sie in der Layer-Kontrolle "sichtbar" geschaltet sind. Außerdem kann jedem Layer ein individueller Anzeigebereich zugeordnet werden. Befindet sich der aktuelle Maßstab außerhalb des Bereichs, wird der Layer ausgeblendet, was durch das Symbol [image] signalisiert wird.

Reihenfolge
Die Reihenfolge der Layer in der Layer-Kontrolle ist entscheidend für die Reihenfolge, in der die Layer vom System gezeichnet werden. Dabei überlagern Informationen (Geo-Objekte) eventuell darunter liegende Informationen. Der oberste Layer in der Layer-Kontrolle ist gleichzeitig der Layer der auf der Karte "oben" liegt und somit zuletzt gezeichnet wird. Daher sollten Bilddateien (Rasterkarten) immer unter Vektordateien (z.B. Punkte) liegen.

Die Reihenfolge der Karten in der Layer-Kontrolle kann am einfachsten per Drag&Drop geändert werden. Dabei wird ein Layer mit gedrückt gehaltener linker Maustaste an die gewünschte Position in der Layer-Kontrolle bewegt und anschließend die Maustaste freigegeben. Alternativ kann auch das Menü "Layer" bzw. das Kontext-Menü in der Layer-Kontrolle zur Änderung der Reihenfolge genutzt werden.
Mit dem Menüpunkt "Ansicht - Legende sortieren" kann die Reihenfolge der Layer sortiert werden.

Name und Info-Feld(er)

Der Name eines Layers kann geändert werden, indem der aktive Layer einmal mit der linken Maustaste angeklickt wird, Strg + U betätigt oder der Menüpunkt "Layer - Umbenennen" ausgewählt wird.

Ein Info-Feld kann für Vektordateien (Punkt, Linie und Polygon) definiert werden, indem der Menüpunkt "Layer - Info-Feld" aktiviert wird. Hierbei können 1 bis 3 beliebige Felder aus der mit dem Layer assoziierten Merkmalsdatei gewählt werden. Das Symbol [image] um das Kontrollkästchen neben dem Layer signalisiert, dass (mindestens) ein Info-Feld gewählt wurde. Info-Felder bewirken für den aktiven Layer eine Anzeige der gewählten Information zum Geo-Objekt in Form von Tooltipps (Quickinfo) im Karten-Element.

Tasten- und Mausfunktionen

Tastenfunktionen

Taste | Aktion
Einfügen (Einfg) | neuen Layer hinzufügen
Entfernen (Entf) | Layer aus der Layer-Kontrolle entfernen
Eingabe (Enter) | Einfärbung
Leertaste | Sichtbarkeit ein/aus
Strg + U | Layer umbenennen
Alt + Pfeil hoch | Layer nach oben verschieben
Alt + Pfeil tief | Layer nach unten verschieben
Alt + Pos1 | Layer an den Anfang verschieben
Alt + Ende | Layer an das Ende verschieben

Mausfunktionen

Mausklick | Aktion
Doppelklick | auf Layer-Namen: Einfärbung
einfacher Mausklick | auf Layer-Namen: Layer umbenennen auf Kontrollkästchen: Sichtbarkeit des Layers ändern

Kontext-Menüs (rechte Maustaste)

Die Layer-Kontrolle verfügt über zwei verschiedene Kontext-Menüs, die abhängig davon aktiviert werden, ob ein Layer "angeklickt" wird, oder der Klick mit der rechten Maustaste in den leeren Bereich der Layer-Kontrolle erfolgt.

a) rechte Maustaste wird "auf" einem Layer gedrückt

  • Hinweis zu "Speichern Layer"
    temporäre Layer können mit diesem Menüpunkt unter einem wählbaren Namen als Shape-Datei gespeichert werden. temporäre Layer

b) rechte Maustaste wird im "leeren Bereich" der Layer-Kontrolle gedrückt

temporäre Layer

Alle Layer mit einem roten Punkt wurden im Menü "Erstellen" oder über die Zeichnen-Funktionen des Menüs "Extras - Zeichnen" temporär generiert. Um diese Layer dauerhaft zu speichern, sind zwei Wege möglich:

  1. Beim Speichern des Projektes werden diese Layer automatisch als Shape-Datei gespeichert. Dabei wird als Dateiname der Name des Layers in der Layer-Kontrolle verwendet. Als Verzeichnis wird automatisch ein Unterverzeichnis generiert, dass aus dem Projektnamen gebildet wird. Bsp.: Wird ein Projekt unter dem Namen MKS.Kep gespeichert, heißt das zugehörige Verzeichnis MKS-Dateien, in welchem durch den Karten-Explorer erstellte Layer abgespeichert werden.

  2. Wird die Speicherung als Projekt wie unter 1. beschrieben nicht erwünscht, kann ein temporärer Layer mit einem wählbaren Dateinamen dauerhaft gespeichert werden, indem der betreffende Layer selektiert und der Menüpunkt "Layer - Speichern unter" oder das Kontext-Menü der Layer-Kontrolle verwendet wird.


Layer hinzufügen - Karten-Explorer

Layer hinzufügen

Mit dem Menüpunkt "Layer - Layer hinzufügen" können Vektor- oder Bilddaten unterstützter Formate geladen werden. Diese erscheinen nach dem Hinzufügen in der [image] Layer-Kontrolle und können hinsichtlich Einfärbung, Sichtbarkeit, Reihenfolge usw. beeinflusst werden. Tipp: Durch Mehrfachauswahl im Dateiauswahl-Fenster können mehrere Karten auf einmal geladen werden. Außerdem können Karten per Drag&Drop auf das Karten-Element geladen werden.

Vektordaten

Vektordaten sind Daten, die geometrische Objekte wie Punkte, Linien und Polygone beschreiben.
Der Karten-Explorer unterstützt alle ESRI-Formate von Shape-Dateien (inkl. des ESRI-ATKIS - Shapekonverters) sowie räumliche Indices (*.sbn, *.sbx).

Bilddaten

Bilddateien enthalten digitale Landkarten. Der Karten-Explorer unterstützt zahlreiche Bilddatei-Formate wie z.B. *.sid, *.bmp, *.tif, *.tff, *.tiff, *.jpg, *.jpeg.

Bilddatei | Bilddatei | Worlddatei
*.sid | Multi-Resolution Seamless Image Database | *sdw
*.bmp | Windows bitmap | *.bpw
*.tif, *.tff, *.tiff | Tagged Image File Format (inklusive GeoTiff) | *.tfw
*.jpg, *.jpeg | JPEG | *.jgw, *.jpgw
*.bil | Band interleaved by line multiband images | *.blw
*.bip | Band interleaved by pixel multiband images | *.bpw
*.bsq | Band sequential multiband images | *.bqw
*.sun | Sun rasterfiles | *.snw
*.rs, *.ras |  | *.rsw
*.rlc | Run-length compressed files | *.rcw

Folgende Verschlüsselungs-Schemen werden unterstützt:
CCITT Group 3 und 4 Algorithmus (TIFF Kompressions-Schema 2, 3, 4 and 32771)
JPEG post-6.0-style DCT Algorithmus (TIFF Kompressions-Schema 7)
NeXT 2-bit Verschlüsselungs-Schema (TIFF Kompressions-Schema 32766)
Macintosh PackBits Algorithmus (TIFF Kompressions-Schema 32773)
ThunderScan 4-bit-Verschlüsselung (TIFF Kompressions-Schema 32809)
SGI’s Kompressions-Schema für hochauflösende Farbbilder (TIFF Kompressions-Schema 34676 und 34677)

Folgende Tiff-Varianten werden unterstützt:
TIFF 6.0 (TIFF revision 6.0). Enhancements to image definition, RGB colorimetry. Includes JPEG compression.
GeoTIFF (TIFF mit Geo header)


Layer erstellen - Karten-Explorer

Layer erstellen

Neben dem Hinzufügen von vorhandenen Vektor- und Bilddateien ( [image] Layer hinzufügen) ist das Erstellen von Layern aus verschiedenen Quellen möglich.
Diese Layer werden temporär erstellt und nur dann (dauerhaft) als Shape-Datei im Projekt-Verzeichnis abgelegt, wenn das Projekt gespeichert wird oder der Layer separat mit dem Menüpunkt "Layer - Speichern unter" gesichert wird. temporäre Layer

Abfrage ZTSDB

Seuchenobjekte, die die über TSN-Online gemeldet worden sind, liegen in der Zentralen Tierseuchendatenbank vor und können über einen Web-Service hinsichtlich TS/TK, Zeitraum und Territorium abgefragt und direkt als Layer im Karten-Explorer angezeigt werden.
Layer durch Abfrage der ZTSDB erstellen

Tipp: Laden Sie die aktuellen Fälle einer Tierseuche (z.B. Blauzungenkrankheit) herunter und nutzen Sie die Programmfunktion "Extras- Punkte puffern" um Radien um die Ausbrüche zu generieren und so zu überprüfen, ob die Restriktionszonen Ihr Territorium tangieren.

Grid

Es kann ein Layer mit Gridzellen (Quadrate) wählbarer Kantenlänge und Ausdehnung erzeugt werden.
Grid erstellen

Hexagon

Es kann ein Layer mit Hexagonen (Sechsecke, Waben) wählbarer Kantenlänge und Ausdehnung erzeugt werden.
Hexagon erstellen

Punktdichte

Über ein zu wählendes numerisches Attribut eines geladenen Polygon-Layers kann ein Multipoint-Layer erzeugt werden, indem abhängig vom Wert des Attributes eine entsprechende Anzahl von Punkten pro Polygon erzeugt werden.
Punktdichte erstellen

aus Zwischenablage

In die Zwischenablage können Tabellen kopiert werden, die Koordinatenspalten und weitere beliebige Attribute enthalten. Aus diesen Daten können neue Layer erzeugt werden.
aus Zwischenablage erstellen

aus dBase-Datei

Der Karten-Explorer kann aus jeder dBase-Datei, die Spalten mit Koordinaten enthält (Rechtswert, Hochwert) einen Layer erstellen und anzeigen.
 Layer aus dBase-Datei erstellen

Damit können z.B. externe Programme beliebige Abfragen in Form von dBase-Dateien erstellen und zur Anzeige auf Karten an TSN übergeben.
Außerdem können so genannte "Basisdateien", die zur Georeferenzierung mit dem Karten-Explorer ( [image] Georeferenzieren von Punkten) dienen, angezeigt werden.

aus Textdatei (CSV)

Der Karten-Explorer kann aus Textdateien einen neuen Layer erstellen, sofern diese einen strukturieren Aufbau haben (CSV-Datei mit Spaltentrennzeichen und Kennzeichen für Zeilenende) und Spalten mit Koordinaten enthalten.
aus Textdatei erstellen

aus GPX-Dateien

Der Karten-Explorer kann aus GPX-Dateien (GPS Exchange Format), wie sie z.B. von GPS-Empfängern erzeugt werden, neue Layer erstellen.
aus GPX erstellen

aus KML-Dateien

Der Karten-Explorer kann aus KML-Dateien (Keyhole Markup Language), wie sie z.B. von Google Earth verwendet werden, neue Layer erstellen.
aus KML erstellen

aus Polygon-Datei

Hierbei werden Layer aus Polygonen, die mit dem Polygon-Editor erstellt wurden, geladen. Diese können als Polygon-Datei (*.plg) von der Festplatte geladen werden.


Karten-Explorer - Abfrage der ZTSDB

Layer durch Abfrage der ZTSDB erstellen

Bildschirm anzeigen

In diesem Fenster erfolgt die Abfrage der Zentralen Tierseuchendatenbank (ZTSDB) nach Seuchenobjekten einer auszuwählenden Tierseuche/Tierkrankheit (TS/TK) für einen anzugebenden Zeitraum und für wählbare Bundesländer. Die so abgefragten Seuchenobjekte können (sofern sie georeferenziert sind) direkt im Karten-Explorer als Layer angezeigt werden.

Abfrage erstellen

Die Tierseuche bzw. Tierkrankheit ist aus dem Kombinationsfeld auszuwählen. Über die Optionsfelder "anzeigepflichtige Tierseuchen", "meldepflichtige Tierkrankheiten", "sonstige Tierkrankheiten", "Test-Tierseuchen" und "alle TS/TK" kann die Liste auf die gewünschte Option beschränkt werden.
Die Liste der Tierseuchen/Tierkrankheiten unterliegt einer ständigen Änderung seitens des FLI. Um die aktuelle Liste vom Server des FLI herunter zu laden, betätigen Sie die Schaltfläche Aktualisieren. Die Liste wird lokal auf dem PC gespeichert und bei weiteren Aufrufen dieser Programmfunktion verwendet.

Der Zeitraum kann mit Hilfe des Anfangs- und Enddatums exakt angegeben werden. Alternativ kann ein vordefinierter Zeitraum aus dem Kombinationsfeld ausgewählt werden.

Für die Abfrage der ZTSDB ist die Angabe eines Benutzernamens (E-Mail-Adresse) und eines Kennworts erforderlich, welches den Zugriff zur ZTSDB erlaubt. Anhand des Benutzernamens ermittelt die ZTSDB automatisch den Zuständigkeitsbereich des Benutzers und verwendet ihn als das Territorium, für das Seuchenobjekte ermittelt werden sollen. Falls andere Regionen in die Suche einbezogen werden sollen (z.B. das gesamte Bundesland bei einem Kreis oder ein benachbartes Bundesland) sind die entsprechenden Kontrollkästchen zu aktivieren. Dabei können mit der Schaltfläche [image] alle Bundesländer markiert werden, die Schaltfläche [image] hebt die Markierung aller markierten Einträge auf.

Mit der Schaltfläche Abfrage starten wird die Suche nach passenden Seuchenobjekten in der ZTSDB gestartet. Dazu wird ein sicherer Webservice verwendet. Sofern entsprechende Seuchenobjekte gefunden wurden, werden sie in der Tabelle angezeigt. Der Inhalt der Tabelle kann mit der Schaltfläche [image] in die Zwischenablage kopiert und mit der Schaltfläche [image] in Excel angezeigt werden.

Layer im Karten-Explorer anzeigen

Beim Betätigen der Schaltfläche Layer laden wird ein Layer mit allen (georeferenzierten) Seuchenobjekten der Tabelle im Karten-Explorer erzeugt und angezeigt. Bei Bedarf kann der Name des Layers in der Layer-Kontrolle durch vorherige Eingabe in das Feld Layername variiert werden.

Mehrfachauswahl

Als Alternative zur Ausgabe aller georeferenzierten Einträge der Tabelle als Layer im Karten-Explorer können über den Mehrfachauswahl-Modus die gewünschten Einträge selektiert und dann als Layer erzeugt, in die Zwischenablage kopiert oder in Excel angezeigt werden.

Dieses Kontrollkästchen aktiviert bzw. deaktiviert die Mehrfachauswahl.
Hinweis: Um die Mehrfachauswahl zu aktivieren und gleichzeitig alle Seuchenobjekte zu selektieren, kann auch die Tastenkombination Strg+A betätigt werden.

Bei aktiver Mehrfachauswahl können mit der Schaltfläche [image] alle Seuchenobjekte in der Tabelle markiert werden, die Schaltfläche [image] schaltet die Markierungen um.

Mit der Maustaste können mit Strg+Mausklick einzelne Zeilen markiert/demarkiert werden. Mit Umschalten+Mausklick können Bereiche markiert werden.

Mit der Tastatur kann z.B. ein zusammenhängender Bereich markiert (demarkiert) werden, wenn man bei gedrückter Umschalten-Taste die Tasten Pfeil hoch/tief bzw. Bild auf/ab betätigt. Mit gedrückter Strg-Taste kann unter Verwendung der Leertaste markiert werden. Dabei können (bei gedrückter Strg-Taste) die Richtungstasten Pfeil hoch/tief und Bild auf/ab zum Überspringen von Bereichen genutzt werden.

Filter

Standardmäßig werden mit dieser Programmfunktion Ausbrüche und Verdachtsmeldungen verarbeitet. Mit dem Optionsfeld Verdachtsmeldungen ausblenden kann die Anzeige in der Tabelle bzw. auf Karten auf Ausbrüche beschränkt werden.

Die meisten Ausbrüche von TS/TK wurden in der ZTSDB exakt georeferenziert und können damit sehr genau auf Karten angezeigt werden. Für einige TS/TK und insbesondere für weiter zurück liegende Fälle sind nicht immer genaue Koordinaten vorhanden. Um auch diese Fälle auf Karten anzuzeigen, werden die Koordinaten näherungsweise ermittelt (über zufällige Punkte im Radius von 500 Metern um den angegebenen Ortsmittelpunkt oder alternativ durch einen Zufallspunkt in der angegebenen Gemeinde). Die näherungsweise ermittelten Koordinaten eines Ausbruchs bzw. Verdachtsfalles sind in der ZTSDB gespeichert. Damit fällt die Koordinate auch bei wiederholten Abfragen mit dieser Programmfunktion an die selbe Stelle. Koordinaten werden nur verändert, wenn das Seuchenobjekt nachträglich georeferenziert wird. Die Anzeige von Ausbrüchen bzw. Verdachtsfällen kann mit der Option nicht exakt georeferenzierte Fälle ausblenden auf explizit georeferenzierte Fälle beschränkt werden.

Symbole

Die in der Tabelle verwendeten Symbole haben folgende Bedeutung:
1. Verdacht oder Ausbruch
 | Ausbruch
 | Verdacht
 | interner Verdacht (Ein interner Verdacht ist ein besonderer Typ eines Verdachts, der in der ZTSDB nur für Benutzer des Kreises sichtbar ist.)
. Ausbruchsart (Primär- oder Sekundärausbruch)
 | Primärausbruch
 | Sekundärausbruch
3. Wildtier- oder Haustierbestand
 | Haustierbestand
 | Wildtierbestand (Bestandsart ist 610)
4. Georeferenzierung
 | exakte Koordinaten vorhanden (XY_Typ ist 1)
 | näherungsweise Koordinaten (XY_Typ ist 2 (Zufallspunkt in Nähe Ortsmittelpunkt) oder 3 (Zufallspunkt innerhalb Gemeinde))

Hinweise zu Attributen

Die Attributs-Tabelle des Layers enthält folgende Angaben:

Feldname | Typ | Länge | Beschreibung
SO_KENNUNG | C | 12 | Seuchenobjekt-Nummer
MELDEART | C | 1 | 1=Ausbruch 2=Verdacht 3=interner Verdacht
AUSBR_ART | N | 1 | 1=Primärausbruch 2=Sekundärausbruch
TA_SCHL | C | 4 | Schlüssel der betroffenen Tierart
TA_NAME | C | 100 | Name der betroffenen Tierart
WILDTIER | L | 1 | Ausbruch bei einem Wildtier
KRS_SCHL | C | 5 | Schlüsselnummer Kreis
KRS_NAME | C | 40 | Name des Kreises
GEM_SCHL | C | 8 | Gemeindeschlüssel
GEM_NAME | C | 40 | Gemeindename
OT_SCHL | C | 6 | Schlüssel des Ortsteils
OT_NAME | C | 40 | Name des Ortsteils
ERR_SCHL | C | 5 | Schlüssel des Erregers
ERR_NAME | C | 100 | Name des Erregers
FESTSTELLG | D |  | Feststellungsdatum
VERDACHT | D |  | Verdachtsdatum
AUFHEBUNG | D |  | Aufhebungsdatum
E_M_DATUM | C | 16 | Zeitpunkt erster Meldung
L_M_DATUM | C | 16 | Zeitpunkt letzter Meldung
X_WERT | N | 10(6) | geografische Länge (GPS)
Y_WERT | N | 10(6) | geografische Breite (GPS)
BTR_REGNR | C | 20 | Registriernummer des Betriebs
BTR_NAME | C | 254 | Name des Betriebs
BTR_STR | C | 40 | Straße und Hausnummer des Betriebs
BTR_PLZ | C | 5 | Postleitzahl des Betriebs
BTR_ORT | C | 100 | Ort des Betriebs
ADNS | C | 12 | ADNS-Nummer
BST_SCHL | C | 3 | Schlüssel der Bestandsart
BST_NAME | C | 100 | Name der Bestandsart
XY_TYP | N | 1 | Typ der Koordinaten 1 - exakte Georeferenzierung 2 - Zufallspunkt um Ortsmittelpunkt (500-m-Radius) 3 - Zufallspunkt innerhalb Gemeinde
TS_SCHL | C | 3 | Schlüssel der Tierseuche
STORNO_KZ | L | 1 | Kennzeichen für Stornierung
RECHTSWERT | N | 8 | Rechtswert im verwendeten Koordinatensystem
HOCHWERT | N | 8 | Hochwert im verwendeten Koordinatensystem


Grid erstellen

Bildschirm zeigen

Mit dem Menüpunkt "Erstellen - Grid" des Karten-Explorers ist es möglich, einen Grid-Layer wählbarer Kantenlänge zu erzeugen.

Gridweite

Die Kantenlänge einer (quadratischen) Gridzelle ist zu wählen. Neben der Eingabe der Zahlen können die horizontalen (+/- 1000 Meter) oder vertikalen (+/- 100 Meter) Drehfelder genutzt werden.

Einpassen

Es ist festzulegen, für welche Fläche das Grid zu erzeugen ist:

  • Aktueller Kartenausschnitt erzeugt Gridzellen im momentan sichtbaren Bildschirmbereich.

  • Volle Kartengröße verwendet die gesamte Ausdehnung aller geladenen Karten.

  • Geladener Layer erlaubt die Auswahl eines in der Layer-Kontrolle geladenen Layers mit der Schaltfläche [image], dessen Ausdehnung für die Generierung von Gridzellen verwendet wird.

  • Manuell eingeben erlaubt die freie Angabe einer linken, rechten, oberen und unteren Koordinate für die gewünschte Ausdehnung.

an Raster ausrichten

  • Ist dieses Kontrollkästchen aktiviert, dann wird ein Referenzpunkt für den Ursprung des Grids und die Zählung der IDs verwendet. Dieser wird durch die linke, untere Koordinate der verwendeten Rasterkarten bestimmt (GK3, U32 oder U33).

    • Grids (gleicher Kantenlänge) passen aneinander (z.B. separat erstellte Grids benachbarter Kreise).

    • Die IDs (bei gleicher Kantenlänge) sind deutschlandweit homogen.


Hexagon erstellen

Bildschirm zeigen

Mit dem Menüpunkt "Erstellen - Hexagon" des Karten-Explorers ist es möglich, einen Layer mit regelmäßigen Sechsecken (Waben-Struktur) wählbarer Kantenlänge zu erzeugen.

Kantenlänge

Die Kantenlänge Sechsecks ist zu wählen. Neben der Eingabe der Zahlen können die horizontalen (+/- 1000 Meter) oder vertikalen (+/- 100 Meter) Drehfelder genutzt werden.

Einpassen

Es ist festzulegen, für welche Ausdehnung der Layer zu erzeugen ist:

  • Aktueller Kartenausschnitt erzeugt Hexagone im momentan sichtbaren Bildschirmbereich.

  • Volle Kartengröße verwendet die gesamte Ausdehnung aller geladenen Karten.

  • Geladener Layer erlaubt die Auswahl eines in der Layer-Kontrolle geladenen Layers mit der Schaltfläche [image], dessen Ausdehnung für die Generierung von Hexagonen verwendet wird.

  • Manuell eingeben erlaubt die freie Angabe einer linken, rechten, oberen und unteren Koordinate für die gewünschte Ausdehnung.

an Raster ausrichten

  • Ist dieses Kontrollkästchen aktiviert, dann wird ein Referenzpunkt für den Ursprung ersten Hexagons und die Zählung der IDs verwendet. Dieser wird durch die linke, untere Koordinate der verwendeten Rasterkarten bestimmt (GK3, U32 oder U33).

    • Hexagone (gleicher Kantenlänge) passen aneinander (z.B. separat erstellte Layer benachbarter Kreise).

    • Die IDs (bei gleicher Kantenlänge) sind deutschlandweit homogen.


Punktdichte erstellen

Bildschirm zeigen

Mit dem Menüpunkt "Erstellen - Punktdichte" wird ein Multipoint-Layer erstellt. Grundlage hierfür ist ein auszuwählender Polygon-Layer und ein anzugebendes numerisches Attribut des Layers, welches steuert, wie viele Zufallspunkte je Polygon erzeugt werden sollen.

Layer und Feld auswählen

Zunächst ist mit der Schaltfläche [image] ein geladener Polygon-Layer auszuwählen. Daraufhin werden alle numerischen Attribute des Layers in einem Kombinationsfeld angezeigt. Es ist festzulegen, welche Attribut die Anzahl der zu erzeugenden Punkte steuern soll.

Punktwert

Mit dem Punktwert kann eingestellt werden., wie viele Punkte pro Einheit erzeugt werden sollen. Standardmäßig wird ein Punkt pro Einheit erzeugt, d.h. enthält das ausgewählte Attribut für ein bestimmtes Polygon den Wert 10, werden demzufolge 10 Punkte erzeugt. Kann das betreffende Attribut sehr große Werte annehmen, kann die Zahl der zu erzeugenden Punkte reduziert werden, indem man den Punktwert entsprechend erhöht. Bei Angabe der Zahl 100 würde ein Punkt je 100 Einheiten im Attribut generiert werden.


Karten-Explorer - Layer aus Dbf-Datei erstellen

Punkte-Layer aus dBase-Datei erzeugen

Bildschirm anzeigen

Punkte-Layer können aus dBase-Dateien erstellt werden. Diese müssen lediglich Spalten mit Koordinaten (Rechtswert, Hochwert) enthalten, mit deren Hilfe Geo-Objekte erzeugt werden können.

Es werden nur Datensätze berücksichtigt, die in den angegebenen Spalten für Koordinaten auch tatsächlich Einträge enthalten.

Diese Programmfunktion bietet viele Anwendungsmöglichkeiten:

  1. Mit TSN exportierte Betriebsdaten können nachträglich auf einer Karte dargestellt werden. Insbesondere können Betriebe in Ämtern exportiert und an eine Zentrale zur kartografischen Darstellung übergeben werden.

  2. Externe Programme können beliebige Abfragen (z.B. Diagnosen, eingeleitete Maßnahmen) als dBase-Datei zur kartografischen Darstellung übergeben.

  3. Daten können mit Microsoft Excel, Foxpro etc. erfasst und im dBase-Format exportiert werden.

Die dBase-Datei ist über die Schaltfläche [image] anzugeben. Diese Datei muss eine Spalte für den Rechtswert (X-Koordinate) und Hochwert (Y-Koordinate) enthalten. Diese Spalten sind in den Listenfeldern Rechtswert und Hochwert auszuwählen, wenn die Feldnamen von der Vorgabe ("Rechtswert", "Hochwert") abweichen. Im Listenfeld Info-Feld ist der Name eines [image] Info-Feldes anzugeben.

Unter Layer-Name kann der Name angegeben werden, unter dem der Layer in der [image] Layer-Kontrolle erscheint.

Einfärbung festlegen

Folgende Eigenschaften des Punkt-Symbols können im Bereich Einfärbung festlegen geändert werden:

  • Farbe
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Farbe der Umrisslinie

  • Umrisslinie anzeigen?

  • Symbolgröße

  • Markierung (Kreis, Quadrat, Dreieck, Kreuz, True-Type-Marker)

Wurde bei Markierung die Option "True-Type-Marker" gewählt, können beliebige Zeichen einer zu wählenden Schriftart als Markierung verwendet werden. Über die Schaltfläche [image] kann die Schriftart und über die Schaltfläche [image] das gewünschte Zeichen ausgewählt werden. Zusätzlich kann das Zeichen in einem beliebigen Winkel gedreht werden.

Mit der Schaltfläche [image] Standardsymbole kann eine Auswahl wichtiger vordefinierter Symbole zum Krisenmanagement bei Tierseuchen aktiviert werden.


Erstellen aus Zwischenablage

aus Zwischenablage erstellen

Bildschirm zeigen

Mit dem Menüpunkt "Erstellen - aus Zwischenablage" des Karten-Explorers ist es möglich, einen neuen Layer oder eine dBase-Datei aus einer Tabelle zu erzeugen, die sich in der Zwischenablage befindet. Um einen neuen Layer zu erzeugen, muss die Tabelle Informationen zu Koordinaten enthalten. Sind keine Koordinaten in der Tabelle enthalten, kann diese lediglich als dBase-Datei gespeichert werden.

Aufbau Dialogfenster

Das Dialogfenster enthält zwei Tabellen:

  • eine Voransicht der ersten Zeilen der in der Zwischenablage befindlichen Datentabelle und

  • eine Tabelle mit der Struktur, d.h., dem Aufbau der Datentabelle in der Zwischenablage mit Spaltennamen, Typ und Länge der Spalten sowie ein Kennzeichen, ob es sich um eine Spalte mit Koordinaten handelt.

Daten aus der Zwischenablage einfügen

Die Daten in der Zwischenablage müssen tabellenartig aufgebaut sein, die Spalten sind dabei durch ein spezielles Trennzeichen getrennt, das Zeilenende wird durch Zeilenvorschub (CR LF) begrenzt. Als Trennzeichen wird in der 1. Zeile der Zwischenablage (in dieser Reihenfolge) nach Tabulator, Semikolon, | oder Komma gesucht. Das erste erkannte Zeichen wird als Trennzeichen verwendet. Wird eine Excel-Tabelle in die Zwischenablage kopiert, wird automatisch der Tabulator verwendet.

Beispielhaft könnte in einem Excel-Arbeitsblatt eine Tabelle wie in der folgenden Abbildung erstellt werden. Dabei enthält die erste Zeile Spaltennamen. Welche Konventionen hier gelten, wird im nächsten Abschnitt beschrieben.

Bei Aktivierung des Menüpunktes "Erstellen - aus Zwischenablage" und dem damit verbundenen Öffnen des Dialogfensters wird der aktuell in der Zwischenablage befindliche Text analysiert und die ersten Zeilen und die ermittelte Struktur angezeigt. Mit der Schaltfläche "Daten erneut einlesen" kann der Inhalt der Zwischenablage jederzeit erneut eingelesen werden.

Codierung

Es ist möglich, Zeichen mit einer Codierung entsprechend dem Standard von ANSI (Vorgabe), OEM und UTF einzulesen, um Umlaute korrekt darzustellen. Kontrollieren Sie die in der Voransicht dargestellten Daten und modifizieren Sie ggf. die Einstellung für die Codierung manuell, bis Umlaute und Sonderzeichen korrekt dargestellt werden. Wird ein so genannter BOM (Byte Order Marker) erkannt, wird die Codierung auf UTF gestellt und kann nicht mehr geändert werden.

Struktur

Bei Einlesen der Daten aus der Zwischenablage wird der Inhalt nach einem bestimmten Schema analysiert, um den Aufbau der Tabelle zu ermitteln. Diese Angaben zur Struktur werden zum Erzeugen einer dBase- bzw. Attributdatei benötigt.

Zunächst wird versucht zu ermitteln, ob die erste Zeile (Kopfzeile) Spaltennamen oder eine Spaltendefinition (Spaltenname, -typ und -länge) enthält. Wenn die erste Spalte der ersten Zeile keinen gültigen Spaltenname enthält, geht das System davon aus, dass die Tabelle keine Spaltennamen besitzt und nur aus Daten besteht. Die Spalten werden dann mit SPALTE1, SPALTE2 usw. bezeichnet und entsprechend des Inhaltes der ersten Zeile mit dem Typ "Zeichen", "Numerisch" oder "Datum" vorbelegt. Name, Typ und Länge der Spalte kann in der Tabelle des Dialogfensters individuell angepasst werden.

Falls eine Zeile mit Spaltennamen an einer anderen Position als in der ersten Zeile vorhanden ist, ist diese Zeile zu markieren (auszuwählen) und die Struktur mit der Schaltfläche "Struktur erneut ermitteln" zu berechnen. Dabei muss das Kontrollkästchen "markierte Zeile enthält Spaltennamen" aktiviert sein.

Falls das System die erste Zeile fälschlicherweise als Zeile mit Spaltennamen interpretiert hat, ist das Kontrollkästchen "markierte Zeile enthält Spaltennamen" zu deaktivieren und die Struktur erneut zu berechnen.

Was sind gültige Spaltennamen?

Spaltennamen dürfen bis zu 10 Zeichen lang sein und bestehen aus Buchstaben (ohne Umlaute), Ziffern oder einem Unterstrich. Das erste Zeichen muss ein Buchstabe sein.

Spaltendefinition

Eine Spaltendefinition erlaubt es, neben Spaltennamen auch Typ, Länge und ggf. Anzahl der Nachkommastellen (bei numerischen Felder) anzugeben. Dazu sind in der Kopfzeile für jede gewünschte Spalte einfach Name, Typ, Länge und Nachkommastellen mit Komma getrennt anzugeben.

Es sind mindestens Spaltenname und Typ (C, N, D, L) anzugeben. Längenangaben bei Spalten mit Datums- oder logischen Werten sind nicht notwendig. Wird beim Typ Zeichen keine Länge angegeben, wird die Länge 50 Zeichen verwendet. Bei numerischen Spalten würde beim Fehlen der Angaben die Länge 18 mit 6 Nachkommastellen verwendet werden.

Typ | Code | Länge | Nachkommastellen | Bemerkung | Beispiel
Zeichen | C | 1 bis 256 | 0 | Standard ist Länge 50 | NAME,C,20
Numerisch | N | 1 bis18 | 0 bis Länge-1 | Standard ist Länge 18 mit 6 Nachkommastellen | PRAEVALENZ,N,10,6
Datum | D | 8 | 0 |  | GEBURT,D
Logisch | L | 1 | 0 | Folgende Zellinhalte werde als 'wahr' behandelt: 1, Y, J, T, .T., true, wahr, yes, ja | UNTERSUCHT,L

Zu importierende Spalten auswählen

Per Voreinstellung werden alle erkannten Spalten aus der Zwischenablage zum Erstellen eines Layers oder einer dBase-Datei verarbeitet. Über die Kontrollkästchen der Auswahlspalte [image] können die Spalten per Mausklick aus- oder abgewählt werden, alternativ können die Schaltflächen [image] (alle auswählen), [image] (alle abwählen) und [image] (Auswahl umkehren) verwendet werden.

Koordinatenspalten

Wenn die aus der Zwischenablage eingefügten Daten Spalten mit Koordinaten enthalten, sind diese in der Tabelle Struktur auszuwählen. Spalten mit X-Koordinaten bzw. Y-Koordinaten müssen immer vom Typ "Numerisch" sein.

Ein Sonderfall stellen Koordinaten aus "Google Maps" dar. Diese können ermittelt werden, indem man innerhalb von "Google Maps" an der gewünschten Stelle mit der rechten Maustaste in die Karte klickt und "Was ist hier?" aus dem Kontextmenü auswählt. Die im Infofenster angezeigten Koordinaten in der Form '54.095891, 13.381571' usw. können in eine Excel-Tabelle übertragen werden und bilden hier eine spezielle Spalte, die vom Karten-Explorer verarbeitet werden kann. Diese Spalte ist vom Typ "Zeichen" und wird mit der Auswahl "Google Maps" als Koordinatenspalte gekennzeichnet.
Dabei wird immer die Reihenfolge Latitude (Y) und Longitude (X) erwartet, das Trennzeichen kann Komma oder Leerzeichen sein und die Notation kann dezimal oder in Grad, Minute und Sekunde sein. Dies ergibt folgende Formate, die zeilenweise neu interpretiert werden und damit auch beliebig wechseln können:

  • 54.183793,13.359263

  • 54.180384 13.339940

  • 54°11'01.7"N,13°21'33.4"E

  • 54°10'49.4"N 13°20'23.8"E

Werden beim Erstellen des Layers geografische Koordinaten in den angegebenen Koordinatenspalten erkannt, rechnet der Karten-Explorer den Layer automatisch von geografischen Koordinaten (Google Maps verwendet standardmäßig das vom GPS her bekannte System) in die beim Karten-Explorer eingestellte Projektion um.

Modus (Punkt / Linie)

Es besteht die Möglichkeit über ein Kombinationsfeld zu steuern, ob ein Layer mit Punkten oder ein Layer mit Linien zwischen zwei Punkten (mit optionaler Berechnung des Winkels) erstellt werden soll!

  • Punkt

    • Es sind die Spalten X (Rechtswert) und Y (Hochwert) zuzuordnen.

    • Sonderfall Google Maps (siehe oben): Liegen die Koordinaten in einer Spalte in der Form '54.095891, 13.381571' vor, ist dieser Spalte der Eintrag "Google Maps" zuzuordnen.

  • Linie

    • Es sind die Spalten für den ersten Punkt X1 (Rechtswert) und Y1 (Hochwert) zuzuordnen.

    • Es sind die Spalten für den zweiten Punkt X2 (Rechtswert) und Y2 (Hochwert) zuzuordnen.

    • Sofern die Ausgabe des Winkels erwünscht ist, ist die entsprechende Spalte Winkel (optional) zuzuordnen.

Hinweise zur automatischen Verarbeitung von Adressen und Koordinaten in der Zwischenablage

Bestimmte Spaltennamen werden automatisch als X- und Y-Koordinate oder Adressspalten erkannt. Adressen und Koordinaten in Zwischenablage

  • Werden beim Einfügen mit Strg+V im Karten-Explorer in der Zwischenablage Koordinaten erkannt, werden diese sofort als Karte angezeigt. Dieses Verhalten erfolgt bei Inhalten in der Zwischenablage mit

    • zwei Spalten mit Spaltenüberschriften, die auf Koordinaten hinweisen (X, Y, LAT, LONG etc.)

    • zwei numerischen Spalten oder Spalten mit Grad-Angaben ohne Spaltenüberschriften

  • Werden Adressen und Koordinaten erkannt, erfolgt die Abfrage, ob eine Karte erzeugt werden soll.

  • Werden Adressen (jedoch keine Koordinaten) erkannt/vermutet, erfolgt die Abfrage, ob eine dBase-Datei erstellt werden soll und ob Koordinatenspalten für die Georeferenzierung angefügt werden sollen.

  • Wenn die automatische Interpretation von Adressen und Koordinaten nicht erwünscht ist, kann beim Einfügen aus der Zwischenablage die Tastenkombination ↑+STRG+V verwendet werden, die das standardmäßige Dialog-Fenster „Erstellen aus Zwischenablage“ (also die hier dokumentierte Programmfunktion) anzeigt.

Hinweise zum Kopieren von Koordinaten in die Zwischenablage

  • Mit der Tastenkombination Alt+C werden die Koordinaten an der aktuellen Position der Maus auf der Karte in die Zwischenablage kopiert und können mit Strg+V sofort als Punkt auf der Karte (neuer Layer) dargestellt werden.

  • Alternativ kann eine Liste von Punkten in der Zwischenablage erstellt werden, indem die Tastenkombination ↑+Alt+C betätigt wird. Dann überprüft die Programmlogik, ob bereits eine 2-spaltige Liste in der Zwischenablage ist und fügt (wenn ja) die Koordinaten hinzu bzw. erstellt (wenn nein) einen neuen Eintrag!


Erstellen aus Textdatei (CSV)

aus Textdatei (CSV) erstellen

Bildschirm zeigen

Mit dem Menüpunkt "Erstellen - aus Textdatei" des Karten-Explorers ist es möglich, einen neuen Layer oder eine dBase-Datei aus einer Textdatei zu erzeugen. Alternativ können diese Dateien per Drag & Drop in den Karten-Explorer gezogenen werden. Um einen neuen Layer zu erzeugen, muss die Tabelle Informationen zu Koordinaten enthalten. Sind keine Koordinaten in der Tabelle enthalten, kann diese lediglich als dBase-Datei gespeichert werden.

Aufbau Dialogfenster

Das Dialogfenster enthält zwei Tabellen:

  • eine Voransicht der ersten Zeilen der in der Textdatei befindlichen Datentabelle und

  • eine Tabelle mit der Struktur, d.h., dem Aufbau der Datentabelle mit Spaltennamen, Typ und Länge der Spalten sowie ein Kennzeichen, ob es sich um eine Spalte mit Koordinaten handelt.

Daten aus der Datei einfügen

Die Daten in der Textdatei müssen tabellenartig aufgebaut sein, die Spalten sind dabei durch ein spezielles Trennzeichen getrennt, das Zeilenende wird durch Zeilenvorschub (CRLF) begrenzt. Als Trennzeichen wird in der 1. Zeile der Datei (in dieser Reihenfolge) nach Tabulator, Semikolon, | oder Komma gesucht. Das erste erkannte Zeichen wird als Trennzeichen verwendet.

Beispielhaft könnte eine Tabelle wie folgt aussehen. Dabei enthält die erste Zeile Spaltennamen. Welche Konventionen hier gelten, wird im Abschnitt "Struktur" beschrieben.

PLZ;ORT;ORTSTEIL;STRASSE;HAUS;X;Y
 17489;Greifswald;Innenstadt;Karl-Marx-Platz;9;13,368130;54,095560
16868;Wusterhausen;;Seestraße;55;12,461540;52,907610
17493;Greifswald;Riems;Südufer;10;13,361290;54,182530

Codierung

Es ist möglich, Zeichen mit einer Codierung entsprechend dem Standard von ANSI, OEM (Vorgabe) und UTF einzulesen, um Umlaute korrekt darzustellen. Kontrollieren Sie die in der Voransicht dargestellten Daten und modifizieren Sie ggf. die Einstellung für die Codierung manuell, bis Umlaute und Sonderzeichen korrekt dargestellt werden. Wird ein so genannter BOM (Byte Order Marker) erkannt, wird die Codierung auf UTF gestellt und kann nicht mehr geändert werden.

Struktur

Bei Einlesen der Daten wird der Inhalt nach einem bestimmten Schema analysiert, um den Aufbau der Tabelle zu ermitteln. Diese Angaben zur Struktur werden zum Erzeugen einer dBase- bzw. Attributdatei benötigt.

Zunächst wird versucht zu ermitteln, ob die erste Zeile (Kopfzeile) Spaltennamen oder eine Spaltendefinition (Spaltenname, -typ und -länge) enthält. Wenn die erste Spalte der ersten Zeile keinen gültigen Spaltenname enthält, geht das System davon aus, dass die Tabelle keine Spaltennamen besitzt und nur aus Daten besteht. Die Spalten werden dann mit SPALTE1, SPALTE2 usw. bezeichnet und entsprechend des Inhaltes der ersten Zeile mit dem Typ "Zeichen", "Numerisch" oder "Datum" vorbelegt. Name, Typ und Länge der Spalte kann in der Tabelle des Dialogfensters individuell angepasst werden.

Falls eine Zeile mit Spaltennamen an einer anderen Position als in der ersten Zeile vorhanden ist, ist diese Zeile zu markieren (auszuwählen) und die Struktur mit der Schaltfläche "Struktur erneut ermitteln" zu berechnen. Dabei muss das Kontrollkästchen "markierte Zeile enthält Spaltennamen" aktiviert sein.

Falls das System die erste Zeile fälschlicherweise als Zeile mit Spaltennamen interpretiert hat, ist das Kontrollkästchen "markierte Zeile enthält Spaltennamen" zu deaktivieren und die Struktur erneut zu berechnen.

Was sind gültige Spaltennamen?

Spaltennamen dürfen bis zu 10 Zeichen lang sein und bestehen aus Buchstaben (ohne Umlaute), Ziffern oder einem Unterstrich. Das erste Zeichen muss ein Buchstabe sein.

Spaltendefinition

Eine Spaltendefinition erlaubt es, neben Spaltennamen auch Typ, Länge und ggf. Anzahl der Nachkommastellen (bei numerischen Felder) anzugeben. Dazu sind in der Kopfzeile für jede gewünschte Spalte einfach Name, Typ, Länge und Nachkommastellen mit Komma getrennt anzugeben.

PLZ,C,5;ORT,C,30;ORTSTEIL,C,30;STRASSE,C,50;HAUS,C,10;X,N,10,6;Y,N,10,6
 17489;Greifswald;Innenstadt;Karl-Marx-Platz;9;13,368130;54,095560
16868;Wusterhausen;;Seestraße;55;12,461540;52,907610
17493;Greifswald;Riems;Südufer;10;13,361290;54,182530

Es sind mindestens Spaltenname und Typ (C, N, D, L) anzugeben. Längenangaben bei Spalten mit Datums- oder logischen Werten sind nicht notwendig. Wird beim Typ Zeichen keine Länge angegeben, wird die Länge 50 Zeichen verwendet. Bei numerischen Spalten würde beim Fehlen der Angaben die Länge 18 mit 6 Nachkommastellen verwendet werden.

Typ | Code | Länge | Nachkommastellen | Bemerkung | Beispiel
Zeichen | C | 1 bis 256 | 0 | Standard ist Länge 50 | NAME,C,20
Numerisch | N | 1 bis18 | 0 bis Länge-1 | Standard ist Länge 18 mit 6 Nachkommastellen | PRAEVALENZ,N,10,6
Datum | D | 8 | 0 |  | GEBURT,D
Logisch | L | 1 | 0 | Folgende Zellinhalte werde als 'wahr' behandelt: 1, Y, J, T, .T., true, wahr, yes, ja | UNTERSUCHT,L

Zu importierende Spalten auswählen

Per Voreinstellung werden alle erkannten Spalten zum Erstellen eines Layers oder einer dBase-Datei verarbeitet. Über die Kontrollkästchen der Auswahlspalte [image] können die Spalten per Mausklick aus- oder abgewählt werden, alternativ können die Schaltflächen [image] (alle auswählen), [image] (alle abwählen) und [image] (Auswahl umkehren) verwendet werden.

Koordinatenspalten

Wenn die aus der Zwischenablage eingefügten Daten Spalten mit Koordinaten enthalten, sind diese in der Tabelle Struktur auszuwählen. Spalten mit X-Koordinaten bzw. Y-Koordinaten müssen immer vom Typ "Numerisch" sein.

Ein Sonderfall stellen Koordinaten aus "Google Maps" dar. Diese können ermittelt werden, indem man innerhalb von "Google Maps" an der gewünschten Stelle mit der rechten Maustaste in die Karte klickt und "Was ist hier?" aus dem Kontextmenü auswählt. Die im Infofenster angezeigten Koordinaten in der Form '54.095891, 13.381571' usw. können in eine Excel-Tabelle übertragen werden und bilden hier eine spezielle Spalte, die vom Karten-Explorer verarbeitet werden kann. Diese Spalte ist vom Typ "Zeichen" und wird mit der Auswahl "Google Maps" als Koordinatenspalte gekennzeichnet.
Dabei wird immer die Reihenfolge Latitude (Y) und Longitude (X) erwartet, das Trennzeichen kann Komma oder Leerzeichen sein und die Notation kann dezimal oder in Grad, Minute und Sekunde sein. Dies ergibt folgende Formate, die zeilenweise neu interpretiert werden und damit auch beliebig wechseln können:

  • 54.183793,13.359263

  • 54.180384 13.339940

  • 54°11'01.7"N,13°21'33.4"E

  • 54°10'49.4"N 13°20'23.8"E

Werden beim Erstellen des Layers geografische Koordinaten in den angegebenen Koordinatenspalten erkannt, rechnet der Karten-Explorer den Layer automatisch von geografischen Koordinaten (Google Maps verwendet standardmäßig das vom GPS her bekannte System) in die beim Karten-Explorer eingestellte Projektion um.

Modus (Punkt / Linie)

Es besteht die Möglichkeit über ein Kombinationsfeld zu steuern, ob ein Layer mit Punkten oder ein Layer mit Linien zwischen zwei Punkten (mit optionaler Berechnung des Winkels) erstellt werden soll!

  • Punkt

    • Es sind die Spalten X (Rechtswert) und Y (Hochwert) zuzuordnen.

    • Sonderfall Google Maps (siehe oben): Liegen die Koordinaten in einer Spalte in der Form '54.095891, 13.381571' vor, ist dieser Spalte der Eintrag "Google Maps" zuzuordnen.

  • Linie

    • Es sind die Spalten für den ersten Punkt X1 (Rechtswert) und Y1 (Hochwert) zuzuordnen.

    • Es sind die Spalten für den zweiten Punkt X2 (Rechtswert) und Y2 (Hochwert) zuzuordnen.

    • Sofern die Ausgabe des Winkels erwünscht ist, ist die entsprechende Spalte Winkel (optional) zuzuordnen.

Layer aus Textdatei (CSV) automatisch erzeugen

  • Einen Sonderfall stellen CSV-Dateien dar, die in einem Zip-Archiv (*.zip oder *.kez) gespeichert sind. Aus ihnen kann der Karten-Explorer automatisch Layer generieren. Diese Funktionalität wird für eine zukünftige Schnittstelle zwischen TSN-KVP und TSN-Online 4 benötigt, kann jedoch auch gerne durch versierte TSN-Anwender genutzt werden.

  • In der Kopfzeile der CSV-Datei muss die Beschreibung von Spaltennamen, -typen und -längen definiert sein:
    SO_KENNUNG,C,12;VERDACHT,D,8;X_WERT,N,10,6;Y_WERT,N,10,6

  • Eine Datei *.kep in der Zip-Datei steuert die Generierung von Koordinaten und die Einfärbung

    • Ein (einfaches) Beispiel für die Verarbeitung einer
        CSV-Datei namens Ausbruch.csv sähe wie folgt aus:
[MAP]
LAYERCOUNT=1
[MAPLAYER0]
BASE=0^Ausbruch.Shp^Ausbrüche
AUTOCREATE=X_WERT,Y_WERT,2

    • AUTOCREATE gibt im ersten und zweiten Parameter die X- und Y-Spalte an, wobei GPS-Koordinaten automatisch erkannt und auf die im Karten-Explorer verwendetet Projektion transformiert werden. Im dritten Parameter ist das Format codiert (0=ANSI, 1=OEM, 2=UTF-8, 3=UTF-7; UTF-8 und UTF-7-BOM werden erkannt und setzten die Codierung automatisch korrekt.)


Layer aus GPX erstellen

Bildschirm anzeigen

Mit der Programmfunktion "Erstellen - aus GPX-Datei" des Karten-Explorers können aus GPX-Dateien (GPS Exchange Format) Shape-Dateien erstellt und als Layer geladen werden. Dabei werden die Geo-Objekte einer GPX-Datei in Shape-Dateien der Typen "Punkt" und "Linie" konvertiert, Attribute der Geo-Objekte importiert und die Shape-Dateien als Layer geladen.

GPX-Dateien können wie folgt geöffnet werden:

  • Dateiauswahl mit der Schaltfläche Öffnen-Dialog anzeigen

  • Einfügen aus der Zwischenablage mit der Schaltfläche [image] oder Strg + V

    • Einfügen eines Dateinamens einer GPX-Datei

    • Einfügen des Quelltextes einer GPX-Datei

  • Drag&Drop einer GPX-Datei in den Karten-Explorer oder dieses Programmfenster

Layer-Tabelle

Spaltenname | Beschreibung
Layername | In der Spalte Layername wird für jede Route und jeden Track der GPX-Datei ein separater Eintrag mit dem Namen des Elements entsprechend der GPX-Datei erzeugt. Werden Wegepunkte gefunden, werden diese in einem einzigen Layer "Wegepunkte" zusammengefasst.
Beschreibung | Hier wird eine Beschreibung der Route oder des Tracks angezeigt, sofern diese in der GPX-Datei hinterlegt ist.
Typ

Typ des Layers:

  • Waypoint
  • Route
  • Track
Punkte | Anzahl der Punkte im Layer
Segmente | Anzahl der Segmente eines Tracks → ausschließlich Tracks bestehen aus Segmenten - im Idealfall aus einem einzigen, häufig aber aus mehreren, wenn das GPS-Signal zwischenzeitlich nicht verfügbar war.
Größe | Größe des Layers in der GPX-Datei

Schaltflächen

Öffnen-Dialog anzeigen | GPX-Datei öffnen erlaubt die Auswahl einer GPX-Datei.
 | aus Zwischenablage einfügen (Strg + V) analysiert den Inhalt der Zwischenablage und fügt eine GPX-Datei (Inhalt ist Dateiname) oder den Quelltext einer GPX-Datei (Inhalt ist Text) ein.
 | alle Layer generieren erzeugt für jeden Eintrag der Tabelle einen Karten-Layer und öffnet ihn im Karten-Explorer als temporären Layer.
 | ausgewählten Layer generieren erzeugt einen Karten-Layer für den markierten Eintrag und öffnet ihn im Karten-Explorer als temporären Layer. Alternativ kann die Eingabetaste oder ein Mausdoppelklick verwendet werden.

Konvertierung von GPX in Karten-Layer

Das GPX-Format unterscheidet Waypoint, Route und Track:

  • Waypoint

    • Waypoints stellen einzelne Ortspunkte/Wegepunkte dar.

    • Werden Elemente vom Typ Waypoint gefunden, werden diese zu einem Layer zusammengefasst und als ein Karten-Layer vom Typ Punkt erstellt.

  • Route

    • Routen stellen eine sortierte Abfolge von Ortspunkten/Wegepunkten dar.

    • Elemente vom Typ "Route" werden immer als Karten-Layer vom Typ "Linie" exportiert.

    • Da jeder einzelne Punkt der Route Attribute enthält, die sich nicht dem Karten-Layer "Linie" zuordnen lassen würden, wird zusätzlich ein Karten-Layer vom Typ "Punkt" erzeugt, der die Attribute jedes Punktes der Route verfügbar macht.

  • Track

    • Tracks sind die vom GPS-Gerät aufgezeichneten Pfade.

    • Elemente vom Typ "Track" werden immer als Karten-Layer vom Typ "Linie" exportiert.

    • Da jeder einzelne Punkt des Tracks Attribute (insbesondere Zeitpunkt der Erstellung und Höhe) enthält, die sich nicht dem Karten-Layer "Linie" zuordnen lassen würden, wird zusätzlich ein Karten-Layer vom Typ "Punkt" erzeugt, der die Attribute jedes Punktes de Tracks verfügbar macht.

Mit dem Kontrollkästchen bei Routen und Tracks nur Linien-Layer (und keinen zusätzlichen Punkte-Layer) erzeugen kann das oben beschriebene Verhalten, dass bei Routen und Tracks zum Linien-Layer ein zusätzlicher Punkte-Layer erzeugt wird, der die Attribute (z.B. Zeitpunkt und Höhe) des Wegepunkte enthält, gesteuert werden.

Attribute

Attribute werden automatisch importiert, wenn bestimmte, fest vordefinierte "Tags" zu einem Wegepunkt gefunden wurden. Der folgenden Tabelle ist zu entnehmen, nach welchen Attributen in der GPX-Datei gesucht wird und unter welchem Namen sie im Karten-Explorer als Attribut des Karten-Layers zu finden sind.

Attribut in GPX | Beschreibung | Name im Karten-Explorer
NAME | Name des Ortspunktes / Wegepunktes | NAME
ELE | Höhe in Metern | HOEHE
TIME | Datum und Zeit entsprechend ISO 8601, z.B. 2011-12-31T23:59:59Z | ZEITPUNKT
CMT | Kommentar | KOMMENTAR
DESC | Beschreibung | BESCHREIB
SRC | Datenquelle / Ursprung | QUELLE
SYM | Darstellungssymbol | SYMBOL
TYPE | Kategorie / Klassifikation | TYP
URL | URL | URL
URLNAME | URL-Name | URLNAME


Layer aus KML erstellen

Bildschirm anzeigen

Mit der Programmfunktion "Erstellen - aus KML-Datei" des Karten-Explorers können aus KML-Dateien (Keyhole Markup Language) Shape-Dateien erstellt und als Layer geladen werden. Dabei werden die Geo-Objekte einer KML-Datei in Shape-Dateien der Typen "Punkt", "Linie", "Polygon" und "Multipoint" konvertiert, Attribute der Geo-Objekte importiert, die Shape-Dateien als Layer geladen und entsprechend der Formatierung der KML-Datei eingefärbt.

KML-Dateien können wie folgt geöffnet werden:

  • Dateiauswahl mit der Schaltfläche Öffnen-Dialog anzeigen

  • Einfügen aus der Zwischenablage mit der Schaltfläche [image] oder Strg + V

    • Einfügen eines Dateinamens einer KML-Datei

    • Einfügen des Quelltextes einer KML-Datei

  • Drag&Drop einer KML-Datei in den Karten-Explorer oder dieses Programmfenster

Layer-Tabelle

Spaltenname | Beschreibung
Layername | In der Spalte Layername wird für jeden so genannten "Folder", der in der KML-Datei gefunden wurde, dessen Name angezeigt. In der Regel enthält ein Folder in der KML-Datei Geo-Objekte eines Typs und würde in eine Shape-Datei bzw. einen Layer umgewandelt werden.
 | Layer enthält Polygone
 | Layer enthält Linien
 | Layer enthält Punkte
 | Layer enthält Multipunkte Werden Punkte in KML als Multigeometrie zusammengefasst, erstellt der Karten-Explorer daraus den Typ "Multipoint")
 | Layer verwendet so genannte Style-URLs. Die Einfärbung der Styles kann modifiziert werden.
 | Layer enthält Extended Data Bei 'Extended Data' wird die Beschreibung eines Geo-Objektes
 | Layer enthält 'Schema-Definition' Bei 'Schema-Definition' werden Name und Typ eines Attributes definiert und erlauben das typgerechte Importieren von Sachdaten. Die Struktur kann modifiziert werden.
Objekte | Anzahl der Geo-Objekte im Layer
Größe | Größe des Layers (Folders) in der KML-Datei

Schaltflächen

Öffnen-Dialog anzeigen | KML/KMZ-Datei öffnen erlaubt die Auswahl einer KML-Datei.
 | aus Zwischenablage einfügen (Strg + V) analysiert den Inhalt der Zwischenablage und fügt eine KML-Datei (Inhalt ist Dateiname) oder den Quelltext einer KML-Datei (Inhalt ist Text) ein.
 | ausgewählten Layer generieren erzeugt einen Karten-Layer für den markierten Eintrag und öffnet ihn im Karten-Explorer als temporären Layer. Alternativ kann die Eingabetaste oder ein Mausdoppelklick verwendet werden.
 | alle Layer generieren erzeugt für jeden Eintrag der Tabelle einen Karten-Layer und öffnet ihn im Karten-Explorer als temporären Layer. Mit den Kontrollkästen für die Typen [image] Punkt, [image] Linie und [image] Polygon kann die automatische Erstellung auf Layer bestimmter Typen beschränkt werden.
 | Einfärbung bearbeiten öffnet eine Programmfunktion, die das Bearbeiten der Styles der Einfärbung erlaubt. hier
 | Dateistruktur bearbeiten öffnet eine Programmfunktion, die das Bearbeiten der Datenstruktur der Attribute des markierten Layers erlaubt, sofern der Layer eine 'Schema-Definition' enthält. hier


Layer aus KML erstellen - Struktur bearbeiten

Layer aus KML erstellen - Datenstruktur bearbeiten

Bildschirm anzeigen

Wenn eine KML-Datei 'Schema-Definitionen' enthält, kann die Datenstruktur, die automatisch ermittelt worden ist, mit dieser Programmfunktion modifiziert werden. Insbesondere kann angegeben werden, welche Attribute (Spalten) importiert werden sollen, wie sie heißen und welchen Typ sie haben sollen.

Spaltenname | Beschreibung
Import? | Mit diesem Kontrollkästchen wird gesteuert, ob das betreffende Attribut importiert werden soll.
Feldname

Hier wird der Feldname im zu erstellenden Karten-Layer angegeben, der den Konventionen für dBase-Dateien entsprechen muss:

  • max. 10 Zeichen, Buchstaben, Zahlen und Unterstrich sind erlaubt!
  • keine Leerzeichen, Umlaute und Sonderzeichen, außer Unterstrich: _
  • erstes Zeichen muss ein Buchstabe sein!
Typ

Folgende Typen sind für dBase möglich (in Klammern die möglichen Längen):

  • Zeichen (Länge 1-256)
  • Numerisch (Länge 1-18)
  • Datum (immer 8)
  • Logisch (immer 1)
Länge | Abhängig vom Typ sind hier für "Zeichen" und "Numerisch" die Längen anzugeben.
Dezimal | Beim Typ "Numerisch" ist hier die Anzahl der gewünschten Dezimalstellen anzugeben. Die Länge muss so gewählt werden, dass Stellen vor dem Komma, das Komma und die Nachkommastellen beachtet sind!
Name in KML | Diese Spalte gibt den Namen des Attributs in der KML-Datei an. Diese Namen sind häufig länger als 10 Zeichen und enthalten Zeichen, die bei der notwendigen Konvertierung in dBase unzulässig sind.
Typ in KML

Die Schema-Definition kann folgende Typen enthalten:

  • string → wird in "Zeichen" mit der Länge 50 konvertiert.
    • Da im KML-Standard keine Länge hinterlegt ist, sollte verifiziert werden, ob die automatische Angabe von 50 Zeichen zweckmäßig ist.
    • In KML-Dateien, die von TSN-Online oder vom Karten-Explorer generiert wurden, ist eine Länge (in einem Kommentar) hinterlegt, so dass hier bereits eine sinnvolle Länge verwendet wird.
  • double, float → wird in "Numerisch"' mit der Länge 18 und 6 Dezimalstellen konvertiert
  • int, uint → wird in "Numerisch" mit der Länge 12 konvertiert
  • short, ushort → wird in "Numerisch" mit der Länge 6 konvertiert
  • bool → wird in "Logisch" (immer Länge 1) konvertiert


Layer aus KML erstellen - Einfärbung bearbeiten

Bildschirm anzeigen

Alle Stile (Styles) für die Einfärbung von Geo-Objekten, die in der KML-Datei definiert sind, werden mit dieser Programmfunktion mit Namen, dem verwendeten Symbol für die Einfärbung und einer Beschreibung angezeigt:

  • Die Spalte Name ist die Identifikation des jeweiligen Styles in der KML-Datei. Das zugehörige Symbol wird zentral an einer Stelle der KML definiert und einem oder mehreren Geo-Objekten der KML-Datei zugeordnet. Dieser Name kann nicht modifiziert werden.

  • Die Spalte [image] visualisiert die Einfärbung des Styles. Mit einem Doppelklick auf das betreffende Symbol kann diese Einfärbung individuell angepasst werden. Symbol bearbeiten

  • Die Beschreibung enthält den Namen, der in der Legende des Karten-Explorers für dieses Symbol verwendet wird, wenn ein Karten-Layer erzeugt wird. Diese Bezeichnung kann modifiziert werden.


Layer-Statistik

Bildschirm zeigen

Die Layer-Statistik gibt Auskunft über zahlreiche Eigenschaften des Layers. Sie erlaubt im Falle eines Layers mit Vektordaten (Shape-Datei bzw. ARC/INFO-Datei) die Abfrage der Struktur der Attribute und die Berechnung von statistischen Angaben zu numerischen Attributen.

  • Name steht für die Bezeichnung des Layers in der Layer-Kontrolle, die unabhängig vom Dateinamen des Layers ist.
    Tipp: Geben Sie dem Layer mit dem Menüpunkt "Layer - Umbenennen" einen aussagekräftigen Namen.

  • Datei gibt den tatsächlichen Namen der Datei an, die mit dem Layer assoziiert ist. Beachten Sie, dass hier lediglich der Name der "Hauptdatei" angegeben ist, während z.B. eine Shape-Datei aus mindestens drei Dateien besteht (*.shp, *.shx, *.dbf).

  • Typ gibt an, ob es sich um eine Bilddatei (Rasterdaten) oder Vektordatei (Polygon, Linie oder Punkt) handelt.

  • Geo-Objekte gibt die Anzahl der geografischen Objekte (Punkt, Linie, Polygon) bei Vektordaten an. Beachten Sie, dass ein Geo-Objekt aus mehreren Segmenten bestehen kann (z.B. Gemeinde mit Enklave bzw. Exklave)!

  • Ausdehnung gibt die minimale linke bzw. untere sowie die maximale rechte bzw. obere Koordinate des Layers an.

  • Struktur Attribute gibt bei Vektordaten die Struktur (den Aufbau) der Attribute (Sachdaten) an, die mit den Geo-Objekten assoziiert sind.
    Tipp: Bei Shape-Dateien kann die Struktur der Attribute-Datei mit dem Menüpunkt "Extras - Attribute - Struktur ändern" modifiziert werden.

  • Statistik berechnen erlaubt es, für alle numerischen Attribute (numerische Felder) eines Layers mit Vektordaten folgende Werte zu berechnen:

    • Summe,

    • Minimum,

    • Maximum,

    • Mittelwert und

    • Standardabweichung.

  • Fläche berechnen ist für Layer vom Type Polygon verfügbar. Sie berechnet und summiert über die Schaltfläche [image] die Flächen alle Geo-Objekte des Layers. Die Ausgabe erfolgt in km².
    Anmerkung: Diese Funktion arbeitet nur für Karten mit der Karteneinheit "Meter" korrekt. Daher ist sie bei der Karteneinheit "Dezimalgrad" deaktiviert.


Legende - Karten-Explorer

Legende

Eine Legende kann wahlweise direkt auf der Karte oder in einem separaten Fenster angezeigt werden.

Legende in Karte anzeigen

Mit der Schaltfläche [image] oder über den Menüpunkt "Ansicht - Legende in Karte anzeigen" kann die Anzeige einer Legende im Karten-Element ein- und ausgeschaltet werden.

Die Legende wird automatisch an der oberen linken Position der Karte angezeigt. Sie wird auch beim Drucken der Karte oder Exportieren der Karte in die Zwischenablage oder in eine Datei ausgegeben.

  • Um die Position der Legende zu verändern, ist der Menüpunkt "Ansicht - Legende positionieren" zu nutzen. Es erscheint ein Fadenkreuz. Mit gedrückter linker Maustaste ist ein Rahmen für die neue Position der Legende im Karten-Element von links, oben nach rechts, unten zu ziehen.

  • Schaffen Sie ggf. Platz für die Legende, indem Sie die Karte mit der Schaltfläche [image] verschieben.

  • Verschieben Sie den Teilungsbalken (zwischen Karte und Layer-Kontrolle), um das Karten-Element der Karte anzupassen.

Hinweis:
In der Layer-Kontrolle können über das Plus-Minus-Symbol einzelne Layer zusammengeklappt werden. Diese erscheinen fortan nicht mehr in der Legende (sowohl beim Drucken als auch bei der Anzeige von Legenden in der Karte).

Legende in Fenster anzeigen

Mit dem Menüpunkt "Ansicht - Legende in Fenster anzeigen" kann die Anzeige einer Legende in einem separaten Fenster ein- und ausgeschaltet werden.

Folgende Aktionen sind über die Legende aktivierbar:

  1. Die Einfärbung eines Layers kann per Doppelklick auf den Layer-Namen geändert werden.

  2. Die Sichtbarkeit eines Layers kann über das zugehörige Kontrollkästchen ein- bzw. ausgeschaltet werden.

  3. Die Reihenfolge der Layer kann verändert werden, indem ein Layer mit gedrückter linker Maustaste auf die gewünschte Position verschoben wird.

Für weitere Informationen über die Bedienung der Legende (Bedeutung von Symbolen, Tastenkombinationen und Mausfunktionen) konsultieren Sie bitte die Erläuterungen zur [image] Layer-Kontrolle.

vorhandenen Layer hinzufügen (Shapedatei, Coverage, Rasterkarte | .Hinzufügen lädt existierende Shape-Dateien oder Bilddateien (Rasterkarten) und fügt sie der Layer-Kontrolle zu. Hierbei können per Mehrfachauswahl mit Strg + Mausklick im Dateiauswahl-Dialog gleichzeitig beliebig viele Dateien der unterstützten Formate geöffnet. Layer hinzufügen
Einpassen auf aktiven Layer | Einpassen auf aktiven Layer bewirkt das optimale Einpassen des markierten (aktiven) Layers im Karten-Element.
Info-Felder | Info-Feld (Strg + I) aktiviert bis zu drei beliebiges Felder der der Attribut-Datei eines Layers dergestalt, dass für das an der Mausposition befindliche Geo-Objekt die gewählte Information als Tooltipp (Quick-Info) angezeigt wird. Info-Felder auswählen


Karten-Explorer - Einfärben

Eigenschaften für Einfärbung

Übersicht

Art der Einfärbung | Anwendung
einfaches Symbol | Alle Geo-Objekte werden einheitlich eingefärbt (einheitliche Farbe, Größe, Stil).
Klassen (automatisch, individuell) | Geo-Objekte werden in Abhängigkeit eines numerischen Merkmals abgestuft eingefärbt, Klassenbereiche können automatisch oder manuell festgelegt werden.
Einzelwert | Geo-Objekte werden in Abhängigkeit eines diskreten Wertes (Einzelwertes) eines Merkmals eingefärbt (z.B. braun für Wert "Ackerland", grün für Wert "Wald" usw.).
Punkthäufigkeiten | Flächen werden mit Punkthäufigkeiten in Abhängigkeit eines zu wählenden numerischen Merkmals eingefärbt. Diese Option ist nur für Polygone (nicht für Linien und Punkte) möglich.
Beschriftung | Geo-Objekte werden mit den Werten eines wählbaren Merkmals beschriftet.

Fensteraufbau

(Klicken Sie auf die Registerlaschen (Einfach, Klassen usw.), um sofort zu den betreffenden Erläuterungen zu gelangen)

  1. Die gewünschte Art der Einfärbung des Layers wird über die aktuell gewählte Registerlasche (im Beispiel "einfaches Symbol") ausgewählt.

  2. Alle gewünschten Optionen sind auf der jeweiligen Seite ggf. einzustellen (Farben, Stil usw.).

  3. Mit "Ok" oder "Übernehmen" werden die aktuellen Einstellungen aktiviert.
    Hinweis:
    Mit "Ok" werden die Einstellungen aktiviert und der Dialog sofort geschlossen. Mit "Übernehmen" hat man die Möglichkeit, die aktuellen Einstellungen zu übernehmen, um sich über das konkrete Erscheinungsbild der Karte einen Eindruck zu verschaffen ohne den Dialog zu schließen (Experimentieren mit der "richtigen" Einstellung).

einfaches Symbol

Bildschirm anzeigen

Geo-Objekte werden einheitlich eingefärbt. Abhängig davon, ob Polygone, Punkte oder Linien eingefärbt werden, sind verschiedene Optionen verfügbar.

Flächen-Symbol

  • Farbe (des Füllmusters)
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Farbe der Umrisslinie

  • Umrisslinie anzeigen?

  • Stärke der Umrisslinie

  • Füllstil (vollständig gefüllt, transparent, schraffiert usw.)
    Bei der Verwendung von Rasterkarten als Hintergrund ist i.d.R. die Option "transparent" oder eine Schraffur zu wählen.

Punkt-Symbol

  • Farbe
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Farbe der Umrisslinie

  • Umrisslinie anzeigen?

  • Symbolgröße

  • Markierung (Kreis, Quadrat, Dreieck, Kreuz, True-Type-Marker)

Wurde bei Markierung die Option "True-Type-Marker" gewählt, können beliebige Zeichen einer zu wählenden Schriftart als Markierung verwendet werden. Über die Schaltfläche [image] kann die Schriftart und über die Schaltfläche [image] das gewünschte Zeichen ausgewählt werden. Zusätzlich kann das Zeichen in einem beliebigen Winkel gedreht werden.

Mit der Schaltfläche [image] Standardsymbole kann eine Auswahl wichtiger vordefinierter Symbole zum Krisenmanagement bei Tierseuchen aktiviert werden.

Linien-Symbol

  • Farbe
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Linienstärke

  • Linienart (Durchgehend, Gestrichelt, Gepunktet, Strich-Punkt)

Klassen (automatisch)

Bildschirm anzeigen

Geo-Objekte werden in Abhängigkeit eines numerischen Merkmals abgestuft eingefärbt, Klassenbereiche (Klassengrenzen) werden automatisch in Abhängigkeit vom Maximalwert des Merkmals generiert.

  • numerisches Feld trifft die Auswahl des Feldes aus der Merkmalsdatei des Layers.

  • Maximalwert zeigt den höchsten Wert in der Merkmalsdatei für das gewählte Feld an.

  • Klassenanzahl legt die Zahl der anzuzeigenden Klassen (3 bis 20) fest.

  • Farbstufen werden zwischen einem Anfangs- und Endwert für jede Klasse automatisch berechnet. Das Ändern der Anfangs- bzw. Endfarbe erfolgt per Mausklick in die jeweilige farbige Fläche.

  • Symbolgröße legt einen Anfangs- bzw. Endwert für die Größe von Punkten und Linien fest. Für Flächen ist diese Option nicht verfügbar. Die Symbolgröße wird für die jeweilige Klasse automatisch berechnet.

Klassen (individuell)

Bildschirm anzeigen

Geo-Objekte werden in Abhängigkeit eines numerischen Merkmals abgestuft eingefärbt, Klassenbereiche (Klassengrenzen) und die Einfärbung jeder Klasse können individuell festgelegt werden. Des weiteren können die Einstellungen in Legendendateien gespeichert und wieder hergestellt werden.

  • numerisches Feld trifft die Auswahl des Feldes aus der Merkmalsdatei des Layers.

  • Maximalwert zeigt den höchsten Wert in der Merkmalsdatei für das gewählte Feld an.

  • Klassenanzahl legt die Zahl der anzuzeigenden Klassen (3 bis 100) fest.

individuelle Festlegung von Klassengrenzen und Klassensymbol

Per Mausklick auf das gewünschte Symbol oder durch Betätigen der Eingabetaste erscheint ein Dialog, mit dem die obere Klassengrenze sowie alle Eigenschaften des für die Klasse verwendeten Symbols (Farbe, Größe, Stil) separat festgelegt werden können.

Klassen-Designer

Die Schaltfläche Designer erlaubt es, die Klassengrenzen einzugeben oder berechnen zu lassen (wahlweise für gleiche Distanzen oder gleiche Anzahlen je Klasse). Des Weiteren wird die Verteilung (Anzahl pro Klasse) grafisch dargestellt. Es können Farbverläufe (auch für Teilbereiche) generiert, Klassen eingefügt und gelöscht werden.
Klassen-Designer

globale Änderungen

Mit den Schaltflächen im Bereich "global ändern" können auf Wunsch Änderungen für alle Klassen vorgenommen werden:

  • Farbverlauf erlaubt es, eine Anfangs-, Zwischen- und Endfarbe anzugeben. Die Farben für die dazwischen liegenden Klassen werden automatisch ermittelt. Außerdem können vordefinierte Farbschemen zugewiesen werden.

  • Symbolgröße erlaubt es, eine Anfangs- und Endgröße für Punkte bzw. Linien anzugeben. Die Symbolgröße für die dazwischen liegenden Klassen wird automatisch ermittelt.

  • Symbol-Stil erlaubt es, wählbare Eigenschaften (Farben, Füllmuster, Linienstärke, Sichtbarkeit der Umrisslinie usw.) für die Symbole aller Klassen zu ändern.
    Symboleigenschaften für alle Symbole ändern

Legende laden und speichern

Die aktuellen Einstellungen für Klassenanzahl, Klassengrenzen und Symbole (Farbe, Stil, Größe) können in einer Legendendatei gespeichert und geladen werden. Dies ist nützlich, falls ein bestimmtes Schema der Einfärbung häufiger verwendet werden soll. In diesem Fall ist lediglich das numerische Feld auszuwählen und die Legende zu laden.

Einzelwert

Bildschirm anzeigen

Geo-Objekte werden in Abhängigkeit eines diskreten Wertes (Einzelwertes) eines Merkmals eingefärbt. Diese Art der Einfärbung ist für einen begrenzten Wertevorrat eines Merkmalfeldes sinnvoll wie:

  • 10 Betriebsarten (ein Symbol für "Schlachthof", ein Symbol für "TKBA" usw.),

  • 3 Tierarten (einen Kreis für Schwein, ein Dreieck für Rind, ein Quadrat für Schaf),

  • 5 Vegetationsarten (z.B. braun für Wert "Ackerland", dunkelgrün für Wert "Wald", hellgrün für Wert "Wiese" usw.)

Feldauswahl

Es ist ein Feld auszuwählen, für das Einzelwerte eingefärbt werden sollen. Die Auswahl eines numerischen Feldes mit kontinuierlichen Werten ist i.d.R. nicht sinnvoll. Hierfür sollte die Einfärbung mit Klassen (siehe oben) verwendet werten.

Werte einfärben

  • Liste ermittelt eine Liste aller (noch nicht in der Legende aufgeführten) Einzelwerte des gewählten Feldes. Diese können ausgewählt und individuell eingefärbt werden.
    Hinweis: Sind mehr als 1000 Einzelwerte für das Feld vorhanden, werden weitere Einzelwerte nicht mehr angezeigt!

  • Manuell erlaubt die Eingabe eines Einzelwertes und die anschließende Festlegung der Einfärbung.
    Achtung: Die exakte Schreibweise ist zu beachten, Groß- und Kleinschreibung sind signifikant!

  • Automatisch ermittelt alle Einzelwerte und färbt sie automatisch ein.
    Hinweis: Sind mehr als 100 Einzelwerte für das Feld vorhanden, werden weitere Einzelwerte nicht mehr eingefärbt!

  • Symbol-Stil erlaubt es, wählbare Eigenschaften (Farben, Füllmuster, Linienstärke, Sichtbarkeit der Umrisslinie usw.) für die Symbole aller Einzelwerte zu ändern.
    Symboleigenschaften für alle Symbole ändern

  • Farbverlauf erlaubt es, eine Anfangs- und Endfarbe anzugeben. Die Farben für die dazwischen liegenden Einzelwerte werden automatisch ermittelt.

  • Alle löschen entfernt alle Einträge aus der Legende.

Legende bearbeiten (Symbole ändern/löschen/verschieben)

Per Mausklick auf das gewünschte Symbol in der Legende erscheint ein Dialog, mit dem der Einzelwert sowie alle Eigenschaften des für den jeweiligen Einzelwert verwendeten Symbols (Farbe, Größe, Stil) nachträglich geändert werden können. Mit der Entf.-Taste kann das markierte Symbol gelöscht werden. Mit gedrückter linker Maustaste kann das markierte Symbol an die gewünschte Stelle verschoben werden (Drag & Drop).

Default-Symbol

Das Default-Symbol, ist ein Symbol zum Einfärben aller Einzelwerte in der Merkmalsdatei, für die in der Legende keine Einfärbung festgelegt wurde. Bei deaktiviertem Kontrollkästchen "Default", werden diese Geo-Objekte auf der Karte nicht angezeigt. Bei aktiviertem Kontrollkästchen "Default" werden sie mit dem "Default-Symbol" eingefärbt. Über [image] wird die Einfärbung des Default-Symbols festgelegt.

Legende laden und speichern

Die aktuellen Einstellungen für Einzelwerte und deren Symbole (Farbe, Stil, Größe) können in einer Legendendatei gespeichert bzw. aus dieser geladen werden. Dies ist nützlich, falls ein bestimmtes Schema der Einfärbung häufiger verwendet werden soll. In diesem Fall ist lediglich das Feld auszuwählen und die Legende zu laden.

Punkthäufigkeiten

Bildschirm anzeigen

Geo-Objekte (Polygone) werden mit Punkthäufigkeiten in Abhängigkeit eines zu wählenden numerischen Merkmals eingefärbt. Die Punkte werden zufällig innerhalb des Polygons verteilt. Es kann in Abhängigkeit des Maximalwertes des Merkmals sinnvoll festgelegt werden, wie viele Einheiten des Merkmals einen Punkt darstellen sollen (z.B. bei Tieren je Gemeinde, 1 Punkt pro Tier bei geringer Tierdichte oder 1 Punkt je 100 Tiere bei hoher Tierdichte).

Diese Art der Einfärbung ist nur für Polygone (nicht für Linien und Punkte) möglich!

  • numerisches Feld trifft die Auswahl des Feldes aus der Merkmalsdatei des Layers.

  • Maximalwert zeigt den höchsten Wert in der Merkmalsdatei für das gewählte Feld an.

  • Punktfarbe erlaubt das Ändern der Farbe per Mausklick in die farbige Fläche!

  • Ändern der Farbe per Mausklick in die farbige Fläche!

  • Punktwert gibt an, wie viele Einheiten des Merkmals einen Punkt darstellen sollen. Der Standard ist ein Punkt je Einheit. Sind hohe Werte des Merkmals (s.o. Maximalwert) vorhanden, sollte dieser Punktwert sinnvoll erhöht werden.

  • Punktgröße legt die Größe des Punktes in Pixel fest.

  • Hintergrund zeichnen
    Ist das Kontrollkästchen aktiviert, wird neben der Darstellung von Punkthäufigkeiten auch die Darstellung des Hintergrundes (Umrisslinien und Füllmuster) entsprechend der unter "einfaches Symbol" getroffenen Einstellungen verwendet.

Beschriftungen

Bildschirm anzeigen

Geo-Objekte werden mit den Werten eines wählbaren Merkmals beschriftet. Dabei wird ein Mechanismus verwendet, der die Beschriftung so platziert, dass Überlagerungen der Texte vermieden werden. Ggf. können bei starker Häufung von Geo-Objekten nicht alle Beschriftungen angezeigt werden.

Zur Festlegung der Schriftgröße existieren zwei Verfahren:

  1. absolute Schriftgröße: die Schriftgröße ist unabhängig vom Kartenmaßstab

  2. skalierte Schriftgröße: die Schriftgröße variiert mit dem Maßstab (Zoomebene)

Optionen festlegen

  • Beschriftungsfeld legt das zur Beschriftung zu verwendende Merkmal fest.

  • Font erlaubt es über [image] die Schriftart und -farbe sowie Attribute wie fett, unterstrichen und kursiv festzulegen.

  • Beschriftung platzieren ist nur für Punkte-Layer verfügbar und steuert, ob Texte auf, über oder unter Geo-Objekten (Punkten) angezeigt werden. Der Abstand vom Geo-Objekt kann ebenfalls variiert werden.

  • Hintergrund zeichnen
    Ist das Kontrollkästchen aktiviert, wird neben der Darstellung von Beschriftungen auch die Darstellung des Hintergrundes (Umrisslinien und Füllmuster) entsprechend der unter "einfaches Symbol" getroffenen Einstellungen verwendet.

  • Duplikate erlaubt steuert die Anzeige gleich lautender Beschriftungen. Ist das Kontrollkästchen deaktiviert, werden gleiche Texte nur einmal im sichtbaren Kartenausschnitt angezeigt (z.B. könnte die Beschriftung von Exklaven von Gemeinden damit verhindert werden).

  • Beschriftung einrahmen hinterlegt die Beschriftungstexte mit der unter Hintergrund angegebenen Farbe.
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Schriftgröße legt die Größe der Beschriftungstexte für die Verwendung absoluter Schriftgrößen (unabhängig vom Kartenmaßstab) fest.

  • skalierte Beschriftung legt fest, ob die Schriftgröße der Beschriftungstexte mit dem aktuellen Maßstab (Zoomebene) variieren soll. Über den Schieberegler Schriftgröße (skaliert) kann diese Schriftgröße geändert werden.

  • Anzeigebereich für Beschriftung verwenden legt fest, ob die Beschriftungen nur in einem bestimmten, wählbaren Bereich (ab Maßstab ... bis Maßstab) eingeblendet werden sollen.

Tipp: Über die Option „Hintergrund zeichnen“ wird gesteuert, ob neben der Beschriftung auch die Geo-Objekte (Punkte, Umrisslinien) etc. gezeichnet werden sollen, wie es mit der ersten Registerlasche „Einfach“ (einfaches Symbol) festgelegt ist. Mitunter möchten Sie einen Layer aber mit unterschiedlichen Symbolen einfärben (Klassen bzw. Einzelwert), wobei nicht gleichzeitig Beschriftung aktivierbar ist. Für dieses Problem gibt es eine einfache Lösung. Laden Sie den betreffenden Layer mit [image] ein zweites Mal (sinnvollen Layer-Namen wie „Beschriftung Betriebe“ etc. vergeben!) und aktivieren Sie für diesen Layer den Modus Beschriftung mit den gewünschten Parametern. Wenn Sie jetzt noch die Option „Hintergrund zeichnen“ für diesen Layer deaktivieren, wird er ausschließlich aus Beschriftungen bestehen.

Frage – Antwort: Häufig wurde dem TSN-Support die Frage gestellt: „Wie kriege ich denn die Beschriftungen wieder weg?“ Nun ganz einfach: Indem ich anstatt der Registerlasche „Beschriftung“ eine andere Lasche wie z.B. „Einfach“ aktiviere.


alle Symbole ändern - Karten-Explorer

Eigenschaften für alle Symbole ändern

Bildschirm zeigen

Beim Einfärben von Symbolen im Karten-Explorer nach individuellen Klassen Bildschirm zeigen oder Einzelwerten Bildschirm zeigen kann für jede Klasse (1-10, 10-20 usw.) bzw. für jeden Einzelwert ("Rind", "Schaf" usw.) ein Symbol individuell festgelegt werden. Um bestimmte Eigenschaften aller Symbole effizient ändern zu können (z.B. alle Flächen kreuzweise schraffiert oder alle Umrisslinien in roter Farbe), kann diese Programmfunktion mit der Schaltfläche "Symbol-Stil" aktiviert werden.

Um eine oder mehrere Symboleigenschaften global zu ändern, gehen Sie wie folgt vor:

  1. Global zu übernehmende Symboleigenschaft(en) durch Aktivierung des zugehörigen Kontrollkästchens auswählen!

  2. Betreffende Symboleigenschaft auf den gewünschten Wert setzen!

  3. Änderung aller Symbole durch Betätigen der Schaltfläche Ok ausführen!

  • Siehe Beispiel im "Screenshot" Bildschirm zeigen !
    Hier werden für alle Symbole 3 Eigenschaften geändert:

    1. Sichtbarkeit der Umrisslinie [gewählter Wert: anzeigen],

    2. Stärke der Umrisslinie [gewählter Wert: 2] und

    3. Füllstil der Flächen [gewählter Wert: "vollständig gefüllt"].


Klassengrenzen berechnen - Karten-Explorer

Klassen-Designer

Bildschirm zeigen

Beim Einfärben von Symbolen im Karten-Explorer nach individuellen Klassen Bildschirm zeigen kann mit der Schaltfläche Designer diese Programmfunktion aktiviert werden. Damit lassen sich Klasseneinteilungen für numerische Attribute effizient festlegen, berechnen, einfärben und visualisieren.

Die Funktion "Klassengrenzen-Designer" erlaubt:

  • das manuelle Festlegen von Klassengrenzen,

  • das Berechnen von Klassengrenzen mit gleichen Distanzen (automatische oder manuelle Klassenbreiten),

  • das Berechnen von Klassengrenzen mit gleichen Anzahlen je Klasse,

  • das Einfügen und Löschen von Klassen,

  • die Einfärbung für einzelne Symbole und Farbverläufe für wählbare Bereiche,

  • die Visualisierung der Verteilung der Geo-Objekte auf die Klassen (Anzahl je Klasse).

Klassen einfügen, löschen und Einfärben

Verwenden Sie die Schaltfläche [image] (Zeile oberhalb) bzw. (Zeile unterhalb), um neue Zeilen über oder unter der markierten Zeile einzufügen. Sofern möglich, wird neue Klasse so eingefügt, dass der Abstand (Klassenbreite) und der Farbwert entsprechend der benachbarten Klassen (Zeilen) angepasst wird.

Die Farbe einer einzelnen Zeile kann mit einem Doppelklick (oder Betätigen der Eingabetaste) in der Farbspalte geändert oder die unten beschriebenen Schaltflächen geändert werden. In Abhängigkeit vom Markierungsmodus [image] wirken sich die Änderungen auf alle Klassen oder die markierten Klassen aus.

neue Zeile über der markierten Zeile einfügen
neue Zeile unter der markierten Zeile einfügen
markierte Zeile löschen
vordefiniertes Farbschema zuweisen [image] hier
Farbverlauf für alle oder die markierten Klassen berechnen. Dabei wird die erste Klasse als Anfangs- und die letzte Klasse als Endfarbe für die Berechnung benutzt.
Farbverlauf aus den markierten Klassen berechnen und auf alle Klassen anwenden. Diese Funktion ist nur im Markierungsmodus verfügbar. Es sind zwei oder mehr Klassen zu markieren.
Beispiel: 20 Klassen sind vorhanden. 3 Klassen werden mit Farben (Grün, Gelb, Rot) versehen und markiert. Nach Betätigen der Schaltfläche [image] wird für die 20 Klassen ein wunderschöner Farbverlauf von Grün über Gelb nach Rot erzeugt.
Farbverlauf umkehren!
Das Kontrollkästchen aktiviert/deaktiviert den Markierungsmodus. Um einen zusammenhängenden Bereich zu markieren, ist mit gedrückter linker Maustaste über den gewünschten Bereich zu ziehen. Für die Auswahl einzelner Klassen ist zusätzlich die Strg-Taste zu verwenden, wenn Klassen angeklickt werden.
Die grafische Darstellung der Verteilung der Werte auf die Klassen kann wahlweise auf den Maximalwert oder auf 100% bezogen werden. Bei nicht aktiviertem Kontrollkästchen wird die Breite des Balken der Klasse auf 100% (die Summer aller Werte) bezogen, bei aktiviertem Kontrollkästchen wird der höchste Wert ermittelt und füllt die Spalte komplett aus - allen anderen Werte werden relativ dazu dargestellt.

Klassengrenzen festlegen

manuell

In der Spalte "bis" können die Werte für die obere Klassengrenze einer Klasse eingegeben werden. Es gilt, dass der eingegebene Wert für die obere Klassengrenze der Startwert für die nächste Klasse ist. Wird zum Beispiel 10 als obere Klassengrenze für die erste Klasse angegeben, fallen alle Werte kleiner 10 in die erste Klasse, der Wert 10 gehört bereits zur zweiten Klasse.

Abstand zuweisen

Neben der Schaltfläche "Abstand zuweisen" kann ein Wert eingegeben werden, der beim Betätigen der besagten Schaltfläche automatisch für alle Klassen als Klassenbreite zugewiesen wird. Alternativ kann der Abstand nur für gewünschte Klassen zugewiesen werden, indem mit dem Kontrollkästchen "Mehrfachauswahl" der Markierungsmodus aktiviert wird, um anschließend alle gewünschten Zeilen (Klassen) per Maus oder Tastatur zu markieren.

Automatisch berechnen

Die Klassengrenzen können mit den Schaltflächen "gleiche Abstände" und "gleiche Anzahlen" automatisch berechnet werden.

Vorab sollte mit Kontrollkästchen "Grenzwert für erste Klasse nicht verändern" festgelegt werden, ob die erste Klasse in die Berechnung einbezogen werden soll oder ob sie als Klasse für Null- bzw. Fehlwerte fungiert. Ist dies der Fall, sollte das Kontrollkästchen aktiviert werden und der Grenzwert für die erste Klasse auf einen sinnvollen Wert gesetzt werden.

Beispiel:
Hat ein Layer mit allen Tierhaltern eines Kreises 2000 Geo-Objekte, die nach einem Feld "Rinder" mit individuellen Klassen eingefärbt werden sollen, von denen im Feld "Rinder" für 1500 Geo-Objekte der Wert 0 ist (keine Rinderhalter sondern Schweinehalter, Hühnerhalter usw.), so sollte der Wert für die obere Grenze der ersten Klasse auf 1 gesetzt werden und das Kontrollkästchen aktiviert werden.
Enthält andererseits ein Layer nur Rinderhalter (Feld Rinder ist erwartungsgemäß immer größer 0), sollte das Kontrollkästchen deaktiviert und die erste Klasse damit in die Berechnung der Klasseneinteilung einbezogen werden.

Gleiche Abstände

Mit dieser Schaltfläche werden Klassen mit konstanten Klassenbreiten generiert. Dazu wird der Maximalwert durch die Klassenanzahl dividiert und die Klassengrenzen entsprechend modifiziert.

Gleiche Anzahlen*

Mit dieser Schaltfläche werden Klassen mit gleichen Anzahlen je Klasse erzeugt. Dabei haben die Klassengrenzen ggf. sehr unterschiedliche Abstände.

Die Berechnung erfolgt dergestalt, dass z.B. bei 4 Klassen und 1000 Geo-Objekten zunächst die Werte sortiert werden und der 250. Wert als 1. obere Klassengrenze, der 500. Wert als 2. obere Klassengrenze und der 750. Wert als 3. obere Klassengrenze verwendet wird.

Klasse | obere Grenze ermitteln | Klassengrenzen
1 | 250. Wert ist 130 | x < 130
2 | 500. Wert ist 350 | 130 <= x < 350
3 | 750. Wert ist 780 | 350 <= x < 780
4 |  | x >= 780

* Eine exakte Gleichverteilung der Anzahlen auf die Klassen ist i.d.R. aus zwei Gründen nicht möglich:
1. Auftreten gleicher Werte.
2. Anzahl der Werte kein Vielfaches der Klassenanzahl.


Layervorlagen - Karten-Explorer

Layer-Vorlagen (*.kel)

Layer-Vorlagen stellen eine optionale Erweiterung einer Karten-Datei (Shape-Datei oder Bild-Datei) dar, die der Karten-Explorer verwendet, um Informationen über Einfärbung, Namen in der Layer-Kontrolle und Info-Feld zu speichern. Diese Datei hat die Erweiterung *.kel für Karten-Explorer-Layer-Vorlage.
Wird z.B. eine Shape-Datei (*.shp) über [image] zu einem Projekt hinzugefügt, sucht der Karten-Explorer automatisch nach einer gleichnamigen Layer-Vorlage (*.kel), um die Einfärbung etc. festzulegen.

Ist eine Karten-Datei einmal als Layer zu einem Karten-Explorer-Projektes (*.kep) hinzugefügt, so werden die Einstellungen durch die KEP-Datei gesteuert.

Das Menü "Layer - Layer-Vorlage" des Karten-Explorers enthält vier Menüpunkte:

  1. Laden: Die Einstellungen aus der mit der Karten-Datei assoziierten (also gleichnamigen) KEL-Datei werden aktiviert. Dies ist hilfreich, wenn innerhalb eines Projektes die Einstellungen für den Layer geändert worden sind und die in der KEL-Datei gespeicherten Angaben reaktiviert werden sollen.

  2. Speichern: Die aktuellen Einstellungen des Layers werden in einer KEL-Datei (mit dem Namen der Karten-Datei) abgelegt.

  3. Importieren: Die Einstellungen einer auszuwählenden KEL-Datei werden geladen. Dies erlaubt es, die KEL-Datei einer anderen Karten-Datei zu importieren.

  4. Exportieren: Die aktuellen Einstellungen des Layers werden in eine KEL-Datei mit anzugebendem Namen exportiert.

  5. Vorlagenbibliothek: Vordefinierte Layer-Vorlagen, z.B. für Einfärbungen von Tierdichten, sind in einer Bibliothek fest hinterlegt. Eigenen Layer-Vorlagen können hinzugefügt werden.
    Vorlagenbibliothek

Die Festlegung komplexer Einfärbungen wie das Einfärben nach Einzelwerten oder Klassen ist ggf. recht zeitaufwändig. Über Exportieren/Importieren können Bibliotheken für bevorzugte Einfärbungen angelegt bzw. geladen werden, die neben der Zeitersparnis auch die einheitliche Verwendung von Farben, Klassengrenzen usw. erlauben.


Vorlagenbibliothek - Karten-Explorer

Vorlagenbibliothek

Bildschirm zeigen

Vordefinierte und benutzerdefinierte Layer-Vorlagen können über das Menü „Layer – Layer-Vorlagen - Vorlagenbibliothek“ oder mit (↑ + V) aktiviert werden.

  • Vordefiniert

    • DLM (Standard, Vegetation, Wald)

    • Tierarten (Klauentier-, Schweine-, Rinder-, Geflügeldichte)

  • Eigene

    • Eigene Vorlagen können in die Vorlagenbibliothek integriert werden, wenn eine KEL-Datei (Layer-Vorlage) in das „Vorlagen-Verzeichnis“ kopiert wird.

      • Unterhalb des bei den Einstellungen von TSN hinterlegten Karten-Verzeichnisses ist ein Ordner /KEL anzulegen.

      • In diesen Ordner können KEL-Dateien aufgenommen werden, indem die aktuelle Einfärbung eines Layers über das Kontextmenü (rechter Mausklick auf Layer) mit dem Menüpunkt „Layer-Vorlage - Exportieren“ gespeichert wird oder eine vorhandene Layer-Vorlage in das Verzeichnis kopiert wird.

Im Fenster der Vorlagenbibliothek werden immer alle vorhandenen Vorlagen angezeigt, die mit dem Typ des aktiven Layers (markierter Layer in der Layer-Kontrolle) übereinstimmen, d.h., eine Layer-Vorlage ist immer spezifisch für einen Layer vom Typ [image] Punkt, [image] Linie oder [image] Polygon.

In der Spalte Attribut ist angegeben, ob die Einfärbung nach einem bestimmten Attribut erfolgt und welchen Typ das Attribut haben muss (eine Einfärbung nach Klassen erfordert z.B. immer ein numerisches Attribut).

Die in der Tabelle verwendeten Symbole für den Typ des Attributs folgende Bedeutung:
 | Das Attribut muss alphanumerisch sein.
 | Das Attribut muss numerisch sein.
 | Das Attribut kann einen beliebigen Typ haben. Das ist z.B. bei Beschriftungen möglich.
 | Es ist kein Attribut erforderlich, was bei der Einfärbung mit einem einheitlichen Symbol für alle Geo-Objekte der Fall ist.

Wenn der Vorgabewert für das Attribut in der gewählten Vorlage nicht in den Attributen des aktiven Layers gefunden wurde, ist ein alternatives Attribut des Layers manuell auszuwählen.


Karten-Explorer - Einfärben (einfaches Symbol)

Standard-Symbole

Für die wichtigsten Markierungen (öffentliche Einrichtungen, Kontaktbestände, Sperren usw.) im Zusammenhang mit dem Krisenmanagement von Tierseuchen sollten einheitliche Standardsymbole verwendet werden, die aus einer Liste ausgewählt werden können.

Schriftart installieren!
Die Schriftdatei TSN-Symbole.ttf muss installiert (im Systemordner Fonts vorhanden) sein. Wenn das folgende Zeichen E kein Schwein ist, ist die notwendige Schriftart auf Ihrem Computer nicht verfügbar.
Anzeige optimieren!
Falls die Anzeige von Symbolen auf dem Bildschirm undeutlich erscheint, kann es notwendig sein, die Kantenglättung von Schriftarten bei den Anzeigeeigenschaften von Windows zu aktivieren.

- Auf der Registerkarte 'Darstellung' die Schaltfläche 'Effekte' aktivieren,
- Kontrollkästchen 'Folgende Methode zum Kantenglätten....' aktivieren.
- Modus 'Normal' auswählen.

Liste der Standardsymbole

Kontaktbestände |  | sonstige Betriebe
) | K1 - Kontaktbestände der Kategorie 1 | 0 | Viehhandelsunternehmen
* | K2 - Kontaktbestände der Kategorie 2 | 1 | Viehmarkt/Viehsammelstelle
+ | K3 - Kontaktbestände der Kategorie 3 | 2 | Besamungsstelle
, | Tierkontakt | 3 | Zoo/Tierpark
- | Personenkontakt | 4 | Tierheim
. | Fahrzeugkontakt | 5 | Zoohandlung
/ | Kontakt über Erzeugnisse/Stoffe | 6 | Schlachtbetrieb Rotfleisch (auch schlachtende Metzgereien)
seuchenspezifische Einrichtungen |  | 7 | Wildannahmestelle
| | MBZ - Mobiles Bekämpfungszentrum | 8 | Molkerei/Käserei/Milch verarbeitender Betrieb
a | Straßensperre | 9 | Futtermittel herstellender Betrieb
` | Verbotsschilder aufgestellt | : | TKBA - Tierkörperbeseitigungsanlage
> | Desinfektionseinrichtung (allgemein) | ; | Klärwerk
? | Desinfektionseinrichtung (Schleusen) für Personen | < | Lebensmittelbetrieb
@ | Desinfektionseinrichtung (Schleusen) für PKW (ohne LKW) |  |
A | Desinfektionseinrichtung (Schleusen) für PKW (mit LKW) |  |
öffentliche Einrichtungen |  |  |
" | LA - Landratsamt |  |
# | VUA -Veterinäruntersuchungsamt |  |
$ | POL - Polizeidienststelle |  |
% | FEU - Feuerwehr |  |
& | THW - Technisches Hilfswerk |  |
' | BuWe - Bundeswehrstandort oder -einrichtung |  |
( | KH - Krankenhaus/Klinik |  |
Tiersymbole |  |  |
B | Rind |  |
C | Schaf |  |
D | Ziege |  |
E | Schwein |  |
F | Huhn |  |
G | Pute |  |
H | Gans |  |
I | Pferd (Einhufer) |  |
J | Fische |  |
K | Hund |  |
L | Katze |  |
M | Kaninchen |  |
N | Reh |  |
O | Schwarzwild |  |
P | Fuchs |  |
Q | Zootier |  |
Å | Biene |  |
Æ | Reptil |  |
Ç | Maus |  |
È | Fledermaus |  |
É | Rotwild |  |
Ê | Kameliden |  |
Ë | Gans |  |
Ì | Laufvogel |  |
Í | Wildvogel |  |
Î | Raubvogel |  |


Farbschema zuweisen - Karten-Explorer

Farbschema zuweisen

Bildschirm zeigen

Beim Betätigen der Schaltfläche [image] im [image] Klassen-Designer wird diese Programmfunktion aufgerufen und erlaubt die Auswahl vordefinierter Farbschemata aus einer internen Bibliothek, sowie das Hinzufügen von individuellen Farbschemata zu dieser Bibliothek.

Alle Einträge, deren Beschreibung eine fett hervorgehobene Schriftart haben, können nicht geändert werden. Alle anderen Einträge können mit [image] gelöscht, per einfachen Mausklick auf den Text bzw. ↑+Eingabetaste umbenannt und per Drag&Drop auf eine andere Position verschoben werden. Änderungen werden mit [image] gespeichert.

Der letzte Eintrag in der Liste stellt die aktuelle Einfärbung im Klassen-Designer dar und ist mit <zum Speichern umbenennen> gekennzeichnet. Demzufolge kann dieser neue Eintrag durch Umbenennen und Betätigen von [image] konserviert werden.

Die individuellen Farbschemata werden in der Datei farbschema.ini im eingestellten Kartenverzeichnis gespeichert.


Drucken - Karten-Explorer

Karten drucken

Neben dem Ausdruck von Karten auf beliebigen Druckern ist auch die Ausgabe von Legende, Nordpfeil, Maßstab und Titel neben der Karte optional möglich.

Drucklayout-Modus

Bevor die Karte ausgedruckt werden kann, ist der Drucklayout-Modus über den Menüpunkt "Ansicht - Drucklayoutmodus" oder die zugehörige Schaltfläche zu aktivieren.

Um ein optimales Druckergebnis zu ermöglichen, ist es notwendig, die Proportionen des Karten-Elements exakt an den Druckbereich für die Karte auf dem gewählten Drucker (unter Beachtung von Papiergröße, Papierformat, Seitenrändern und Platz für Legende) anzupassen. Damit wird sicher gestellt, dass das Ergebnis des Ausdrucks mit der Ansicht auf dem Bildschirm übereinstimmt.

Die Voreinstellung ist der Ausdruck im Modus Karte mit Legendenbereich auf dem Standarddrucker von Windows. Um dies zu ändern, verwenden Sie die Programmfunktion "Drucker einrichten"

Drucker einrichten

Mit der Schaltfläche [image] bzw. dem Menüpunkt "Datei - Drucker einrichten" wird der Druckmodus, der zu verwendende Drucker, das Papierformat usw. festgelegt. Sollte der Drucklayoutmodus nicht aktiv sein, wird er nach der Druckereinrichtung aktiviert.

Grundsätzlich werden zwei Arten der Druckausgabe unterschieden:

  • nur Karte [image] bzw.
    Die Karte wird, wie sie auf dem Bildschirm dargestellt ist, auf den druckbaren Bereich auf dem Ausgabemedium eingepasst. Der Ausdruck ist im Hoch- oder Querformat möglich.

  • Karte mit Legendenbereich
    Ausgabe bei Druck von Karte mit Legende Neben der Karte wird ein Bereich zur Darstellung der Legende für alle sichtbaren Layern mit Vektordaten (Punkte, Linien, Polygone) angezeigt. Zusätzlich können (jeweils optional) Titel, Anmerkungen, Nordpfeil und Maßstabsleiste ausgedruckt werden. Der Ausdruck kann nur im Querformat erfolgen.

Drucken

Bei aktivem Drucklayoutmodus, wird der Druck über den Menüpunkt "Datei - Drucken" oder die zugehörige Schaltfläche gestartet.
Wurde der Modus Karte mit Legende gewählt, erscheint ein Fenster für die Auswahl der Druckoptionen für Titel, Nordpfeil usw.
Karte mit Legendenbereich drucken

Aktion läuft

Beim Ausdruck von Rasterkarten ist zu beachten, dass diese Dateien eine enorme Größe besitzen. Die Aufbereitung der Ausgabe kann erhebliche Zeit in Anspruch nehmen. Die konkrete Hardware-Konfiguration (Druckertyp, verfügbarer Druckerspeicher, Übertragungsgeschwindigkeit im Netzwerk usw.) entscheidet i.d.R. über die Praktikabilität. Dies ist ein allgemeines Problem bei GIS-Anwendungen. Hinweise zum Drucken


Drucker einrichten - Karten-Explorer

Drucker einrichten

Bildschirm anzeigen

Mit der Schaltfläche [image] bzw. dem Menüpunkt "Datei - Drucker einrichten" wird der Druckmodus, der zu verwendende Drucker, das Papierformat usw. festgelegt. Sollte der Drucklayoutmodus nicht aktiv sein, wird er nach der Druckereinrichtung aktiviert.

Drucker auswählen

Über die Schaltfläche [image] wird der Windows-Dialog zur Druckereinrichtung aufgerufen. Hier kann ein anderer Drucker ausgewählt, Papierformat und Papiergröße eingestellt, sowie auf weitere Eigenschaften des Druckers zugegriffen werden.

Druckmodus

Der Karten-Explorer unterschiedet grundsätzlich zwei Arten der Druckausgabe:

  • nur Karte [image] bzw.
    Die Karte wird, wie sie auf dem Bildschirm dargestellt ist, auf dem Drucker ausgegeben. Der Ausdruck ist im Hoch- oder Querformat möglich.

  • Karte mit separatem Legendenbereich
    Ausgabe bei Druck von Karte mit Legende Neben der Karte wird ein Bereich zur Darstellung der Legende für alle sichtbaren Layern mit Vektordaten (Punkte, Linien, Polygone) angezeigt. Zusätzlich können (jeweils optional) Titel, Anmerkungen, Nordpfeil und Maßstabsleiste ausgedruckt werden. Der Ausdruck kann nur im Querformat erfolgen. Karte mit Legendenbereich drucken


Legende drucken - Karten-Explorer

Karten mit separatem Legendenbereich drucken

Bildschirm anzeigen

Ausgabe bei Druck von Karte mit Legende Neben der Karte wird ein Bereich für den Ausdruck einer Legende, sowie für Titel, Anmerkungen, Nordpfeil und Maßstabsleiste verwendet.

Titel

Wird hier ein Text angegeben, wird er über der Legende als Titel gedruckt.

Anmerkungen

Wird hier ein Text angegeben, wird er zwischen Titel und Legende gedruckt.

Rahmen um Karte drucken

Aktivieren (deaktivieren) Sie das Kontrollkästchen, um einen Rahmen um den Kartenbereich anzuzeigen (nicht anzuzeigen).

Legende

Aktivieren (deaktivieren) Sie das Kontrollkästchen, um die Legende anzuzeigen (nicht anzuzeigen).

Es wird die Symbologie (Einfärbung) aller sichtbaren Layer mit Vektordaten in der Legende ausgegeben. Ist ein Layer in der Layer-Kontrolle "zusammengeklappt", wird er in der Legende ebenfalls dargestellt.

Falls bereits eine Legende direkt auf der Karte angezeigt wird, kann der Ausdruck einer weiteren Legende neben der Karte durch Deaktivieren dieses Kontrollkästchens unterbunden werden. Titel, Nordpfeil und Maßstab können dabei weiterhin ausgegeben werden.

Nordpfeil

Aktivieren (deaktivieren) Sie das Kontrollkästchen, um einen Nordpfeil unterhalb der Legende anzuzeigen (nicht anzuzeigen).

Maßstab

Aktivieren (deaktivieren) Sie das Kontrollkästchen, um eine Maßstabsleiste unterhalb der Legende anzuzeigen (nicht anzuzeigen).

Feldbezeichnungen drucken

Ist dieses Kontrollkästchen aktiviert, werden in der Legende die Feldbezeichnungen (Spaltenname in Attribut-Tabelle), die bei Einfärbung nach Klassen, Einzelwerten und Punkthäufigkeiten ausgewählt wurden, in Klammern neben dem Namen des Layers gedruckt. Wird z.B. im Layer Bundesländer bei Einfärbung nach Einzelwert das Feld "Name" ausgewählt, um jedem Bundesland eine eigene Farbe zu geben, wird bei aktiviertem Kontrollkästchen "Feldbezeichnungen drucken" in der Legende folgende Ausgabe erzeugt: Bundesländer (Name).

Symbologie skalieren

Bei Ausgabe der Karte auf einem Drucker wird die Symbologie (Punkte, Umrisslinien von Polygonen) häufig zu klein bzw. zu dünn dargestellt. Dieser Effekt verstärkt sich mit höherer Auflösung des Druckers und steigender Papiergröße. Grund dafür ist die Tatsache, dass eine gewählte Linienstärke von z.B. 5 Punkten auf dem Bildschirm viel breiter erscheint, weil der Bildschirm viel weniger Punkte darstellen kann als ein Drucker. Ist das Kontrollkästchen "Symbole skalieren" aktiviert, wird ermittelt, welche Auflösung und Größe das Ausgabemedium (Druckqualität und Papiergröße) besitzt und zur Auflösung des Bildschirms in Verhältnis gesetzt. Für den Ausdruck auf dem Drucker wird die Größe der Punkte und Linien so angepasst, dass sie dem der Bildschirmausgabe nahe kommt. Zusätzlich wird die Größe in Abhängigkeit von der ausgewählten Papiergröße skaliert (z.B. 75% bei A5, 100% bei A4, 125% bei A3, 150% bei A2, 175% bei A1, 200% bei A0). Bei Bedarf kann die Skalierung auch mit dem Schieberegler zwischen 50% und 300 % manuell variiert werden.

Kopien

Legen Sie die Anzahl der gewünschten Kopien fest. Werden mehrere Ausdrucke ein und derselben Karte benötigt, sollte aus Gründen der Performance die Anzahl der Kopien entsprechend hoch gesetzt werden, anstatt die Karte mehrfach auszudrucken.

Aktion läuft

Beim Ausdruck von Rasterkarten ist zu beachten, dass diese Dateien eine enorme Größe besitzen. Die Aufbereitung der Ausgabe kann erhebliche Zeit in Anspruch nehmen. Die konkrete Hardware-Konfiguration (Druckertyp, verfügbarer Druckerspeicher, Übertragungsgeschwindigkeit im Netzwerk usw.) entscheidet i.d.R. über die Praktikabilität. Dies ist ein allgemeines Problem bei GIS-Anwendungen. Hinweise zum Drucken


Druckmaßstab - Karten-Explorer

Druckmaßstab

Bildschirm anzeigen

Der Maßstab auf dem Bildschirm und auf dem Ausdruck sind nicht identisch, da die Größe vom Karten-Element und vom Druckmedium nicht übereinstimmen. Ein Maßstab von z.B. 1:25.000 sagt aus, dass 1 cm auf der Karte 25.000 cm (250 Meter) in der Realität entspricht. Wird eine Karte auf einem 19-Zoll-Bildschirm im Maßstab 1:100.000 dargestellt, dann würde die gleiche Karte auf einem (bedeutend größeren) A0-Blatt auf einem Plotter einen Maßstab in der Größenordnung von etwa 1:25.000 ergeben. Da Kartenausdrucke oft in ganz bestimmten Maßstäben gewünscht sind, um z.B. Entfernungen einfach messen zu können (so entspricht 1cm = 1km beim Maßstab 1:100.000), kann der gewünschte Druckmaßstab vor dem Drucken mit dem Menüpunkt "Ansicht - Druckmaßstab festlegen" eingestellt werden. Dabei wird ausgehend von den gewählten Druckereinstellungen (Papierformat, Seitenränder) der Maßstab auf dem Bildschirm so angepasst, dass der gewünschte Druckmaßstab erreicht wird.

Wählen Sie dazu im Kombinationsfeld "gewünschter Maßstab Drucker" den Maßstab aus der Liste aus oder geben sie ihn manuell ein.

Bitte beachten Sie folgendes:

  1. Der Maßstab der Karte darf bis zum Ausdruck nicht mehr verändert werden - die Karte darf nur verschoben, nicht jedoch vergrößert oder verkleinert werden.

  2. Verwenden Sie nach Möglichkeit die folgenden Papiergrößen bei der Auswahl des Papierformates: A3, A4, A5, ISO-A0, ISO-A1, ISO-A2, ISO-A3, ISO-A4. Für diese Formate kann der Karten-Explorer die Dimensionen der Seite und somit den Maßstab korrekt berechnen.


Hinweise zum Drucken - Karten-Explorer

Hinweise zum Drucken

Das Ausdrucken von komplexen Karten wurde bei der Entwicklung des Karten-Explorers auf unterschiedlichster Drucktechnik von Standard-Laserdruckern, über Farblaserdrucker, Farbtintenstrahldrucker bis hin zum A0-Plotter intensiv getestet.

Erfahrungsgemäß gibt es bei den Nutzern immer wieder Probleme beim Ausdruck von Rasterkarten, die mit der Software assoziiert werden. In der Tat ist es jedoch (wahrscheinlich) kein Problem des Karten-Explorers, wenn Druckausgaben sehr zeitintensiv sind bzw. die Kapazität der vorhandenen Hardware überfordern.

Der Ausdruck von reinen Vektorkarten ist in der Regel unproblematisch und sollte zügig erfolgen. Handelt es sich hierbei jedoch um viele Layer mit sehr vielen Geo-Objekten (z.B. detaillierte ATKIS-Daten) oder werden großflächige Rasterkarten ausgedruckt, dann entstehen zum Teil Druckjobs mit enormer Größe. Drucker bauen i.d.R. Kartenschichten in ihrem internen Hauptspeicher komplett auf, bevor sie sie ausgeben. Liegen viele Layer übereinander oder werden viele topografische Karten ausgedruckt, so werden ggf. einige 100 MB an den Drucker gesendet.

Sollten Sie Probleme mit dem Ausdruck haben, beachten Sie bitte folgende Hinweise:

  • Verwenden Sie Drucker mit viel internem Speicher!

  • Verringern Sie ggf. die Größe des auszudruckenden Gebietes!

  • Verzichten Sie ggf. auf Rasterkarten (topografische Karten)!

  • Drucken Sie mit Kopien, wenn Sie dieselbe Karte mehrfach benötigen, anstatt sie mehrfach neu an den Drucker zu senden!

  • Verwenden Sie die Option "Im Computer aufbereiten" bei den Eigenschaften des Druckers, wenn Sie über zu wenig Druckspeicher verfügen, die z.B. bei vielen Plottern angeboten wird und bei den Geschwindigkeiten heutiger Prozessoren (nach Erfahrungen des Autors) häufig die bessere Performance beim Ausdruck erzielt.

  • Reduzieren Sie ggf. die Druckqualität. Die höchste Auflösung vieler Drucker ist oft nicht erforderlich, die Option "Normaldruck" bzw. die nächst niedrige dpi-Zahl (dots per inch) ist vielfach völlig ausreichend!

Generell sollten Sie folgende Hinweise beachten, die mit der technischen Realisierung der Druckfunktion des Karten-Explorers bei der Berechnung von Proportionen in Zusammenhang steht:

  1. Verwenden Sie nach Möglichkeit die folgenden Papiergrößen bei der Auswahl des Papierformates: A3, A4, A5, ISO-A0, ISO-A1, ISO-A2, ISO-A3, ISO-A4.

  2. Wird eine Papiergröße verwendet, die vom Karten-Explorer nicht über standardisierte Windows-Konstanten interpretiert werden kann, wird versucht die Papiergröße über benutzerdefinierte Formate zu ermitteln.

    • Bitte überprüfen Sie in diesem Falle in der dann angezeigten Sicherheitsabfrage, ob die ermittelten Werte korrekt sind.

    • Bei falschen Werten sollten Sie die Einrichtung erneut über 'Datei - Drucker einrichten' aufrufen und die Auswahl des Papierformates etc. über den Eigenschaften-Dialog des Druckers vornehmen.

  3. Verwenden Sie keine unterschiedlichen Auflösungen beim Ausdruck in horizontaler und vertikaler Richtung, die von einigen Tintenstrahldruckern unterstützt werden wie 1200 dpi x 600 dpi oder 600 dpi x 300 dpi sondern immer 600 dpi x 600 dpi, 300 dpi x 300 dpi usw.


Karten-Explorer - Exportieren

Exportieren (Karten, Legenden, Geo-Daten)

Karte und Legende können in die Zwischenablage exportiert und damit leicht in andere Programme (z.B. Office-Produkte von Microsoft) eingefügt werden. Geodaten können exportiert werden, um sie mit anderen Programmen zu verarbeiten (KEZ, KML, GPX).

Karte exportieren

Der Inhalt des Karten-Elementes kann in die Zwischenablage oder in eine Datei exportiert werden.

  • Beim Export in eine Datei kann zwischen verschiedenen Formaten (Bitmap, JPEG, TIFF, PNG und Enhanced Metafile) gewählt und die Größe zwischen 10 und 500% der aktuellen Größe des Karten-Elements skaliert werden. Karte als Datei exportieren

  • Beim Export in die Zwischenablage wird die standardmäßig die Originalgröße des Karten-Elements als Grundlage für die Bildgröße verwendet.

    • Über den Menüpunkt "Export - Kartengröße in Zwischenablage skalieren" kann die Größe der exportierten Karten von 50 bis 500% in Bezug zur Originalgröße skaliert werden.

    • Der Export ist als Windows Metadatei (EMF = Enhanced Metafile) oder als Bitmap möglich. Metadateien können nachträglich besser skaliert werden und sind für reine Vektordaten (Punkte, Linien, Polygone) die bessere Wahl. Für reine Bilddaten (wie digitale Landkarten) eignet sich eher das Bitmap-Format.

Legende exportieren

Beim Export der Legende wird die Symbologie (Einfärbung) aller sichtbar geschalteten Layer mit Vektorformat (Punkte, Linien und Polygone) in die Zwischenablage ausgegeben. Ist ein Layer in der Layer-Kontrolle "zusammengeklappt", wird er in der Legende nicht dargestellt.

Wie bei der Karte ist hier die Formatwahl unter Windows Metadatei (Enhanced Metafile) und Bitmap möglich. Dabei bietet sich i.d.R. die Verwendung des EMF-Formates an, da neben der freien Skalierung auch eine einfache Nachbearbeitung mit externen Programmen möglich ist (Microsoft Word: rechte Maustaste drücken und "Grafik bearbeiten" auswählen).

KEZ (Online-Projekt) exportieren

Neben der Ausgabe der Karten als Grafik unterstützt der Karten-Explorer ein internes Format zur Datenübergabe (z.B. per Email an Krisenzentren) oder lediglich zur Archivierung von Karten. Alle oder einzelne geladenen Shape-Dateien werden inklusive der Informationen zu ihrer Einfärbung etc. in ein spezielles Zip-Archiv (*.kez für "Karten-Explorer-Zip") komprimiert. Diese Online-Projekte können mit dem Karten-Explorer (Menüpunkt "Datei - Öffnen Online-Projekt") aufgerufen werden und sind technisch gesehen identisch mit den Online-Projekten, die von der ZTSDB herunter geladen werden können.
Rasterkarten (topografische Karten) werden bei Online-Projekten bewusst nicht mit übergeben, da diese Dateien i.d.R. sehr groß sind und nicht weiter komprimiert werden können. Werden Daten ans Krisenzentrum übergeben, liegen die Rasterdaten dort üblicherweise vor und können mit der Programmfunktion "Layer - Rasterkarten hinterlegen" automatisch für das betreffende Gebiet geladen werden. Online-Projekt exportieren

KML exportieren

Alle oder einzelne geladenen Shape-Dateien des aktuellen Karten-Explorer-Projektes können im KML-Format (Keyhole Markup Language) exportiert werden, welches von zahlreichen GIS-Programmen (z.B. FLI-Maps, ESRI ArcGIS, Google Earth und Google Maps) unterstützt wird. Dabei bleiben im Karten-Explorer vorgenommenen Einfärbungen weitestgehend erhalten, die Attribute können auf Wunsch vollständig exportiert werden.

Eine zentrale Anwendung des Exports von KML stellt die Verknüpfung zu [image] FLI-Maps dar. Ist Google Earth installiert, kann die Karte sofort auch mit diesem Programm angezeigt werden. Mit beiden Plattformen stehen den Benutzern des Karten-Explorers praktisch auf Knopfdruck weltweite Sattelitenbilder als Hintergrundkarten für vorhandene Vektordaten zur Verfügung. KML exportieren

GPX exportieren

Alle oder einzelne geladenen Shape-Dateien des aktuellen Karten-Explorer-Projektes können im GPX-Format (GPS Exchange Format) exportiert werden, welches von GPS-Empfängern und zahlreichen anderen Geräten zum Austausch und zur Archivierung von GPS-Daten verwendet wird. GPX exportieren

Beachten Sie die Lizenzbedingungen für den Gebrauch externen Softwareprodukte und die geltenden Datenschutzbestimmungen! Für die Verletzung von Lizenzbedingungen externer Softwareprodukte, die unerlaubte Nutzung von Kartenmaterial oder die unerlaubte Weitergabe personenbezogener Daten haftet der Benutzer. Google Earth und Google Maps


Karten-Explorer - Karte als Datei exportieren

Karte als Datei exportieren

Bildschirm anzeigen

Der sichtbare Kartenausschnitt kann in eine Datei unterschiedlicher Formate exportiert werden. Die Bilder können anschließend in anderen Programmen angezeigt, eingefügt oder ausgedruckt werden. Bei Verwendung der meisten Formate ist die Ausgabe einer so genannten World-Datei möglich, die die Georeferenzierung enthält und das Laden in GIS-Anwendungen (QGIS, ESRI ArcGIS, Karten-Explorer) ermöglicht. Bei der Ausgabe in eine Datei kann die Größe der Karte bis zu 500% skaliert werden. Damit lassen sich großflächige Bilder mit hoher Qualität erzeugen, die z.B. in andere Dokumente (Präsentationen oder Word-Dokumente) eingefügt oder ausgedruckt werden können. Insbesondere zum Laden in GIS-Anwendungen ist die vergrößerte Ausgabe sinnvoll. Je höher die Karte skaliert wird (je mehr Pixel ausgegeben werden), desto besser kann die Karte im Zielprogramm vergrößert/gezoomt werden.

Der Name der Datei, in die die Grafik ausgegeben werden soll, ist über die Schaltfläche [image] anzugeben.

Das gewünschte Format ist aus dem Optionsfeld auszuwählen. Folgende Formate werden unterstützt:

  • Bitmap (*.bmp)

    • Das Bitmap-Format ist ein verlustfreies Format, welches weit verbreitet ist , jedoch recht große Dateien erzeugt.

    • Bei Verwendung der Option World-Datei (*.bmpw) kann die Bitmap-Datei als Layer in den Karten-Explorer geladen werden.

  • JPEG (*.jpg)

    • Das JPEG-Format ist ein verlustbehaftetes Format mit variabler Kompression, welches sehr kleine Dateigrößen erzeugt.

    • Die Kompressionsrate/Qualität kann zwischen 1 (schlecht) und 100 (bestmöglich) per Schieberegler eingestellt werden. Die Voreinstellung ist 100 (bestmöglich). In der linken Position (0) wird die Standardqualität (ca. 80) mit einem guten Verhältnis zwischen Qualität und Dateigröße verwendet.

    • Bei Verwendung der Option World-Datei (*.jgw) kann die JPEG-Datei als Layer in den Karten-Explorer geladen werden.

  • TIFF (*.tif)

    • Das TIFF-Format ist ein weit verbreitetes Grafikformat, welches mit unterschiedlichen Kompressionsverfahren arbeiten kann und im GIS-Bereich sehr verbreitet ist.

    • Bei Verwendung der Option World-Datei (*.tfw) können einige Varianten (unkomprimiert, Packbits, JPEG) als Layer in den Karten-Explorer geladen werden. QGIS unterstützt alle Varianten.

    • Das Kompressionsverfahren ist über das Kombinationsfeld auszuwählen. Abhängig vom Kompressionsverfahren ist die Qualität und Dateigröße unterschiedlich. Des Weiteren ist zu beachten, dass nicht alle Programme mit jeder Kompressionsmethode kompatibel sind.

      • unkomprimiert

        • große Dateien

        • kein Qualitätsverlust

        • als Layer im Karten-Explorer unterstützt

      • Packbits

        • gute Komprimierung

        • kein Qualitätsverlust

        • als Layer im Karten-Explorer unterstützt

      • JPEG

        • sehr gute Komprimierung

        • Qualitätsverlust

        • als Layer im Karten-Explorer unterstützt

      • LZW

        • sehr gute Komprimierung

        • kein Qualitätsverlust

        • gute Option für QGIS/ArcGIS, als Layer im Karten-Explorer nicht unterstützt

      • Deflate

        • sehr gute Komprimierung

        • kein Qualitätsverlust

        • als Layer im Karten-Explorer nicht unterstützt

  • PNG (*.png)

    • Das PNG-Format ist ein verlustfreies, hoch komprimiertes Format für Bilddateien mit geringen Dateigrößen.

    • gute Option für QGIS, als Layer im Karten-Explorer nicht unterstützt

  • Enhanced Metafile (*.emf)

    • Enhanced Metafile ist ein von Microsoft entwickeltes Grafikformat, welches Vektorgrafiken (Shape-Dateien) beliebig skalieren und Rastergrafiken hinterlegen kann. Es ist deshalb insbesondere für die Ausgabe bzw. Weitegabe von Vektordaten (Punkte, Linien, Polygone) an unterstützte Anwendungen hilfreich, weil das Verkleinern und Vergrößern der Grafiken für Vektordaten zu keinerlei Qualitätseineinbußen führt.

Die Skalierung gibt an, ob die Grafik vergrößert oder verkleinert werden soll. 100% beziehen sich auf die aktuelle Größe des Karten-Elements. Nutzen Sie ggf. das horizontale Drehfeld, um die Skalierung in Hunderterschritten zu ändern.

Tipps zum Exportieren von Dateien zur Verwendung in GIS-Anwendungen

Die Ausgabe als georeferenzierte Bilddatei und die spätere Verwendung als Layer (z.B. im Karten-Explorer) ist eine sehr hilfreiche Option, um anderen Anwendern oder Anwendungen (komplexe) Hintergrundkarten zur Verfügung zu stellen. Beachten Sie jedoch folgende Tipps und Tricks, um das vorhandene Potential maximal auszuschöpfen.

  • Skalieren (vergrößern) Sie die Karte nach Möglichkeit maximal, um eine hohe Pixelzahl zu erzeugen und so das Zoomen der Karte (in gewissen Grenzen) zu ermöglichen.

    • Dabei sollte bereits das Anwendungsfenster (Karten-Explorer) gezoomt bzw. möglichst groß sein, denn es dient als Basis für die Berechnung der zu exportierenden Datei.

    • Des Weiteren sollte das Fenster optimal an die Form der Karte angepasst sein, um möglichst wenige "leere" (meist weiße) Bereiche zu exportieren. Für eine Deutschlandkarte macht es zum Beispiel Sinn, das Fenster solange schmaler zu machen, bis alle Ränder des Karten-Elements die Staatsgrenze berühren.

    • Nach Möglichkeit sollte mit hoher (höchster) Skalierung ausgegeben werden, wenn die Karte später entsprechend gezoomt werden soll.

      • Beachten Sie, dass es bei der Ausgabe der Karte (zunächst immer als Bitmap mit ggf. anschließender Konvertierung des Bildes in das gewählte Format) zu Ressourcenproblemen kommen kann, wenn die Zwischendateien bestimmte Größen überschreiten. In diesem Fall erfolgt ein Hinweis, dass die Skalierung verkleinert werden sollte, um die gewünschte Ausgabe generieren zu können.

  • als Layer im Karten-Explorer:

    • Verwenden Sie JPEG mit maximaler Qualität oder TIFF (Kompression: Packbits oder JPEG), um eine gute Qualität und akzeptable Dateigrößen zu erreichen.

    • Aktivieren Sie die Option World-Datei und vergessen Sie nicht, diese auch mit dem exportiertem Bild weiterzugeben, wenn Sie die Karte anderen Anwendern zur Verfügung stellen wollen.

  • als Layer in QGIS, ArcGIS:

    • Verwenden Sie nach Möglichkeit TIFF (Kompression LZW) für QGIS und ArcGIS, weil dieses Format sehr kleine Dateien ohne jeden Qualitätsverlust erzeugt. Leider wird dieses Format vom Karten-Explorer als Layer nicht unterstützt.

    • Für QGIS wurden alle angebotenen Formate und Kompressionen erfolgreich getestet!


Projekt als GPX exportieren

GPX exportieren

 Bildschirm zeigen

Mit dem Menüpunkt "Export - GPX" des Karten-Explorers können Layer (Shape-Dateien) des aktuellen Karten-Projektes im GPX-Format ausgegeben werden. Damit ist insbesondere die Übergabe von Geo-Daten an GPS-Geräte möglich.

Layer-Tabelle

In der Tabelle sind alle geladenen Shape-Dateien aufgeführt. Das Kontrollkästchen in der ersten Spalte gibt an, ob der Layer exportiert werden soll. Per Doppelklick auf einen Layer oder mit der Schaltfläche [image] können die in der Tabelle farblich markierten Layer-Optionen bearbeitet werden. Die Tabelle enthält folgende Informationen:

Spaltenname | Beschreibung
Layer | In der Spalte Layer ist der Name des Layers in der Layer-Kontrolle und ein Symbol für den Typ des Layer angegeben. Das Kontrollkästchen aktiviert/deaktiviert den Export für den jeweiligen Layer.
Shapetyp | Typ des Layers (Punkt, Linie, Polygon, Multipoint). Hinweis: Die Ausgabe von Layern vom Typ Multipoint wird derzeit nicht unterstützt, diese Layer nicht nicht auswählbar.
GPX-Typ | Der Zieltyp in der GPX-Datei kann Waypoint oder Route sein! Bei Layern vom Typ "Punkt" kann der Zieltyp ausgewählt werden, bei Layern vom Typ "Linie" bzw. "Polygon" ist er immer Route!
Objekte | Anzahl der Geo-Objekte im Layer.
Koordinatensystem | Koordinatensystem, Bezugssystem und Streifen des Layers werden angezeigt, sofern diese Informationen in der jeweiligen Shape-Datei gespeichert sind. Für alle Layer, deren Projektion nicht aus der Shape-Datei ermittelt werden kann, werden die Einstellungen des Bereiches "Projektion" verwendet.
Bezugssystem
Streifen
 |  | Attribut in GPX | Vorgabe im Karten-Explorer
Name | Attribut Name in GPX einem Feld im Layer zuordnen | NAME | NAME
Höhe | Attribut Höhe in GPX einem Feld im Layer zuordnen | ELE | HOEHE
Zeitpunkt | Attribut Zeitpunkt in GPX einem Feld im Layer zuordnen | TIME | ZEITPUNKT
Kommentar | Attribut Kommentar in GPX einem Feld im Layer zuordnen | CMT | KOMMENTAR
Beschreibung | Attribut Beschreibung in GPX einem Feld im Layer zuordnen | DESC | BESCHREIB
Quelle | Attribut Quelle in GPX einem Feld im Layer zuordnen | SRC | QUELLE
Symbol | Attribut Symbol in GPX einem Feld im Layer zuordnen | SYM | SYMBOL
Kategorie | Attribut Kategorie in GPX einem Feld im Layer zuordnen | TYPE | TYP
URL | Attribut URL in GPX einem Feld im Layer zuordnen | URL | URL
URL-Nmae | Attribut URL-Name in GPX einem Feld im Layer zuordnen | URLNAME | URLNAME

Konvertierung von Layern

Das GPX-Format unterscheidet Waypoint, Route und Track:

  • Waypoint

    • stellen einzelne Ortspunkte/Wegepunkte dar

    • Layer vom Typ "Punkt" werden per Voreinstellung als Waypoint exportiert, um z.B. Betriebe, Seuchenobjekte oder Orientierungspunkte an GPS-Geräte zu übergeben.

  • Route

    • stellen eine sortierte Abfolge von Ortspunkten/Wegepunkten dar

    • Layer vom Typ "Polygon" und "Linie" werden immer als Route exportiert, Layer vom Typ "Punkt" können als Route exportiert werden.

  • Track

    • Tracks sind ausschließlich die vom GPS-Gerät aufgezeichneten Pfade und können mit dieser Programmfunktion nicht exportiert werden.

Attribute

Wahlweise können Attribute exportiert werden. Ein Wegepunkt kann nur bestimmte, durch den GPX-Standard definierte Attribute haben. Mit den Layer-Optionen der Schaltfläche [image] kann für jeden einzelnen Layer eingestellt werden, ob und welche Attribute des Layers diesen möglichen Attributen zugeordnet werden sollen. Die folgende Tabelle zeigt die verfügbaren Attribute entsprechend der GPX-Konventionen an. In der der Spalte "Vorgabe im Karten-Explorer" sind die Namen von Attributen angegeben, die bei Vorhandensein im Layer automatisch den korrespondierenden Attributen in GPX zugeordnet werden würden. Haben die entsprechenden Attribute im Layer andere Namen, müssen die Zuordnungen (wie bereits erwähnt) manuell vorgenommen werden.

Attribut in GPX | Beschreibung | Vorgabe im Karten-Explorer
NAME | Name des Ortspunktes / Wegepunktes | NAME
ELE | Höhe in Metern | HOEHE
TIME | Datum und Zeit entsprechend ISO 8601, z.B. 2011-12-31T23:59:59Z | ZEITPUNKT
CMT | Kommentar | KOMMENTAR
DESC | Beschreibung | BESCHREIB
SRC | Datenquelle / Ursprung | QUELLE
SYM | Darstellungssymbol | SYMBOL
TYPE | Kategorie / Klassifikation | TYP
URL | URL | URL
URLNAME | URL-Name | URLNAME

Projektion

Die Ausgabe in das GPX-Format erfordert eine Umrechnung aller Koordinaten in geografische Koordinaten (Dezimalgrad) mit dem Bezugssystem WGS84. Daher ist die Kenntnis der Projektion der zu exportierenden Layer entscheidend, um die Daten korrekt projizieren zu können. Enthalten zu exportierende Layer separate Informationen zur Projektion, so werden diese herangezogen. Für Layer, die keine Informationen zur Projektion enthalten, werden die Einstellungen aus dem Bereich "Projektion" verwendet. Voreingestellt ist die dem Projekt zugewiesene Projektion ( [image] Projektion verwalten) bzw. der beim Karten-Explorer unter [image] Einstellungen - Projektion hinterlegte Standard. Ggf. ist die korrekte Projektion mit der Schaltfläche [image] einzustellen.
Koordinatensystem, Bezugssystem, Streifen


Projekt als KML exportieren

KML exportieren

 Bildschirm zeigen

Mit dem Menüpunkt "Export - KML" des Karten-Explorers können Layer (Shape-Dateien) des aktuellen Karten-Projektes im KML-Format ausgegeben werden. Damit ist u.a. die Anzeige der Karten im Internet-Browser durch einen Map-Server des FLI möglich (FLI-Maps). Zahlreiche GIS-Programme, insbesondere die bekannten Anwendungen Google Earth und Google Maps, sind in der Lage, dieses Format zu verarbeiten. Damit können die im Karten-Explorer geladenen Daten einfach auf hochauflösende Hintergrundkarten (Sattelitenbilder) projiziert werden. Die im Karten-Explorer vorgenommenen Einfärbungen bleiben dabei erhalten. Wahlweise können alle oder einzelne Attribute exportiert werden. Die Export-Optionen können dabei für jeden Layer einzeln vorgenommen werden. Neben der Anzeige (FLI-Maps, Google Earth) ist auch das Speichern im genormten Standard KML (wahlweise auch als KMZ-Datei als komprimierter Variante der KML-Datei) möglich, um die Daten mit anderen GIS-Anwendungen (ArcGIS, Karten-Explorer) auszutauschen oder Lagedarstellungen und Restriktionszonen an andere Behörden (national und international) zu übergeben.

Layer-Tabelle

In der Tabelle sind alle geladenen Shape-Dateien aufgeführt. Das Kontrollkästchen in der ersten Spalte gibt an, ob der Layer exportiert werden soll. Die Vorgabe ist, dass alle sichtbar geschalteten Layer zu exportieren sind. Per Doppelklick auf einen Layer oder mit der Schaltfläche [image] können die in der Tabelle farblich markierten [image] Layer-Optionen bearbeitet werden. Die Tabelle enthält folgende Informationen:

Spaltenname | Beschreibung
Layer | In der Spalte Layer ist der Name des Layers in der Layer-Kontrolle und ein Symbol für den Typ des Layer angegeben. Das Kontrollkästchen aktiviert/deaktiviert den Export für den jeweiligen Layer.
Typ | Typ des Layers (Punkt, Linie, Polygon, Multipoint).
Objekte | Anzahl der Geo-Objekte im Layer.
Name | Ein oder mehrere Felder (Attribute), die dem Geo-Objekt in der Seitenleiste von Google seinen Namen geben und als Beschriftung in der Karte erscheinen (im Beispiel der Landesname Finland).
Snippet (nur Google Earth) | Ein oder mehrere Felder (Attribute), die das Geo-Objekt in der Seitenleiste von Google näher beschreiben (im Beispiel ISO-Name FIN und Bevölkerungszahl 5031379).
Beschreibung | Alle gewählten Felder (Attribute), die als Beschreibung des Geo-Objektes verwendet werden und die beim Anklicken des Geo-Objektes in der Karte als Tabelle angezeigt werden.
Beschriftung | Hier wird angezeigt, ob Objekte in der Karte beschriftet werden sollen.
Skalierung | Hier wird angezeigt, wie die Beschriftung in der Karte skaliert wird (Faktor 1 steht für Standardgröße).
Höhe (nur Google Earth) | Es kann ein Feld (numerisches Attribut) ausgewählt werden, das steuert, um wie viele Meter das Objekt erhoben dargestellt wird. Damit lassen sich 3-dimensionale Objekte erstellen. Beispiel
Koordinatensystem | Koordinatensystem, Bezugssystem und Streifen des Layers werden angezeigt, sofern diese Informationen in der jeweiligen Shape-Datei gespeichert sind. Für alle Layer, deren Projektion nicht aus der Shape-Datei ermittelt werden kann, werden die Einstellungen des Bereiches "Projektion" verwendet.
Bezugssystem
Streifen

Modus für die Ausgabe

Bei der Verwendung von FLI-Maps erfolgt die Ausgabe im Internet-Browser unter Verwendung eines Map-Servers des FLI. Dazu ist ein Zugang zu TSN-Online erforderlich.
Ist der Modus für die Ausgabe auf "KML/KMZ-Datei" gestellt, erscheint ein Dialog zur Auswahl des Dateinamens. Hier kann der Dateityp auf KML oder KMZ festgelegt werden. Das Format KMZ ist lediglich eine ZIP-komprimierte Version der KML-Datei, die den Vorteil einer deutlichen Größenreduzierung mit sich bringt und von Google Earth oder Google Maps ebenso unterstützt wird.
Ist Google Earth auf dem PC installiert bzw. eine Betriebssystem-Verknüpfung für die Dateierweiterung *.kml auf dem PC hinterlegt, kann die Ausgabe in "Google Earth" erfolgen.
Bei Verwendung der Option "Google Maps" erfordert die Ausgabe im Internet-Browser.
Google Earth und Google Maps

Optionen

Lebensdauer der Karte auf FLI-Server

Bei Ausgabe der Karte auf dem FLI-Server erhält die Karte eine standardisierte Lebensdauer von zurzeit 2 Stunden. Um die Lebensdauer der Karte individuell anzupassen, ist es erforderlich, sich einmal während der Programmsitzung des Mandanten als Benutzer der Zentralen Tierseuchendatenbank - TSN-Online zu authentifizieren. Der Dialog zur Anmeldung erscheint, sobald das Kontrollkästchen "Lebensdauer der Karte auf FLI-Server" geklickt wird. Nach erfolgreicher Anmeldung ist das Kontrollkästchen aktiviert und das Dialogfeld zur Auswahl der Lebensdauer ist zur Auswahl der gewünschten Zeit frei geschaltet. Außerdem sollte der Karte ein aussagekräftiger Titel gegeben werden, um die Verwaltung eigener publizierter Karten auf TSN-Online zu erleichtern. Wird eine Karte mit individueller Lebensdauer und Titel an den FLI-Server übertragen, wird die bei der Anmeldung autorisierte E-Mail-Adresse ebenfalls übergeben und stellt sicher, dass diese Karte dem Benutzer zugeordnet wird und von diesem bei Bedarf künftig mit einer anderen Laufzeit versehen oder vom Server gelöscht werden kann. Nähere Informationen hierzu erhält der Benutzer unmittelbar nach Übertragung der Karte durch eine automatisierte E-Mail, die Details zur Karte und einen Link zum Verwaltungsbereich von TSN-Online enthält.

Projektion

Die Ausgabe in das KML-Format erfordert eine Umrechnung aller Koordinaten in geografische Koordinaten (Dezimalgrad) mit dem Bezugssystem WGS84. Daher ist die Kenntnis der Projektion der zu exportierenden Layer entscheidend, um die Daten korrekt projizieren zu können. Enthalten zu exportierende Layer separate Informationen zur Projektion, so werden diese herangezogen. Für Layer, die keine Informationen zur Projektion enthalten, werden die Einstellungen aus dem Bereich "Projektion" verwendet. Voreingestellt ist die dem Projekt zugewiesene Projektion ( [image] Projektion verwalten) bzw. der unter [image] Einstellungen - Projektion hinterlegte Standard. Ggf. ist die korrekte Projektion mit der Schaltfläche [image] einzustellen.
Koordinatensystem, Bezugssystem, Streifen

Schema für die Ausgabe von Beschreibungen

Diese Option legt fest, nach welchem Prinzip die unter "Beschreibung" ausgewählten Attribute ausgegeben werden sollen:

  • HTML
    Traditionell wurden Beschreibungen in KML im HTML-Format ausgegeben. Ist diese Option gewählt, werden alle gewählten Felder der Beschreibung eines Objektes als Tabelle im HTML-Format ausgegeben. Diese Option ist zu wählen, um die Beschreibung eines angeklickten Objektes auf Karten in FLI-Maps anzeigen zu können.

  • Extended Data
    Seit der Version 2.2 erlaubt KML die Ausgabe von Beschreibungen als "Extended Data", wobei sowohl die Bezeichnung als auch der Typ jedes einzelnen Attributes standardisiert übergeben werden kann. Für den Datenaustausch mit Anwendungen, die dieses neue Format unterstützen, ist diese Option die erste Wahl, insbesondere dann, wenn die Attribute weiter verarbeitet werden sollen. Der Karten-Explorer ist nur bei Auswahl dieser Option in der Lage, die Beschreibungen beim Einlesen von KML-Dateien zu importieren. Layer aus KML erstellen

Ausgabereihenfolge der Layer invertieren

Die Aktivierung des Kontrollkästchens "Ausgabereihenfolge der Layer invertieren" gibt die einzelnen Layer in umgekehrter Reihenfolge aus.
Ggf. ist diese Option hilfreich, um eine erwartungskonforme Zeichenreihenfolge zu erhalten. Beim Karten-Explorer gilt die Regel, dass ein Layer, der in der Layer-Kontrolle oben ist, alle darunter liegenden Informationen "überzeichnet". Bei Ausgabe an einige Versionen von Google Earth (Februar 2011) verhält sich dieses Programm für Polygone genau entgegengesetzt: Der Polygon-Layer, der in der Legende unten ist, " überzeichnet" den Polygon-Layer, der in der Legende darüber liegt. Wenn Kreisgrenzen z.B. Gemeindegrenzen überlagern sollen, sollte die Ausgabereihenfolge invertiert werden...

Umsetzung der Einfärbungen

Die vom Karten-Explorer unterstützten Arten für [image] Einfärbungen von Layer werden in KML umgesetzt. Alle Typen von Einfärbungen (einfaches Symbol, Einzelwerte, Klassen und Beschriftungen) außer Punkthäufigkeiten können verwendet werden. Die Darstellung von Symbolen unterliegt gewissen Einschränkungen, die im Folgenden erläutert werden.

Polygone
Linien werden mit voller Deckkraft gezeichnet, die Linienstärke wird 1:1 übergeben. Die Schraffur und Musterung der Fläche wird über Variieren der Transparenz vorgenommen.
Vollständig gefüllt | 70% Deckkraft
Transparent | 0% Deckkraft
Horizontal gestreift | 25% Deckkraft
Vertikal gestreift | 30% Deckkraft
aufwärts diagonal gestreift | 35% Deckkraft
aufwärts diagonal gestreift | 40% Deckkraft
kreuzweise gestreift | 45% Deckkraft
diagonal kreuzweise gestreift | 50% Deckkraft
Hellgrau | 55% Deckkraft
Grau | 60% Deckkraft
Dunkelgrau | 65% Deckkraft
Linien
Die Linienstärke wird 1:1 übergeben. Linientypen werden von KML nicht unterstützt. Die Unterscheidung von Linientypen wird durch Variieren der Deckkraft der Linien vorgenommen.
Durchgehend | 100% Deckkraft
Gestrichelt | 80% Deckkraft
Gepunktet | 50% Deckkraft
Strich-Punkt | 70% Deckkraft
Strich-Punkt-Punkt | 60% Deckkraft
Punkte
Punkte werden in Adressen auf im Internet verfügbare Ressourcen umgesetzt.
Kreis | https://visualgeoserver.fli.de/content/img/placemark_circle.png
Rechteck | https://visualgeoserver.fli.de/content/img/placemark_square.png
Dreieck | https://visualgeoserver.fli.de/content/img/triangle.png
Kreuz | https://visualgeoserver.fli.de/content/img/open-diamond.png
TrueTypeMarker

Zeichen aus einer Schriftart, so genannte TrueTypeMarker, werden in Adressen konvertiert, indem der Name der Schriftart und die Nummer des Zeichens innerhalb der Schriftart als eine Webadresse auf das Ressourcen-Verzeichnis https://www2.fli.de/kml/shapes/ gelenkt werden. Das 91. Zeichen der Schriftart BFAV-Symbole wird demzufolge in https://www2.fli.de/kml/shapes/BFAV-Symbole_91.png umgewandelt, das 197. Zeichen der Schriftart TSN-Symbole (eine Biene) wird demzufolge zu https://www2.fli.de/kml/shapes/TSN-Symbole_197.png.
Zahlreiche Schriftarten, die für kartografische Darstellungen von Bedeutung sind, sind auf dem Server des FLI verfügbar:

  • Ariel
  • BFAV-Symbole
  • TSN-Symbole
  • Windings
  • verschiedene Schriftarten mit Symbolen von ESRI


Projekt als KML exportieren - Optionen

 Bildschirm zeigen

Für jeden Layer können beim Exportieren im KML-Format eine Reihe von Optionen modifiziert werden.

Name

Es können Felder ausgewählt werden, die in der Seiteleiste von Google den Namen des Geo-Objektes bilden und die als Beschriftung des Geo-Objektes auf der Karte verwendet werden, sofern der Beschriftungsmodus (siehe unten) aktiviert wird. Als Vorgabe wird das erste Info-Feld des Layers verwendet, sofern Info-Felder definiert sind.

"Snippet"

Es können Felder ausgewählt werden, die in der Seitenleiste von Google als "Snippet" (Schnipsel) unterhalb des Namens des Geo-Objektes angezeigt werden. Als Vorgabe werden das zweite und dritte Info-Feld des Layers verwendet, sofern Info-Felder definiert sind.

Beschreibung

Es können beliebig viele Felder als Beschreibung des Geo-Objektes exportiert werden. Bei der Anzeige der Karte (z.B. in Google Earth) werden alle Beschreibungsfelder als Tabelle angezeigt, wenn das Geo-Objekt mit der Maus angeklickt wird. Als Vorgabe sind alle Felder zum Export markiert. Mit den Schaltflächen können [image] bzw. können alle Felder gewählt bzw. abgewählt werden. Die Schaltfläche [image] kehrt die Auswahl um. Als Vorgabe sind alle Felder markiert.
Bei der Verwendung von Google Maps ist zu beachten, dass personenbezogene Daten, die in den Attributen enthalten sind, nicht unbefugten Dritten zugänglich gemacht werden dürfen. Während bei der Verwendung von Google Earth die Daten lokal verarbeitet werden, findet bei Google Maps ein Zugriff der Server von Google auf alle anzuzeigenden Daten nebst aller beschreibenden Attribute statt!

Beschriftung der Objekte in der Karte

Es kann ausgewählt werden, ob die Geo-Objekte des Layers in der Karte beschriftet werden sollen oder nicht. Auf Wunsch ist auch die Option verfügbar, nur die Beschriftung anzuzeigen, ohne die Geo-Objekte zu zeichnen.

Die Schriftgröße und die Farbe der Schrift können eingestellt werden. Mit einem Wert von 1,0 im Eingabefeld Skalierung wird die Standardschriftgröße verwendet. Der Wert kann per Eingabe oder mit den Drehfeldern geändert werden. Die Schriftfarbe kann mit der Schaltfläche [image] geändert werden.

Typ | Skalierung | Farbe | Bemerkung
Polygon | 1,00 |  | Der Karten-Explorer berechnet den Schwerpunkt des Polygons und platziert dort die Beschriftung.
Linie | 0,90 |  | Der Karten-Explorer beschriftet die Linie in der Mitte.
Punkt, Multipoint | 0,80 |  | Der Karten-Explorer variiert die Beschriftung in Abhängigkeit von der Symbolgröße zwischen 80% und 120%. Eine Symbolgröße von 5 Punkten entspricht 100% und wird mit dem unter Skalierung angegebenen Wert multipliziert.

Objekte erhoben darstellen

Der Export in KML bietet eine Möglichkeit der Einfärbung, die bei der Darstellung im Karten-Explorer von Hause aus nicht verfügbar ist, die 3-dimensionale Darstellung von Geo-Objekten ( [image] Beispiel). Dabei kann ein Feld (numerisches Attribut) ausgewählt werden, das Informationen über die Höhe des Objektes enthält. Geo-Objekte werden entsprechend dieses Wertes erhoben dargestellt. Dabei wird die Einheit von Metern zugrunde gelegt. Über einen Faktor kann der Wert zusätzlich beeinflusst (skaliert) werden. Ein Faktor größer 1 führt zu einer stärkeren Anhebung (Wert=100 und Faktor= 10 bedeutet um 1000 Meter erhöhte Darstellung des Geo-Objektes).


Projekt als KML exportieren (Beispielbilder)

1. Karte im Karten-Explorer
 | Das Bild zeigt eine Karte im Karten-Explorer. Beim Ausdruck der Karte oder Exportieren der Karte in eine Datei oder in die Zwischenablage bleibt die Karte exakt so erhalten.
2. Karte in FLI-Maps
 | Das Bild zeigt dieselbe Karte wie im Beispiel (1) bei der Ausgabe auf FLI-Maps.
3. Karte in Google Earth
 | Das Bild zeigt dieselbe Karte wie im Beispiel (1) bei der Ausgabe in Google Earth.
4. Karte in Google Earth unter Verwendung einer "Höhe"
 | Das Bild zeigt dieselbe Karte wie im Beispiel (1) bei Ausgabe in Google Earth und Angabe eines Feldes (numerischen Attributes) für die Höhe. Jedes Geo-Objekt wird in Abhängigkeit des Inhalts des gewählten Feldes um x Meter erhöht dargestellt.


Online-Projekt exportieren

 Bildschirm zeigen

Mit der Programmfunktion "Export - KEZ (Online-Projekt)" des Karten-Explorers werden alle geladenen Shape-Dateien inklusive der Informationen zu ihrer Einfärbung in ein spezielles Zip-Archiv (*.kez für Karten-Explorer-Zip) komprimiert. Neben der Archivierung von Karten ist damit eine optimale Datenübergabe an Krisenzentren möglich. Online-Projekte können mit dem Menüpunkt "Datei - Öffnen Online-Projekt" aufgerufen werden.

Um ein Online-Projekt zu erzeugen, ist zunächst der Dateiname anzugeben, unter dem das Archiv erstellt werden soll. Mit dem Kontrollkästchen nicht sichtbar geschaltete Shape-Dateien ignorieren kann gesteuert werden, dass alle Layer, die in der Layer-Kontrolle nicht sichtbar geschaltet sind, nicht in das Online-Projekt exportiert werden sollen.

Ist das Kontrollkästchen als Email an aktiviert, wird das Online-Projekt gleichzeitig an einen (oder mehrere) Email-Empfänger versandt. Dazu wird das aktuelle Standard-Email-Programm automatisch aktiviert.


Rasterkarten hinterlegen - Karten-Explorer

Rasterkarten hinterlegen

Das Menü "Raster" des Karten-Explorers erlaubt es, "auf Knopfdruck" die gewünschten Rasterkarten zu laden.

  • Rasterkarten werden immer hinter die Vektordaten (Punkt, Linie, Polygon) gelegt.

  • Bereits geladene Rasterkarten werden zunächst "entladen".

  • Es werden nur die Karten geladen, die für den aktuellen Kartenausschnitt im Karten-Element benötigt werden.

"TSN-Rasterkarten"

Die Menüpunkte "Raster hinterlegen" und "Übersichtskarte hinterlegen" erfordern das Vorhandensein von Rasterkarten, die im Rahmen des Projektes TSN bereit gestellt werden. Bitte beachten Sie die Copyright-Bestimmungen der Landesvermessungsämter.

  • DTK / TOP [image] Rasterkarten hinterlegen

    • Programmfunktion hinterlegt genau die Rasterkarten DTK25, TOP17 oder TOP100, die für den aktuellen Kartenausschnitt erforderlich sind.

    • Rasterkarten müssen im angegebenen Rasterkarten- bzw. Kartenpfad installiert sein. Einstellungen - Allgemein

    • Die Suche basiert auf dem bei den globalen Einstellungen angegebenen Typ der verwendeten Rasterkarten. Einstellungen - TSN-Kompatibilität

  • Übersichtkarte

    • Übersichtskarte (Dateiname ist der nachfolgenden Tabelle zu entnehmen) muss im angegebenen Rasterkarten- bzw. Kartenpfad installiert sein. Einstellungen - Allgemein

    • Programmfunktion lädt eine Übersichtskarte 1.100.000, 1:200.000 bzw. 1:500.000 abhängig vom verwendeten Typ der Rasterkarten. Einstellungen - TSN-Kompatibilität
      Typ der Rasterkarten erforderliche Datei
      TSN 3 'GK3' GK3_200.Sid oder
      GK3_500.Sid
      TSN 3 'U32' Top100.Sid oder
      U32_200.Sid oder
      U32_500.Sid
      TSN 3 'U33' U33_200.Sid oder
      U33_500.Sid

Raster-Katalog

Raster-Kataloge bieten sich immer dann an, wenn individuelle topografische Karten (z.B. Amtliches Liegenschaftskataster ALK) vorhanden sind und mit dem Karten-Explorer genutzt werden sollen. Der Zugriff auf diese Karten kann über Raster-Kataloge sehr komfortabel gestaltet werden.

... weitere Informationen zu Raster-Katalogen finden Sie [image] hier


Rasterkarten hinterlegen DTK25 - Karten-Explorer

Rasterkarten hinterlegen

Bildschirm zeigen

Der Menüpunkt "Raster - Rasterkarten hinterlegen" (Strg + R oder Schaltfläche [image]) hinterlegt genau die Rasterkarten der DTK25 oder TopPlusOpen, die für den aktuellen Kartenausschnitt erforderlich sind. Diese Funktion ist sehr effizient, da jeweils nur die wirklich benötigten Dateien geladen werden. Ein Infofenster zeigt an, ob die erforderlichen Rasterkarten verfügbar (installiert sind).

Die Suche erfolgt abhängig vom Typ der verwendeten Rasterkarten.
Einstellungen - TSN-Kompatibilität
Die Rasterkarten werden im Kartenverzeichnis bzw. Rasterkartenverzeichnis gesucht.
Einstellungen - Allgemein

Veterinärämter bzw. Krisenzentren sollten alle verfügbaren TSN-Rasterkarten im Kartenverzeichnis installieren, um für jedes Territorium ihres Verantwortungsbereiches "auf Knopfdruck" die richtigen Karten hinterlegen zu können.

Downloadoption

Werden Rasterkarten nicht gefunden, erschein ein Hyperlink, [image] Rasterkarten von TSN-Online herunterladen, der die Funktion zum Download von Rasterkarten in TSN-Online mit genau den Kartenblättern aufruft, die nicht gefunden wurden (rot hinterlegt dargestellt).

ic_finger.gif (947 Byte) Tipp: Neben dieser Funktion, die die detaillierten topografischen Karten lädt, kann im Karten-Explorer über den Menüpunkt "Raster - Übersichtskarte hinterlegen" die 'gröbere' TOP100, DTK200 bzw. DTK500 geladen werden, die zur Orientierung bei größeren Gebieten gute Ergebnisse liefert.


Raster-Katalog - Karten-Explorer

Raster-Kataloge

Ein Raster-Katalog ist eine Tabelle (dBase-Datei), welche Verweise auf Rasterdateien und Informationen über deren Ausdehnung enthält. Diese Raster-Kataloge können vom Benutzer über den Karten-Explorer mit eigenen Rasterkarten erstellt bzw. geändert werden. Damit kann der Zugriff auf Rasterkarten optimiert werden, da bei geladenen Raster-Katalogen über den Menüpunkt "Raster - Aktualisieren" oder die Funktionstaste F11 der Karten-Explorer automatisch die gerade benötigten Rasterkarten lädt. Da jedem geladenen Raster-Katalog ein individueller Anzeigebereich zugewiesen werden kann, können Rasterkarten unterschiedlicher Auflösung (1:5.000, 1:50.000, 1:500.000 etc.) in separaten Raster-Katalogen abgelegt und in Abhängigkeit vom aktuellen Maßstab im Karten-Element "per Knopfdruck" nachgeladen werden.

Öffnen
Mit dem Menüpunkt "Raster - Raster-Katalog - Öffnen" können ein oder mehrere Raster-Kataloge ausgewählt werden. In der Statuszeile des Karten-Explorers erscheint in diesem Fall die Ausschrift "... Kat.". Raster-Katalog öffnen

Tipp: Doppelklick auf den Bereich "... Kat" zeigt das Fenster zum Öffnen von Rasterkatalogen an

Schließen
Mit dem Menüpunkt "Raster - Raster-Katalog - Schließen" werden alle geöffneten Raster-Kataloge geschlossen.

Bearbeiten
Mit dem Menüpunkt "Raster - Raster-Katalog - Bearbeiten" können neue Raster-Kataloge erstellt oder bestehende Kataloge bearbeitet werden. Raster-Katalog bearbeiten

Aktualisieren

Das "Aktualisieren" der Rasterkarten prüft bei geladenen Raster-Katalogen, welche Rasterkarten dieser Kataloge im momentan im Karten-Element angezeigten Kartenausschnitt liegen und lädt genau diese Rastkarten. Dabei werden die Optionen verwendet, die unter [image] Raster-Katalog öffnen festgelegt worden sind (z.B. Anzeigebereiche). Werden keine Rasterkarten für den angezeigten Kartenausschnitt gefunden, wird ein Signalton ausgegeben.

Folgende Alternativen zur Aktivierung der Funktion können verwendet werden:

  • Menüpunkt "Raster - Aktualisieren",
  • Funktionstaste F11,
  • Klick mit rechter Maustaste auf den Bereich ".. Kat" in der Statuszeile.


Raster-Katalog bearbeiten- Karten-Explorer

Raster-Katalog bearbeiten

Bildschirm anzeigen

Um einen neuen Raster-Katalog zu generieren, wählen Sie die Schaltfläche Erstellen, um einen bestehenden Katalog zu öffnen und einzulesen die Schaltfläche Öffnen. Alle Änderungen werden erst dann übernommen, wenn das Fester mit der Schaltfläche OK bestätigt wurde.

Im Bereich "Verzeichnis für Rasterkarten (Alternativer Suchpfad)" kann mit der Schaltfläche Verzeichnis auswählen ... ein Verzeichnis ausgewählt werden, in dem die Rasterkarten gesucht werden sollen, wenn im Image-Katalog keine oder andere Zugriffspfade angegeben sind. Damit können Image-Kataloge leicht zwischen verschiedenen PC ausgetauscht werden.

Im Bereich "Katalog bearbeiten" sind alle Rasterkarten des Katalogs sowie ihre Ausdehnung aufgeführt. Die Symbole haben folgende Bedeutung:
Rasterkarte gefunden, [image] im "Alternativen Suchpfad" gefunden [image] nicht gefunden.

Um neue Rasterkarten zum Katalog hinzuzufügen, kann neue Einträge hinzufügen oder die Einfg-Taste betätigt werden. Daraufhin wird ein Dialog zur Auswahl von Dateien geöffnet, mit dem eine oder mehrere Rasterkarten ausgewählt werden können (Mehrfachauswahl mit Strg + A). Um einen Eintrag zu bearbeiten, kann der Dateiname mit der Maus angeklickt oder die Schaltfläche markierten Eintrag ändern betätigt werden. Mit der Schaltfläche markeirten Eintrag löschen (Entf) oder der Entf-Taste kann der markierte Eintrag gelöscht werden.

Die Schaltfläche Aktualisieren prüft das Vorhandensein der Rasterkarten erneut und aktualisiert die entsprechenden Symbole [image], [image], [image]. Dies kann z.B. sinnvoll sein, wenn ein Datenträger (Netzlaufwerk) zur Verfügung gestellt wurde oder Rasterkarten nachträglich in das Verzeichnis kopiert werden.

Die Schaltfläche Pfade ändern erlaubt es, die Zugriffspfade für alle Rasterkarten zu ändern, was z.B. bei Portierung des Image-Kataloges auf andere PC sinnvoll sein kann.

Die Schaltfläche Reduzieren entfernt alle Rasterkarten aus dem Image-Katalog, die nicht für den aktuellen Ausschnitt des Kartenelements des Karten-Explorers benötigt werden.

Mit der Schaltfläche Reset wird der Image-Katalog erneut eingelesen, wobei eventuelle Änderungen verworfen werden.


Karten-Explorer - Geo-Objekte suchen und identifizieren

Identifizieren und Suchen von Geo-Objekten

Zu einem Layer, der Vektordaten enthält ( [image] Punkte, [image] Linie, [image] Polygon), existiert eine Merkmalsdatei, die für jedes Geo-Objekt Informationen speichert. Über diese Merkmalsdatei können Geo-Objekte auf der Karte identifiziert (Wer oder was ist das?) oder gesucht (Wo ist das?) werden.

Identifizieren

Das Identifizieren von Geo-Objekten auf der Karte, also das "Abrufen" von Informationen über das Geo-Objekt, ist über folgende Wege möglich:

1. Info-Feld

Beispiel für Karten-Info

Aus der Merkmalsdatei eines Layers können bis zu drei Felder ausgewählt werden. Ist der Layer aktiv, wird im Karten-Element die Information zum an der Mausposition befindlichen Geo-Objekt als Quick-Info angezeigt.

Um das gewünschte Merkmalsfeld auszuwählen, ist die Schaltfläche [image] zu betätigen oder kann mit der rechten Maustaste auf den Layer geklickt werden (Menüpunkt "Info-Feld" im Kontext-Menü). Info-Felder auswählen

2. Info-Fenster

Bildschirm anzeigen

Während beim Info-Feld nur ein Feld angezeigt wird, kann mit dem Info-Fenster ein Überblick über alle Felder des ausgewählten Geo-Objektes angezeigt werden.

Info-Fenster aktivieren

Aktivieren Sie in der Tasten-Leiste den Modus für Identifizieren [image] und stellen Sie sicher, dass in der Layer-Kontrolle der gewünschte Layer aktiv ist. Klicken Sie das gewünschte Geo-Objekt mit der Maus an. Für weitere Informationen klicken Sie [image] hier

Suchen

Geo-Objekte können gezielt auf der Karte mit der Schaltfläche [image] gesucht und hervorgehoben werden. Dabei kann in einem oder mehreren Layern gleichzeitig nach Zeichenketten gesucht werden. Für weitere Informationen zum Suchen klicken Sie [image] hier


Info-Felder / Hyperlinkfeld

Info-Felder und Hyperlink auswählen

Bildschirm anzeigen

Mit Schaltfläche [image] oder mit einem Klick der rechten Maustaste auf einen Layer (Menüpunkt "Info-Feld" im Kontext-Menü) wird das Auswahlfenster für Info-Felder und/oder eines Feldes für Hyperlinks für den aktiven Layer geöffnet.

Info-Felder

Es werden drei Listenfelder mit jeweils allen Feldern der Attribute-Datei des gewählten Layers angezeigt. Sie können in den ersten drei Listenfeldern jeweils ein Feld auswählen.

Beispiel für Karten-Info

Ist der Layer aktiv, wird im Karten-Element die Information der gewählten Felder zum an der Mausposition befindlichen Geo-Objekt als Quick-Info angezeigt.

Hyperlink-Feld

Das Hyperlink-Feld ist ein Feld aus der Attribute-Datei des Layers, das Internetadressen oder Zugriffspfade zu Dateien enthält. Wird hier ein Feld ausgewählt, kann zum an der Mausposition befindlichem Geo-Objekt durch Mausklick diese Internetadresse oder Datei angezeigt werden

Ist der Layer aktiv, wird im Karten-Element eine Hand als Kursor angezeigt, wenn das Geo-Objekt im Hyperlink-Feld einen Eintrag enthält. Wird jetzt die linke Maustaste betätigt, wird der Hyperlink aktiviert, dass heißt im konkreten Fall der Internet-Browser mit der Adresse www.wusterhausen.de aufgerufen.

Tipps zu Hyperlinks

Hyperlinks sind Verknüpfungen zu Internetadressen oder Dateien. Die Idee ist es, solche Internetadressen bzw. Dateien mit Geo-Objekten wie Gemeinden, Betrieben usw. zu verbinden, so dass beim Anklicken des Geo-Objektes die Internetseite oder die Datei angezeigt wird. Dazu ist es erforderlich, dass in dem Layer, dessen Geo-Objekte man mit derartigen Hyperlinks nutzen möchte, ein Feld in der Attribute-Datei des Layers existiert, welches die entsprechenden Aufrufe enthält wie z.B. www.brandenburg.de als Internetadresse, text.doc als Word-Dokument, tabelle.xls als Excel-Tabelle oder bild.jpg als Bilddatei. Erlaubt ist dabei alles, was vom Betriebssystem des betreffenden PC/Terminals als gültige Dateierweiterung zum Öffnen mit einem bestimmten Programm (Standardverknüpfung) vorgesehen ist.

Sie können mit der Programmfunktion [image] Attribute bearbeiten den gewünschten Layer bearbeiten. Ggf. ist dazu zunächst die Struktur des Layers mit der Schaltfläche Struktur ändern zu ändern, um ein ausreichend großes Feld zu "erzeugen" (z.B. ein Feld namens "Adresse" vom Typ "Zeichen" mit der Länge 100). Für die gewünschten Geo-Objekte sind jetzt die Werte (Internetadressen, Dateinamen) in dieses Feld einzutragen.

Ist dies geschehen, wird mit der Programmfunktion [image] Info-Felder und Hyperlink auswählen das Feld Adresse als Hyperlink-Feld ausgewählt. Ist der Layer aktiv, wird im Karten-Element eine Hand als Kursor angezeigt, wenn das Geo-Objekt im Hyperlink-Feld einen Eintrag enthält. Im Beispiel links ist das Feld zusätzlich noch als Info-Feld ausgewählt worden, um die Adresse zusätzlich noch als Quickinfo unter der Hand anzuzeigen.

Die Hyperlink-Hand [image] erscheint nur dann, wenn kein besonderer Mausmodus wie [image] Vergrößern oder [image] Identifizieren aktiv ist. In diesem Fall kann das Geo-Objekt jedoch mit der rechten Maustaste angeklickt werden und der Eintrag "Hyperlink aufrufen" ausgewählt werden.


Geo-Objekte identifizieren

Bildschirm anzeigen

Wurde der Info-Modus mit der Schaltfläche [image] aktiviert, erscheint dieses Info-Fenster.

Info-Fenster aktivieren

Der Mauskursor [image] im Karten-Element signalisiert, dass das Anklicken eines Geo-Objektes die Anzeige aller Informationen zum geklickten Objekt erfolgt.

Dabei ist das Verhalten abhängig vom Modus, der über das Kombinationsfeld am oberen Fensterrand ausgewählt werden kann. Ist [image] aktiver Layer markiert, werden nur die Geo-Objekte identifiziert, die dem Layer angehören, der in der Layer-Kontrolle gewählt ist. Der Modus [image] alle Layer identifiziert die Geo-Objekte alle Layer an der geklickten Position, der Modus [image] sichtbare Layer berücksichtig nur Layer die in der [image] Layer-Kontrolle sichtbar geschaltet sind.

Bildschirm zeigen Ggf. werden in einem Layer an der angeklickten Position mehrere Geo-Objekte gefunden, die übereinander liegen (Siedlungsarten bei Flächen wie Ortslage und gleichzeitig Wohnfläche) oder sehr nah beieinander liegen (z.B. mehrere Betriebe dicht beieinander). Dann werden alle gefundenen Geo-Objekte im linken Element des Info-Fensters angezeigt. Wählen Sie hier das gewünschte Geo-Objekt aus, um alle Details im rechten Element des Info-Fensters anzuzeigen. Wird ein Geo-Objekt im Info-Fenster (linkes Element) ausgewählt oder mit einem Mausdoppelklick versehen, wird das Geo-Objekt auf der Karte kurzzeitig blinkend dargestellt.

Bildschirm zeigen Beim Identifizieren über mehrere Layern (z.B. alle Layer, oder sichtbare Layer) werden die gefundenen Objekte nach Layer gruppiert im linken Element des Fensters dargestellt.

Kopieren

Der komplette Inhalt des Listenelements mit den Detailangaben kann in die Zwischenablage kopiert werden, indem die Schaltfläche "Kopieren" betätigt wird. Alternativ kann auch das Kontextmenü des rechten Listenelements genutzt werden, um alle Werte oder nur den angeklickten Wert in die Zwischenablage zu kopieren.

Bearbeiten

Die Attribute des im linken Listenelement markierten Geo-Objektes können mit der Schaltfläche "Bearbeiten" geändert werden. Attribute bearbeiten

Hyperlink

Ist für den Layer ein Hyperlink-Feld angegeben und enthält dieses für das selektierte Geo-Objekt einen Eintrag, kann die Verknüpfung (Internetadresse bzw. Datei) mit der Schaltfläche "Hyperlink" aufgerufen werden. Hyperlink aufrufen


Karten-Explorer - Geo-Objekte suchen

Geo-Objekte suchen

Bildschirm anzeigen

Diese Programmfunktion erlaubt es, in einem (oder mehren Layern gleichzeitig) nach Geo-Objekten zu suchen. Die Suche nach dem angegebenen Begriff erfolgt in allen Textfeldern der ausgewählten Layer oder per SQL-Abfrage. Gefundene Geo-Objekte können auf Wunsch gezoomt, zentriert oder blinkend hervorgehoben werden.

Der Dialog führt Sie durch 6 Schritte:

  1. Suchmodus auswählen

    • Textsuche in allen Feldern ( [image] Bild)
      Dies ist der Standardmodus, bei dem eine Suche in allen Textfelder der ausgewählten Layer vorgenommen wird.

    • SQL-Abfrage ( [image] Bild)
      Hierbei handelt es sich um einen Expertenmodus für den versierten Benutzer, bei dem per SQL-Abfrage in den selektierten Layern gesucht werden kann.
      Im SQL-Abfrage-Suchmodus erscheinen drei Schaltflächen. Die Schaltfläche "Assist." ruft einen Assistenten zur Angabe der SQL-Bedingung auf ( [image] SQL-Abfrage), die Schaltfläche "Strukt." zeigt den Aufbau der Attribut-Dateien der Layer an, die Schaltfläche "SQL?" aktiviert die Hilfeseite [image] Crash-Kurs SQL.

  2. zu suchenden Text bzw. SQL-Abfrage eingeben
    Beachten Sie, dass die Groß- und Kleinschreibung bei der Textsuche signifikant ist!

    Hinweis:
    Der Karten-Explorer "merkt" sich für die Dauer einer Programmsitzung alle eingegebenen Suchbegriffe bzw. SQL-Bedingungen, die über das Kombinationsfeld aus der Liste ausgewählt werden können. Einige wenige Windowsinstallationen verarbeiten die selben Begriffe in unterschiedlicher Groß- und Kleinschreibung in Kombinationsfeldern offensichtlich nicht als unterschiedliche Einträge und erlauben somit z.B. nicht, eine "Eingabe von "meier" in "Meier" zu ändern und zu verwenden. Für diese Fälle kann die Liste der "gemerkten" Eingaben mit der Schaltfläche [image] geleert und der Begriff in der gewünschten Weise eingegeben werden.

  3. Optionen auswählen

    • Modus für die Textsuche festlegen (Beispiel siehe [image] hier)

      1. beliebige Feldposition
        Der Suchtext kann an einer beliebigen Position in einem Textfeld vorkommen.

      2. gesamtes Feld
        Der Suchtext muss exakt mit dem Feldinhalt übereinstimmen.

      3. Feldanfang
        Der Suchtext muss am Feldanfang vorkommen.

    • das Kontrollkästchen "nur im aktuellen Kartenausschnitt suchen" legt fest, ob in der gesamten Karte oder nur im aktuell sichtbaren Kartenausschnitt gesucht werden soll. Bei sehr umfangreichen Kartenwerken oder häufig vorkommenden Bezeichnungen (wie z.B. Straßennamen) sollte von dieser Option Gebrauch gemacht werden, um die Suchzeit und/oder die Treffermenge zu optimieren.

  4. Layer auswählen

    1. Der bzw. die zu durchsuchende(n) Layer ist/sind auszuwählen. Zunächst ist der aktive Layer markiert. Mit Strg+Mausklick können Layer markiert bzw. demarkiert werden. Um alle Layer zu markieren, kann die Schaltfläche [image] gewählt werden.

    2. Die Suche kann mit der Tastenkombination Alt+S oder der Schaltfläche "Suche" aktiviert werden.

  5. Aktion auswählen
    Das unter 6. gewählte Geo-Objekt kann hervorgehoben, zentriert oder gezoomt werden:

    • Hervorheben
      Das Geo-Objekt wird zweimal blinkend dargestellt. Falls das Geo-Objekt sich nicht im sichtbaren Kartenausschnitt befindet, sollte es vorher mit der Schaltfläche "Zentrieren" (s.u.) in diesen positioniert werden.
      Hinweis: Ein Mausdoppelklick auf einen Treffer hat die gleiche Wirkung wie die Schaltfläche "Hervorheben".

    • Zentrieren
      Der sichtbare Kartenausschnitt wird dergestalt verschoben, dass das gewählte Geo-Objekt sich im Zentrum befindet.

    • Zoomen
      Die Karte wird auf das Geo-Objekt gezoomt.
      Für Punkte wird die Karte auf den Punkt zentriert und im ausgewählten Maßstab dargestellt, für Polygone und Linien wird die Karte exakt auf die Dimension des gewählten Geo-Objektes gezoomt (Beispiel: Ist das Geo-Objekt eine Gemeinde, so werden ihre Grenzen in den Kartenausschnitt eingepasst).

  6. Treffer auswählen
    Das gewünschte Geo-Objekt ist aus der Liste auszuwählen. Beim Betätigen der Eingabetaste bzw. mit einem Mausdoppelklick auf das Geo-Objekt wird die unter 5. gewählte Aktion (Hervorheben, Zentrieren, Zoomen (Einpassen)) ausgeführt.


Crash-Kurs SQL

Crash-Kurs SQL-Abfrage

Eine SQL-Bedingung zur Selektion von Geo-Objekten ist grundsätzlich folgendermaßen aufgebaut:
Feldname Operator Wert wie z.B. Rind > 0 für ein numerisches Feld oder Name like 'Meier%' für ein Zeichenkettenfeld.

Operatoren

Vergleichsoperatoren
< | kleiner
= | gleich
> | größer
<= | kleiner (oder) gleich
<> | ungleich
>= | größer (oder) gleich
logische Verknüpfungen [image] logische Verknüpfungen
and | verknüpft Teilbedingungen mit einem logischen UND, so dass jede Teilbedingung erfüllt sein muss
or | verknüpft Teilbedingungen mit einem logischen ODER, so dass mindestens eine Teilbedingung erfüllt sein muss
Spezialoperatoren
like | Dieser Operator ist nur für Zeichenketten definiert und vergleicht auf "Teilzeichenketten" in einem Zeichenfeld ( [image] Zeichenfelder).

Numerische Felder

Numerische Felder enthalten ausschließlich Zahlen (ggf. Komma und Vorzeichen). Vergleiche folgen den Regeln der Mathematik, d. h., es werden immer alle Ziffern als Gesamtheit entsprechend ihres Zahlenwertes betrachtet und in Relation zu anderen Zahlen gesetzt wie 1.3 < 5 < 199 usw.

Beispiele:
Rind > 0 findet alle Einträge mit Rindern!
Rind <> 0 findet alle Einträge mit Rindern!
Schwein > 100 findet alle Einträge mit mehr als 100 Schweinen!
Schwein >= 100 findet alle Einträge mit 100 oder mehr Schweinen!

Zeichenfelder

  • Werte sind in einfache Hochkommata einzuschließen, wie z.B. Name = 'Meier'

  • Groß-/Kleinschreibung ist signifikant!

  • Zeichenfelder können Buchstaben, Ziffern und Sonderzeichen enthalten. Die Vergleichsoperationen können angewendet werden, arbeiten jedoch nicht wie bei numerischen Feldern. Bei Zeichenketten werden Zeichen von links beginnend stellenweise verglichen. Ausschlaggebend dabei ist der Wert des Zeichens in der Zeichentabelle (so genannte ASCII-Tabelle).

    Es gilt:
    'A' < 'B', weil 'A' in der ASCII-Tabelle vor dem 'B' steht!
    '1' < 'C', weil Ziffern in der ASCII-Tabelle vor Buchstaben stehen!
    '139' < '9', weil stellenweise verglichen wird und '1' < '9' ist!

    Beispiele:
    Name > 'D' findet alle Einträge die mit 'E', 'F' .. 'Z' beginnen!
    Name < 'D' findet alle Einträge die mit '', 'A', 'B', 'C' beginnen!

  • Der like-Operator und das %-Zeichen erlauben das effiziente Vergleichen (Suchen) mit Teilzeichenketten, wobei mit dem %-Zeichen vor und/oder nach dem eigentlichen Suchwert eine Art Suchmaske gebildet wird.

    Beispiele:
    Name like 'Meier' - Name muss exakt Meier sein!
    Name like 'Meier%' - Name muss mit Meier beginnen!
    Name like '%Meier%' - Name muss (irgendwo) Meier enthalten!

    Krs_Schl like '12%'
    Kreisschlüssel muss mit 12 beginnen! In einer Shape-Datei mit allen Kreisen Deutschlands würde man so alle Kreise Brandenburgs als Ergebnis der Abfrage erhalten!

logische Felder

Logische Felder können genau 2 Werte annehmen true (wahr bzw. ja) oder false (falsch bzw. nein). Für die Abfrage dieser Felder ist lediglich der =-Operator relevant.

Beispiele:
Untersucht = true - findet alle Einträge, für die untersucht wurde (resp. untersucht wahr ist)
Untersucht = false - findet alle Einträge, für die nicht untersucht wurde (resp. untersucht falsch ist)

Datumsfelder

Datumsfelder verhalten sich bei Vergleichen wie numerische Felder. Gewöhnungsbedürftig ist lediglich die Notation, die für Datumswerte erforderlich ist. Hier ist das Datum in der Form MM/TT/JJJJ anzugeben. So wird aus dem 31.12.2001 der Wert 12/31/2001.

Beispiele:
Datum >= 03/01/2000 - findet alle Einträge, für die das Datum größer/gleich 01.03.2000 ist
Datum <> 12/31/2000 - findet alle Einträge, für die das Datum nicht 31.12.2000 ist

logische Verknüpfungen

Es können mehrere (Teil-)Bedingungen mit einem logischen ODER bzw. mit einem logischen UND verknüpft werden.

Feldname1 Operator1 Wert1 or Feldname2 Operator2 Wert2
Feldname1 Operator1 Wert1 and Feldname2 Operator2 Wert2

Beispiel | Wirkung
Rind > 0 and Schwein > 0 | Alle Tierhalter, die sowohl Rinder als auch Schweine besitzen, werden verarbeitet.
Rind > 0 or Schwein > 0 | Alle Tierhalter, die entweder Rinder oder Schweine (oder beides) besitzen, werden verarbeitet.
Rind > 0 and Schwein = 0 | Alle Tierhalter, die Rinder und keine Schweine besitzen, werden verarbeitet.
Datum >= 01/01/2000 and Datum <= 12/31/2000 | Alle Einträge vom 01.01.2000 bis 31.12.2000 werden verarbeitet.


Zeichenmodus

Zeichnenmodus

Der Zeichnenmodus ist aktiviert, wenn eine der folgenden Tasten in der Symbolleiste erscheint:
Kreis, [image] Rechteck, [image] Polygon, [image] Puffer, [image] Linie oder [image] Punkt.

Beachten Sie:
Wenn jetzt ein [image] (Stift) als Mauskursor im Karten-Element erscheint, kann sofort mit dem Zeichnen des Objektes begonnen werden.
Ausnahme:
Eine Ausnahme besteht, wenn eine der folgenden Tasten in der Symbolleiste gedrückt ist:
Vergrößern, [image] Verschieben, [image] Identifizieren, [image] Entfernung, [image] Selektieren!
In diesem Fall ist die jeweilige Funktion durch Betätigen der jeweiligen Schaltfläche zu deaktivieren oder das Zeichnen mit Alt - linke Maustaste im Karten-Element zu aktivieren. Im letzteren Fall ist nach dem Zeichnen des Objektes der vorherige "Mausmodus" (Zoomen, Verschieben, Info oder Entfernungsbestimmung) weiterhin aktiviert.

Wurde das Zeichnen gestartet, erscheint ein Info-Fenster, welches weitere Informationen zum Zeichnen gibt (z.B. Radius beim Kreismodus). Nach Beendigung der Zeichenaktion wird das Geo-Objekt (Kreis, Rechteck, Polygon usw.) als separater Layer zur Layer-Kontrolle hinzugefügt oder in einen bereits geladenen Layer eingefügt. ( [image] Geo-Objekt speichern)

Kreis: Drücken Sie ggf. die Alt-Taste und klicken Sie mit der linken Maustaste auf den Mittelpunkt des zu zeichnenden Kreises. Halten Sie die Maustaste weiterhin gedrückt und ziehen Sie den Kreis nach rechts bis zur gewünschten Größe.
Rechteck: Drücken Sie ggf. die Alt-Taste und klicken Sie mit der linken Maustaste auf die linke obere Ecke des zu zeichnenden Rechtecks. Halten Sie die Maustaste weiterhin gedrückt und ziehen Sie das Rechteck nach rechts unten bis zur gewünschten Größe.
Polygon: Drücken Sie ggf. die Alt-Taste und klicken Sie auf einen Eckpunkt des zu zeichnenden Polygons. Setzen Sie weitere Punkte des Polygons per einfachem Mausklick und den letzten Punkt durch einen Mausdoppelklick, welcher den Zeichnenmodus beendet.
Puffer: Drücken Sie ggf. die Maustaste und klicken Sie mit der linken Maustaste auf den Punkt, der der Mittelpunkt der zu generierenden Pufferzone ist. Die Vorgabe für den Pufferradius ist 3000 Meter und kann mit dem Menüpunkt "Extras - Zeichnenmodus - Pufferradius einstellen" verändert werden.
Linie: Drücken Sie ggf. die Alt-Taste und klicken Sie mit der linken Maustaste auf einen Endpunkt der zu zeichnenden Linie. Setzen Sie weitere Punkte der Linie per einfachem Mausklick und den Endpunkt durch einen Mausdoppelklick, welcher den Zeichnenmodus beendet.
Punkt: Drücken Sie ggf. die Alt-Taste und klicken Sie mit der linken Maustaste auf den zu zeichnenden Punkt.

Folgende Attribute zum Geo-Objekt werden automatisch berechnet und gespeichert:

  • Kreis

    • X- und Y-Koordinate des Mittelpunktes

    • Radius

  • Rechteck

    • Länge und Breite

    • Koordinaten für Links (X), Oben (Y), Rechts (X), Unten (Y)

  • Polygon

    • Fläche und Umfang

  • Puffer

    • X- und Y-Koordinate des Mittelpunktes

    • Radius

  • Linie

    • Länge

  • Punkt

    • X- und Y-Koordinate


Geo-Objekt speichern - Karten-Explorer

Geo-Objekt speichern

Bildschirm zeigen

Gezeichnete Geo-Objekte müssen in eine Shape-Datei abgelegt werden, um sie anzeigen bzw. einfärben zu können. Unmittelbar nach dem Zeichnen des Geo-Objektes wird das Fenster "Geo-Objekt speichern?" geöffnet.

Hier kann festgelegt werden, ob das soeben gezeichnete Geo-Objekt in einem neuen Layer abgelegt werden soll oder ob es zu einem vorhandenen Layer hinzugefügt werden soll.

Kreise (Puffer), Rechtecke und Polygone werden in Shape-Dateien des Typs Polygon gespeichert, Linie und Punkte entsprechend in Shape-Dateien der Typen Linie bzw. Punkt. Es ist nicht möglich, Geo-Objekte unterschiedlichen Typs in einer Shape-Datei (einem Layer) zu speichern.

Neuer Layer

Wird diese Option gewählt, wird automatisch ein neuer Layer ( [image] temporäre Layer) des erforderlichen Typs angelegt.

Mit der Schaltfläche Struktur kann die Dateistruktur der Attribut-Datei geändert oder aus einer anderen Attribut-Datei (dBase-Tabelle) importiert werden.

Vorhandener Layer

Alle geladenen Layer, die dem Typ des soeben gezeichneten Geo-Objekts (Punkt, Linie oder Polygon) entsprechen, werden hier aufgelistet. Wählen Sie den gewünschten Layer aus (am einfachsten durch Doppelklick mit der Maus), um das Geo-Objekt in diesem abzuspeichern.

ic_finger.gif (947 Byte) Tipp: Wollen Sie mehrere Geo-Objekte (z.B. Puffer um Bestände) zeichnen, wählen Sie den Zeichenmodus aus und zeichnen Sie das erste Geo-Objekt. Wählen Sie jetzt beim Abspeichern des ersten Kreises die Option 'in einem neuen Layer anzeigen', worauf der Layer mit einem automatisch vergebenen Namen generiert wird. Benennen Sie den Layer nun ggf. um, um ihm in der Layer-Kontrolle einen aussagekräftigeren Namen zu geben. Beim Zeichnen weiterer Kreise können diese jetzt mit der Option 'zu vorhandenen Layer hinzufügen' in diesem abgelegt werden. Beachten Sie, dass temporäre Layer "verloren" gehen, wenn diese nicht gespeichert werden. ( [image] temporäre Layer)

Aktion läuft

Der Karten-Explorer bietet alle geladenen Layer des erforderlichen Typs zum Abspeichern der Geo-Objekte an. Stellen Sie sicher, dass Geo-Objekte nicht in wichtigen "Systemdateien" (z.B. Gemeindegrenzen, Grenzen Bundesländer usw.) gespeichert werden.


Selektieren - Karten-Explorer

Geo-Objekte selektieren

Einzelne Geo-Objekte eines Layers mit Vektordaten (je nach Typ des Layers Polygone, Linien oder Punkte) können auf verschiedene Arten selektiert und in einen separaten Layer exportiert werden. Dabei können die Geo-Objekte per räumlicher Bedingung, über Liste (Attribute-Datei), SQL-Abfrage oder Mausklick (manuell) selektiert werden.

  1. räumlich
    Geo-Objekte eines Layers werden selektiert, wenn sie einer räumlichen Suchbedingung (Geo-Objekte eines "Such-Layers") entsprechen, wie z.B.

    • alle Tierhalter in Punkte-Layer, die innerhalb Pufferzonen (z.B. 3-km-Radien um Schlachthöfe) in einem Polygon-Layer liegen,

    • alle Straßen in Linien-Layer, die im aktuellen Kartenausschnitt liegen,

    • alle Gemeinden in Polygon-Layer, die ganz oder teilweise einem 10-km-Radius liegen.

    Häufig sollen Geo-Objekte ausgewählt werden, die sich in Pufferzonen, in einem Polygon usw. befinden. Nutzten Sie ggf. die Zeichenfunktionen des Karten-Explorers, um die gewünschten "Such-Layer" zu erstellen. ( [image] Zeichnenmodus).

    Geo-Objekte räumlich selektieren

  2. Liste
    Die Attribute aller Geo-Objekte eines Layers werden tabellarisch angezeigt und können einzeln für einen Export in einen neuen Layer selektiert werden, wie z.B.

    • Auswahl von drei "betroffenen" Beständen aus einem Layer mit 4000 Tierhaltern,

    • Auswahl von 3 Kreisen für ein Krisenzentrum aus einem Layer mit den Kreisgrenzen des Bundeslandes.

    Geo-Objekte aus Liste selektieren

  3. per Abfrage
    Geo-Objekte werden entsprechend einer SQL-Abfrage der Attribute vorgenommen. Damit können Geo-Objekte durch Definition von Bedingungen oder Kombinationen von Bedingungen ausgewählt werden, wie z.B.

    • Rinder > 0 or Schwein > 0
      alle Geo-Objekte mit Rinder und/oder Schweinen

    • Name like '%Meier%'
      alle Geo-Objekte, die im Namen Meier enthalten

    Geo-Objekte per Abfrage selektieren

  4. per Mausklick (manuell)
    Geo-Objekte eines oder mehrer Layer werden per Mausklick aus dem jeweils aktiven Layer selektiert. Diese sehr mächtige Programmfunktion erlaubt Aktionen wie z.B.

    • Selektieren: 5 Gemeinden eines Kreises werden per Mausklick selektiert.

    • Löschen: Aus einem Layer mit 100 Gemeinden werden 3 Gemeinden entfernt.

    • Zusammenführen ("Merge"): 3 Sperrgebiete, die sich in 3 verschiedenen Layern befinden, werden selektiert und in einem Layer gespeichert.

    Geo-Objekte manuell / per Mausklick selektieren


Räumlich selektieren - Karten-Explorer

Geo-Objekte räumlich selektieren

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Selektieren - Räumlich" des Karten-Explorers werden Geo-Objekte eines Layers selektiert, wenn sie einer räumlichen Suchbedingung (räumliche Beziehung zu Geo-Objekten eines "Such-Layers") entsprechen. Diese werden in einem Vorschaufenster angezeigt und können auf Wunsch in einen neuen Layer (separate Shape-Datei) exportiert werden.

1. zu 'Clippenden' Layer auswählen

Alle geladenen Layer mit Vektordaten (Shape-Dateien) werden angezeigt. Der Layer, aus dem Geo-Objekte ausgewählt werden sollen, ist hier zu markieren.

2. 'Such-Layer' auswählen

Alle geladenen Layer mit Vektordaten (Shape-Dateien) sowie der Eintrag <aktueller Kartenausschnitt> werden angezeigt. Der Layer, dessen Geo-Objekte die räumliche Selektionsbedingung bilden, ist hier zu markieren. Alternativ zu geladenen Layer kann auch die Ausdehnung des aktuellen Kartenausschnitts zur Selektion verwendet werden (z.B. alle Punkte eines Layers im aktuellen Kartenausschnitt selektieren).

3. Such-Methode auswählen

Über die Suchmethode wird festgelegt, in welcher Relation die Geo-Objekte des Clip-Layers über den Such-Layer ausgewählt werden.

a) "Containing"

Geo-Objekte aus Clip-Layer (1.) müssen vollständig in Such-Layer (2.) enthalten sein.

Beispiele:

(1) Typ Clip-Layer | (2) Typ Such-Layer |
Punkt | Polygon | Alle Punkte aus (1), die in ein Polygon aus (2) fallen
Polygon, Linie | Polygon | Alle Polygone bzw. Linien aus (1), die vollständig in einem Polygon aus (2) enthalten sind.
beliebig | Punkt, Linie | Keine Ergebnisse! Nutzen Sie ggf. Suchmethode b) "Area Intersect"!

b) "Area Intersect"

Geo-Objekte aus Clip-Layer (1.) müssen ganz oder teilweise in Such-Layer (2.) enthalten sein, mit anderen Worten, die Flächen müssen sich "berühren".

Beispiele:

(1) Typ Clip-Layer | (2) Typ Such-Layer |
Punkt | Polygon | Alle Punkte aus (1), die in ein Polygon aus (2) fallen
Polygon, Linie | Polygon | Alle Polygone bzw. Linien aus (1), die ganz oder teilweise in einem Polygon aus (2) enthalten sind.
Polygon | Punkt | Alle Polygone aus (1), in denen sich min. ein Punkt aus (2) befindet
Polygon | Linie | Alle Polygone aus (1), in denen eine Linie aus (2) ganz oder teilweise enthalten ist
Linie | Linie | Alle Linien aus (1), die eine Linie aus (2) schneiden

c) "Extent Overlap"

Jeder Layer besitzt unabhängig von seinem Typ eine Ausdehnung (Extent), der das kleinste Rechteck beschreibt, innerhalb dessen sich alle Geo-Objekte des Layers befinden. Bei dieser Suchmethode werden alle Geo-Objekte aus dem Clip-Layer (1.) selektiert, die ganz oder teilweise innerhalb des Rechteckes der Ausdehnung des Such-Layers (2.) liegen.

d) "Line Cross"

Linien von Geo-Objekten aus dem Clip-Layer (1.) werden von Linien von Geo-Objekten des Such-Layers (2.) geschnitten.

(1) Typ Clip-Layer | (2) Typ Such-Layer |
Punkt | Polygon | Keine Ergebnisse!
Polygon, Linie | Polygon, Linie | Alle Polygone bzw. Linien aus (1), die Schnittpunkte mit Polygonen bzw. Linien aus (2) haben.
Polygon | Punkt | Keine Ergebnisse!


Abfrage selektieren - Karten-Explorer

Geo-Objekte per Abfrage selektieren

Bildschirm zeigen

Mit dem Menüpunkt "Selektieren - Abfrage" des Karten-Explorers werden Geo-Objekte eines Layers selektiert, wenn sie einer SQL-Bedingung (Abfrage der Attribute von Geo-Objekten) entsprechen. Diese werden in einem Vorschaufenster angezeigt und können auf Wunsch in einen neuen Layer (separate Shape-Datei) exportiert werden.

(1) Layer für Selektion auswählen

Alle geladenen Layer mit Vektordaten werden aufgelistet. Der gewünschte Layer ist zu markieren.
Mit der Schaltfläche [image] kann die [image] Layer-Statistik für den gewählten Layer angezeigt werden, die z.B. den Aufbau der Attributs-Tabelle auflistet.

(2) SQL-Bedingung auswählen/eingeben

Es ist eine Abfragebedingung einzugeben. Diese entspricht der so genannten WHERE-Klausel eines SQL-Statements entsprechend ANSI SQL. Für den EDV-Laien sind im [image] Crash-Kurs SQL die wichtigsten Grundregeln für die Erstellung dieser Abfragen erklärt.

Eine Bedingung ist grundsätzlich folgendermaßen aufgebaut:
Feldname Operator Wert wie z.B. Rinder > 0 für ein numerisches Feld oder Name like 'Meier%' für ein Zeichenkettenfeld.

Die Bedingungen können per Hand in den Eingabebereich eingegeben oder per Mausklick zusammengestellt werden.

Um eine Bedingung per Mausklick zu erstellen, ist folgendermaßen vorzugehen:

  • Zunächst ist ein Feldname auszuwählen (in den Eingabebereich zu übernehmen), indem im Listenfeld 'Feld auswählen' der gewünschte Eintrag mit einem Mausdoppelklick versehen wird.

  • Anschließend ist ein Operator (<, =, >, <=, <>, >=, like) durch Betätigen der entsprechenden Schaltfläche zu wählen.

  • Durch Betätigen der Schaltfläche [image] werden im Listenfeld 'Werte gewähltes Feld' alle verfügbaren (in der Attributs-Tabelle des Layer gefundenen) Werte angezeigt und können per Mausdoppelklick auf den gewünschten Eintrag in den Eingabebereich übernommen werden

  • Um mehrere Bedingungen logisch zu verknüpfen kann jetzt die Schaltfläche "and" bzw. "or" betätigt werden.


Manuell selektieren - Karten-Explorer

Geo-Objekte aus Liste selektieren

Bildschirm zeigen

Mit dem Menüpunkt "Selektieren - Liste" des Karten-Explorers können Geo-Objekte eines Layers einzeln selektiert werden, indem in der Attribute-Tabelle des Layers für die betreffenden Geo-Objekte eine Markierung gesetzt wird.

Zu einem Layer mit Vektordaten existiert eine Attribute-Tabelle, in der inhaltliche Angaben zu jedem Geo-Objekt enthalten sind. Zunächst sind aus der Attribute-Tabelle alle Felder (Spalten) auszuwählen, die bei der Selektion angezeigt werden sollen. Felder selektieren.

Jede Zeile in der Tabelle korrespondiert mit dem betreffenden Geo-Objekt. Das Kontrollkästchen am Zeilenbeginn legt fest, ob das Geo-Objekt selektiert werden soll und kann per Mausklick oder mit der Leertaste umgeschaltet werden.

Über die Schaltflächen [image], [image] oder [image] können alle Geo-Objekte markiert, demarkiert oder deren Markierung umgeschaltet werden.

Mit der Schaltfläche "Speichern" werden die gewählten Geo-Objekte in einen neuen Layer (eine neue Shape-Datei) exportiert.

ic_finger.gif (947 Byte) Tipp: Um Geo-Objekte zu suchen, können Sie eine Suchzeichenkette eingeben. Diese bezieht sich auf den Text in der 1. Tabellenspalte. Es ist daher bei der Auswahl der anzuzeigenden Felder darauf zu achten, dass das "Suchfeld" am Anfang der Liste der gewählten Spalten steht. Felder selektieren


Felder selektieren - Karten-Explorer

Felder selektieren

Bildschirm zeigen

Wird im Karten-Explorer der Menüpunkt "Extras - Manuell selektieren" gewählt, erscheint zunächst das Fenster "Felder selektieren" über welches der gewünschte Layer und die Liste der bei der Selektion anzuzeigenden Spalten (Felder aus der Attribute-Tabelle des Layers) auszuwählen sind.

1) Layer für Selektion auswählen

Alle geladenen Layer mit Vektordaten werden aufgelistet. Der gewünschte Layer ist zu markieren.

2) bei der Selektion anzuzeigende Spalten auswählen

Wurde ein Layer markiert, so wird die Liste der verfügbaren Felder im Bereich 'nicht gewählte Spalten' angezeigt. Alle Spalten, die bei der manuellen Auswahl der Geo-Objekte aufgelistet werden sollen, sind in den Bereich 'gewählte Spalten' zu übernehmen. Nutzen Sie dazu die Schaltflächen oder einen Mausdoppelklick auf die gewünschten Einträge.

ic_finger.gif (947 Byte) Tipp: Stellen Sie sicher, dass das primäre Suchfeld am Anfang der Liste der gewählten Spalten steht, da bei der manuellen Selektion durch Eingabe einer Zeichenkette über dieses Feld auf Geo-Objekte positioniert werden kann. Nutzen Sie ggf. die Schaltflächen "Hoch" bzw. "Tief", um die Reihenfolge der gewählten Spalten dahingehend zu ändern.


per Mausklick selektieren - Karten-Explorer

Selektieren-Fenster - Geo-Objekte manuell / per Mausklick selektieren

Bildschirm zeigen

Mit dem Menüpunkt "Selektieren - Manuell / Mausklick" des Karten-Explorers können Geo-Objekte per Mausklick selektiert werden.

Selektieren per Mausklick im Karten-Element

Um den Modus "Geo-Objekte per Mausklick selektieren" zu aktivieren, ist [image] im Karten-Explorer zu betätigen. ( [image] erscheint als Kursor im Karten-Element). Es öffnet sich ein (zunächst leeres) Auswahlfenster, in dem bisher selektierte Objekte angezeigt werden. Jetzt können Geo-Objekte des aktiven Layers per einfachem Mausklick in das Karten-Element selektiert und damit in das Auswahlfenster kopiert werden.

Sollten bei einem Mausklick mehrere Geo-Objekte getroffen worden sein (z.B. übereinanderliegende bzw. benachbarte Polygone), erscheint ein separates Fenster, mit dem die Geo-Objekte einzeln aus- oder abgewählt werden können. Mehrfachauswahl

Es kann der aktive Layer und sogar das Projekt beliebig oft gewechselt werden. Hierfür gibt es jedoch die Einschränkung, dass der einmal festgelegte Typ (Punkt, Linie oder Polygon) beibehalten werden muss. Wird der Layer gewechselt, ist zu beachten, dass der Typ der Auswahl und die Struktur der Attribut-Datei (die Selektion stellt eine Shape-Datei dar) durch das erste gewählte Geo-Objekt festgelegt wird.
Tipp:

  • Alternativ kann bei nicht gedrückter Taste [image] die Auswahl auch per Mausdoppelklick auf ein Geo-Objekt im Karten-Element vorgenommen werden. Dies ist praktisch, wenn ein anderer Maus-Modus (z.B. "Karte verschieben") aktiv ist.

Laden von Layern - "Merge-Funktion"

Im Karten-Explorer geladene Layer, aber auch externe Shape- oder Polygon-Dateien können in das Selektieren-Fenster geladen werden. Diese Funktionalität eignet sich insbesondere für folgende Aktionen:

  • Zusammenführen (Merge) von Layern bzw. Shape- und Polygon-Dateien
  • Laden eines Layers bzw. einer Shape-Datei, um einzelne Geo-Objekte (siehe folgenden Abschnitt) zu löschen!
  • Anwenden von geometrischen Operationen

Folgende Möglichkeiten können zum Laden von Layer, Shape- oder Polygon-Dateien genutzt werden:

  • Mit der Taste [image] des Auswahlfensters wird ein Dialogfenster (analog der nebenstehenden Abbildung) geöffnet, das alle geladenen Layer anzeigt, sowie die Auswahl weiterer (nicht geladener) Shape-Dateien erlaubt. Damit können geladene Layer, Shape-Dateien oder Polygon-Dateien ausgewählt werden.

  • Per Drag&Drop

    • Layer aus der Layer-Kontrolle

    • Von Dateien aus einem Windows-Explorer

      • ein oder mehrere Polygon-Dateien
      • ein oder mehrere Shape-Dateien
  • Per Menüpunkt "Datei - Einfügen aus Zwischenablage" oder STRG+V können Polygon- oder Shape-Dateien aus der Zwischenablage eingefügt werden

Selektieren und Verarbeiten von Geo-Objekten im Auswahlfenster

  • Auch im Auswahlfenster kann über die Taste [image] ein Selektionsmodus aktiviert werden. Damit können Geo-Objekte im Auswahlfenster markiert werden (siehe Beispiel im "Screenshot" Bildschirm zeigen ), um sie ggf. zu löschen oder geometrische Operationen auszuführen. Mit der Schaltfläche [image] kann die Markierung umgeschaltet werden, mit der Schaltfläche [image] werden alle Marierungen entfernt.

  • Mit dem Menüpunkt "Markieren - mit Layer markieren" kann ein in der Layer-Kontrolle geladener Layer verwendet werden, um die Geo-Objekte im Selektieren-Fenster zu markieren. Dabei können verschiedene Methoden (Geo-Objekte sind vollständig enthalten oder teilweise enthalten, werden vom Layer geschnitten usw.) angewendet werden

  • Markieren per Drag&Drop eines Layers aus der Layer-Kontrolle in das Selektieren-Fenster mit gedrückter STRG- bzw. ↑-Taste
    ... STRG + Drop & Drop ® Geo-Objekte markieren, die sich vollständig innerhalb des Layers befinden.
    ...↑ + Drop & Drop ® Geo-Objekte markieren, die sich innerhalb des Layers befinden oder von ihm geschnitten werden.

Menü Verarbeiten

markierte Geo-Objekte löschen → alle markierten Geo-Objekte werden aus dem Auswahlfenster entfernt!
unmarkierte Geo-Objekte löschen → alle nicht markierten Geo-Objekte werden aus dem Auswahlfenster entfernt!
Linien zu Polygon ermöglicht es, Geo-Objekte vom Typ "Linie" im Auswahlfenster zu einem Polygon zusammenzufassen. Das Polygon wird umgehend als neuer Layer im Karten-Explorer angezeigt. Diese Funktion ist nützlich, um einzelne GPS-Tracks in ein Polygon umzuwandeln.
Geometrische Operationen erlaubt die Verarbeitung von Geo-Objekten vom Typ "Polygon" mit [image] geometrische Operationen.

Zum Löschen markierter Geo-Objekte ist die Taste [image] zu betätigen. Mit der Schaltfläche [image] können die Geo-Objekte mit [image] geometrische Operationen für Geo-Objekte vom Typ "Polygon" verarbeitet werden.

Hinzufügen oder Ersetzen (Selektion speichern)

Um die Geo-Objekte im Selektieren-Fenster als neuen Layer (als neue Shape-Datei) zu speichern, ist die Schaltfläche "Hinzufügen" zu betätigen.

Beim Betätigen der Schaltfläche "Ersetzen" erscheint ein Auswahlfenster mit allen geladenen Layern, die dem Typ des Layers (Punkt, Polygon, Linie oder Multipoint) im Selektieren-Fenster entsprechen.

Der Layer, aus dem die Selektion durchgeführt bzw. begonnen wurde, ist vorselektiert. Durch Betätigen der Eingabetaste, Doppelklick auf einen Layer oder das Betätigen der Schaltfläche „Layer ersetzen“ wird die zugehörige Shape-Datei des gewählten Layers gelöscht und durch die Geo-Objekte im Selektieren-Fenster ersetzt.

weitere Menüfunktionen

 | Auswahlfenster leeren entfernt alle Geo-Objekte.
 | Einfärbung (Strg + E) aktiviert den Dialog zum Einfärben der Geo-Objekte. Es könnte z.B. sehr hilfreich sein, die Geo-Objekte im Auswahlfenster mit einer Beschriftung zu versehen. Eigenschaften für Einfärbung
Info-Felder | Info-Feld (Strg + I) aktiviert bis zu drei beliebiges Felder der der Attribut-Datei eines Layers dergestalt, dass für das an der Mausposition befindliche Geo-Objekt die gewählte Information als Tooltipp (Quick-Info) angezeigt wird. Info-Felder auswählen
 | Karte einpassen bewirkt die optimale Anpassung der Kartengröße an alle geladenen Geo-Objekte.
 | Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.
 | Verkleinern reduziert die Größe der Karte zweifach.
 | Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen. Tipp: Mit Strg + gedrückter linker Maustaste kann die Karte jederzeit verschoben werden.
 | Identifizieren zeigt alle in der Merkmalsdatei vorhandenen Informationen zum mit der linken Maustaste angeklickten Geo-Objekt an.


Selektieren - geometrische Operationen

Geo-Objekte verarbeiten (geometrische Operationen)

Bildschirm zeigen

Achtung: Die Nutzung der Funktionalitäten "Geometrische Operationen" erfordert die Installation des OCX MapObjects 2.x der Firma ESRI auf dem betreffenden PC. Diese Komponenten werden ggf. aus lizenzrechtlichen Gründen standardmäßig nicht mit der Software ausgeliefert.

Diese Programmfunktion erlaubt es, die Geo-Objekte, die sich im [image] Auswahlfenster (zur Auswahl von Geo-Objekten per Mausklick) des Karten-Explorers befinden, mit geometrischen Operationen zu verarbeiten. Dabei sind die geometrischen Operationen "Union", "Intersect", "Differenz" und "Xor" mit den Geo-Objekten möglich. Die Programmfunktion ist auf Geo-Objekte vom Typ Polygon beschränkt.

Innerhalb des Auswahlfensters ist die Markierung von einzelnen Polygonen mit der Schaltfläche [image] möglich. Sind im Auswahlfenster Polygone markiert, kann mit dem Kontrollkästchen "markierte Geo-Objekte verarbeiten" festgelegt werden, ob geometrischen Operationen nur auf die so markierten Geo-Objekte angewendet werden sollen.

Symbol | Aktion | Erläuterungen
 | Union (Vereinigung) | Die Polygone werden zu einem Polygon zusammen gefügt.
 | Intersect (Durchschnitt) | Die Überlappung mehrerer Polygone wird ermittelt.
 | Differenz | Vom zuerst gewählten bzw. markiertem Polygon werden die Flächen der anderen Polygone abgezogen.
 | Xor (Ausschließen) | Die Überlappung von Polygonen wird ausgeschlossen.


Geo-Objekt auswählen - Karten-Explorer

Geo-Objekte per Mausklick selektieren - Auswahl bei Mehrfachselektion

Bildschirm zeigen

Werden beim Selektieren mit der Maus mehrere dicht beieinander oder übereinander liegende Geo-Objekte getroffen, werden diese Geo-Objekte in einem separaten Auswahlfenster angezeigt. Jedes Geo-Objekt kann über ein Kontrollkästchen aus- oder abgewählt werden. Die Attribute des in der Baumansicht markierten Geo-Objekts werden auf der rechten Seite im Listen-Element angezeigt. Beim Wechsel eines Eintrags in der Baumansicht, durch Doppelklick auf einen Eintrag oder Betätigen der Schaltfläche Hervorheben wird zusätzlich das markierte Geo-Objekt auf der Karte hervorgehoben.

Mit der Schaltfläche Ok werden die markierten Geo-Objekte übernommen.


Attribute manipulieren - Karten-Explorer

Attribute manipulieren

Vektordaten speichern neben den eigentlichen geografischen Objekten (Punkt, Linie, Polygon) weitere Informationen, so genannte Attribute, die die Geo-Objekte beschreiben. Für Shape-Dateien können diese Attribute manipuliert werden, indem die Informationen bearbeitet oder die Struktur der Informationen (Tabellenaufbau) verändert wird. Zur Weiterbearbeitung der Informationen mit anderen Programmen (z.B. Excel) können die Attribute sowohl von Shape-Dateien als auch von ARC/INFO-Dateien exportiert werden.

Da mit dem Menü 'Extras' des Karten-Explorers geografische Objekte gezeichnet, georeferenziert bzw. aus vorhandenen Vektordaten beliebig selektiert werden können, ist mit dem Zugriff auf die Attribute als deren beschreibende Eigenschaften die vollständige Kontrolle über darzustellende Informationen möglich. Insbesondere können bereits vorhandene Informationen ergänzt werden, indem die Attribute-Datei um fehlende Spalten ergänzt wird (Struktur Attribute-Datei ändern), die Informationen danach erfasst werden (Attribute editieren) und danach entsprechende Darstellungen (Einfärbungen) der Karte vorgenommen werden.

Attribute editieren, [image] Struktur Attribute-Datei ändern, [image] Attribute exportieren, [image] Attribute in Zwischenablage exportieren


Attribute anzeigen - Karten-Explorer

Attribute anzeigen

Bildschirm zeigen

Mit dem Menüpunkt "Layer - Attribute - Anzeigen" des Karten-Explorers können Attribut-Dateien von Shape-Dateien angezeigt und auf der Karte "lokalisiert" werden. Die Datei kann als Liste oder tabellarisch angezeigt werden. In der Statuszeile wird die aktuelle Position in der Datei und die absolute Anzahl aller Einträge angezeigt.

Menüfunktionen

Bearbeiten
 | Bearbeiten öffnet ein Fenster zum Bearbeiten der Attribute. Attribute bearbeiten
Navigation
Anfang | Anfang positioniert an den Anfang der Datei.
Zurueck | Zurück positioniert auf das vorhergehende Objekt in der Datei.
Vor | Vor positioniert auf das nächste Objekt in der Datei.
Ende | Ende positioniert auf das letzte Objekt in der Datei.
Suchen | Suchen öffnet einen Dialog zum Suchen nach Objekten (Datensätzen) anhand von anzugebenden Bedingungen. Damit ist in großen Dateien das schnelle Auffinden von Objekten möglich. Datensatz suchen
Ansicht
Liste | Liste zeigt alle Attribute (Felder) des aktuellen Objektes in Listenform untereinander an. Zur Eingabe von Attributen ist dieser Modus i.d.R. der Tabelle vorzuziehen.
Tabelle | Tabelle zeigt die Daten in Tabellenform an.
 | Spalten anpassen passt die Breite der sichtbaren Spalten an den aktuellen Inhalt an.
Karte
 | Einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Kartenelements.
 | Geo-Objekt einpassen (F11 oder Strg+Eingabetaste) bewirkt, dass das in der Tabelle markierte Objekt auf der Karte eingepasst wird.
 | Geo-Objekt hervorheben (F12 oder Eingabetaste) bewirkt, dass das in der Tabelle markierte Objekt auf der Karte blinkend hervorgehoben wird.
 | Vorheriger Kartenausschnitt (F9) bewirkt die Anzeige des Kartenausschnittes, der vor der letzen Zoom- oder Verschiebeaktion angezeigt wurde (Zurückblättern).
 | Nächster Kartenausschnitt (Strg+F9) bewirkt die Anzeige des nächsten Kartenausschnittes nach dem "Zurückblättern".


Attribute editieren - Karten-Explorer

Attribute bearbeiten

Bildschirm zeigen

Mit dem Menüpunkt "Layer - Attribute - Bearbeiten" des Karten-Explorers können Attribut-Dateien von Shape-Dateien und sonstige dBase-Dateien bearbeitet werden. Die Datei kann als Liste oder tabellarisch angezeigt werden.

Spalten können hinzugefügt, berechnet oder mit geografischen Eigenschaften gefüllt werden. Das Umrechnen von Koordinaten und das Ermitteln von Koordinaten (Georeferenzieren) ist ebenfalls möglich.

Menüfunktionen

Bearbeiten
Struktur ändern | Struktur ändern erlaubt es, den Aufbau der Attribute-Datei einer Shape-Datei zu modifizieren. Struktur der Attribute-Datei ändern
Attribute berechnen/ersetzen | Berechnen/Ersetzen erlaubt es, Attribute (Spalten) mit Werten oder Berechnungen zu ersetzen. Attribute berechnen/ersetzen
Attribute mit geografischen Eigenschaften ersetzen | Geografische Berechnungen erlaubt es, Attribute (Spalten) mit geografischen Eigenschaften wie Länge, Fläche oder Koordinaten zu ersetzen. Attribute mit geografischen Eigenschaften ersetzen
 | Koordinaten umrechnen erlaubt es, Spalten mit Koordinaten hinsichtlich Koordinatensystem, Bezugssystem und Streifen umzurechnen. Koordinaten umrechnen
 | Datensatz anfügen (Einfg) fügt einen neuen Datensatz ans Ende der Tabelle an. Diese Funktion ist nur verfügbar, wenn eine dBase-Datei bearbeitet wird, die nicht Bestandteil einer Shape-Datei ist.
 | Datensatz löschen entfernt den markierten Datensatz aus der Tabelle. Diese Funktion ist nur verfügbar, wenn eine dBase-Datei bearbeitet wird, die nicht Bestandteil einer Shape-Datei ist.
 | in Zwischenablage kopieren (Alt+C) erlaubt es, alle (bzw. im Mehrfachauswahlmodus die markierten) Datensätze in die Zwischenablage zu kopieren und auf Wunsch in Excel zu öffnen.
Georeferenzieren
 | "Geokodierung, manuell" (Strg+H) aktiviert die Programmfunktion [image] Geokodierung, die die Zuordnung von Koordinaten über die (manuelle) Angabe/Auswahl einer Adresse erlaubt.
 | "Geokodierung, automatisch" erlaubt die Georeferenzierung über Geokodierung ohne weiteren Benutzereingriff. Voraussetzungen dafür sind vollständige Adressangaben. Alle selektierten Datensätze werden in einem Programmlauf verarbeitet. Vorhandene Koordinaten können durch Aktivierung einer entsprechenden Option im angezeigten Dialogfenster überschrieben werden.
 | "Umgebungssuche" (Strg+U) erlaubt die Georeferenzierung über die Suche nach Adressen in der Umgebung einer Koordinate. Umgebungssuche
 | Georeferenzieren (Strg+G) ruft die Programmfunktion [image] Georeferenzieren auf, die die manuelle Georeferenzierung über einen Mausklick in Karten erlaubt oder die Überprüfung von Koordinaten durch ihre Darstellung auf Karten ermöglicht.
 | Koordinaten eingeben erlaubt es, die Koordinaten per Hand einzugeben. Koordinaten eingeben
 | aus Zwischenablage einfügen (Alt+V) versucht Koordinaten und/oder Adressen aus der Zwischenablage einzufügen. Wird dabei festgestellt, dass die Koordinaten in der Zwischenablage aus Google Maps stammen, werden sie korrekt in das verwendete Koordinatensystem umgewandelt.
 | Adresse in Zwischenablage kopieren kopiert vorhandene Adressangaben in der Form [Straße Nummer PLZ Ort] in die Zwischenablage, wo sie z.B. für die Suche nach Adressen in Google Maps (siehe unten) zur Verfügung stehen.
 | Shape-Datei erstellen (Strg+S) erzeugt eine Shape-Datei unter Verwendung der unter [image] Einstellungen Georeferenzierung angegebenen Koordinaten-Spalten. hier
 | Einstellungen (Strg+E) ruft eine Fenster auf, das die Zuordnung von Spalten zu Adressangeben erlaubt und den Typ der zu ermittelnden Koordinaten (GPS oder "Standardprojektion") festlegt. Einstellungen Georeferenzierung
Navigation
Anfang | Anfang positioniert an den Anfang der Datei.
Zurueck | Zurück positioniert auf das vorhergehende Objekt in der Datei.
Vor | Vor positioniert auf das nächste Objekt in der Datei.
Ende | Ende positioniert auf das letzte Objekt in der Datei.
Suchen | Suchen (Strg+F) öffnet einen Dialog zum Suchen nach Objekten (Datensätzen) anhand von anzugebenden Bedingungen. Damit ist in großen Dateien das schnelle Auffinden von Objekten möglich. Datensatz suchen
Ansicht
Liste | Liste zeigt alle Attribute (Felder) des aktuellen Objektes in Listenform untereinander an. Zur Eingabe von Attributen ist dieser Modus i.d.R. der Tabelle vorzuziehen.
Tabelle | Tabelle zeigt die Daten in Tabellenform an.
 | Spalten anpassen passt die Breite der sichtbaren Spalten an den aktuellen Inhalt an.

Mehrfachauswahl

Mit der Schaltfläche [image] wird der Modus für die Mehrfachauswahl ein- bzw. ausgeschaltet. Der aktive Mehrfachauswahlmodus und die Anzahl der markierten Einträge werden in der Statuszeile angezeigt.

Der Modus zur Mehrfachauswahl hat Auswirkungen auf die Programmfunktionen:

  • Löschen

  • in Zwischenablage kopieren

  • automatisches Geokodieren mit der Schaltfläche

  • Berechnen/Ersetzen mit der Schaltfläche Attribute berechnen/ersetzen

  • Geografische Berechnungen mit der Schaltfläche Attribute mit geografischen Eigenschaften ersetzen

Bei aktiver Mehrfachauswahl können mit der Schaltfläche [image] bzw. der Tastenkombination Strg+A alle Einträge in der Tabelle markiert werden, die Schaltfläche [image] schaltet die Markierungen um.

Maus: Mit der Maustaste können mit Strg+Mausklick einzelne Zeilen markiert/demarkiert werden. Mit Umschalten-Mausklick können Bereiche markiert werden.

Tastatur: Mit der Tastatur kann z.B. ein zusammenhängender Bereich markiert (demarkiert) werden, wenn man bei gedrückter Umschalten-Taste die Tasten Pfeil hoch/tief bzw. Bild auf/ab betätigt. Mit gedrückter Strg-Taste kann unter Verwendung der Leertaste markiert werden. Dabei können (bei gedrückter Strg-Taste) die Richtungstasten Pfeil hoch/tief und Bild auf/ab zum Überspringen von Bereichen genutzt werden.

Hinweise zum Georeferenzieren

Die Programmfunktion vereint mehrere Möglichkeiten zur Ermittlung von Koordinaten (Geokodierung, manuelle Georeferenzierung durch Mausklick in Karten und Einfügen von Koordinaten aus der Zwischenablage). Ggf. können diese Möglichkeiten nacheinander genutzt werden, um einen größeren Datenbestand mit Koordinaten zu versehen. Sofern in der Tabelle Adressen vorhanden sind, kann man zunächst die automatische Geokodierung [image] verwenden. Häufig werden dabei nicht alle Adressen zugeordnet, weil die Adresse nicht exakt angegeben oder dem Web-Service unbekannt ist. Einträge mit nicht zuordenbaren Koordinaten können eventuell mit dem Menüpunkt Geokodierung manuell [image] per Hand ausgewählt werden. Sind Koordinaten vorhanden, kann nach Adressen in deren Umgebung mit [image] gesucht werden. Eine weitere Möglichkeit ist die Ermittlung von Koordinaten über die Georeferenzierung [image] auf einer Karte. Damit können auch bereits ermittelte Koordinaten überprüft und ggf. "verbessert" werden.
Letztendlich können Koordinaten aus anderen Anwendungen über die Zwischenablage eingefügt werden. Dies könnte ein separat gestarteter Karten-Explorer oder eine Browseranwendung wie Google Maps sein.

Tipp:
Häufig liegen zu georeferenzierende Daten in Excel vor. Mit dem Menüpunkt "Erstellen - aus Zwischenablage" des Karten-Explorers können diese leicht in dBase-Dateien umgewandelt werden. Erstellen aus Zwischenablage

Tipps zur Ermittlung von Koordinaten mit Google Maps

Um Koordinaten mit Google Maps zu ermitteln, ist es hilfreich, eine eventuell in den Attributen vorhandene Adresse an Google Maps weiter zu geben. Dies geschieht am einfachsten mit dem Menüpunkt "Georeferenzierung - Adresse in Zwischenablage einfügen". Diese Adresse kann mit Strg+V in das Suchfeld von Google Maps eingefügt werden. Wird die Adresse gefunden, kann die Position auf der Karte mit der rechten Maustaste angeklickt und der Menüpunkt "Was ist hier?" ausgewählt werden. Um die Koordinate in die Zwischenablage zu kopieren, klickt man dieselbe am besten im angezeigten Infofenster an. Daraufhin wird diese ins Suchfeld von Google Maps übernommen und kann leicht markiert und per Strg+C in die Zwischenablage kopiert werden. Aus der Zwischenablage können die Koordinaten mit Alt+V oder dem Menüpunkt "Georeferenzierung - aus Zwischenablage einfügen" in die vorgesehenen Spalten eingefügt werden.


Attribute ersetzen - Karten-Explorer

Attribute berechnen/ersetzen

Bildschirm zeigen

Mit dieser Programmfunktion können Attribute (Felder, Spalten) durch Werte oder Ausdrücke (Berechnungen) ersetzt werden. Dabei kann die Ersetzung für alle oder nur für bestimmte Datensätze (Bereich, Filter) durchgeführt werden. So können Aufgabenstellungen wie Berechne das Feld Anzahl aus Rind+Schwein+Schaf oder Ersetze das Feld Ergebnis mit 'Positiv' für die Filterbedingung Code=2

Feld wählen:
Zunächst ist das zu ersetzende Feld aus der Listenansicht auszuwählen.

Ersetzen mit:
Des weiteren ist der Wert bzw. Ausdruck , mit dem das Feld ersetzt werden soll anzugeben. Beachten Sie, das die Notation des Wertes bzw. Ausdrucks in Abhängigkeit des Feldtyps (Zeichen, Numerisch, Datum und Logisch) differiert. Wird eine Zeichenkette durch einen Wert ersetzt, ist dieser z.B. in Hochkommata einzuschließen. Des weiteren gibt es eine Vielzahl von Funktionen und Operatoren mit der Ausdrücke gebildet werden können, die in einem kleinen Crash-Kurs geordnet nach Feldtypen dargestellt sind:

  • numerische Felder z.B. 100
  • Zeichenfelder z.B. 'Meier'
  • Datumsfelder z.B. CtoD( '10.08.1965')
  • Logische Felder z.B. .t.

Bereich für Ersetzung festlegen

Es kann entschieden werden, ob

  • alle Datensätze

  • Datensätze die eine Markierung haben (Selektion)

  • der Rest der Datei ab dem aktuellen Datensatz

  • die nächsten ? Datensätze

  • oder alle Datensätze, die einem Filter genügen,

ersetzt werden sollen.

Filterbedingungen stellen einen logischen Ausdruck wie z.B. eine Vergleichsoperation dar.
Für ein numerisches Feld könnte dies z.B. sein Rind>0, für ein Zeichenfeld Name="Meier", für ein Datumsfeld Datum>=CtoD("01.01.2000") und für ein logisches Feld !Untersucht ("nicht untersucht"). Umfangreiche Hinweise zum Bilden von Filterausdrücken finden Sie [image] hier. Beachten Sie, dass Filterbedingungen letztendlich immer logische Werte (Wahr oder Falsch, bzw. .t. oder .f.) ergeben, während die im weiteren diskutieren Ersetzungsausdrücke, mit denen der Feldinhalt ersetzt wird, in Abhängigkeit vom Typ des selektierten Feldes einen numerischen, Zeichen-, Datums- oder logischen Ausdruck ergeben müssen .

Crash-Kurs "Notation von Ersetzungsausdrücken"

Numerische Felder

Numerische Felder enthalten ausschließlich Zahlen (ggf. Dezimalpunkt und Vorzeichen) wie z.B. 1000 oder 1234.45.

Außerdem kann man mit numerischen Felder selbstverständlich rechnen wie z.B. Rind+Schaf+Schwein. Hier gilt Punkt- vor Strichrechnung, Klammern sind erlaubt und die Division durch Null ist ungültig...

numerische Operatoren (Auszug)
+ | Addition
- | Subtraktion
* | Multiplikation
/ | Division
^ | Potenzieren (2^3=8 oder 4^0.5=2)
% | Moduls (ganzzahliger Rest einer Division, z.B. 17 % 10 = 7)
wichtige Funktionen
Min | Min( Zahl1, Zahl2 ) ® Zahl ... ermittelt das Minimum zweier Zahlen
Max | Max( Zahl1, Zahl2 ) ® Zahl ... ermittelt das Maximum zweier Zahlen
Val | Val( Text ) ® Zahl ... wandelt eine Zeichenkette in eine Zahl um
Sqrt | Sqrt( Zahl ) ® Zahl ... Quadratwurzel (auch mit Zahl^0.5 notierbar)
Log | Log( Zahl ) ® Zahl ... natürlicher Logarithmus
Exp | Log( Zahl ) ® Zahl ... Antilogarithmus
Recno | Recno() ® Zahl ... ermittelt die aktuelle Datensatznummer

ic_finger.gif (947 Byte) Experten-Tipp: Die Division durch Null ist bekanntlich nicht erlaubt. Wird bei der Abarbeitung des Ersetzens eine Division durch Null vorgenommen, bricht das Ersetzen an dieser Stelle ab.
Der Ausdruck Positiv/ Untersucht*100 liefert z.B. die Prävalenz und funktioniert so lange, bis ggf. ein Datensatz im Feld "Untersucht" eine Null enthält. Um diesen Fall abzufangen, kann der IIF-Operator verwendet werden, der nach dem Schema IIf( Bedingung, Ausdruck1, Ausdruck2 ) funktioniert und dann, wenn der logische Ausdruck Bedingung erfüllt ist, Ausdruck1, ansonsten Ausdruck2 zurück gibt.
Demnach wären Sie mit der Notation IIf( Untersucht>0, Positiv/ Untersucht*100, 0 ) auf der sicheren Seite.

Zeichenfelder

  • Werte sind in einfache oder doppelte Hochkommata einzuschließen, wie z.B. 'Meier' oder "Meier"

  • Um einen Leerwert (leere Zeichenkette) zu erzeugen, sind lediglich 2 Hochkommata z.B. ' ' oder " " anzugeben.

wichtige Funktionen
(Hinweis: grau dargestellte Parameter sind optional und können ggf. weggelassen werden)
Left | Left( Text, Anzahl ) ® Zeichen ... ermittelt den linken Teil einer Zeichenkette
Right | Right( Text, Anzahl ) ® Zeichen ... ermittelt den rechten Teil einer Zeichenkette
Substr | Substr( Text, Startposition, Anzahl ) ® Zeichen ... gibt die gewünschte Anzahl der Zeichen ab der Startposition zurück. Wird der optionale Parameter Anzahl nicht angegeben, werden alle Zeichen ab der Startposition zurück gegeben.
Str | Str( Zahl, Länge, Dezimal ) ® Zeichen ... wandelt eine Zahl in eine Zeichenkette um. Optional können Länge (inklusive Dezimalpunkt und Nachkommastellen) und / oder Anzahl der Nachkommastellen angegeben werden
At | At( Suchtext, Text ) ® Zahl ... ermittelt die Position des Auftretens von Suchtext im Text und gibt sie zurück (0, wenn nicht gefunden)
Upper | Upper( Text ) ® Zeichen ... wandelt Text in Großbuchstaben um
Lower | Lower( Text ) ® Zeichen ... wandelt Text in Kleinbuchstaben um
StrZero StrZero( Zahl, Länge, Dezimal ) ® Zeichen ... wandelt eine Zahl in eine Zeichenkette mit führenden Nullen um. Optional können Länge (inklusive Dezimalpunkt und Nachkommastellen) und / oder Anzahl der Nachkommastellen angegeben werden.
Tipp:
Die Funktionen StrZero() und Recno() können kombiniert werden, um aufgrund der Datensatznummer eindeutige Identifikationsschlüssel zu erzeugen. StrZero( Recno(), 5 ) würde ab dem ersten Datensatz 00001, 00002, 00003 usw. zurückgeben.
StrTran StrTran( Text, Suchtext, Ersetzungstext, Start, Anzahl ) ® Zeichen .. ersetzt Zeichen in einer Zeichenkette, indem im Text ein Suchtext mit dem Ersetzungstext ausgetauscht wird. Optional kann eine Startposition (ab Zeichen ?) und / oder die Anzahl der durchzuführenden Ersetzungen angegeben werden.
  • StrTran( Name, "ü", "ue" ) ersetzt im Feld Name die Zeichenfolge ue mit ü
  • StrTran( Name, "/", "" ) löscht im Feld Name das Zeichen / (ersetzt es mit Leerzeichen)
LTrim | LTrim( Text ) ® Zeichen ... entfernt führende Leerzeichen
Trim | Trim( Text ) ® Zeichen ... entfernt Leerzeichen am Ende
AllTrim | AllTrim( Text ) ® Zeichen ... entfernt führende Leerzeichen und Leerzeichen am Ende
Zeichenkettenoperatoren
+ fügt 2 Zeichenketten zusammen
- fügt 2 Zeichenketten zusammen und entfernt abschließende Leerzeichen in der ersten

Datumsfelder

  • Werte vom Typ Datum können mit der Funktion CtoD() generiert werden, wie z.B. CtoD( '31.08.2003' )

  • Tage können addiert und subtrahiert werden. Für 01.01.2003 - 1 ist das Ergebnis 31.12.2002 und 01.01.2003 + 31 ergibt sich 01.02.2003.

  • Die Differenz zwischen Kalenderdaten kann durch Subtraktion von 2 Datumswerten ermittelt werden.

wichtige Funktionen
Today | Today() ® Datum ... gibt das Tagesdatum zurück
CtoD | CtoD( Zeichenkette ) ® Datum ... wandelt eine Zeichenkette in ein Datum um
DtoC | DtoC( Datum ) ® Zeichen ... wandelt ein Datum in eine Zeichenkette um
Year | Year( Datum ) ® Zahl ... ermittelt die Jahreszahl aus einem Datum
Month | Month( Datum ) ® Zahl ... separiert die Nummer des Monats aus einem Datum
CMonth | CMonth( Datum ) ® Zeichen ... ermittelt den Monatsnamen aus einem Datum
Day | Day( Datum ) ® Zahl ... separiert den Tag aus einem Datum
CDoW | CDoW( Datum ) ® Zeichen ... ermittelt den Namen des Wochentags aus einem Datum
Min | Min( Datum1, Datum2 ) ® Datum ... ermittelt das Minimum zweier Datumswerte
Max | Max( Datum1, Datum2 ) ® Datum ... ermittelt das Maximum zweier Datumswerte
Datumsoperatoren
+ Datum + Zahl ® Datum ... addiert n Tage zu einem Datum
-
  • Datum - Zahl ® Datum ... subtrahiert n Tage von einem Datum
  • Datum1 - Datum2 ® Zahl ... ermittelt die Differenz aus 2 Datumswerten

Logische Felder

Logische Felder sind Datenbankfelder, die genau zwei Zustände annehmen können, nämlich die Wahrheitswerte "Wahr" oder "Falsch". Diese Werte werden durch .T. oder .F. (auch .t. oder .f.) definiert.


Filterbedingung Crash-Kurs für Expertenmodus

Crash-Kurs für die Syntax von Filterbedingungen

Filterbedingungen stellen logische Ausdrücke dar. In der Regel handelt es sich um Vergleichsoperationen nach dem Schema Feldname Operator Wert wie z.B. Rind > 0 für ein numerisches Feld oder Name = 'Meier' für ein Zeichenkettenfeld. Abhängig vom Typ des betreffenden Feldes (Zeichen, Numerisch, Logisch oder Datum) sind einige Besonderheiten bei der Notation der Bedingungen zu beachten. Des weiteren können mehrere Teilbedingungen angegeben werden, die dann durch logische Operatoren (.and. bzw. .or.) verknüpft werden wir z.B. Rind > 0 .or. Schwein > 0.

Der kleine Crash-Kurs in in folgende Abschnitte unterteilt:

  • Übersicht Vergleichsoperatoren
  • numerische Felder
  • Zeichenfelder
  • Datumsfelder
  • Logische Felder
  • Verknüpfungen - Logische Operatoren

Übersicht Vergleichsoperatoren

Vergleichsoperatoren sind das A und O bei der Definition von Bedingungen für Filterausdrücke. Die folgende Tabelle enthält eine Übersicht. Beachten Sie, dass die konkrete Anwendung eines Vergleichsoperators häufig vom Typ des jeweiligen Feldes abhängig ist.

Vergleichsoperatoren
< | kleiner
= | gleich
== | genau gleich (exakter Vergleichsoperator [image] Zeichenfelder)
> | größer
<= | kleiner (oder) gleich
<> | ungleich (alternativ können # oder != verwendet werden)
>= | größer (oder) gleich
$ | "Enthalten"-Operator für [image] Zeichenfelder

Numerische Felder

Numerische Felder enthalten ausschließlich Zahlen (ggf. Komma und Vorzeichen). Vergleiche folgen den Regeln der Mathematik, d. h., es werden immer alle Ziffern als Gesamtheit entsprechend ihres Zahlenwertes betrachtet und in Relation zu anderen Zahlen gesetzt wie 1,3 < 5 < 199 usw.

Beispiele:
Rind > 0 findet alle Einträge mit Rindern!
Rind <> 0 findet alle Einträge mit Rindern!
Schwein > 100 findet alle Einträge mit mehr als 100 Schweinen!
Schwein >= 100 findet alle Einträge mit 100 oder mehr Schweinen!

Außerdem kann man mit numerischen Felder selbstverständlich rechnen, was für Ihre Fälle durchaus von Bedeutung sein könnte. So kann man für den Filter "Klauentiere" notieren: Rind+Schaf+Ziege+Schwein+Gatterwild>0. Alternativ kann man aber auch mit Teilbedingungen und Verknüpfungen arbeiten wie Rind>0 .or. Schaf>0 .or. Ziege>0 .or. Schwein>0 .or. Gatterwild>0.

numerische Operatoren (Auszug)
+ | Addition
- | Subtraktion
* | Multiplikation
/ | Division
^ | Potenzieren
wichtige Funktionen
Min | Min( Zahl1, Zahl2 ) ® Zahl ... ermittelt das Minimum zweier Zahlen
Max | Max( Zahl1, Zahl2 ) ® Zahl ... ermittelt das Maximum zweier Zahlen
Val | Val( Text ) ® Zahl ... wandelt eine Zeichenkette in eine Zahl um

Zeichenfelder

  • Werte sind in einfache Hochkommata einzuschließen, wie z.B. Name = 'Meier' oder Name = "Meier"

  • Es wird zwischen dem Vergleichsoperator (=) und dem exakten Vergleichsoperator (==) unterschieden. Der Vergleichsoperator (=) vergleicht "zeichenweise". Der Vergleich wird spätestens beendet, wenn das Ende der rechten Zeichenkette erreicht ist. Damit liefert 'ABCDE' = 'ABC' logisch "Wahr". Wollen Sie jedoch ermitteln, ob ein Ausdruck auf der linken Seite exakt mit dem auf der rechten Seite übereinstimmt (Wert und Länge), verwenden Sie den exakten Vergleichsoperator (==), bei dem der Ausdruck 'ABCDE' == 'ABC' logisch "Falsch" und nur 'ABCDE' == 'ABCDE' logisch "Wahr" ergibt.

  • Groß-/Kleinschreibung ist für Werte signifikant! Das bedeutet 'A' ist nicht gleich 'a'. Wenn Sie Vergleiche unabhängig von Groß- und Kleinschreibung machen wollen, verwenden Sie die Funktionen Upper() oder Lower(), die den Text wahlweise in Groß- bzw. Kleinbuchstaben umwandeln wie Upper(Ort) = 'WUSTERHAUSEN'.

  • Um zu ermitteln, ob eine Zeichenkette leer ist, verwenden Sie z.B. den Ausdruck Name = " " (mit einem Leerzeichen zwischen den Anführungszeichen!). Alternativ kann auch Len( Trim( Name ) = 0 verwendet werden.

    Demzufolge ermittelt der Ausdruck Name != " " (mit einem Leerzeichen zwischen den Anführungszeichen!), ob das Feld Name nicht leer ist. Alternativ kann auch Len( Trim( Name ) > 0 verwendet werden.

  • Zeichenfelder können Buchstaben, Ziffern und Sonderzeichen enthalten. Die Vergleichsoperationen können angewendet werden, arbeiten jedoch nicht wie bei numerischen Feldern. Bei Zeichenketten werden Zeichen von links beginnend stellenweise verglichen. Ausschlaggebend dabei ist der Wert des Zeichens in der Zeichentabelle (so genannte ASCII-Tabelle).

    Es gilt:
    'A' < 'B', weil 'A' in der ASCII-Tabelle vor dem 'B' steht!
    '1' < 'C', weil Ziffern in der ASCII-Tabelle vor Buchstaben stehen!
    '139' < '9', weil stellenweise verglichen wird und '1' < '9' ist!

    Bespiele:
    Name > 'D' findet alle Einträge die mit 'E', 'F' .. 'Z' beginnen!
    Name < 'D' findet alle Einträge die mit '', 'A', 'B', 'C' beginnen!

  • Der $-Operator ermittelt, ob eine Zeichenkette in einer anderen enthalten ist. Dabei spielt die Position keine Rolle. So liefert "Stone" $ "Rolling Stones" logisch "Wahr".
    Beispiele:
    Name == 'Meier' - Name muss exakt Meier sein!
    Name = 'Meier' - Name muss mit Meier beginnen!
    'Meier' $ Name - Name muss (irgendwo) Meier enthalten!

wichtige Funktionen
Left | Left( Text, Anzahl ) ® Zeichen ... ermittelt den linken Teil einer Zeichenkette
Right | Right( Text, Anzahl ) ® Zeichen ... ermittelt den rechten Teil einer Zeichenkette
Substr | Substr( Text, Startposition, Anzahl ) ® Zeichen ... gibt die gewünschte Anzahl der Zeichen ab der Startposition zurück
Str | Str( Zahl ) oder Str( Zahl, Länge, Dezimal ) ® Zeichen ... wandelt eine Zahl in eine Zeichenkette um. Optional können Länge (inklusive Dezimalpunkt und Nachkommastellen) und Anzahl der Nachkommastellen angegeben werden
At | At( Suchtext, Text ) ® Zahl ... ermittelt die Position des Auftretens von Suchtext im Text und gibt sie zurück (0, wenn nicht gefunden)
Upper | Upper( Text ) ® Zeichen ... wandelt Text in Großbuchstaben um
Lower | Lower( Text ) ® Zeichen ... wandelt Text in Kleinbuchstaben um
Len | Len( Text ) ® Numerisch ... ermittelt die Länge einer Zeichenkette
LTrim | LTrim( Text ) ® Zeichen ... entfernt führende Leerzeichen
Trim | Trim( Text ) ® Zeichen ... entfernt Leerzeichen am Ende
AllTrim | AllTrim( Text ) ® Zeichen ... entfernt führende Leerzeichen und Leerzeichen am Ende
Zeichenkettenoperatoren
+ | fügt 2 Zeichenketten zusammen
- | fügt 2 Zeichenketten zusammen und entfernt abschließende Leerzeichen in der ersten

Datumsfelder

  • Werte vom Typ Datum, wie sie z.B. für Vergleichsoperationen benötigt werden, können mit der Funktion CtoD() generiert werden, wie z.B. CtoD( '31.08.2003' ).

  • Alle Vergleichsoperatoren wie =, ==, <>, #, !=, und Ordnungsoperatoren wie <, >, <=, >= können auf den Typ Datum angewendet werden, wie z.B. Datum < CtoD( '01.01.2003' ).

  • Um zu ermitteln, ob eine Datumsangabe leer ist, kann die Funktion Empty() oder die Notation CtoD("") verwendet werden.
    Demzufolge ist der Test auf ein leeres Datum über Empty( Datum ) oder Datum = CtoD("") möglich.

  • Tage können addiert und subtrahiert werden. Für 01.01.2003 - 1 ist das Ergebnis 31.12.2002 und 01.01.2003 + 31 ergibt sich 01.02.2003.

  • Die Differenz zwischen Kalenderdaten kann durch Subtraktion von 2 Datumswerten ermittelt werden.

wichtige Funktionen
Empty | Empty( Datum ) ® Logisch ... ermittelt, ob ein Datum leer ist
Today | Today() ® Datum ... gibt das Tagesdatum zurück
CtoD | CtoD( Zeichenkette ) ® Datum ... wandelt eine Zeichenkette in ein Datum um
DtoC | DtoC( Datum ) ® Zeichen ... wandelt ein Datum in eine Zeichenkette um
Year | Year( Datum ) ® Zahl ... ermittelt die Jahreszahl aus einem Datum
Month | Month( Datum ) ® Zahl ... separiert die Nummer des Monats aus einem Datum
Day | Day( Datum ) ® Zahl ... separiert den Tag aus einem Datum
Min | Min( Datum1, Datum2 ) ® Datum ... ermittelt das Minimum zweier Datumswerte
Max | Max( Datum1, Datum2 ) ® Datum ... ermittelt das Maximum zweier Datumswerte
Datumsoperatoren
+ Datum + Zahl ® Datum ... addiert n Tage zu einem Datum
-
  • Datum - Zahl ® Datum ... subtrahiert n Tage von einem Datum
  • Datum1 - Datum2 ® Zahl ... ermittelt die Differenz aus 2 Datumswerten

Logische Felder

Logische Felder sind Datenbankfelder, die genau zwei Zustände annehmen können nämlich die Wahrheitswerte "Wahr" oder "Falsch". Diese Werte werden durch .T. oder .F. (auch .t. oder .f.) definiert.

Um zu ermitteln, ob ein Feld "Wahr" oder "Falsch" ist, kann der Vergleichsoperator = oder != (auch # oder <>) verwendet werden wie z.B. Untersucht = .t. oder Untersucht = .f.
Es ist jedoch eine leichtere Notation möglich, indem man lediglich notiert Untersucht (gleich bedeutend mit Untersucht = .t.) oder !Untersucht (gleich bedeutend mit Untersucht = .f., das Ausrufungszeichen steht für die Negation).

Eng verwandt mit logischen Feldern sind logische Ausdrucke wie Vergleiche (z.B. Rind > 10) die ebenfalls einen Wahrheitswert .t. oder .f. für "wahr" oder "falsch" liefern.

Verknüpfungen - Logische Operatoren

Logische Operatoren kommen dann ins Spiel, wenn mehrere Teilbedingungen zu verknüpfen sind.

logische Operatoren
.and. | verknüpft Teilbedingungen mit einem logischen UND, so dass jede Teilbedingung erfüllt sein muss
.or. | verknüpft Teilbedingungen mit einem logischen ODER, so dass mindestens eine Teilbedingung erfüllt sein muss
.not. oder ! | negiert eine Bedingung

Feldname1 Operator1 Wert1 .or. Feldname2 Operator2 Wert2
Feldname1 Operator1 Wert1 .and. Feldname2 Operator2 Wert2

Beispiel | Wirkung
Rind > 0 .and. Schwein > 0 | Alle Tierhalter, die sowohl Rinder als auch Schweine besitzen, werden verarbeitet.
Rind > 0 .or. Schwein > 0 | Alle Tierhalter, die entweder Rinder oder Schweine (oder beides) besitzen, werden verarbeitet.
Rind > 0 .and. Schwein = 0 | Alle Tierhalter, die Rinder und keine Schweine besitzen, werden verarbeitet.

Nicht unerwähnt bleiben soll, dass bei der Formulierung mehrer Teilbedingungen ein Problem auftritt, das Sie aus der Mathematik kennen. Erinnern Sie sich: (3+5)*3 = 24 und 3+5*3=18. Wenn Sie komplizierte Bedingungen mit mehreren "And" und "Or" verwenden und sich nicht sicher sind, in welcher Reihenfolge sie abgearbeitet werden, dann setzen Sie sicherheitshalber Klammern ().


Attribute mit geografischen Eigenschaften ersetzen - Karten-Explorer

Attribute mit geografischen Eigenschaften ersetzen

Bildschirm zeigen

Diese Programmfunktion erlaubt es, beim Bearbeiten der Attribute einer Shape-Datei einzelne numerische Felder (Attribute) mit geografischen Eigenschaften bzw. Berechnungen zu ersetzen. So könnte man aus einem Flächen-Layer mit den Kreisen Deutschlands die Kreisfläche berechnen und in einem Feld 'Flaeche' speichern.

Die geografischen Eigenschaften werden dabei direkt aus den Geo-Objekten in der Shape-Datei ermittelt. Mit den Kombinationsfeldern ist auszuwählen, in welches Feld die jeweilige Eigenschaft (z.B. Fläche) gespeichert werden soll. Eventuell sind diese Felder durch Ändern der Struktur der Attribute-Datei zunächst zu erzeugen ( [image] Struktur der Attribute-Datei ändern).

Achtung: Die ermittelten Längen oder Flächen können in Abhängigkeit der Projektion der Karten mehr oder weniger stark von den realen Werten abweichen.

Abhängig davon, ob es sich um Punkte-, Linien- oder Flächen-Layer handelt, stehen folgende Optionen zur Verfügung:

Punkte-Layer:

  • X-Koordinate

  • Y-Koordinate

Linien-Layer:

  • Länge (wahlweise in Meter oder Kilometer)

Flächen-Layer:

  • Fläche (wahlweise in Quadratmeter oder Quadratkilometer)

  • Umfang (wahlweise in Meter oder Kilometer)

  • Zentroid (X-Koordinate, Y-Koordinate des Schwerpunktes des Polygons)

  • Anzahl je Fläche (je Quadratkilometer, Hektar oder Quadratmeter)
    Mit dieser Option kann der Inhalt eines Feldes in Bezug zur Fläche des Geo-Objektes gesetzt werden. Zu Beispiel kann der Wert des Feldes "Einwohner" einer Gemeinde in Bezug zur Gemeindefläche gesetzt und im Feld "Ew_Je_Qkm" (Einwohner je Quadratkilometer) gespeichert werden.


Datensatz suchen

Bildschirm zeigen

Mit der Suchfunktion kann eine Datenbanktabelle nach bestimmten Werten durchsucht werden.

Es ist das Feld für die Suche auszuwählen. Abhängig vom Typ des Feldes (Zeichen, Numerisch, Datum oder Logisch) stehen verschiedene Operatoren zur Auswahl, von denen die gewünschte Option zu wählen ist. Der Suchwert ist abhängig vom Feldtyp als Zeichen, Zahl oder Datum anzugeben bzw. auszuwählen.

Mit den Schaltflächen Anfang, Vorwärts, Rückwärts und Ende wird die Suche in der entsprechenden Richtung gestartet.

Schaltfläche | Suche
Anfang | vom Dateianfang beginnend vorwärts
Vorwärts | von aktueller Position beginnend vorwärts
Rückwärts | von aktueller Position beginnend rückwärts
Ende | vom Dateiende beginnend rückwärts

Operatoren

Vergleichsoperatoren
= | gleich Dieser Operator ist für alle Feldtypen definiert. Bei Zeichenketten ist zu beachten, dass diese von links nach rechts verglichen werden und die Länge der Zeichenketten nicht übereinstimmen muss. Es gilt 'Meier' = 'M' ist wahr!
== | genau gleich Dieser Operator ist nur für Zeichenketten definiert. Im Gegensatz zum "="-Operator muss die Länge der verglichenen Zeichenketten übereinstimmen. Es gilt 'Meier' = 'M' ist falsch, 'Meier' = 'Meier' ist wahr!
<> | ungleich
< | kleiner
> | größer
<= | kleiner (oder) gleich
>= | größer (oder) gleich
Spezialoperatoren
$ | Enthalten-Operator Dieser Operator ist nur für Zeichenketten definiert und vergleicht auf "Teilzeichenketten" in einem Zeichenfeld. Es gilt 'Rudolf Meier' $ 'Meier' ist wahr!

Zeichenfelder

Zeichenfelder können Buchstaben, Ziffern und Sonderzeichen enthalten. Die Vergleichsoperationen können angewendet werden, arbeiten jedoch nicht wie bei numerischen Feldern. Bei Zeichenketten werden Zeichen von links beginnend stellenweise verglichen. Ausschlaggebend dabei ist der Wert des Zeichens in der Zeichentabelle (so genannte ASCII-Tabelle).

Es gilt:
'A' < 'B', weil 'A' in der ASCII-Tabelle vor dem 'B' steht!
'1' < 'C', weil Ziffern in der ASCII-Tabelle vor Buchstaben stehen!
'139' < '9', weil stellenweise verglichen wird und '1' < '9' ist!

Bespiele:
Name > 'D' findet alle Einträge die mit 'E' .. 'Z' beginnen!
Name < 'D' findet alle Einträge die mit '', 'A', 'B', 'C' beginnen!


Attribute editieren (Einstellungen Georeferenzierung) - Karten-Explorer

Attribute bearbeiten - Einstellungen Georeferenzierung

Bildschirm zeigen

Beim Georeferenzieren von Attribut-Dateien / dBase-Dateien werden Adressen und Koordinaten aus bestimmten Spalten ermittelt bzw. Koordinaten in Spalten geschrieben. Um hier auf die "richtigen" Spalten zuzugreifen, versucht das Programm aus der Dateistruktur automatisch passende Spalten zu ermitteln.

Außerdem kann festgelegt werden, ob die gewählten Spalten (X und Y) Koordinaten im GPS-System (dezimale geografische Koordinaten) oder projizierte Koordinaten (z.B. UTM) entsprechend der aktuell eingestellten Projektion enthalten.

Beim Aufruf einer entsprechenden Programmfunktion wie "Georeferenzieren, automatisch" wird überprüft, ob alle notwendigen Zuordnungen getroffen sind und das Fenster für die Einstellungen bei Bedarf aufgerufen. Spaltenzuordnungen für Adressen sind nur nötig, wenn die Georeferenzierung über [image] Geokodierung automatisch erfolgen soll oder die Adresse in die Zwischenablage kopiert werden soll.

Folgende automatische Zuordnungen werden automatisch vorgenommen:

Spalte | automatisch erkannte Namen
X-Koordinate | X, X_WERT, X_ERZEUGT, RECHTSWERT, LONG, LONGITUDE
Y-Koordinate | Y, Y_WERT, Y_ERZEUGT, HOCHWERT, LAT, LATITUDE
Postleitzahl | PLZ, S_PLZ, A_PLZ, B_PLZ
Ort | ORT, S_ORT, A_ORT, B_ORT
Ortsteil | ORTSTEIL, S_ORTSTEIL, A_ORTSTEIL, B_ORTSTEIL
Straße | STRASSE, S_STRASSE, A_STRASSE, B_STRASSE
Hausnummer | HAUS, HAUSNUMMER, NUMMER, NR, HNR, S_HNR, A_HNR, B_HNR
  • Die erforderliche Qualität legt fest, wann ein Treffer bei der Geokodierung als genau akzeptiert wird:
    • A: innerhalb Gebäude (Gebäude existiert sicher)
    • B: innerhalb Flurstück (Gebäude existiert sicher)
    • R: innerhalb Flurstück (Gebäude ist nicht sicher vorhanden)
  • bei automatischer Geokodierung vorhandene Koordinaten überschreiben legt fest, ob Koordinaten nur dann in die gewählten Spalten eingetragen werden sollen, wenn diese leer sind. Bei deaktiviertem Kontrollkästchen werden Datensätze mit vorhandenen Koordinaten bei der automatischen Geokodierung ignoriert.
  • bei automatischer Geokodierung PLZ präferieren, legt fest, ob bei vorhandener Angabe für PLZ und Ort die Suche nur mit PLZ, Straße und Hausnummer erfolgen soll. Dies erhöht erfahrungsgemäß die Trefferquote und senkt die Suchzeiten, da Ortsnamen häufig abweichende Schreibweisen aufweisen.
  • bei Geokodierung Adressangaben überschreiben legt fest, ob eine gefundenen Adresse genutzt werden darf, um abweichende oder fehlende Adressbestandteile in den ausgewählten Spalten für die Adresse zu ergänzen.

Selbst wenn alle notwendigen Zuordnungen automatisch getroffen werden konnten, wird das Fenster mit den Einstellungen einmalig zur Kontrolle angezeigt, wenn eine Programmfunktion aus dem Menü "Georeferenzieren" aufgerufen wurde.


Attribute editieren Shape-Datei erstellen

Attribute bearbeiten - Shape-Datei erstellen

Bildschirm zeigen

Mit dieser Programmfunktion kann beim Bearbeiten der Attribute aus der dBase-Tabelle eine Shape-Datei erstellt werden. Dazu werden die Koordinaten aus den Spalten "X" und "Y", die bei den [image] Einstellungen Georeferenzierung angegeben wurden, verwendet.
Grundsätzlich sind zwei Modi unterschieden, das Erstellen aus dem Original (der dBase-Tabelle, die gerade bearbeitet wird) und das Erstellen aus einer Kopie:

  • aus Original erstellen

    • Das Erstellen aus dem Original ist nur möglich, wenn alle(!) Einträge der dBase-Tabelle Koordinaten haben. ( [image] Screenshots)

    • Wird eine dBase-Tabelle bearbeitet, die noch keine korrespondierende Shape-Datei hat, ist das Anfügen und Löschen von Datensätzen möglich. Sobald die Shape-Datei aus dem Original erstellt worden ist, ist diese Funktionalität gesperrt.

    • Die Shape-Datei erhält automatisch den Dateinamen der dBase-Tabelle.

  • aus Kopie erstellen

    • Das Erstellen aus der Kopie der in Bearbeitung befindlichen Tabelle ist möglich, sobald ein Eintrag Koordinaten hat.

    • Es wird eine Kopie aller Einträge mit Koordinaten angelegt und danach die Shape-Datei erstellt.

    • Der Dateiname kann vom Nutzer angegeben werden oder es kann ein temporärer Layer automatisch im Karten-Explorer erzeugt werden.


Attributestruktur ändern - Karten-Explorer

Struktur der Attribut-Datei ändern

Bildschirm zeigen

Mit dem Menüpunkt "Layer - Attribute - Struktur ändern" kann die Struktur (der Aufbau) einer Attribut-Datei einer Shape-Datei beliebig modifiziert werden. Damit können Felder (Spalten) gelöscht, hinzugefügt oder die Feldlänge geändert werden.

Struktur und Zeichensatz

Die Attribut-Datei einer Shape-Datei ist eine dBase-Datei (*.dbf), die jedem Geo-Objekt der Geometriedatei (*.shp) genau eine Zeile mit Attributen zuordnet. Die Struktur kann auf Wunsch beliebig angepasst werden.

Wichtig: Der Karten-Explorer unterstützt den "normalen" dBase-Standard mit den Feldtypen "Zeichen", "Numerisch", "Datum" und "Logisch" sowie die Zeichensätze "ANSI" und "OEM". Für die Feldnamen gelten strenge Regeln (10 Zeichen, nur Großbuchstaben ohne Umlaute, Ziffern und der Unterstrich sind erlaubt; Feldnamen sind maximal 10 Zeichen lang). Es ist möglich, alle vorhandenen Felder beliebig umzubenennen, ihren Typ zu ändern, sie zu löschen oder die Reihenfolge zu ändern, ohne Datenverlust zu erleiden (außer Felder werden explizit gelöscht).

In der ersten Spalte der Tabelle signalisiert die Spalte "Status" den Änderungszustand durch ein Symbol. Die Ziffern neben dem Symbol geben die Nummer des Feldes in der Ursprungsdatei an, sofern es sich nicht um ein neu hinzugefügtes Feld handelt.

unverändert = ein vorhandenen Feld wurde nicht geändert

geändert = vorhandenes Feld wurde verändert
gelöscht = ein vorhandenes Feld wurde zur Löschung markiert
neu = das Feld wurde zur Struktur hinzugefügt

Folgende Schaltflächen, Tasten- und Mausfunktionen können zur Manipulation der Struktur verwendet werden:

Ein neues Feld wird hinzugefügt und das Fenster "Feld bearbeiten" aufgerufen. (alternativ "Einfg")

Das markierte Feld wird bearbeitet. (alternativ "Enter" oder Doppelklick mit der Maus)
Das markierte Feld wird zur Löschung markiert. Ein neu hinzugefügtes Feld wird sofort aus der Tabelle entfernt. (alternativ "Entf")
Bei markierten Feld werden alle Änderungen rückgängig gemacht. (alternativ Strg + Z)
Markiertes Feld an den Anfang der Tabelle bewegen. (alternativ Strg + Pos1)
Markiertes Feld eine Position nach oben bewegen. (alternativ Strg + ↑)
Markiertes Feld eine Position nach unten bewegen. (alternativ Strg + ↓)
Markiertes Feld an das Ende der Tabelle bewegen. (alternativ Strg + Ende)
Alle vorhandenen Felder werden zur Löschung markiert, eventuell neu hinzugefügte Felder werden aus der Tabelle entfernt.
Die Struktur einer anderen dBase-Datei kann eingelesen und zur aktuellen Struktur hinzugefügt werden.

Mit der Statistik-Funktion wird für jedes Feld entsprechend des Feldtyps folgende Berechnung durchgeführt:

  • Zeichen: die tatsächlich durch Daten verwendete Länge (von - bis)

  • Numerisch: der tatsächlich verwendete Bereich (kleinste bis größte Zahl)
  • Datum: Spanne (kleinstes bis größtes Datum)
  • Logisch: Anzahl "Ja" und "Nein" wird gezählt

Die Statistik-Funktion sollte genutzt werden, um die Länge der Felder zu optimieren. Gerade Felder vom Typ "Zeichen" werden häufig sehr lang gewählt und führen zu unnötig große dBase-Dateien.

Voransicht

Die Voransicht gibt einen komfortablen Ausblick darauf, wie die Attributs-Datei aussehen würde, wenn die aktuellen Einstellungen für Struktur und Zeichensatz angewendet werden. Dazu wird eine größere Anzahl von Zeilen der realen dBase-Datei von der Festplatte in eine virtuelle Tabelle im Speicher eingelesen und entsprechend konvertiert.

Voransicht aktualisieren (alternativ Strg + A)
Spaltenbreite anpassen (Strg + S)

Eine Änderung des Zeichensatzes der Ursprungsdatei wird sofort auf die Voransicht angewendet, um dem Nutzer nach Möglichkeit sofort zu signalisieren, dass mit der gewählten Einstellung Umlaute korrekt verarbeitet werden. Eine Änderung der Struktur, also das Hinzufügen neuer oder Ändern/Löschen bestehender Felder wird nicht sofort auf die Voransicht angewendet, um bei größeren Modifikationen der Struktur nicht durch die Aktualisierung der Voransicht behindert zu werden. Dafür werden die geänderten Spalten in der Voransicht bis zur manuellen Aktualisierung mit der Schaltfläche [image] oder der Tastenkombination Strg + A farblich markiert:

Feld wurde zur Löschung markiert
Feldname und/oder Feldlänge wurde modifiziert
Der Feldtyp wurde geändert


Attribute exportieren - Karten-Explorer

Attribute exportieren

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Attribute exportieren" des Karten-Explorers können (wählbare) Attribute von Shape-Dateien exportiert werden. Die Dateien werden im dBase-Format ausgegeben, das z.B. von Microsoft Excel geöffnet werden kann.

Aktion läuft

Die zu Shape-Dateien gehörenden Attribut-Dateien sind dBase-Dateien, die auch mit Excel direkt geöffnet werden könnten. Bitte bearbeiten Sie jedoch niemals die Attribut-Datei einer Shape-Datei direkt, da dies zu Zerstörung der Shape-Datei führen kann.

  1. Layer auswählen
    Im Listenfeld 'Layer auswählen' werden alle Layer mit Vektordaten angezeigt, es ist der gewünschte Eintrag auszuwählen.

  2. Felder auswählen
    Im Bereich 'Felder auswählen' kann über die Optionsfelder ausgewählt werden, ob alle oder einzelne Felder exportiert werden sollen. Wurde die Option 'einzelne' gewählt, können die Felder über das zugehörige Kontrollkästchen selektiert werden. Die Schaltflächen [image] (alle markieren), [image] alle demarkieren) und [image] (Auswahl umkehren) unterstützen die schnelle Auswahl.

  3. Exportformat auswählen
    Im Bereich 'Exportformat auswählen' ist anzugeben, ob die Exportdatei mit TSN oder mit anderen Programmen wie Excel weiter verarbeitet werden soll.
    Hierbei wird die Konvertierung von deutschen Umlauten entsprechend dem ANSI- bzw. OEM-Standard vorgenommen. Wenn z.B. Betriebe exportiert werden, um sie mit dem Menüpunkt "Betriebe - Exportdatei verarbeiten" zu öffnen, ist der Modus 'TSN' zu wählen.

  4. Dateiname angeben
    Geben Sie mit der Schaltfläche [image] den Dateinamen für die Exportdatei an!

Mit der Schaltfläche Ok wird der Export der Daten gestartet!


Attribute in Zwischenablage exportieren - Karten-Explorer

Attribute in Zwischenablage exportieren

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Attribute in Zwischenablage exportieren" des Karten-Explorers können (wählbare) Attribute von Shape-Dateien in die Windows-Zwischenablage exportiert werden. Danach können die Daten in eine Vielzahl von Windows-Applikationen z.B. Microsoft Excel eingefügt werden.

  1. Layer auswählen
    Im Listenfeld 'Layer auswählen' werden alle Layer mit Vektordaten angezeigt, es ist der gewünschte Eintrag auszuwählen.

  2. Felder auswählen
    Im Bereich 'Felder auswählen' kann über die Optionsfelder ausgewählt werden, ob alle oder einzelne Felder exportiert werden sollen. Wurde die Option 'einzelne' gewählt, können die Felder über das zugehörige Kontrollkästchen selektiert werden. Die Schaltflächen [image] (alle markieren), [image] (alle demarkieren) und [image] (Auswahl umkehren) unterstützen die schnelle Auswahl.

    Ist die Option "Feldbeschreibung in Kopfzeile ausgeben" aktiviert, werden neben den Spaltennamen auch Feldtypen und -längen in die Kopfzeile geschrieben. Dies ist nützlich, wenn aus der Zwischenablage ein Karten-Layer oder eine dBase-Datei erzeugt werden soll. Erstellen aus Zwischenablage

Mit der Schaltfläche Ok wird der Export der Daten in die Zwischenablage gestartet! Ist die Das Kontrollkästchen [image] aktiviert, wird der Inhalt der Zwischenablage nach dem Export in Excel geöffnet.


Verknüpfen - Karten-Explorer

Verknüpfen

Die Programmfunktionen "Extras - Verknüpfen" generieren neue Shape-Dateien, indem

  1. die Attribute eines Layers über eine räumliche Beziehung mit den Attributen eines weiteren Layers verknüpft werden,

  2. die Attribute eines Layers über ein gemeinsames Schlüsselfeld mit den Attributen eines weiteren Layers oder einer dBase-Datei verknüpft werden,

  3. die Informationen einer dBase-Datei mit einem geladenen Punkte-Layer oder Flächen-Layer zu einem Punkte-Layer verknüpft werden,

  4. die Informationen einer dBase-Datei mit einem geladenen Flächen-Layer zu einem Multipoint-Layer verknüpft werden,

  5. die Informationen (numerische Attribute) von Punkte-Layern auf Polygone eines Flächen-Layers kumuliert werden,

  6. die Informationen (numerische Attribute) von Punkte-Layern auf Gridzellen eines automatisch erstellten Grid-Layers kumuliert werden.

Quelle | verknüpft mit | Art der Verknüpfung | Resultat
1. Menüpunkt: Join (über räumliche Beziehung)
Layer | Layer | räumliche Beziehung von Geo-Objekten | Layer mit Attributen aus Quelle und verknüpftem Layer
2. Menüpunkt: Join (über Schlüsselfeld)
Layer | Layer oder dBase-Datei | gemeinsames Schlüsselfeld | Layer mit Attributen aus Quelle und verknüpftem Layer
3. Menüpunkt: Koordinaten generieren
dBase-Datei | Flächen-Layer | gemeinsames Schlüsselfeld | Punkte-Layer mit zufällig erzeugten Koordinaten
dBase-Datei | Punkte-Layer | gemeinsames Schlüsselfeld | Punkte-Layer
4. Menüpunkt: Koordinaten generieren (Multipoint)
dBase-Datei | Flächen-Layer | gemeinsames Schlüsselfeld | Multipoint-Layer mit zufällig erzeugten Koordinaten
5.Menüpunkt: Punkt-Flächen-Verknüpfung generieren
Punkte-Layer | Flächen-Layer | Koordinate fällt in Polygon | Flächen-Layer mit kumulierten Attributen
6. Menüpunkt: Punkt-Grid-Verknüpfung generieren
Punkte-Layer | Flächen-Layer (generiertes Grid) | Koordinate fällt in Gridzelle | Flächen-Layer (Grid) mit kumulierten Attributen


räumlicher Join

Verknüpfen - Join (über räumliche Beziehung)

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Join (über räumliche Beziehung)" des Karten-Explorers ist es möglich, Attributen eines Layers Attribute eines weiteren Layers zuzuordnen. Für die Zuordnung wird eine räumliche Beziehung zwischen beiden Layern verwendet. Als Ergebnis entsteht ein neuer Layer.

Beispiel:
Es ist ein Layer mit den Gemeinden eines Bundeslandes vorhanden. Ein weiterer Layer enthält die Kreise des Bundeslandes. Die Attribut-Tabelle des "Gemeinde-Layers" soll um den Kreisnamen aus dem "Kreis-Layer" erweitert werden. Dabei wird die räumliche Beziehung, dass eine Gemeinde des "Gemeinde-Layers" vollständig in einem Kreis des "Kreis-Layers" enthalten ist, genutzt.

(1) Basis-Layer und zu übernehmende Attribute auswählen

An dieser Stelle ist der Layer mit der Schaltfläche [image] auszuwählen, dessen Geo-Objekte übernommen werden sollen. Des Weiteren kann für jedes Attribut des Layers festgelegt werden, ob es übernommen werden soll. Die Schaltflächen [image] (alle markieren), [image] alle demarkieren) und [image] (Auswahl umkehren) unterstützen die schnelle Auswahl.

(2) Layer für räumliche Verknüpfung und zu übernehmende Attribute auswählen

An dieser Stelle ist der Layer mit der Schaltfläche [image] zu selektieren, dessen wählbare Attribute mit dem Layer, der unter (1) selektiert wurde, verknüpft werden sollen.

(3) Modus für die Verknüpfung auswählen

  • Vollständig oder teilweise enthalten
    Geo-Objekte aus (1) werden Attribute eines Geo-Objektes aus (2) zugeordnet, in dem sie sich vollständig oder teilweise befinden. Sollte ein Geo-Objekt aus (1) in mehreren Geo-Objekten aus (2) enthalten sein, werden die Attribute des ersten gefundenen Geo-Objekts zugeordnet.

  • Vollständig enthalten
    Geo-Objekten aus (1) werden Attribute des Geo-Objektes aus (2) zugeordnet, in dem sie sich vollständig befinden. Fällt ein Geo-Objekt aus (1) in mehrere Geo-Objekte aus (2), erfolgt keine Zuordnung von Attributen.

Mit dem Kontrollkästchen "nicht zuordenbare Geo-Objekte ignorieren" kann gesteuert werden, ob Geo-Objekte aus (1), die keine räumlich korrespondierende Geo-Objekte in (2) haben, in den neuen Layer übernommen werden sollen.

Wie erfolgt die Verarbeitung?

In einem ersten Lauf wird ermittelt, welche Geo-Objekte aus (1) in (2) enthalten sind, dass heißt, welches Geo-Objekt in (1) räumlich mit welchem Geo-Objekt in (2) korrespondiert. In einem zweiten Lauf werden die Geo-Objekte aus (1) in einen neuen Layer kopiert und um die gewünschten Attribute aus (2) ergänzt.


Join über Schlüsselfeld - Karten-Explorer

Verknüpfen - Join (über Schlüsselfeld)

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Join (über Schlüsselfeld)" des Karten-Explorers ist es möglich, Attributen eines Layers Attribute eines weiteren Layers, einer dBase-Datei, CSV-Datei oder der Zwischenablage zuzuordnen. Für die Zuordnung wird ein gemeinsames Schlüsselfeld verwendet (Name muss nicht identisch sein, der Typ muss jedoch übereinstimmen!). Als Ergebnis entsteht ein neuer Layer.

Beispiel:
Es ist ein Layer mit den Gemeinden eines Bundeslandes vorhanden. Eine CSV-Datei enthält die Streckendaten pro Gemeinde (Gemeindeschlüssel und Strecke). Die Attribut-Tabelle des "Gemeinde-Layers" soll um das Attribut "Strecke" erweitert werden.

(1) Basis-Layer und zu übernehmende Attribute auswählen, Schlüsselfeld markieren

An dieser Stelle ist mit der Schaltfläche [image] der Layer auszuwählen, dessen Geo-Objekte übernommen werden sollen. Das gewünschte Schlüsselfeld ist zu selektieren (Schlüsselfelder müssen vom Typ "Zeichen" oder "Numerisch" sein!). Des Weiteren kann für jedes Attribut des Layers über das dazugehörige Kontrollkästchen festgelegt werden, ob es übernommen werden soll. Die Schaltflächen [image] (alle markieren), [image] alle demarkieren) und [image] (Auswahl umkehren) unterstützen die schnelle Auswahl.

(2) Quelle für Verknüpfung und zu übernehmende Attribute auswählen, Schlüsselfeld markieren

Zunächst ist über die Optionen Layer, dBase-Datei, Zwischenablage bzw. CSV-Datei die Datenquelle für die Verknüpfung festzulegen. Jetzt ist der Layer mit der Schaltfläche [image] bzw. die dBase-Datei / CSV-Datei mit der Schaltfläche [image] oder die Zwischenablage mit der Schaltfläche [image] auszuwählen. Danach ist das Schlüsselfeld für die Verknüpfung mit dem unter (1) gewählten Layer in der Liste der Attribute zu selektieren. Beachten Sie, dass der Typ der Schlüsselfelder in (1) und (2) identisch sein muss. Des Weiteren ist über die Kontrollkästchen festzulegen, welche Attribute in den neuen Layer übernommen werden sollen.

Hinweis: Bei Verknüpfung mit den Daten einer CSV-Datei oder einer Tabelle aus der Zwischenablage wird zunächst eine Programmfunktion zum Importieren dieser Daten aufgerufen [image] hier

Kumulieren numerischer Felder

Mit dem Kontrollkästchen "Numerische Felder bei Datensätzen mit gleichem Schlüsselausdruck kumulieren" werden für die gewählten numerische Felder aus (2) die Inhalte bei Datensätzen mit gleichem Schlüsselfeld addiert (z.B. alle Rinder bei gleichem Gemeindeschlüssel)

Beispiel:
Es ist ein Layer (1) mit Kreisen des Bundeslandes und eine dBase-Datei (2) mit den Gemeinden gewählt. Die dBase-Datei enthält ein Feld "Rind", welches die Anzahl der Rinder je Gemeinde enthält. Die Anzahl der Rinder soll nun mit jedem Kreis verknüpft werden. Im Layer (1) wird der Kreisschlüssel als Schlüsselfeld gewählt, in der dBase-Datei (2) werden die ersten fünf Stellen des Feldes für den Gemeindeschlüssel als Schlüsselfeld gewählt. Das Kontrollkästchen neben dem Feld "Rind" wird in der dBase-Datei (2) selektiert und die Option 'Numerische Felder bei Datensätzen mit gleichem Schlüsselausdruck kumulieren' aktiviert. Dann werden zunächst alle Einträge im Feld "Rind" auf Ebene des Schlüsselausdrucks (erste fünf Stellen des Gemeindeschlüssels, was dem Kreisschlüssel entspricht) zusammengezählt und dann mit den Kreisen aus Layer (1) verknüpft.
Wichtig: Die Länge der zu kumulierenden numerischen Felder muss groß genug sein, um die Summe aufnehmen zu können!

(3) Modus für die Verknüpfung auswählen

  • Schlüsselausdrücke müssen vollständig übereinstimmen
    Wenn die unter (1) und (2) gewählten Schlüsselausdrücke identisch sind, ist dieser Modus zu wählen. Es wird ermittelt, ob der Wert aus (1) mit dem Wert aus (2) übereinstimmt, wobei bei Schlüsselfeldern vom Typ "Zeichen" die Feldlänge des kürzeren Feldes für den Vergleich relevant ist:
    "12345" = "12345" → Feld1: 5 Stellen, Feld2: 5 Stellen
    "12345" = "12345678" → Feld1: 5 Stellen, Feld2: 8 Stellen
    "12345678" = "12345" → Feld1: 8 Stellen, Feld2: 5 Stellen
    Bei gleicher Feldlänge muss jedoch der gesamte Schlüsselausdruck übereinstimmen (inklusive eventueller Leerzeichen):
    "12345 " ≠ "12345678" → Feld1: 8 Stellen, Feld2: 8 Stellen

  • Übereinstimmung von Teilen des Schlüsselausdrucks
    Diese Option ist nur für Schlüsselfelder vom Typ "Zeichen" verfügbar. Falls nur Bereiche der unter (1) und (2) gewählten Schlüsselfelder für den Vergleich relevant sind, kann für jedes Schlüsselfeld festgelegt werden, von welchem Zeichen bis zu welchem Zeichen der Vergleich geführt werden soll. Erfolgt keine Angabe, wird das gesamte Feld verarbeitet.

Mit dem Kontrollkästchen "Geo-Objekte aus (1) ohne zuordenbaren Schlüssel aus (2) ignorieren" kann gesteuert werden, ob Geo-Objekte aus (1), die keine über einen Schlüssel korrespondierende Attribute in (2) haben, in den neuen Layer übernommen werden sollen.

Mit dem Kontrollkästchen "Fehlerprotokoll aller Datensätze aus (2), die nicht mit (1) verknüpft wurden, erstellen" wird eine dBase-Datei mit allen aus (2) nicht zugeordneten Datensätzen erstellt. Dies sind Datensätze, die in (1) nicht gefunden wurden oder in (2) mehrfach mit gleichem Schlüsselausdruck auftraten.
Hinweis: Werden in (2) mehrere Datensätze mit gleichem Schlüsselausdruck gefunden, wird nur der erste Datensatz mit (1) verknüpft. Überprüfen Sie dann, ob Sie ggf. vergessen haben die Option Kumulieren numerischer Felder zu aktivieren!

Wie erfolgt die Verarbeitung?

In einem ersten Lauf wird ermittelt, welche Geo-Objekte aus (1) über den Schlüsselausdruck welchen Attributen aus (2) zugeordnet sind. In einem zweiten Lauf werden die Geo-Objekte aus (1) in einen neuen Layer kopiert und um die gewünschten Attribute aus (2) ergänzt.


Koordinaten verknüpfen - Karten-Explorer

Verknüpfen - Koordinaten generieren

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Koordinaten generieren" des Karten-Explorers ist es möglich, aus Tabellen (dBase-Datei, CSV-Datei oder Zwischenablage) Shape-Dateien vom Typ Punkt zu generieren. Dazu werden die Geo-Objekte eines geladenen Layers über ein gemeinsames Schlüsselfeld genutzt, um die Koordinaten zu erzeugen. Ist der gewählte Layer vom Typ 'Punkt', werden die Koordinaten bei gleichem Schlüsselfeld direkt übernommen, ist der Layer vom Typ 'Polygon', wird ein Zufallspunkt innerhalb des Polygons mit übereinstimmendem Schlüsselfeld erzeugt.

Beispiel:
Es ist eine Tabelle mit geschossenen Füchsen vorhanden, bei denen lediglich die Gemeindenummer und die Strecke bekannt ist. Über Verknüpfung mit einem "Gemeinde-Layer" kann jedem Fuchs eine zufällige Koordinate innerhalb der Gemeinde zugeordnet werden.

Datenquelle und Schlüsselfeld auswählen

Zunächst ist über die Optionen dBase-Datei, Zwischenablage bzw. CSV-Datei die Datenquelle für die Verknüpfung festzulegen. Jetzt ist die dBase-Datei / CSV-Datei mit der Schaltfläche [image] oder die Zwischenablage mit der Schaltfläche [image] auszuwählen. Danach ist das Schlüsselfeld für die Verknüpfung mit dem gewählten Layer in der Liste der Attribute zu selektieren.

Hinweis: Bei Verknüpfung mit den Daten einer CSV-Datei oder einer Tabelle aus der Zwischenablage wird zunächst eine Programmfunktion zum Importieren dieser Daten aufgerufen [image] hier

Layer und Schlüsselfeld auswählen

An dieser Stelle ist ein geladener Layer mit der Schaltfläche [image] auszuwählen. Dieser muss vom Typ 'Polygon' oder 'Punkt' sein. Des weiteren ist das Schlüsselfeld auszuwählen, über das die Verknüpfung zur oben beschriebenen Quelle erfolgt.

Wie erfolgt die Verarbeitung?

Die Datenquelle wird kopiert und um die Spalten X_Erzeugt und Y_Erzeugt erweitert. Danach wird diese Datei sequentiell verarbeitet. Für jeden Wert im gewählten Schlüsselfeld wird im Layer nach einem identischen Wert gesucht. Wird er gefunden, dann werden die Koordinaten (bei Punkt-Layer direkt, bei Polygon-Layer die erzeugten Zufallskoordinaten) in X_Erzeugt und Y_Erzeugt übernommen. Danach werden die Geometrie-Datei *.shp und die Index-Datei *.shx erzeugt, die zusammen mit der dBase-Datei *.dbf die Shape-Datei bilden. Diese wird als neuer Layer geladen.


Koordinaten verknüpfen - Multipoint

Verknüpfen - Koordinaten generieren (Multipoint)

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Koordinaten generieren (Multipoint)" des Karten-Explorers ist es möglich, aus aus Tabellen (dBase-Datei, CSV-Datei oder Zwischenablage) Shape-Dateien vom Typ Multipoint zu generieren. Dazu werden die Geo-Objekte eines geladenen Polygon-Layers über ein gemeinsames Schlüsselfeld genutzt, um die Koordinaten zu erzeugen. Bei gleichem Schlüsselfeld in dBase-Datei und Polygon-Layer werden Zufallspunkte innerhalb des zugehörigen Polygons erzeugt.

Beispiel:
Eine dBase-Tabelle enthält die Gemeindenummer und die Anzahl der Rinder. Über Verknüpfung mit einem "Gemeinde-Layer" kann für jedes Polygon eine entsprechende Anzahl zufälliger Koordinaten innerhalb der Gemeinde erzeugt und als Multipoint-Layer abgespeichert werden.

Datenquelle und Schlüsselfeld auswählen

Zunächst ist über die Optionen dBase-Datei, Zwischenablage bzw. CSV-Datei die Datenquelle für die Verknüpfung festzulegen. Jetzt ist die dBase-Datei / CSV-Datei mit der Schaltfläche [image] oder die Zwischenablage mit der Schaltfläche [image] auszuwählen. Danach ist das Schlüsselfeld für die Verknüpfung mit dem gewählten Layer in der Liste der Attribute zu selektieren.

Außerdem ist ein numerisches Feld auszuwählen, das die Anzahl der zu erzeugenden Punkte enthält.

Hinweis: Bei Verknüpfung mit den Daten einer CSV-Datei oder einer Tabelle aus der Zwischenablage wird zunächst eine Programmfunktion zum Importieren dieser Daten aufgerufen [image] hier

Layer und Schlüsselfeld auswählen

An dieser Stelle ist ein geladener Layer mit der Schaltfläche [image] auszuwählen. Dieser muss vom Typ 'Polygon'. Des weiteren ist das Schlüsselfeld auszuwählen, über das die Verknüpfung zur oben beschriebenen Quelle erfolgt.

Fehlerprotokoll

Bei Aktivierung des Kontrollkästchens Fehlerprotokoll wird eine dBase-Tabelle erstellt, die alle Datensätze enthält, für die kein korrespondierendes Schlüsselfeld im Layer gefunden wurde.


Fläche verknüpfen - Karten-Explorer

Verknüpfen - Punkt-Flächen-Verknüpfung

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Punkt-Flächen-Verknüpfung generieren" des Karten-Explorers ist es möglich, die numerischen Attribute eines Punkte-Layers auf der Basis der Polygone eines wählbaren Flächen-Layers zu kumulieren.

Beispiel:
Es ist ein Layer mit den Rinderhaltern eines Kreises vorhanden, der über das numerische Attribut "Rinder" verfügt. Um zu ermitteln, wie viele Rinder je Gemeinde resultieren und eine Karte entsprechend einzufärben, wird der Punkte-Layer mit den Rindern mit einem "Gemeinde-Layer" verknüpft.

Flächen-Layer auswählen

An dieser Stelle ist mit der Schaltfläche [image] der Flächen-Layer auszuwählen, auf Basis dessen Polygone die numerischen Attribute kumuliert werden sollen.

Punkte-Layer und zu kumulierende Felder auswählen

An dieser Stelle ist mit der Schaltfläche [image] ein geladener Punkte-Layer auszuwählen. Daraufhin werden alle numerischen Attribute des Punkte-Layers zur Auswahl angeboten. Es ist festzulegen, welche Attribute entsprechend der Polygone des gewählten Flächen-Layers kumuliert werden sollen.

Zusätzliche Optionen für Verarbeitung auswählen

Mit dem Kombinationsfeld Modus wird festgelegt, wie die Werte des Punkte-Layers kumuliert werden sollen:

  • Summieren
    Für die gewählten numerischen Felder des Punkte-Layers werden die Werte je korrespondierender Fläche addiert (z.B. alle Rinder pro Gemeinde)

  • Zählen
    Für die gewählten numerischen Felder des Punkte-Layers werden die Werte je korrespondierender Fläche gezählt, die einen Wert größer Null enthalten (z.B. alle Rinderhalter pro Gemeinde)

  • Summieren und Zählen
    Dieser Modus summiert die gewählten numerischen Felder je Fläche und zählt gleichzeitig die Anzahl von Datensätzen mit einem Wert größer Null für diese Felder. Dabei wird das gewählte Feld (z.B. SCHWEIN) fürs Summieren verwendet und ein korrespondierendes Feld zum Zählen automatisch hinzugefügt (in diesem Falle A_SCHWEIN)

Mit dem Kontrollkästchen "Ergebnisse auf einen Quadratkilometer normieren" wird festgelegt, ob die Ergebnisse in Bezug zur Flächengröße gesetzt werden sollen.

Wie erfolgt die Verarbeitung?

Der Flächen-Layer wird kopiert. Seine Attribut-Tabelle wird um die gewählten numerischen Attribute des Punkte-Layers erweitert. Daraufhin wird der Punkte-Layer sequentiell verarbeitet, indem für jeden Punkt ermittelt wird, in welches Polygon des Flächen-Layers er fällt, um die zu kumulierenden Attribute des Punktes beim Flächen-Layer zu addieren und/oder zu zählen.


Grid verknüpfen - Karten-Explorer

Verknüpfen - Punkt-Grid-Verknüpfung

Bildschirm zeigen

Mit dem Menüpunkt "Extras - Verknüpfen - Punkt-Grid-Verknüpfung generieren" des Karten-Explorers ist es möglich, einen Grid-Layer wählbarer Kantenlänge zu erzeugen und die numerischen Attribute eines beliebigen Punkte-Layers anhand der Zellen des Grids zu kumulieren.

Gridweite

Die Kantenlänge einer (quadratischen) Gridzelle ist zu wählen. Neben der Eingabe der Zahlen können die horizontalen (+/- 1000 Meter) oder vertikalen (+/- 100 Meter) Drehfelder genutzt werden.

Einpassen

Es ist festzulegen, für welche Fläche das Grid zu erzeugen ist:

  • Aktueller Kartenausschnitt erzeugt Gridzellen im momentan sichtbaren Bildschirmbereich.

  • Volle Kartengröße verwendet die gesamte Ausdehnung aller geladenen Karten.

  • Geladener Layer erlaubt die Auswahl eines in der Layer-Kontrolle geladenen Layers mit der Schaltfläche [image], dessen Ausdehnung für die Generierung von Gridzellen verwendet wird.

an Raster ausrichten

  • Ist dieses Kontrollkästchen aktiviert, dann wird ein Referenzpunkt für den Ursprung des Grids und die Zählung der IDs verwendet. Dieser wird durch die linke, untere Koordinate der verwendeten Rasterkarten bestimmt (GK3, U32 oder U33).

    • Grids (gleicher Kantenlänge) passen aneinander (z.B. separat erstellte Grids benachbarter Kreise).

    • Die IDs (bei gleicher Kantenlänge) sind deutschlandweit homogen.

Punkte-Layer und zu kumulierende Felder auswählen

An dieser Stelle ist mit der Schaltfläche [image] ein geladener Punkte-Layer auszuwählen. Daraufhin werden alle numerischen Attribute des Punkte-Layers zur Auswahl angeboten. Es ist festzulegen, welche Attribute entsprechend der Gridzellen des zu erzeugenden Grid-Layers kumuliert werden sollen.

Zusätzliche Optionen für Verarbeitung auswählen

Mit dem Kombinationsfeld Modus wird festgelegt, wie die Werte des Punkte-Layers kumuliert werden sollen:

  • Summieren
    Für die gewählten numerischen Felder des Punkte-Layers werden die Werte je korrespondierender Gridzelle addiert

  • Zählen
    Für die gewählten numerischen Felder des Punkte-Layers werden die Werte je korrespondierender Gridzelle gezählt, die einen Wert größer Null enthalten

  • Summieren und Zählen
    Dieser Modus summiert die gewählten numerischen Felder je Gridzelle und zählt gleichzeitig die Anzahl von Datensätzen mit einem Wert größer Null für diese Felder. Dabei wird das gewählte Feld (z.B. SCHWEIN) fürs Summieren verwendet und ein korrespondierendes Feld zum Zählen automatisch hinzugefügt (in diesem Falle A_SCHWEIN)

Mit dem Kontrollkästchen "Ergebnisse auf einen Quadratkilometer normieren" wird festgelegt, ob die Ergebnisse in Bezug zur Flächengröße der Gridzelle gesetzt werden sollen.

Wie erfolgt die Verarbeitung?

Der Grid-Layer wird erzeugt. Seine Attribut-Tabelle enthält die gewählten numerische Attribute des Punkte-Layers. Daraufhin wird der Punkte-Layer sequentiell verarbeitet, indem für jeden Punkt ermittelt wird, in welche Gridzelle des Grid-Layers er fällt, um die zu kumulierenden Attribute des Punktes in der Gridzelle zu addieren.


Karten-Explorer

Geometrische Operationen

Achtung: Die Nutzung der Funktionalitäten "Geometrische Operationen" erfordert die Installation des OCX MapObjects 2.x der Firma ESRI auf dem betreffenden PC. Diese Komponenten werden ggf. aus lizenzrechtlichen Gründen standardmäßig nicht mit der Software ausgeliefert.

Puffer

Mit dem Menüpunkt "Extras - Geometrische Operationen - Puffer" können Puffer um Punkte, Linien und Polygone gebildet werden.

Geo-Objekt(e) | Puffer

Geometrische Operationen - Puffer

Zusammenfassen (Union)

Mit dem Menüpunkt "Extras - Geometrische Operationen - Zusammenfassen" können mehrere Geo-Objekte (Linien bzw. Polygone) zu einem Geo-Objekt zusammen gefasst werden.

Geo-Objekte | Union

überlappende Objekte zusammenfassen (Dissolve)

Mit dem Menüpunkt "Extras - Geometrische Operationen - überlappende Objekte zusammenfassen" können mehrere, sich überlappende Geo-Objekte (Linien bzw. Polygone) zu einem Geo-Objekt zusammen gefasst werden. Dabei entstehen ggf. mehrere Objekte, die mit Attributen versehen, gesucht und identifiziert werden können. Im folgenden Beispiel entstehen aus ursprünglich zehn Geo-Objekten drei zusammengefasste Geo-Objekte. Die oben vorgestellte Programmfunktion Zusammenfassen (UNION) hätte alle Geo-Objekte zu einem zusammengefasst.

Geo-Objekte | Union

Ausschneiden

Mit dem Menüpunkt "Extras - Geometrische Operationen - Ausschneiden" können Geo-Objekte eines Layers (Linien oder Polygone) anhand eines anderen Layers (z.B. ein Rechteck, ein oder mehrere Gemeinden usw.) ausgeschnitten werden. Geo-Objekte, die vom "Such-Layer" geschnitten werden, werden dabei geteilt.

Geo-Objekte | Ausschnitt


Puffer - Geometrische Operationen - Karten-Explorer

Geometrische Operationen - Puffer

Bildschirm anzeigen

Achtung: Die Nutzung der Funktionalitäten "Geometrische Operationen" erfordert die Installation des OCX MapObjects 2.x der Firma ESRI auf dem betreffenden PC. Diese Komponenten werden ggf. aus lizenzrechtlichen Gründen standardmäßig nicht mit der Software ausgeliefert.

Der Menüpunkt "Extras - Geometrische Operationen - Puffer" können Puffer um Punkte, Linien und Polygone gebildet werden.

1. Layer auswählen

Puffer können um alle Layer mit Vektordaten gebildet werden. Im Falle von Punkten entstehen Kreise, bei Linien und Polygonen entstehen Polygone.

2. Puffergröße festlegen

Die Puffergröße gibt an, wie weit die Außenlinie der Pufferzone vom Geo-Objekt entfernt sein soll. Für Polygone kann ein negativer Wert angegeben werden. In diesem Fall wird "nach innen gepuffert".

3. Optionen festlegen

Attributwerte übernehmen erlaubt es, die Attribute der Geo-Objekte des "Ausgangs-Layers" für die Geo-Objekte (Pufferzonen) des "Resultat-Layers" zu übernehmen.

Modus für Polygone erlaubt es, bei "Ausgangs-Layern" vom Typ 'Polygon' das Ausgabeergebnis zusätzlich zu manipulieren. Die folgende Tabelle demonstriert, wie für Polygone die Optionen Puffergröße (positiver oder negativer Wert) und der Modus (nur Puffer oder Puffer +/- Ausgangspolygon) kombiniert werden können.

Ausgangspolygon |  |
Puffergröße | Modus für Polygone | Ergebnis
Positiver Wert | nur Puffer |
Negativer Wert | nur Puffer |
Positiver Wert | Ausgangspolygon +/-Puffer |
Negativer Wert | Ausgangspolygon +/-Puffer |


Karten-Explorer - Puffer erstellen

Puffer erstellen

Mit dem Menüpunkt "Extras - Punkte puffern" des Karten-Explorers wird ein neuer Layer vom Typ Polygon erstellt, der Pufferzonen um Punkte (also Kreise) enthält. Grundlage dafür ist ein auszuwählender Layer vom Typ Punkt (Bestände, Betriebe, Seuchenobjekte etc.), um den Kreise mit einem wählbaren Radius gezogen werden.


Flächenanalyse

Flächenanteile, Längenanteile

Bildschirm zeigen

Der Menüpunkt "Extras - Analyse" des Karten-Explorers erlaubt die Analyse von Flächen- und Längenanteilen wie Waldfläche je Gemeinde oder Flusslänge je Gemeinde.

Achtung: Die Nutzung der Funktionalitäten "Geometrische Operationen" erfordert die Installation des OCX MapObjects 2.x der Firma ESRI auf dem betreffenden PC. Diese Komponenten werden ggf. aus lizenzrechtlichen Gründen standardmäßig nicht mit der Software ausgeliefert.

Flächenanteile: Ein Polygon-Layer (1) mit Grenzen wie z.B. Gemeinden oder Untersuchungsgebiete wird "über" einen Polygon-Layer (2) mit flächenmäßig zu analysierenden Geo-Objekten gelegt. Aus Layer (2) wird ein Attribut gewählt, das flächenmäßig zu analysierende Merkmale wie Acker, Wald, Wiese, Ortschaft usw. beschreibt. Es kann festgelegt werden, für welche konkreten Werte des Attributes (z.B. Acker, Wald) eine Analyse vorgenommen werden soll.

Längenanteile: Ein Polygon-Layer (1) mit Grenzen wie z.B. Gemeinden oder Untersuchungsgebiete wird "über" einen Linien-Layer (2) mit längenmäßig zu analysierenden Geo-Objekten gelegt. Aus Layer (2) wird ein Attribut gewählt, das längenmäßig zu analysierende Merkmale wie Autobahn, Bundesstraße, Landstraße usw. beschreibt. Es kann festgelegt werden, für welche konkreten Werte des Attributes (z.B. Bundesstraße, Landstraße) eine Analyse vorgenommen werden soll.

Vorgehensweise am Beispiel einer Analyse von Flächenanteilen Bildschirm zeigen

1. Schritt: "Grenz-Layer auswählen"

Es ist der Polygon-Layer auszuwählen, der die Grenzen wie Gemeinden oder Untersuchungsgebiete enthält.

2. Schritt: Layer mit 'Flächen-Objekten' auswählen

Es ist der Polygon-Layer auszuwählen, der die Flächen-Objekte wie Wald, Landwirtschaft und Gewässer enthält.

3. Schritt: Attribut auswählen

Es wird aus der Attribut-Tabelle des unter (2) gewählten Layers ein Attribut (ein Feld, eine Spalte) ausgewählt, das Werte enthält, die die Art des Objektes beschreiben. Im Beispiel des Screenshots ist es das Attribut 'Objektart', das beschreibt, ob es sich bei dem jeweiligen Geo-Objekt um 'Wald', 'Landwirtschaft', 'Stillgewässer' usw. handelt.

Wird das Kontrollkästchen "Keine Analyse für einzelne Werte vornehmen" aktiviert, werden alle Polygone aus (2) verarbeitet! Der 4. Schritt entfällt dann!

4. Schritt: zu analysierende Werte auswählen

Nun sind aus der Liste der verfügbaren Werte des gewählten Attributes die Werte auszuwählen, die tatsächlich analysiert werden sollen (Flächenanteil berechnen). Des weiteren ist für jeden Wert anzugeben, in welchem Feld das Ergebnis (Flächenanteil) zu speichern ist. Im Beispiel werden die Werte 'Wald', 'Landwirtschaft', 'Stillgewässer' analysiert und die Ergebnisse in den Feldern 'Wald', 'LW' und 'Gewaesser' gespeichert.

Um einen zu analysierenden Wert zur Liste hinzuzufügen, gehen Sie wie folgt vor:

  1. Hinzufügen Eintrag: Betätigen der Schaltfläche neue Einträge hinzufügen

  2. zu analysierenden Wert festlegen: Der Wert kann direkt eingegeben werden oder aus der Liste der verfügbaren Werte ausgewählt werden. Um die Liste (einmalig) zu initialisieren, d.h. die Attribut-Tabelle nach vorhandenen Werten des gewählten Attributs zu durchsuchen, ist die Schaltfläche Liste mit Werten aus Layer initialisieren zu betätigen.

  3. Feld für Ergebnis festlegen: Das System vergibt automatisch Namen für das Feld (FLAECHE001, FLAECHE002 usw.), in dem das Ergebnis der Flächenberechnung zum gewählten Wert eingetragen wird. Diese Felder sollten in aussagekräftige Bezeichnungen umbenannt werden wie z.B. 'WALD' oder 'LW'.
    Hinweis zu Feldnamen:

    • maximal 10 Stellen

    • erlaubt sind Buchstaben, Ziffern und Unterstrich, jedoch keine Umlaute, Sonder- und Leerzeichen

    • Feldname muss mit Buchstaben beginnen

5. Ausgabeoptionen festlegen

  • Es ist anzugeben, ob das Ergebnisfeld den Flächenanteil in km2, m2 oder als prozentualen Anteil an der Gesamtfläche des Objektes aus dem Grenz-Layer (Gemeinde, Untersuchungsgebiet usw.) enthalten soll.

  • Außerdem kann auf Wunsch zusätzlich die Gesamtfläche der Objekte des Grenz-Layers (Fläche der Gemeinde, des Untersuchungsgebietes usw.) im Feld 'GESAMT_FL' ausgegeben werden.

Beim Betätigen der Schaltfläche "Ok" startet die Berechnung - Das Ergebnis wird in einem gesonderten Fenster Bildschirm zeigen angezeigt und kann

  • als neuer Layer hinzugefügt

  • als Shape-Datei oder dBase-Datei gespeichert werden oder

  • in Excel angezeigt werden.


Georeferenzieren - Karten-Explorer

Georeferenzieren

Der Karten-Explorer bietet die Möglichkeit, beliebige Sachinformationen auf Basis von Punkten (geografischen Orten) zu georeferenzieren. Grundlage dieses Prozesses ist die so genannte Basisdatei. Die Basisdatei ist eine dBase-Tabelle, die eine vom Nutzer festzulegende Struktur (Spalten) hat und im Wesentlichen der Attribut-Tabelle einer Shape-Datei entspricht. Die Software fügt der Struktur automatisch eine Spalte "Hochwert" und "Rechtswert" hinzu, die für die Aufnahme der Koordinaten des Punktes (Geo-Objektes) dienen. Die Attribute können mit dem Karten-Explorer beliebig geändert werden, es können neue Zeilen (Geo-Objekte) hinzugefügt bzw. gelöscht werden. Zudem können über die Tastenkombination Strg+linke Maustaste in die Karte für den markierten Eintrag die Koordinaten festgelegt (und jederzeit geändert) werden. Die Werte werden dabei automatisch in den oben genannten Feldern "Rechtswert" und "Hochwert" abgelegt. Aus dieser Basisdatei kann zu jedem Zeitpunkt eine Shape-Datei erstellt werden, die vom Karten-Explorer oder externer Software wie ARC/INFO®, ArcView® etc. angezeigt bzw. räumlich ausgewertet werden kann.

Mit dem Menüpunkt "Extras - Georeferenzieren - Öffnen Basisdatei" wird eine vorhandene Basisdatei geöffnet. Es erscheint der "Georeferenzieren-Editor", der alle Attribute zum Editieren anbietet, das Hinzufügen und Löschen von Geo-Objekten sowie deren Georeferenzierung erlaubt.
Georeferenzieren-Editor

Der Menüpunkt "Extras - Georeferenzieren - Erstellen Basisdatei" erlaubt es, eine neue Basisdatei beliebiger Struktur zu erstellen. Die Basisdatei kann alternativ auf Basis von dBase-Dateien (Excel-Tabellen können im dBase-Format gespeichert werden) oder aus vorhandenen Shape-Dateien erstellt werden. Dabei werden die Daten übernommen (importiert) und können anschließend sofort georeferenziert werden. Erstellen Basisdatei

Der Menüpunkt "Extras - Georeferenzieren - Strukturänderung Basisdatei" gestattet es, den Aufbau einer Basisdatei nachträglich zu ändern. Es können Attribute (Spalten) hinzugefügt oder gelöscht sowie bei Bedarf die Spaltenbreite geändert werden. Dies ist ggf. erforderlich, wenn Basisdateien mit dem Menüpunkt "Erstellen Basisdatei" aus vorhandenen dBase- bzw. Shape-Dateien erstellt worden sind.
Strukturänderung Basisdatei

Der Menüpunkt "Extras - Georeferenzieren - Zusammenführen Basisdateien" dient dazu, mehrere Basisdateien zu einer zu vereinigen (Merge). Dadurch ist es leicht möglich, die Georeferenzierung von Sachverhalten auf mehrere Stellen (Verantwortungsbereiche) zu verteilen. Z.B. könnte man zunächst unter dem Menüpunkt "Erstellen Basisdatei" eine Datei mit der gewünschten Struktur erzeugen, an alle Kreisämter eines Regierungspräsidiums per Email verschicken, um dort die Sachverhalte (Betriebe, Tierfunde oder was auch immer) zu georeferenzieren, die Basisdateien an die Zentrale zurück zu schicken und dort eine gemeinsame Basisdatei und später eine Shape-Datei zu erzeugen.
 Zusammenführen Basisdateien

Der Menüpunkt "Extras - Georeferenzieren - Shape-Datei erzeugen" generiert aus einer Basisdatei eine Shape-Datei (3 Einzeldateien: *.shp, *.shx, *.dbf), die mit dem Karten-Explorer oder externer Software angezeigt bzw. verarbeitet werden kann. Dazu wird die Basisdatei dupliziert und dient als Merkmalsdatei (*.dbf) der Shape-Datei, die "Geografie-Datei" (*.shp) wird aus den Informationen der Felder "Rechtswert" und "Hochwert" erzeugt. Wurde die Basisdatei geändert, ist die Shape-Datei neu zu erzeugen, um den aktuellen Stand wiederzugeben.


Georeferenzieren-Editor - Karten-Explorer

Georeferenzieren - Editor

Bildschirm zeigen

Der Editor für das Georeferenzieren zeigt die Datensätze (im folgenden Objekte) einer "Basisdatei" an und erlaubt:

  • das Georeferenzieren von Objekten über Umschalten+linke Maustaste im Karten-Element,

  • das Ändern der Attribute zum Objekt,

  • das Hinzufügen und Löschen von Objekten.

Die Basisdatei kann als Liste oder tabellarisch angezeigt werden. In der Statuszeile wird die aktuelle Position in der Basisdatei und die absolute Anzahl aller Einträge angezeigt. Ist das Objekt an der aktuellen Position in der Basisdatei (aktueller Datensatz) georeferenziert, d.h., enthalten die Felder "Rechtswert" und "Hochwert" Koordinaten, wird in der Statuszeile das Symbol [image], ansonsten [image] bzw. in der ersten Spalte der Tabelle angezeigt.

Modus: Karte manuell aktualisieren (Standard)!
Beim Navigieren durch die Basisdatei wird die Markierung, die die Position des Objektes auf der Karte angibt, nicht automatisch aktualisiert, weil dies bei hinterlegten Rasterkarten zu erheblichen Verzögerungen beim Navigieren führen würde.
Um die Position anzuzeigen, ist die Funktionstaste F12 oder die Schaltfläche [image] zu betätigen. Des Weiteren besteht die Möglichkeit, das Symbol [image] in der ersten Spalte per Mausdoppelklick anzuklicken oder die Eingabetaste in der ersten Spalte zu betätigen, um die Anzeige des Punktes zu aktualisieren!

Karte automatisch aktualisieren!
Beim Navigieren in der Basisdatei wird die Karte automatisch aktualisiert.

Menüfunktionen

Datensatz
 | auf Karte zeigen bewirkt die Anzeige einer Markierung für die Position des in der Basisdatei markierten Objektes (aktueller Datensatz) im Karten-Element. Ist die Karte gezoomt, wird sie auf die Position der Markierung zentriert.
 | Neu fügt ein neues Objekt (einen neuen Datensatz) an die Basisdatei an. Danach können für dieses Objekt Attribute eingegeben und Koordinaten mit Umschalten+linke Maustaste festgelegt werden.
 | Löschen entfernt das markierte Objekt (den aktuellen Datensatz) aus der Basisdatei.
 | Berechnen/Ersetzen aktiviert eine Programmfunktion, mit der Attribute durch Werte oder berechnete Ausdrücke ersetzt werden können. Attribute berechnen/ersetzen
 | Schließen beendet den Editor und schließt die Basisdatei.
Navigation
 | Anfang positioniert an den Anfang der Basisdatei.
 | Zurück positioniert auf das vorhergehende Objekt in der Basisdatei.
 | Vor positioniert auf das nächste Objekt in der Basisdatei.
 | Ende positioniert auf das letzte Objekt in der Basisdatei.
 | Suchen öffnet einen Dialog zum Suchen nach Objekten (Datensätzen) anhand von anzugebenden Bedingungen. Damit ist in großen Basisdateien das schnelle Auffinden von Objekten möglich. Datensatz suchen
Ansicht
 | Liste zeigt alle Attribute (Felder) des aktuellen Objektes in Listenform untereinander an. Zur Eingabe von Attributen ist dieser Modus i.d.R. der Tabelle vorzuziehen.
 | Tabelle zeigt die Basisdatei in Tabellenform an.
Karte
 | manuell aktualisieren deaktiviert die automatische Anzeige einer Markierung auf der Karte für die Koordinaten des aktuellen Objektes in der Basisdatei. Soll die Markierung angezeigt werden, ist die Funktionstaste F12 oder die Schaltfläche [image] zu betätigen oder das Symbol [image] mit einem Mausdoppelklick zu versehen.
 | automatisch aktualisieren bewirkt die automatische Anzeige einer Markierung auf der Karte für die Koordinaten des aktuellen Objektes in der Basisdatei. Jede Bewegung in der Basisdatei führt zur Aktualisierung der Karte.


Erstellen Basisdatei - Karten-Explorer

Georeferenzieren - Erstellen Basisdatei

Bildschirm zeigen

Der Menüpunkt "Extras - Erstellen Basisdatei" des Karten-Explorers erlaubt es, eine neue Basisdatei beliebiger Struktur zu erstellen, sowie den Import von Daten aus dBase- und Shape-Dateien.

Die Basisdatei kann auf drei verschiedene Arten erstellt werden:

  • Struktur manuell festlegen

    Ist diese Option gewählt, kann eine beliebige Struktur eingegeben werden. Außerdem kann die Struktur einer bestehenden dBase-Datei über die Schaltfläche Struktur imp. eingelesen und anschließend modifiziert werden.

    Neues Feld: Um ein neues Feld einzufügen,

    • betätigen Sie die abgebildete Schaltfläche oder

    • machen Sie einen Mausdoppelklick in einen freien Bereich des Listenelementes oder

    • drücken Sie die Einfg.-Taste.

    Ändern Feld: Um das markierte Feld zu ändern,

    • betätigen Sie die abgebildete Schaltfläche oder

    • machen Sie einen Mausdoppelklick auf das gewünschte Listenelement oder

    • drücken Sie die Leertaste.

    Löschen Feld: Um das markierte Feld zu löschen,

    • betätigen Sie die abgebildete Schaltfläche oder

    • drücken Sie die Entf.-Taste.

    Die Reihenfolge der Felder kann per Drag&Drop geändert werden, d.h., ein Eintrag kann mit gedrückter linker Maustaste auf die gewünschte Position geschoben werden.

  • dBase-Datei importieren

    Ist diese Option gewählt, werden die Daten und die Struktur einer dBase-Datei übernommen. Da Microsoft Excel Daten im dBase-Format speichern kann, ist es auf diese Weise auch möglich, Daten aus Excel einzulesen.

  • Shape-Datei importieren

    Ist diese Option gewählt, werden die Daten einer Shape-Datei eingelesen. Dabei muss es sich um eine Shape-Datei vom Typ "Punkt" handeln. Es werden die Struktur, die Daten der Attribut-Datei und die Koordinaten aus der Shape-Datei eingelesen.

Um eine Basisdatei zu erzeugen, arbeiten Sie die 3 Schritte ab:

  1. Geben Sie den Namen der Basisdatei an!

  2. Legen Sie die Struktur der Basisdatei fest bzw. importieren Sie diese wie eingangs beschrieben!

  3. Erzeugen Sie die Basisdatei durch Betätigen der Schaltfläche Ok!


Karten-Explorer - Basisdateien zusammenführen

Georeferenzieren - Basisdateien verknüpfen

Bildschirm zeigen

Der Menüpunkt "Extras - Zusammenführen Basisdateien" des Karten-Explorers dient dazu, mehrere Basisdateien zu einer zu vereinigen.

Im Listview-Element "Basisdateien" sind alle Basisdateien aufgeführt, die zusammenzuführen sind. Über die Schaltfläche [image] neben diesem Listview-Element können Dateien hinzugefügt, mit der Schaltfläche [image] können Einträge entfernt werden. Die Struktur der markierten Datei wird zur Kontrolle im Listview-Element "Struktur" angezeigt. Werden Basisdateien mit unterschiedlicher Struktur zusammengeführt, enthält die Basisdatei die Summe aller vorhandener Felder aller Basisdateien (Vereinigung). Sollten gleichnamige Felder mehrerer Basisdateien nicht vom gleichen Feldtyp sein, werden inkompatible Daten beim Einlesen ignoriert (Bsp.: Hat ein Feld 'PLZ' in Basisdatei1 den Typ 'Zeichen' und in Basisatei2 den Typ 'numerisch', wird die zusammengeführte Basisdatei das Feld 'PLZ' als vom Typ 'Zeichen' verwenden und die Daten aus Basisdatei2 für das Feld 'PLZ' nicht einlesen).

Nach Auswahl der einzelnen Basisdateien und Angabe des Namens der zusammengeführten Basisdatei mit der Schaltfläche [image] ist der Vorgang mit der Schaltfläche Ok zu starten.

Das Verknüpfen von Basisdateien dient der dezentralen Georeferenzierung von Sachverhalten (Geo-Objekte an mehreren verantwortlichen Stellen erfassen), die anschließend zentral verarbeitet (kartografisch dargestellt) werden sollen. Gehen Sie dabei wie folgt vor:

  1. Erstellen der Basisdatei mit einer "zentral" vorgegebenen Struktur (Menüpunkt 'Erstellen Basisdatei') und Zustellung (Email) an die mit der Erfassung betrauten Stellen.

  2. Dezentrale Erfassung der Geo-Daten (Menüpunkt 'Öffnen Basisdateien' und Georeferenzierung mit dem Karten-Explorer).

  3. Rücksendung der Basisdateien an die Zentrale und Zusammenführung der Basisdateien mit dieser Funktion.

  4. Erzeugen der Shape-Datei zur Anzeige der Daten (Menüpunkt 'Shape-Datei' erzeugen).


Projektinformationen - Karten-Explorer

Projektinformationen

Bildschirm zeigen

Die Projektinformationen erlauben

  1. die Änderung von Titel und Anmerkungen

  2. Anzeige zahlreicher Informationen zum Projekt wie

    • Erstellungs- und Änderungsdatum

    • Karteneinheit, Einstellungen für [image] Rasterskalierung

    • Informationen zu geladenen [image] Layern

  3. die Aktivierung einer [image] Layer-Statistik zu jedem Layer per Mausdoppelklick auf den gewünschten Layer

  4. das Erstellen eines räumlichen Index oder einer [image] Layer-Vorlage per rechter Maustaste auf den gewünschten Layer

Titel und Anmerkungen ändern

Titel und Anmerkungen können bearbeitet werden. Bei Änderung dieser Eingabefelder wird die Schaltfläche "Ok" freigegeben, um diese Änderungen für das Projekt zu aktivieren. Neben der Anzeige bei den Projekteigenschaften, erscheinen diese beiden Angaben auch als Vorgabe beim Ausdruck der Karte mit Legende ( [image] Karte mit Legende drucken) für einen optionalen Titel und optionale Anmerkungen. Die kleine Markierung über dem Eingabefeld für Anmerkungen sollte ggf. als Hinweis für den rechten Rand beachtet werden, um bei diesen Ausdrucken der Anmerkungen ein optisch ansprechendes Ergebnis zu erreichen (Zeilenumbruch etwa an dieser Stelle mit der Eingabetaste erzwingen).

Erst beim Speichern des Projektes im Karten-Explorer werden diese Angaben (dauerhaft) mit den anderen Projekteinstellungen gesichert.

Angaben zu Layern

Das Listen-Element enthält folgende Angaben:

  • Name: Name des Layers in der Layer-Kontrolle

  • Typ: Typ des Layers (Punkt, Linie, Polygon, Bild)

  • Infofeld: Attribut, für das Quickinfos zum Geo-Objekt an der Mausposition angezeigt werden sollen

  • Objekte: Anzahl der Geo-Objekte

  • Index: Vorhandensein eines räumlichen Index für den Layer (*.sbn, *.sbx)

  • Vorlage: Vorhandensein einer Layer-Vorlage (*.kel)

  • Pfad: vollständiger Dateiname des Layers

Schaltflächen und Kontext-Menü

Das Kontextmenü des Listen-Elements "Layer" bzw. die korrespondierende Schaltfläche erlaubt folgende Operationen zum gewählten Layer:

  • oder Menüpunkt Layer-Statistik
    Die Programmfunktion [image] Layer-Statistik wir aufgerufen.

  • oder Menüpunkt Index erstellen
    Ein räumlicher Index wird erstellt, sofern die Bibliotheken von MapObjects Professional auf dem PC installiert sind.

  • oder Menüpunkt Layer-Vorlage speichern
    Wird diese Option gewählt, wird eine Layer-Vorlage (*.kel) entsprechend der aktuellen Einstellungen zum Layer (Name, Info-Feld, Einfärbung) erstellt.


Projekion verwalten - Karten-Explorer

Projektion verwalten

Bildschirm zeigen

Der Menüpunkt "Datei - Projektion verwalten" bietet folgende Möglichkeiten zur Manipulation der Projektion für so genannte Vektor-Layer (Punkte, Linien, Polygone, Multipoint):

  • Zuweisung einer Projektion zum dem gesamten Projekt,

  • Zuweisung einer Projektion zu einzelnen Layern,

  • Transformieren (Umrechnen der Koordinaten) einzelner Layer oder des gesamten Projektes.

Projektion des Projektes

Einem Projekt kann die Projektion ( [image] Koordinatensystem, Bezugssystem, Streifen) mit der Schaltfläche "Projektion des Projektes festlegen..." zugewiesen werden.
Vergessen Sie nicht, das Projekt im Hauptfenster des Karten-Explorers mit der Schaltfläche [image] zu speichern, um die Änderung der Eigenschaften der Projektion auch wirklich im Karten-Explorer-Projekt zu speichern.

Die Zuweisung der Projektion ist für eine Reihe von Funktionen des Karten-Explorers wichtig:

  1. Beim Exportieren des Projektes als Online-Projekt ( [image] Online-Projekt exportieren) wird die Projektion mit übergeben. Werden Online-Projekte unterschiedlicher Projektion gemischt (zu einem geöffneten Projekt hinzugeladen), werden die geladenen Layer automatisch korrekt projiziert.
    Damit ist es jetzt leichter möglich, dass Nachbarkreise Lagedarstellungen per Online-Projekt an eine zentrale Stelle übertragen und diese problemlos eine Gesamtlagedarstellung erstellen kann, auch wenn die Kreise z.B. mit unterschiedlichen Koordinatensystemen arbeiten.

  2. Beim [image] Exportieren als KML (für Google Earth etc.) ist die Kenntnis der Transformation des Projektes bzw. der Layer notwendig, um die erforderliche Transformation der Koordinaten in das weltweit gültige "GPS-System" fehlerfrei zu gewährleisten.

  3. Schließlich kann man einem Projekt jederzeit eine neue Wunschprojektion zuweisen und die Layer des Projektes (sofern erforderlich) mit einem Tastendruck der Schaltfläche "Layer mit Status 'Rot' wie Projekt transformieren" physisch projizieren.
    Voraussetzung zum Transformieren eines Projektes ist jedoch, dass auch jedem einzelnen Layer seine momentane Projektion korrekt zugewiesen ist. Beachten Sie dazu die folgenden Ausführungen.

Status der Projektion der Layer

Die Tabelle enthält die Layer des Projektes. Über kleine Symbole in der Spalte [image] wird der momentane Status der Projektion angezeigt:

Das gelbe Symbol bedeutet, dass dem Layer keine Projektion zugeordnet ist. Um dem Layer eine Projektion zuzuweisen, kann man diesen einzeln per Doppelklick anwählen und die Projektion zuweisen. Haben mehrere Layer den Status 'Gelb' (also noch keine explizit zugewiesene Projektion), kann man ihnen allen die beim Projekt hinterlegte Projektion zuweisen, indem man die Schaltfläche "Layer mit Status 'Gelb' wie Projekt setzen" betätigt. Alternativ kann eine Projektion auswählt und zugewiesen werden, indem man die Schaltfläche "Layer mit Status 'Gelb' wie Auswahl setzen..." benutzt.
Das grüne Symbol signalisiert, dass die beim Projekt festgelegte Projektion und die Projektion des Layers übereinstimmen.
Das rote Symbol signalisiert, dass die beim Projekt festgelegte Projektion und die Projektion des Layers nicht übereinstimmen. Mit der Schaltfläche "Layer mit Status 'Rot' wie Projekt transformieren" können alle Layer entsprechend der beim Projekt festgelegten Projektion transformiert werden. Beachten Sie, dass es nicht immer möglich ist, Layer zu transformieren, weil die Koordinaten außerhalb der für das Koordinatensystem bzw. für den zulässigen Streifen definierten Grenzen liegen. Beispiel
Kleine Symbole in der Spalte [image] signalisieren die Zulässigkeit der Umrechnung (und Rücktransformation). Hinweis: Bewegen Sie den Mauskursor auf das entsprechende Symbol [image] oder [image] , um die Genauigkeit einer Rücktransformation als Quickinfo anzuzeigen.
 | Die Transformation ist in beide Richtungen möglich (Transformation kann wieder ohne nennenswerte Abweichungen umgekehrt werden).
 | Die Transformation ist möglich, die Transformation kann jedoch nicht mehr umgekehrt werden. Falls der Layer wieder in der jetzigen Projektion benötigt werden sollte, wären er in der Regel nicht mehr brauchbar. In diesem Falle sollte eine Kopie des Layers für die Transformation verwendet bzw. der Original-Layer gesichert werden.
 | Die Transformation des Layers ist nicht möglich.

Kontextmenü

Per Doppelklick auf einen Layer in der Tabelle kann die Projektion (Info über Koordinatensystem, Bezugssystem und Streifen) für den Layer zugewiesen oder entfernt und der Layer transformiert werden.

  • Beachten Sie, dass die Zuweisung einer falschen Projektion und anschließende Transformation den Layer unbrauchbar machen kann.
  • Verwechseln Sie nicht das Zuweisen der Projektion mit dem Transformieren von Layern. Dem Layer wird immer seine momentane Projektion zugewiesen. Um die Projektion zu ändern (also die Koordinaten physisch umzurechnen), ist der Layer zu transformieren!


Karten-Explorer - Tipps und Tricks

Tipps & Tricks zum Karten-Explorer

Tastenfunktionen in Layer-Kontrolle

  1. Leertaste schaltet Sichtbarkeit des Layer ein/aus

  2. Eingabe (Enter) aktiviert das Einfärben

  3. Entfernen (Entf) löscht den Layer

  4. Einfügen (Einfg) fügt Layer hinzu

Mausfunktionen in Layer-Kontrolle

  1. einfacher Mausklick zum Umbenennen

  2. Doppelklick auf Layer-Namen zum Einfärben

neue Layer per Drag&Drop hinzufügen

  • Layer können hinzugefügt werden, wenn (eine oder mehrere) Shape-Dateien oder unterstützte Bilddateien per Drag&Drop aus einem anderen Fenster (z.B. Windows-Explorer) auf das Karten-Element des Karten-Explorers bewegt werden.

  • Karten-Projekte (*.kep) und Online-Projekte (*.kez) können ebenfalls durch Drag&Drop auf das Karten-Element geöffnet werden.

schnelles Zoomen und Verschieben

  • Benutzen Sie das Kontextmenü (rechte Maustaste)

  • Strg + Mausrad zentriert die Karte an aktueller Mausposition

  • Strg + linke Maustaste verschiebt die Karte

  • Benutzen Sie Favoriten

  • Plus (Zehnertastatur) vergrößert die Karte 2-fach

  • Minus (Zehnertastatur) verkleinert die Karte 2-fach

  • Strg + Mausrad drehen

    • nach oben drehen = Vergrößern

    • nach unten drehen = Verkleinern

  • Strg + Minus (Zehnertastatur) passt die gesamte Karte ein

  • Hat das Karten-Element den Eingabefokus (wenn nicht, dann einmal mit der Maus ins Karten-Element klicken) können die Richtungstasten , ¯, ¬, ® , Bild¯, Bild, Pos1, Ende zum Verschieben der Karte genutzt werden

  • Die Karte kann mit Mausrad nach oben, Mausrad¯ nach unten, mit Mausrad¬ nach links und mit Mausrad® nach rechts verschoben werden. Nach links bzw. rechts kann die Karte alternativ mit Umschalten + Mausrad bzw. Mausrad¯ verschoben werden.

Favoriten

  1. Definieren Sie Favoriten mit der Funktionstaste F7, die sich die aktuelle Position der Karte (die Umgebung eines Ortes oder ein Sperrgebiet) unter aussagekräftigen Namen "merken" und den Kartenausschnitt (unabhängig vom Projekt) schnell auf den betreffenden Bereich bewegen.

  2. Durch Betätigen von F8 oder Alt + Mausrad wird das Fenster mit den definierten Favoriten angezeigt.

Mausdoppelklick in Statusleiste

Verwenden Sie ggf. einen Mausdoppelklick auf Bereiche der Statusleiste für den Zugriff auf folgende Optionen:

  • im Bereich aktiver Layer à Info-Felder ändern
  • im Bereich Skalierbereich à Einstellungen Skalierbereich für Rasterkarten ändern
  • im Bereich Drucklayoutmodus à Drucklayoutmodus aktivieren und Drucker einrichten
  • im Bereich Projektion à die Projektion der Layer ändern

Einfärben von Karten

  1. Doppelklick auf Layer in Layer-Kontrolle oder Legende aktiviert Dialogfenster zum Einfärben.

  2. Deaktivieren Sie ggf. Rasterkarten (Sichtbarkeit ausschalten oder Rasterskalierung einschalten), wenn Sie an der Einfärbung von Layern "feilen", um bei einem häufigerem Neuaufbau der Karte das Neuzeichnen der Karten zu beschleunigen.

  3. Der Neuaufbau von Karten kann auch aus dem Dialogfenster zum Einfärben mit ESC abgebrochen werden.


kartografiespezifische Begriffe

buch.gif (3012 Byte)

Abbildung
mathematische Vorschrift; eindeutige Zuordnung aller Elemente einer Urbildmenge in eine Bildmenge.
hier auch: allgemein für Kartenprojektion

Abbildungsfläche
Eine in eine Ebene abwickelbare Fläche, worauf die Sphäroidoberfläche projiziert wird. Dies sind Zylinder, Kegel, Ebene.

Abplattung
Abweichung eines rotierenden Himmelskörpers von der Kugelgestalt infolge auftretender Zentrifugalkräfte. Die Abplattung bewirkt eine Verkürzung des in der Rotationsachse liegenden Radius (kleine Halbachse b) und einer Vergrößerung des dazu senkrechten Äquatorradius (große Halbachse a). Die Abplattung f ist definiert als das Verhältnis der Differenz aus großer und kleiner Achse zur großen Achse. f = (a-b)/a. Z.B. für das Besselellipsoid ist die Abplattung 1:299.15.

Abszisse
Wert auf einer Abszissenachse (Primärachse); versus Ordinate

Abszissenachse
primäre Achse eines kartesischen Koordinatensystems

Amtliches Topographisches-Kartographisches Informationssytem
kurz: ATKIS. Standardisierte Anleitung zur Beschreibung der
Landschaft in Form von Vektor- (DLM) oder Rasterdaten (DTK) in der
Bundesrepublik Deutschland.

Azimut
Winkel zwischen geographisch Norden und der zu bestimmenden Richtung.

Beschreibungsschema
Es beinhaltet die lexikalische Sprache und die graphische Notation zur formalen Beschreibung räumlicher Phänomene.

Bezugsfläche
räumliche Fläche zur Beschreibung der Erdoberfläche (Kugel, Ellipsoid, Geoid)

Bezugssystem
Bezugsfläche mit zugeordnetem Koordinatensystem.

Breitenkreis
Parameterlinie von geographischen Koordinaten auf einem Sphäroid mit konstanter geographischer Breite. Ein Breitenkreis bildet eine Ebene, die parallel zur Äquatorebene liegt.

Daten
aus Erhebungen, Messungen, Beobachtungen, Statistiken u.ä. gewonnene Informationen und Fakten.

Datenerfassung
Ermittlung, Erkennung und Zusammenführung von Daten und deren Eingabe in ein Informationssystem.

Datenqualität
Kriterium für die Verwendbarkeit von Daten für bestimmte Anwendungen ausgedrückt durch Merkmale wie Herkunft, Gebrauch und Qualitätsparameter.

Datenstruktur
Der innere Aufbau der erlaubten Werte und Ausprägungen der zu modellierenden Daten.

Datumstransformation
Koordinatentransformation von einem geodätischen Datum in ein anderes.

Deklination
Winkel zwischen magnetisch Nord und geographisch Nord. Die Deklination ist gleich magnetisch Nord minus geographisch Nord.

Digitales Landschaftsmodell
kurz: DLM. Standardisierte Beschreibung der Landschaft im Maßstab 1:3000 - 1:5000 in Form von Vektordaten im Rahmen des ATKIS- Projektes.

Digitale Topografische Karte
kurz: DTK. Aus den Vektordaten des Digitalen Landschaftsmodelles (DLM) des ATKIS-Projektes abgeleitete Rasterkarte in den Maßstäben 1:10'000, 1:25'000, 1:50'000, 1:100'000, 1:250'000, 1:500'000 und 1:1'000'000.

Digitales Geländemodell
kurz: DGM; auch digitales Höhenmodell (DHM). Regelmäßig oder unregelmäßig angeordnete Höheninformationen mit Lagebezug zur flächendeckenden Beschreibung des Reliefs. DGMs werden meist durch die Auswertung von Stereomodellen aus Luft- und Satellitenbildern erstellt.

Digitales Höhenmodell
kurz: DHM. Synonym für Geländemodell

Einzelvermessung
Erfassung von Detailformen der Erdoberfläche und der darauf befindenden Infrastruktur mit topographischen Vermessungen, Katastervermessungen und Ingenieurvermessungen.

Ellipse
Eine Ellipse ist ein Kegelschnitt in der Form eines affin verzerrter Kreis. Sie ist der geometrische Ort aller Punkte, für die die Summe der Abstände von zwei gegebenen festen Punkten, den Brennpunkten, konstant ist.

Ellipsoid
geometrischer Körper, der durch Rotation einer Ellipse um eine ihrer Achsen entsteht) (analytische Fläche zweiter Ordnung mit Symmetriepunkt). Die Ellipsoidoberfläche beschreibt ein geschlossenes Volumen.

Ellipsoidnormale
Gerade, die senkrecht zur Ellipsoidoberfläche steht.

ellipsoidische Koordinaten
Koordinaten, die einen Punkt bezüglich einer Ellipsoidoberfläche beschreiben; in der Geodäsie auf Rotationsellipsoid: geographische Länge, Breite und ellipsoidische Höhe h

Erdmessung
Bestimmung der Erdfigur einschließlich des äußeren Schwerefeldes.

Fernerkundung
"Feeling without touching"
"Fernerkundung ist eine Beobachtung eines Objektes mittels einer Vorrichtung, die von diesem durch eine gewisse Entfernung getrennt ist" [Barrett 76] In Verbindung mit GIS meist Satellitenfernerkundung gemeint. Photogrammetrie kann als Bestandteil der Fernerkundung betrachtet werden, obwohl die Photogrammetrie viel älter ist.

Fläche
1.) engl: area; zweidimensionale geometrische Primitive in der Vektordarstellung; Inhalt einer geschlossenen Linienfolge
2) engl: face; zwei-dimensionale strukturelle Primitive in der Vektordarstellung; Eigenschaft der geschlossenen Fläche; => Facetten

Flächentheorie
Teilbereich der Differentialgeometrie zur Untersuchung von Maßverhältnissen, Krümmungen und Kurven auf beliebigen Flächen.

Flächentreue
auch: Äquivalenz. In der Flächentheorie eine differentialgeometrische Eigenschaft einer Abbildung. Flächentreue liegt dann vor, wenn die Tissotsche Indikatrix dieselbe Fläche wie ihr Urbild hat, d.h. das Abbild eines Einheitskreises ist eine Ellipse mit demselben Flächeninhalt. Ein flächentreuer Kartennetzentwurf liegt dann vor, wenn die Tissotsche Indikatrix für jeden Punkt die geforderte Eigenschaft besitzt.

Gauß-Krüger-Koordinaten
Sie definieren ein Kartengitter / Koordinatengitter, basierend auf der konformen transversalen Mercator-Abbildung, (auch Gauß-Abbildung genannt), bezogen auf einen Meridianstreifen.

Generalisierung
Unterdrückung "unwesentlicher" Einzelheiten im Rahmen der Modellbildung. Oft versteht man darunter speziell eine kartographische Maßnahme die beim Übergang von größeren kleineren Maßstäben durch eine gezielte Verringerung des Informationsgehaltes die Lesbarkeit sicherstellt. [Bartelme 89]

Geodäsie
"Wissenschaft von der Ausmessung und Abbildung der Erdoberfläche" F.R. Helmert, 1880.

Geo-Daten
Geographische Daten; Daten, welche Phänomene des geographischen Raumes mit Geometrie und Sachdaten beschreiben.

geodätische Linie
kürzeste Verbindung zwischen zwei Punkten auf einer Fläche. (In der Ebene: Gerade; Auf der Kugel: Großkreis). Flächentheorie: Eine Linie auf einer räumlichen Flache, in der in jedem Punkt die Hauptnormale der Kurve zur Flächennormale parallel oder antiparallel ist. Ist dies der Fall, so ist die geodätische Krümmung Null.

geodätisches Datum
Parameter von Form, Lage und Größe einer Bezugsfläche in einem übergeordneten Bezugssystem. Form und Größe werden durch die Bezugsfläche festgelegt, die Lage durch eine räumliche Ähnlichkeitstransformation, bestehend aus 7 Parametern (3 für Translation, 3 für Orientierung, 1 für Maßstab)

geographische Breite
Vom Äquator zum Pol zählender Parameter (Winkel) auf einem Sphäroid. Die geographische Breite ist der Winkel, den die Sphäroidnormale in einen Punkt mit der Äquatorebene bildet. Der Äquator besitzt die Breite Null. Die nördliche Hemisphäre hat positive Breiten, der südlichen Hemisphäre sind negative Werte zugeordnet.

geographische Länge
Orthogonal zur geographischen Breite verlaufender Parameter (Winkel) auf einem Sphäroid. Der Winkel zwischen der Nullmeridianebene (i.d.R. durch Greenwich) und der Meridianebene eines Punktes.

geographische Koordinaten
Parameter (Winkel) zur Positionsbeschreibung auf einem Sphäroid. Es sind dies geographische Länge und Breite.

Geographischer Raum
Die Umwelt mit allen wahrnehmbaren Phänomenen unter, auf und über der Erdoberfläche.

Geographisches Informationssystem auch Geo-Informationssystem (GIS)
Ein rechnergestütztes System aus Hardware, Software, und Anwendungen, mit dem raumbezogene Daten digital erfasst und redigiert, gespeichert und reorganisiert, modelliert und analysiert sowie alphanumerisch und graphisch präsentiert werden können.

Geographisch Nord
Richtung entlang des Meridians zur Rotationsachse der Erde.

Geokodierung
Synonym für Georeferenzierung.

geometrische Auflösung
Unter Auflösung versteht man den Mindestabstand zweier verschiedener Größen, bei denen sie gerade noch unterschieden werden können. Die geometrische Auflösung wird in den Erfassungskriterien festgelegt. Daraus folgen die Mindestgrößen für Objekte, die geometrische Beschreibung von Objekten, wie z.B. Linie, Kreis, Spline, Klothoide sowie die Art der Stützpunktverteilung - Digitalisierung markanter Punkte oder äquidistante Punktverteilung - und der geometrische Generalisierungsgrad.

geometrische Genauigkeit
Maßangabe für die Lageabweichung der digitalen Objekte gegenüber der Realität. Sie ist ebenso wie die geometrische Auflösung Bestandteil der Datenqualität.

Geo-Objekt
Ein Geo-Objekt ist abhängig vom Typ des Layers ein Punkt, eine Linie oder eine Fläche.

Georeferenzierung
auch: Geokodierung;
Prozess der Herstellung des Raumbezuges. Zuordnung von Informationen zur Beschreibung von Form, Größe, Lage und Orientierung von räumlichen Objekten. Auf metrischer Seite erfordert dies die Festlegung und Zuordnung eines Bezugssystems durch das geodätische Datum und einem Kartennetzentwurf zur Abbildung in die Ebene. Zur Herstellung des Raumbezuges werden in vielen Fällen Transformationen notwendig.

Gitter
ist eine 2-dimensionale, rechtwinklig-regelmäßige Anordnung von Punkten. Jedem Punkt können mehrere Werte zugeordnet werden. Beispiele für die Anwendung eines Gitters sind Geländemodelle mit regelmäßig verteilten Höheninformationen.

GPS
Global Positioning System; satellitengestütztes Navigationssystem, das sich für die Positionsbestimmung auf der Erdoberfläche eignet

Gradmessung
Verfahren zur Bestimmung des Erdradius, genauer des Meridiankrümmungsradius, durch Messen einer Bogenlänge und des zugehörigen Zentriwinkels.

Greenwich
Sternwarte in Greenwich, durch welche der Nullmeridian festgelegt ist. Der Nullmeridian besitzt die geographische Länge Null.

Helmertsche Projektion
Projektion von Punkten entlang der Flächennormalen auf die Sphäroidoberfläche.

Hemisphäre
Ein Sphäroid wird durch den Äquator in zwei Hemisphären, die nördliche und die südliche geteilt.

Hochwert
Parameter der ebenen Gauß-Krüger-Koordinaten. Der Hochwert ist vom Äquator aus nach Norden positiv gezählte Abszissenwert entlang dem Hauptmeridian eines Meridianstreifens.

Höhe
Vertikaler Abstand eines Punktes von einer Höhenbezugsfläche (Geoid, Ellipsoid)

Information
allg: Mitteilung, Nachricht, Auskunft.
Informatik: formatierte Beschreibung von Sachverhalten, Ereignissen oder Abläufen.

Interpolation
Ermittlung einer Kurve oder Fläche, die durch vorgegebene Punkte oder Flächenkurven hindurchgeht und zusätzliche Nebenbedingungen (wie etwa einen möglichst glatten Verlauf) erfüllt. [Bartelme 89]

Kante
gerichtete eindimensionale strukturelle Primitive der Vektordarstellung

kartesische Koordinaten
Koordinaten in einem Koordinatensystem mit senkrecht aufeinanderstehenden Achsen

Karte
"maßstäblich verkleinerte, generalisierte und erläuterte Grundrissdarstellung von Erscheinungen und Sachverhalten der Erde, der anderen Weltkörper und des Weltraumes in einer Ebene" [IKV 73]
"Die Karte ist ein maßgebundenes und strukturiertes Modell räumlicher Bezüge. Die ist im weiteren Sinn ein digitales, graphikbezogenes Modell, im engeren Sinne ein graphisches (analoges) Modell" [Hake 88]

Karten-Projekt
Ein Karten-Projekt umfasst alle Informationen zu geladenen Layern, deren Einfärbung, Sichtbarkeit und Reihenfolge. Diese können in einer Datei (*.kep für "Karten-Explorer-Projekt") gespeichert und komplett wieder hergestellt werden.

Kartenabbildung
Synonym für Kartennetzentwurf

Kartengitter
Parameterlinien des in der Kartenprojektion definierten kartesischen Koordinatensystems. Eine Koordinatenachse ist i.d.R. parallel zum Hauptmeridian.

Kartennetz
Das Abbild der Parameterlinien geographischer Koordinaten (Meridiane und Breitenkreise) in der Kartenprojektionsebene.

Kartennetzentwurf
Ein Kartennetzentwurf (Kartenprojektion) bildet die Projektion der Erdoberfläche auf ein Sphäroid in eine Ebene ab. Es erfolgt dabei eine analytisch beschreibbare Transformation von geographischen Koordinaten in ebene Koordinaten. Diese Koordinatenumwandlung ist nicht verzerrungsfrei möglich.
Die Abbildung erfolgt vom Sphäroid auf eine verzerrungsfrei in eine Ebene abwickelbare Fläche (Zylinder, Kegel oder Horizontalebene). Die Lagerung der Abbildungsflächen erfolgt normal, transversal oder schiefachsig. Die globalen Verzerrungseigenschaften von Kartenprojektionen sind Äquidistanz (partielle Längentreue), Winkeltreue oder Flächentreue.

Kartenprojektion
siehe Kartennetzentwurf; auch Kartenabbildung

Kartographie
Wissenschaft und Technik der graphischen Darstellung raumbezogener Daten

Kegel
Eine Kegelfläche entsteht durch das Drehen einer Geraden durch eines festen Punkt entlang einer Leitlinie. Ein Kegel wird durch eine Kegelfläche mit geschlossener Leitkurve und einer Ebene begrenzt
Hier: Abbildungsfläche eines Sphäroids als gerader Kreiskegel mit Kreis als Grundfläche und Spitze senkrecht über dem Kreismittelpunkt. Ein gerader Kreiskegel ist verzerrungsfrei in eine Ebene abwickelbar.

Koordinaten
Größen (Parameter) zur Beschreibung der Lage von Punkten im n-dimensionalen Raum. Koordinaten werden in einem Koordinatensystem festgelegt.

Koordinatensystem
Festlegung von Koordinatenachsen und Maßeinheiten

Kugel
Die Kugel ist eine räumliche Fläche. Sie ist der geometrische Ort aller Punkte, welche von einem Punkt denselben Abstand haben.

Lage
Räumliche Information ohne Höhe

Layer
Ein Layer stellt eine geladene Karte (eine Shape-Datei, eine ARC/INFO-Datei oder eine Rasterkarte) dar. Eine Kartendarstellung kann aus mehreren Layern (Schichten) bestehen, die übereinander angeordnet sind.

Linie
hier: eindimensionale geometrische Primitive in der Vektordarstellung

Maßstab
Der Maßstab gibt das Verhältnis der lineare Verkleinerung eines Gegenstandes in einer Karte gegenüber der Natur.

magnetisch Nord
Magnetisch Nord ist eine geomagnetische Erscheinung und weist auf den magnetischen Nordpol, welcher nicht mit dem geographischen Nordpol zusammenfällt. Die Lage des magnetischen Nordpols ist einer kontinuierlichen zeitlichen Veränderung unterworfen. Die Deklination ‹ ist die Differenz zwischen geographisch und magnetisch Nord. Als Nadelabweichung bezeichnet man die Differenz zwischen Kartennord und magnetisch Nord.

Meridian
Parameterlinie von geographischen Koordinaten mit konstanter geographischer Länge. Ein Meridian ist eine nord-süd-verlaufende Linie, welche durch den Schnitt einer durch einen Punkt und der Rotationsachse gebildeten Ebene (Meridianebene) mit dem Sphäroid gebildet wird

Metadaten
Daten, welche ergänzend zu Geo-Daten erfasst werden sollen, um die Offenheit der Informationen zu gewährleisten. Dies sind Informationen über Herkunft, Datenmodell, Datenstruktur, Datenqualität, Fortführung, Verfügbarkeit, sowie über Abfragemodelle und Verwahrung der Daten.

Modell
allg. für Muster, Entwurf, Vorbild, Beispiel.
In der Geoinformatik ein Abbild der Natur unter Betrachtung der Phänomene durch einem bestimmten Blickwinkel. Dabei werden für wesentlich erachtete Aspekte hervorgehoben und für unwesentlich angesehene weggelassen. Ein Modell dient zur Beschreibung der Welt in der Vergangenheit, der Gegenwart und liefert die Grundlagen zur Simulation zukünftigen Verhaltens.

Nordrichtung
Es ist zwischen drei Nordrichtungen zu unterscheiden: geographisch Nord, Kartennord und magnetisch Nord. Siehe dort.

Nordwert
engl.: Northing. Parameter der ebenen UTM-Koordinaten. Der Nordwert (Hochwert) ist der vom Äquator aus nach Norden positiv gezählte Abszissenwert entlang dem Mittelmeridian eines Meridianstreifens.

Online-Projekt
Ein Online-Projekt speichert alle geladenen Layer (nur Shape-Dateien) und alle Einfärbungsoptionen in einer einzigen komprimierten Datei (*.kez für "Karten-Explorer-Zip"), die mit dem Karten-Explorer geladen werden kann. Dies ist der effizienteste Weg zur elektronischen Übertragung (Email) und Archivierung von Vektordaten.

Ordinate
Wert auf einer Ordinatenachse

Ordinatenachse
sekundäre Koordinatenachse eines kartesischen Koordinatensystems

Ostwert
Parameter der ebenen UTM-Koordinaten. Der Ostwert ist die Ordinate, vom Mittelmeridian eines Meridianstreifens aus nach Osten positiv gezählt. Damit in einem Streifen keine negativen Koordinatenwerte entstehen, werden noch 500'000 m addiert.

Parameter
In der Mathematik eine Variable von Funktionen, Gleichungen etc, deren Wert festgehalten oder systematisch verändert wird, um das Verhalten der Funktionen, Gleichungen etc zu untersuchen oder zu beschreiben.

Pixel
engl. für PIcture ELement; kleinste geometrische Primitive in der Rasterdarstellung mit flächenhafter Ausprägung, meist rechteckige Zelle.

Position
Die Position stellt die räumliche und zeitliche Information über ein Phänomen dar

Projektion
In der Kartennetzentwurfslehre Synonym zu Kartennetzentwurf.
Im strengen geometrischen Sinne eine Abbildung entlang von die Projektion bestimmenden Geraden; z.B. Zentralprojektion, Parallelprojektion, Helmertsche Projektion.

Punkt
0-dimensionale geometrische Primitive in der Vektordarstellung

Quadrant
In einem zweidimensionalen kartesischen Koordinatensystem teilen die Koordinatenachsen die Ebene in vier Teile, die Quadranten. Diese werden mit den römischen Ziffern I, II, III, IV bezeichnet. Die Zählweise der Quadranten richtet sich nach dem Umlaufsinn, wobei der von der positiven x- und y-Achse eingeschlossene Quadrant die I ist.

Raster
Regelmäßig angeordnete Zellen (Pixel)

Rasterdarstellung
Darstellung der Geometrie als Raster

Rasterfläche
Dies ist eine 2-dimensionale regelmäßige Anordnung (Mosaik) von Zellen (Pixel).

Rastermodell
siehe auch Rasterdarstellung

Raumbezug
Beschreibung der Position in einem Referenzsystem zur geometrisch eindeutigen Identifikation, Lokalisierung und Zuordnung eines Phänomens.

räumlicher Bezug
siehe Raumbezug

Rechtswert
Parameter der ebenen Gauß-Krüger-Koordinaten. Der Rechtswert ist die Ordinate, vom Hauptmeridian eines Meridianstreifens aus nach Osten positiv gezählt. Damit in einem Streifen keine negativen Koordinatenwerte entstehen, werden noch 500'000 m addiert. Die Kennung des Meridianstreifens wird als Million m ebenfalls addiert, z.B. plus 3'000'000 m für 3. Meridianstreifen.

Referenzsystem
Synonym für Bezugssystem

Richtungswinkel
Winkel zwischen Kartennord und der zu bestimmenden Richtung.

Rotationsachse
Achse, um welche sich ein Körper dreht. Hier auch: Erdachse.

Rotationsellipsoid
auch: Sphäroid. Ein an den Polen abgeplattetes Rotationsellipsoid entsteht durch die Rotation einer Ellipse um ihre kleine Achse.

Sphäroid
Synonym für Rotationsellipsoid

Topologie
Sammelbegriff für jene Eigenschaften, die bei einer stetigen Abbildung nicht verloren gehen, wie etwa "Verbundensein", Berühren", "Benachbartsein", "überdecken", "Beinhalten" [Bartelme]

Transformation
Umformung, Umgestaltung, Umwandlung
umkehrbar eindeutige mathematische Abbildung.

transversale Abbildung
auch: querachsig, äquatorachsig. Die Achse der Abbildungsfläche steht senkrecht zur Rotationsachse des Sphäroides

UTM
Universal Transversal Mercator Projektion; winkeltreu; Aufteilung der Erde in 6 Grad breite Meridianstreifen

Vektor
mathematisch: gerichtete Strecke im Raum

Vektordarstellung
Darstellung der Geometrie durch Punkte und Linien.

x-Achse/X-Achse
primäre Koordinatenachse in einem kartesischen Koordinatensystem, Abszissenachse

y-Achse/Y-Achse
sekundäre Koordinatenachse in einem kartesischen Koordinatensystem; Ordinatenachse

z-Achse/Z-Achse
tertiäre Achse in einem räumlichen kartesischen Koordinatensystem.


Koordinatensystem und geodätisches Datum

Koordinatensystem, Bezugssystem und Streifen/Zone

Die Voreinstellung für Koordinatensystem, Bezugssystem und Streifen/Zone wird über [image] Einstellungen Projektion vorgenommen.

Koordinatensystem

Räumliche Daten liegen in einem bestimmten Koordinatensystem vor, die Lage eines geografischen Ortes wird durch die X-Koordinate (geografische Länge, Longitude) und die Y-Koordinate (geografische Höhe, Latitude) gekennzeichnet. Es kommen hierbei verschiedene Koordinatensysteme zum Einsatz, die der Tatsache geschuldet sind, dass es verschiedene Verfahren (Projektionen) gibt, um die geografischen Koordinaten einer gewölbten Oberfläche ("Erdkugel") in rechtwinklige Koordinaten (Rechtswert, Hochwert) einer flachen Karte zu transformieren.

Für die Angabe der Position von Punkten kommen in Deutschland vorrangig folgende Koordinatensysteme zur Anwendung:

  1. Geografisches Koordinatensystem: Hierbei werden die Koordinaten in geografischer Länge (Longitude) und geografischer Breite (Latitude) angegeben. Die Einheit ist Grad. Dabei unterscheidet man für den Nachkommaanteil die dezimale Schreibweise (12,5050°) oder die gradielle Notation in Grad, Minute und Sekunde (12°20‘30‘‘ bzw. 12,2030°)

  2. Rechtwinklige Koordinatensysteme: Die Koordinaten werden als Rechtswert (Entfernung vom Koordinatenursprung nach Osten in Meter) und Hochwert (Entfernung vom Koordinatenursprung nach Norden in Meter) angegeben.
    a) UTM-Koordinaten (Universale transversale Mercatorprojektion)
    b) Gauß-Krüger-Koordinaten (3-Grad)

Bei UTM-Koordinaten ist der (vollständige) Rechtswert achtstellig und für Gauß-Krüger-Koordinaten siebenstellig. Oftmals werden die ersten Stellen nicht aufgeführt, da sie sich für kleine Gebiete nicht ändern. Da die über TSN bereitgestellten Hintergrundkarten auf dem vollständigen Rechtswert basieren, ist in TSN der vollständige Wert einzutragen!

unterstütze Koordinatensysteme |  | Bezugssystem (Standard) | Streifen bzw. Zone
a) Deutschland
UTM8 | Universale Transversale Mercatorprojektion (UTM) | ETRS89 | 32, 33 für Deutschland
UTM6 | Universale Transversale Mercatorprojektion (UTM7) 6-stelliger Rechtswert (Rechtsverschiebung -32.000.000)
UTM7 | Universale Transversale Mercatorprojektion (UTM7) 7-stelliger Rechtswert (Rechtsverschiebung -30.000.000)
GK3 | Gauß-Krüger-Koordinaten 3°-Streifen | Potsdam Datum (DHDN) Datum Pulkowo (System 42/83) | 1-5
b) allgemein
GeoK | geografische Koordinaten, dezimal | WGS84 |
LAEA | Lambert azimuthal equal-area projection | ETRS89 |

Bezugssystem (Geodätisches Datum)

Die landläufige Meinung, die Erde sei rund, stimmt nur bei recht oberflächlicher Betrachtung. Eigentlich handelt es sich um ein unregelmäßiges dreidimensionales Gebilde. Um dennoch die Positionen von Punkten auf der Erdoberfläche genau identifizieren zu können, verwendet man i.d.R. unterschiedliche Referenzellipsoide. Diese Ellipsoide ermöglichen eine gute Annäherung an die Erdoberfläche. Um die regional beste Annäherung zu erreichen, haben sich jedoch in verschiedenen Regionen der Erde unterschiedliche Ellipsoide durchgesetzt (unterschiedliche Länge ihrer Halbachsen).

Das geodätische Datum beschreibt über verschiedene Parameter (Ellipsoide, Achsenverschiebungen und Drehwinkel) das jeweilige Bezugssystem für verwendete Koordinaten.

Die Arbeitsgemeinschaft der Vermessungsverwaltungen der Bundesrepublik Deutschland (AdV) hat 1991 für alle Aufgabenbereiche des Vermessungs- und Katasterwesens die Einführung des Europäischen Terrestrischen Referenzsystems ( ETRS89) beschlossen. Dieses System hat inzwischen weitgehend etabliert.

Zahlreiche Karten liegen jedoch nach wie vor in zuvor verwendeten Systemen vor. Während in den alten Bundesländern und im wiedervereinten Deutschland das Potsdam Datum (DHDN) verwendet wurde und wird, liegt einigen Karten der neuen Bundesländern das System 42/83 (Pulkowo-Datum) zugrunde, das in der DDR (und großen Teilen Osteuropas) verbindlich war.

Die folgende Tabelle fasst die unterstützten Bezugssysteme (geodätisches Datum) zusammen:

Bezugssystem (Geodätisches Datum) | Ellipsoid | Zentralpunkt | Verwendung
Potsdam Datum oder DHDN (Deutsches Hauptdreiecksnetz) | Bessel (1941) | Rauenberg | alte Bundesländer, wiedervereinigtes Deutschland
System 42/83 oder Pulkowo-Datum | Krassowski (1942) | Pulkowo (Polen) | Osteuropa, neue Bundesländer zu "DDR-Zeiten"
WGS (World Geodetic System) | WGS84 (1984) | earth centred | GPS
ETRS89 (Europäisches Terrestrisches Referenzsystem 1989) | GRS80 (1980) | earth centred | einheitliches europäisches Bezugssystem

Streifen (Zentralmeridian)

Rechtwinklige Koordinatensysteme (Gauß-Krüger, UTM) arbeiten mit sog. Streifensystemen. In Deutschland sind folgende Streifensysteme üblich:

Koordinaten- system | Streifen- breite | Streifennummer (Zentralmeridian)
UTM | 6° | 32. Streifen (9°) 33. Streifen (15°)
Gauß-Krüger (3°-Streifen) | 3° | 2. Streifen (6°) 3. Streifen (9°) 4. Streifen (12°) 5. Streifen (15°)

Die Streifenbildung hat Auswirkungen auf den Rechtswert. Dieser wird willkürlich um die sog. Ostverschiebung erhöht.
Beispiel Gauß-Krüger-Koordinaten in 3°-Streifen:
Die Ostverschiebung setzt sich zusammen aus der Nummer des Meridianstreifens erhöht um den Wert 500000. Alle Koordinaten im dritten Streifen beginnen somit der Ziffer 3, die im vierten Streifen mit der Ziffer 4 etc.

Beim Übergang von einem Streifen zu einem anderen, erfolgt ein "Sprung" des Rechtswertes. Für die Darstellung auf gedruckten Karten oder digitalisierten Rasterkarten ist dies sehr unhandlich bzw. führt zu erheblichen technischen Problemen. Daher treffen Landesvermessungsämter, deren Territorium von mehreren Streifen berührt wird, bei der Digitalisierung die Festlegung, dass ein Streifen bzw. Zentralmeridian für alle Kartenblätter des Landes als verbindlich gilt.


Extras

Das Menü Extras fasst eine Reihe von Werkzeugen und ergänzenden Programmfunktionen zusammen.

Einstellungen erlaubt das Modifizieren von Verzeichnissen, Standardprojektion usw.

Polygon-Editor ruft das gleichnamige Werkzeug zum Erstellen und Bearbeiten von Polygonen auf. Diese Polygone stellen häufig Restriktionszonen wie Sperrbezirke und Beobachtungsgebiete anhand natürlicher Grenzen dar und können z.B. mit dem [image] Karten-Explorer verarbeitet werden.

Shape-Datei konvertieren

  • Shape-Datei transformieren erlaubt es, die Projektion von Shape-Dateien sowie die Dateistruktur der Attribute-Datei zu ändern und Filter anzuwenden. Die ausgewählte Datei wird überschrieben!

  • Shape-Datei exportieren erstellt eine Kopie einer Shape-Datei und erlaubt es, die Projektion der Shape-Dateien sowie die Dateistruktur der Attribute-Datei zu ändern und Filter anzuwenden. Die Ursprungsdatei wird nicht modifiziert!

Koordinaten umrechnen aktiviert eine Programmfunktion, die das manuelle Umrechnen von Koordinaten (Koordinatensystem, Bezugsdatum, Zentralmeridian) erlaubt.

Archiv-Manager ist ein Werkzeug zum Erstellen und Ändern von Zip-Archiven.


Einstellungen

Bildschirm anzeigen

Mit dem Menüpunkt "Extras - Einstellungen" können folgende Einstellungen modifiziert werden:

Allgemein
Auf der Registerkarte [image] Allgemein können Verzeichnisse für das Programm und Adressen für Online-Funktionen geändert werden.
Standardprojekt:
Auf der Registerkarte [image] Standardprojekt wird festgelegt, welche Karten bei kartografischen Darstellungen standardmäßig geladen werden sollen.
Projektion:
Auf der Registerkarte [image] Projektion wird eingestellt, mit welcher Voreinstellung für das verwendete Koordinatensystem gearbeitet werden soll.
TSN-Kompatibilität:
Auf der Registerkarte [image] TSN-Kompatibilität können Nutzer von Veterinärämtern Einstellungen für die Verwendung von Karten und Funktionen der Applikation TSN vornehmen.

Hinweis:

Die Einstellungen werden in einer Konfigurationsdatei gespeichert. Standardmäßig ist dies die Datei Config.cfg (mit der assoziierten Hilfsdatei Config.Fpt), die in dem Verzeichnis abgelegt ist, welches bei der Installation als Datenorder angegeben wurde. Um die Einstellungen (mit dieser Programmfunktion) bearbeiten zu können, ist zu gewährleisten, dass der schreibende Zugriff auf besagte Dateien gewährleistet ist. Der Speicherort (und Dateiname) der Konfigurationsdatei kann geändert werden, indem die Datei ke.ini im Programmverzeichnis der Applikation modifiziert wird. Dazu ist der Eintrag Konfigurationsdatei=... zu ändern.


Einstellungen - Allgemein

Bildschirm anzeigen

Auf der Registerkarte [image] Allgemein können Verzeichnisse für Dateien und Adressen für Online-Funktionen geändert werden.

Verzeichnisse

Die Verzeichnisse, die für Such- und Speichervorgänge standardmäßig verwendet werden sollen, können hier festgelegt werden.

  • Das Verzeichnis für Karten wird z.B. für den Download von Karten für Staatsgrenzen verwendet. Die Funktion zum Hinterlegen von Rasterkarten sucht Bilddateien in diesem und alternativ im Verzeichnis für Rasterkarten. Diese Funktionen sind im Allgemeinen Benutzern aus Veterinärämtern vorbehalten.

  • Beim Abspeichern von Karten-Explorer-Projekten erfolgt per Vorgabe im Ordner Projekte.

  • Das Verzeichnis für Dokumente wird z.B. beim Abspeichern von KML-Dateien als Vorgabe verwendet.

Adressen für Online-Funktionen

Die Adresse "KE-Online" beinhaltet den Link zur Homepage des Karten-Explorers.

Die Adresse für "Ressourcen" teilt dem Karten-Explorer mit, welcher Link für die Darstellung von Symbolen bei der Ausgabe in KML (Google Earth) verwendet werden soll. Bei der Einfärbung von Layern mit Punkten können Zeichen aus Schriftarten als so genannte True-Type-Marker verwendet werden, die vom Karten-Explorer bei der Ausgabe in KML als Links auf die hier eingestellte Adresse umgewandelt werden. Das 77. Zeichen der Schriftart TSN-Symbole, die mit dem Karten-Explorer installiert wird, würde in https://www2.fli.de/kml/shapes/TSN-Symbole_77.png konvertiert werden. Für zahlreiche in der Kartografie verwendete Schriftarten mit Symbolen sind auf der voreingestellten Ressource die korrespondierenden Grafiken im Format PNG hinterlegt. Bei Angabe einer alternativen Ressource sind die verwendeten Zeichen der Schriftart (schriftname_nummer.png) als Grafik bereitzustellen. KML exportieren


Einstellungen - Standardprojekt

Bildschirm anzeigen

Auf der Registerkarte [image] Standardprojekt wird festgelegt, welche Karten standardmäßig geladen werden sollen und wie die Einfärbung erfolgt. Das Standardprojekt kann im [image] Öffnen-Dialog (Projektauswahl) des Karten-Explorers aktiviert werden. Wird der [image] Polygon-Editor zum Bearbeiten von Restriktionszonen aus dem Hauptfenster mit dem Menüpunkt "Extras - Polygon-Editor" aufgerufen, wird ebenfalls das Standardprojekt verwendet. Das Standardprojekt wendet sich in erster Linie an Anwender aus Veterinärämtern (TSN-Benutzer).

Layer-Liste

In der Layer-Liste sind anzuzeigende Vektorkarten (Shape-Dateien) und Rasterkarten (MrSID-Dateien, Tiff-Dateien usw.) eingetragen.
Layer hinzufügen

Hier werden folgende Angaben angezeigt:

  • Name
    Dies ist der Name der in der Layer-Kontrolle des Karten-Explorers angezeigt wird.

    • Mit dem Kontrollkästchen wird gesteuert, ob die Karte geladen werden soll oder nicht. So können Karten bei Bedarf ausgeschaltet werden, ohne sie endgültig aus der Liste zu entfernen.
      Karte wird geladen.
      Karte wird nicht geladen.

    • Mit dem Symbol für Validität wird signalisiert, ob die Karte vorhanden ist und alle Komponenten gefunden wurden.
      Die Karte wurde gefunden, alle Komponenten sind vorhanden.
      Die Karte wurde gefunden, eine Hilfsdatei fehlt jedoch. Layer hinzufügen
      Die Karte wurde nicht gefunden.

  • Typ
    Die Spalte Typ informiert darüber, ob es sich um Vektordaten (Typen: Polygon, Linie, Punkt) oder Rasterkarten (Typ: Bild) handelt.

  • Vorlage
    Gibt an, ob für den Layer spezielle Eigenschaften für die Einfärbung, Info-Felder, Anzeigebereiche usw. definiert wurden. In diesem Fall existiert eine mit dem Dateinamen des Layers korrespondierende Datei (*.kel), die das Erscheinungsbild des Layers in Kartenansichten festlegt.

  • Index
    Gibt an, ob für Shape-Dateien ein räumlicher Index (*.sbx) bzw. Attribute-Index (*.sbn) vorhanden ist, der Zoom- und Suchvorgänge insbesondere bei umfangreichen Shape-Dateien signifikant beschleunigt.

  • Bereich
    Gibt an, ob für den Layer ein individueller Maßstabsbereich festgelegt wurde, innerhalb dessen der Layer angezeigt werden soll.

  • Datei
    In dieser Spalte ist der Zugriffspfad und Dateiname des Layers angegeben. Beachten Sie, dass dies der Name der "Hauptdatei" einer Shape-Datei (*.shp) oder Bild-Datei (z.B. *.sid, *.tif usw.) ist, dass diese jedoch i.d.R. noch mehrere gleichnamige "Hilfsdateien" mit abweichender Dateierweiterung haben.

In der Layer-Liste können "beliebige" Karten angemeldet werden. Die folgenden Erläuterungen beziehen sich auf den TSN-Standard für ein Kreisämter, welche i.d.R. eine Shape-Datei für Gemeindegrenzen (*.shp) und mehrere Rasterkarten im MrSID-Format (*.sid) benutzen.

  • Shape-Datei
    Am Listenanfang sollte die Shape-Datei der Gemeindegrenzen (z.B. Gem98201.Shp) angegeben sein. Es ist darauf zu achten, dass Shape-Dateien in der Liste vor den Rasterkarten (MrSID-Dateien) aufgeführt sind, da sie ansonsten bei der Anzeige von diesen verdeckt werden.

  • MrSID-Dateien
    Hier sind alle Kartenblätter (MrSID-Dateien z.B. Bfav2117.Sid), die auf Rasterkarten erscheinen sollen, aufgeführt. In der Regel sind hier alle Kartenblätter anzugeben, die erforderlich sind, um das Territorium des Mandanten abzudecken. Wenn die Rasterkarten nicht erscheinen, gehen Sie bitte vor, wie es unter "Rasterkarten hinterlegen" beschrieben ist.

Karten hinzufügen

Mit der Schaltfläche Hinzufügen wird der Windows-Dialog zur Dateiauswahl geöffnet. Über das Kombinationsfeld Dateityp kann die Auswahl von Shape-Dateien (*.shp), MrSID-Dateien (*.sid) bzw. Tiff-Dateien (*.tif) gesteuert werden, die zur Layer-Liste hinzugefügt werden sollen. Das Dateiauswahlfenster unterstützt Mehrfachauswahl mit Strg + Mausklick! Mit der Schaltfläche Löschen kann der in der Liste markierte Eintrag entfernt werden. Ist kein Eintrag markiert, werden alle Karten aus der Liste entfernt.

Rasterkarten hinterlegen

Es ist ein Layer in der Liste zu markieren, der mit Rasterkarten zu hinterlegen ist. In der Regel sollte hier ein Layer der administrativen Grenzen (Gemeinden oder Kreise) ausgewählt werden, der das gesamte Gebiet des Mandanten abdeckt. Anschließend ist die Schaltfläche Hinterlegen zu betätigen, welche die Programmfunktion [image] Rasterkarten (DTK25) hinterlegen aktiviert. Wenn die Karten gefunden wurden, werden sie in der Liste der anzuzeigenden Karten angemeldet. Sollten die Karten nicht gefunden werden, stellen Sie sicher, dass das angegebene Verzeichnis für Karten bzw. Rasterkarten korrekt ist und die benötigten Kartenblätter installiert sind.
Sie können die Rasterkarten direkt über die Programmfunktion "Rasterkarten (DTK25) hinterlegen" von TSN-Online herunterladen, indem Sie den Hyperlink [image] Rasterkarten von TSN-Online herunterladen benutzen, der genau die Kartenblätter anfordert, die beim "Hinterlegen" nicht gefunden worden sind. https://tsn.fli.de/service/DownloadKarten.Aspx

Reihenfolge der Layer

Die Reihenfolge in der Layer-Liste legt die Reihenfolge der Anzeige der Karten fest. Der oberste Eintrag in der Layer-Liste wird zuletzt gezeichnet und überlagert demzufolge die darunter liegenden Karten.

Die Schaltflächen "Pfeil auf" bzw. "Pfeil ab" ermöglichen es, den in der Layer-Liste markierten Eintrag nach oben/unten zu bewegen. Mit gedrückter linker Maustaste können die Karten per Drag&Drop an die gewünschte Position bewegt werden. Wie bereits erwähnt, sollten Shape-Dateien am Listenanfang stehen, um bei der Anzeige der Karten nicht von den Rasterkarten verdeckt zu werden.

Eigenschaften des Layers

Bildschirm anzeigen

Um die Eigenschaften des Layers (Einfärbung, Anzeigebereich usw.) zu ändern, ist der gewünschte Layer in der Layer-Liste zu markieren und die Schaltfläche Eigenschaften zu betätigen. Mausdoppelklick auf den gewünschten Layer hat dieselbe Wirkung. Layer-Optionen festlegen

Funktion 'gesamte Karte anzeigen'

Wird das Kontrollkästchen "auf Übersichtslayer einpassen" aktiviert, berechnet TSN die Größe zum Einpassen der Karte anhand der Datei (des Layers) der als Übersichtsfenster gewählt worden ist. Beim Georeferenzieren oder Laden des Standardprojektes im Karten-Explorer wird auf diese Größe gezoomt.

Datei für Übersichtsfenster auswählen

An dieser Stelle kann eine Datei (ein Layer) als Übersichtsfenster für den Karten-Explorer ausgewählt werden.

Ein Übersichtsfenster erlaubt es, eine beliebige Karte in vollständiger Größe in einem gesonderten Fenster anzuzeigen. Diese korrespondiert mit den geladenen Karten im Karten-Element. Ein rotes Rechteck in der Übersichtskarte zeigt an, welcher Bereich im Karten-Element sichtbar ist. Dies ist insbesondere bei "gezoomter" Darstellung hilfreich.

Mit der Schaltfläche [image] kann eine Datei als Übersichtsfenster ausgewählt werden, mit der Schaltfläche als Übersicht wird der in der Layer-Liste markierte Eintrag als Übersichtsfenster übernommen.

Sichtbarkeit von Bilddateien (Rasterkarten)

Mit diesem Optionsfeld kann das Standardverhalten für die Anzeige geladener Rasterkarten gesteuert werden. Diese können bei Initialisierung des "Standardprojektes" eingeblendet, ausgeblendet oder abhängig vom aktuellen Maßstab erst ab 1:50.000 angezeigt werden.

Transparenz von Bilddateien (Rasterkarten)

Falls Sie Bilddateien (Rasterkarten, Topografische Karten) verwenden, die nicht blattschnittfrei sind (um die Karte befindet sich ein Rand), können Bilddateien für eine Farbe (i.d.R weiß) transparent geschaltet werden. Damit können mehrere Bilddateien aneinander gelegt werden ohne dass störende Zwischenräume entstehen. Aktivieren Sie das Kontrollkästchen "Bilddateien transparent schalten", wenn Sie Karten mit Blattschnitt verwenden und wählen Sie ggf. die "durchsichtige" Farbe aus, indem Sie auf das Kästchen "transparente Farbe" mit der Maus klicken. Normalerweise ist diese Funktion zu deaktivieren.


Einstellungen - Projektion

Bildschirm anzeigen

Auf der Registerkarte [image] Projektion wird eingestellt, welche Art von Koordinaten standardmäßig verwendet werden. Die hier eingestellten Werte gelten als Voreinstellung für Projekte im Karten-Explorer und bei Umrechnungen von Koordinaten.

Die Einstellungen für die Projektion (Koordinatensystem, geodätisches Datum und Zentralmeridian) beim Mandanten sollten identisch mit dem Typ der Rasterkarten sein, der unter [image] TSN-Kompatibilität eingestellt worden ist.

Für Informationen zu theoretischen Fragen [image] Koordinatensystem, Bezugssystem und Streifen.

Koordinatensystem

Hier wird eingestellt, welches Koordinatensystem den Koordinaten, die für Betriebe, Ausbrüche usw. angegeben werden, zugrunde liegt. Bitte beachten Sie, dass Koordinatensystem und geodätisches Datum (Bezugssystem) in der Regel in Kombinationen auftreten!

Bezugssystem (Geodätisches Datum)

Hier wird eingestellt, welches Bezugssystem (geodätische Datum) den Koordinaten zugrunde liegt. Die Angabe des Bezugssystems ist wichtig für die korrekte interne Verarbeitung von Koordinaten.

Streifen (Zentralmeridian)

Alle Kartenblätter der DTK (Deutsche Topographische Karten) 1:25.000, 1:50.000 und 1:100.000, die als Rasterkarten erhältlich sind, werden in rechtwinkligen Koordinatensystemen ( Gauß-Krüger- oder UTM- Systeme) unter Bezugnahme auf einen Zentralmeridian (=Mittelmeridian) eingepasst. Dieser Zentralmeridian korrespondiert mit fortlaufend nummerierten (3° bzw. 6° breiten) Streifen.

Sollte der vorab eingestellte Wert für den Streifen (Zentralmeridian) nicht mit den verwendeten Rasterkarten übereinstimmen, ist der richtige Wert auf dem Schieberegler einzustellen.

Anzeige Mausposition

Bei kartografischen Darstellungen werden die Koordinaten der aktuellen Mausposition auf der Karte in der Statuszeile angezeigt. Auf allen Karten kann das Format der Koordinatenanzeige gewählt werden. Hierbei sind folgende Einstellungen möglich:

  1. Gauß-Krüger/UTM (dies ist die Vorgabe) Es werden Rechts- und Hochwerte (Gauß-Krüger- bzw. UTM- Koordinaten) auf Grundlage eingestellten Koordinatensystems (siehe oben) angezeigt

  2. geografisch (dezimal): Es werden geografischen Koordinaten in dezimaler Schreibweise (z.B. 9.5050) angezeigt.

  3. geografisch (gradiell): Es werden geografischen Koordinaten in der Schreibweise Grad, Minute und Sekunde (z.B. 9°30'30'') angezeigt.

  4. geografisch (WGS 1984)

    5. Hinweis: Bei den Einstellungen 1.-3. erfolgt die Anzeige von Koordinaten immer bezogen auf das gewählte geodätische Datum (siehe oben). TSN führt für interne Zwecke eine Koordinatentransformation ins TSN-Referenzsystem WGS 1984 durch. Bei der Einstellung 4. erfolgt die Anzeige in dezimalen geografischen Koordinaten bezogen auf das geodätische Datum WGS 1984. Diese Option dient in erster Linie der Programmentwicklung/ -testung.


Einstellungen - TSN-Kompatibilität

Bildschirm anzeigen

Auf der Registerkarte [image] TSN-Kompatibilität werden Einstellungen getroffen, die sich in erster Linie an TSN-Benutzer in Veterinärbehörden wenden. Diesen Benutzern stehen erweiterte Funktionen des Karten-Explorers wie spezielle Rasterkarten, Vektorkarten (administrative Grenzen) und Web-Services zur Verfügung.

Typ der verwendeten TSN Rasterkarten

Innerhalb des TSN-Systems werden den Veterinärbehörden Rasterkarten der Deutschen Topografischen Karten im Maßstab 1:25.000 (DTK25) zur Verfügung gestellt. Dies sind die Rasterkarten älterer TSN-Versionen (TSN 2) oder die Rasterkarten der Version TSN 3, welche wahlweise in Gauß-Krüger-Koordinaten oder UTM-Koordinaten verfügbar sind.
An dieser Stelle ist der Typ der verwendeten Rasterkarten einzustellen. Diese Einstellung betrifft insbesondere die Arbeitsweise der Funktion [image] Rasterkarten hinterlegen im Karten-Explorer und [image] Polygon-Editor.

Bezeichnung | Kartenstand | Dateiname | Projektion (Koordinatensystem, Bezugssystem, Streifen)
'GK3' | 2017 | GK3_????.SID | Gauß-Krüger, Potsdam Datum, 3. Streifen
'U32' | 2019 | U32_????.SID | UTM, ETRS89, 32. Streifen, 1:25.000
 | 2018 | TOP17_????.SID | UTM, ETRS89, 32. Streifen, 1:17.500
 | 2018 | TOP100_????.SID | UTM, ETRS89, 32. Streifen, 1:100.000
'U33' | 2007 | U33_????.SID | UTM, ETRS89, 33. Streifen
'LAEA' Europa | 2018 | TOP250_????.SID | LAEA, ETRS89

Es ist die Option auszuwählen, die dem Typ der verwendeten Rasterkarten entspricht. Es wird empfohlen, mit 'U32' (UTM-Koordinatensystem bezogen auf ETRS89 im 32. Meridianstreifen) oder 'LAEA' zu arbeiten. 'GK3' (Gauß-Krüger-System) und 'U33' (UTM-Koordinatensystem bezogen auf ETRS89 im 33. Meridianstreifen für östliche neue Bundesländer) stehen weiterhin zur Verfügung, werden jedoch nicht mehr gepflegt.

Beachten Sie, dass bei jedem Mandanten die korrekte Projektion eingestellt ist. Einstellungen - Projektion

Web-Service für Datenaustausch

Einige der erweiterten Funktionalitäten des Karten-Explorers für Benutzer mit einem Zugang zu TSN-Online arbeiten auf der Basis von Web-Services:

  • Herunterladen von Karten vom TSN-Server

  • Abfrage der Tierseuchenlage
  • Darstellung von Karten mit FLI-Maps

Die Adresse des Web-Service [image] https://service.tsn.fli.de/endpoint/tsn_v4.asmx?WSDL (Stand März 2022) ruft verschiedene Funktionen (so genannte Web-Services) auf, die auf einem Server des FLI abgearbeitet werden. Der Karten-Explorer kommuniziert mit diesen Services programmintern über die Komponente "Microsoft Toolkit 3.0".

Bei der Kommunikation verwendet die Applikation eine Zeitspanne, ein so genanntes Timeout (Standard 60 Sekunden), innerhalb der der Web-Service antworten muss, bevor eine Fehlermeldung erfolgt. Für diese Zeitspanne reagiert die Applikation ggf. nicht auf Benutzeraktionen. Falls es bei bestehender Internetverbindung und ansonsten korrekter Funktion des Web-Service zu Abbrüchen kommt, weil die Antwort nicht rechtzeitig erfolgt (z.B. wegen langsamer Internetverbindungen oder stark ausgelasteter Server des FLI) kann dieser Wert erhöht werden. Er wurde bewusst eher niedrig angesetzt, um bei Fehlfunktionen in akzeptabler Zeit Fehlermeldungen zu bringen, weil Nutzer ansonsten den Absturz der Applikation vermuten und diese terminieren.

Benutzername und Kennwort

Der Zugang erfordert die Authentifizierung mit einem Benutzernamen und Kennwort. Diese Zugangsdaten entsprechen denen vom Online-Zugang zu TSN. In der [image] Benutzerverwaltung von TSN-Online sollte dem Benutzer das Recht "Downloadseite für Karten einsehbar" eingeräumt worden sein. Die Benutzerverwaltung (TSN-Online) eines Kreises kann vom Administrator des Kreises, die des Landes von einem Landesadministrator, die gesamte von den Administratoren von TSN verwaltet werden. Bitte wenden Sie sich ggf. an diese Administratoren, um Zugriff zu erhalten.

Proxy-Einstellungen

Die Vorgabe ist <CURRENT_USER> als Adresse für den Proxy-Server. Damit verwendet der Web-Service die beim Betriebssystem hinterlegten Einstellungen für den angemeldeten Benutzer (Es wird der Proxy-Server verwendet, der in den LAN-Einstellungen vom Internet Explorer festgelegt ist).

Im Allgemeinen sollten die Voreinstellungen (siehe oben) problemlos funktionieren und nicht geändert werden. Bei Bedarf ändern Sie die Einstellungen für die Adresse des Proxy-Servers.

Verbindung testen

Der Zugriff auf den Web-Service kann über die Schaltfläche [image] gestestet werden. Es sollte sich innerhalb einer kurzen Zeitspanne ein Fenster mit Bestätigung des erfolgreichen Zugriffs melden oder eine Fehlermeldung erscheinen.

Bei Fehlermeldungen sind folgende Punkte zu überprüfen:

  • Besteht eine Internetverbindung?

  • Sind die Benutzername und Kennwort korrekt?

  • Stimmen die Proxy-Einstellungen?

  • Gibt es Probleme mit dem Web-Service?
    https://service.tsn.fli.de/endpoint/tsn_v4.asmx?WSDL sollte sich mit einer Dienstbeschreibung melden.

  • Weitere Hinweise bei Problemen mit dem Web-Service finden Sie [image] hier

Erscheinungsbild der 'Staatsgrenzen' festlegen

Die Staatsgrenzen (Nuts1 = Bundesländer, Nuts2 = Regierungsbezirke und Nuts3 = Kreise) werden im Karten-Explorer ( [image] Projektauswahl) verwendet. Es kann über die jeweiligen Kontrollkästchen festgelegt werden, ob die dazugehörige Ebene angezeigt werden soll. Mit der zugehörigen Schaltfläche [image] wird die Einfärbung gesteuert. Der Karten-Explorer verwendet beim Laden von Staatsgrenzen die Bundesländer als [image] Übersichtskarte, wenn das Kontrollkästchen Übersichtsfenster anzeigen aktiviert wird.

Mit der Schaltfläche NUTS herunterladen wird das [image] Download-Center zum Herunterladen von Karten aktiviert.


Einstellungen - TSN - Download

Download-Center

Bildschirm anzeigen

Diese Programmfunktion lädt bei Bedarf die administrativen Grenzen (Bundesländer, Regierungspräsidien, Kreise) herunter.

Beim Aufruf der Funktion überprüft die Applikation die Aktualität der Daten, indem es die Versionskennungen der lokalen Installation mit denen der Zentralen Tierseuchendatenbank (ZTSDB) über einen Web-Service vergleicht. Sind die Daten lokal nicht installiert oder besitzen sie keine bzw. ältere Versionskennungen, werden die jeweiligen Kontrollkästchen neben der Versionskennung aktiviert und das zugehörige Steuerelement "Version FLI" hellrot hinterlegt. Auf Wunsch kann die Markierung der Kontrollkästchen manuell ein- und ausgeschaltet werden. Über die Schaltfläche [image] können alle Kontrollkästchen aktiviert bzw. alle Elemente zum Download markiert werden. Über die fett markierte Schaltfläche "Download" neben der Schaltfläche [image] werden alle per Kontrollkästchen markierten Karten nacheinander herunter geladen. Alternativ kann die jeweilige Schaltfläche "Download" neben jedem Eintrag genutzt werden, um die Karte einzeln (und unabhängig vom Aktivierungszustand des zugehörigen Kontrollkästchens) herunter zu laden.

Das Herunterladen von Daten erfordert die Angabe eines Benutzernamens und Kennwortes, welches in der Zentralen Tierseuchendatenbank (TSN-Online) hinterlegt ist.

Die administrativen Grenzen stellen Shape-Dateien dar, die in das unter [image] Einstellungen - Allgemein angegebene Kartenverzeichnis kopiert werden.


Kommunikationsprobleme

Mögliche Ursachen für Kommunikationsprobleme

Der Karten-Explorer verwendet für die Kommunikation mit dem BKG und dem FLI zwei unterschiedliche Architekturen:

  • Webservices des FLI - SOAP
    • kartografische Darstellung mit FLI-Maps, Abfrage der ZTSDB und Download von Staatsgrenzen
    • Die Anzeige von Karten mit FLI-Maps steht allen zur Verfügung, andere Services sind nur für Benutzer des TSN-Online nach Angabe von Benutzernamen und Kennwort verfügbar!
  • Webservices des BKG - REST
    • Geokodierung, Umgebungssuche und Routenberechnung

    • Die Nutzung erfordert ggf. eine Freischaltung [image] Nutzungsbedingungen

Bei Problemen mit SOAP...

Verursachen Web-Services zum FLI eine Fehlermeldung oder kommt es zu einem Absturz des Programms, dann prüfen Sie bitte, ob folgende Lösungsvorschläge das Problem beseitigen:

  • Der Webservice verwendet die Einstellungen des Internet-Explorers für den angemeldeten Benutzer, sofern unter "Einstellungen - TSN-Kompatibilität" der Eintrag <CURRENT_USER> als Adresse für den Proxy-Server angegeben wurde. Diese Einstellungen sind i.d.R. beizubehalten. Stellen Sie bitte sicher, dass der Benutzer für Https frei geschaltet ist. Die Adresse für den Web-Service ist https://service.tsn.fli.de/endpoint/tsn_v4.asmx?WSDL (Stand März 2022)! Einstellungen - TSN-Kompatibilität

  • Des Weiteren ist zu überprüfen, ob das Problem behoben werden kann, wenn man im Internet-Explorer unter „Extras – Internetoptionen“, Registerkarte „Erweitert“ im Knoten „Sicherheit“ den (ersten) Eintrag „Auf gesperrte Serverzertifikate überprüfen“ deaktiviert.
  • Teilweise tritt das Problem auf, wenn beim Internet-Explorer unter "Extras - Internetoptionen", Registerkarte "Inhalte", Schaltfläche "Zertifikate" unter "vertrauenswürdige Stammzertifizierungsstellen" der Eintrag "DFN-Verein Global Issuing CA" fehlt. Dies ist die Zertifizierungsstelle des FLI!
  • Unter „Extras – Internetoptionen“, Registerkarte „Erweitert“ im Knoten „Sicherheit“ sollte "Verschlüsselte Seiten nicht auf der Festplatte speichern“ deaktiviert sein.
  • Sollten alle beschriebenen Punkte nicht zum Erfolg führen, hilft im Allgemeinen der Eintrag einer Proxyausnahme (https, http) für service.tsn.fli.de bzw. 193.22.112.6 (Stand März 2022). Informieren Sie sich ggf. über aktualisierte Adressen.

Bei Problemen mit REST...

Standardmäßig verwendet der Karten-Explorer die automatische Erkennung der Verbindungseinstellungen (des Proxy-Servers). Hierbei werden die Angaben auf der Registerkarte [image] Einstellungen - TSN-Kompatibilität für den Proxy-Server ausgewertet. Ist dort die automatische Erkennung deaktiviert und ein Proxy-Server angegeben, benutzt die Rest-Schnittstelle ebenfalls die Kommunikation über diesen Proxy-Server.

Erforderliche Einstellungen des Internet Explorers:

  • auf der Registerkarte "Erweitert" im Knoten "Sicherheit" muss

    • „TLS 1.2 verwenden“ aktiviert und

    • „auf gesperrte Serverzertifikate überprüfen“ deaktiviert sein!


Verwaltung - Ini-Datei (tsn.ini)

Ini-Datei (tsn.ini)

Vom Installationsprogramm wird automatisch eine Datei ke.ini in das Installationsverzeichnis des Programms (oberhalb vom Bin-Verzeichnis) geschrieben.

Aufbau der Ini-Datei

Die Ini-Datei enthält eine Sektion [Installation] mit den beim Setup angegebenen Speicherorten für das Programm und für Daten. Diese werden beim ersten Programmaufruf für diverse Initialisierungen des System verwendet.

Bestimmte Einstellungen wie die zuletzt geöffneten Projekte oder welche Layer im "Standard-Projekt" zu laden sind, werden in der Konfigurationsdatei hinterlegt. Bei Installation des Karten-Explorers im Netzwerk kann es Sinn machen, den Zugriffspfad auf eine benutzerspezifische Ressource (z.B. Dokumente-Ordner des Benutzers) festzulegen, um jedem Benutzer seine eigene Konfigurationsdatei zu geben und so das Abspeichern ausschließlich eigener Angaben zu erlauben.

Beispiel einer ke.ini bei einer Standard-Installation:

[Installation]
Datenordner=C:\Karten-Explorer\

Programmordner=C:\Program Files (x86)\Karten-Explorer\
Konfigurationsdatei=C:\Karten-Explorer\config.cfg

Erweiterte Möglichkeiten

Eine Sektion [Optionen] kann hinzugefügt werden und folgende Einträge und Werte enthalten:

  • Internetbrowser=…
    Es kann ein Browser angegeben werden, der bei Aufrufen von Internetadressen (KE-Online, Internethilfe, FLI-Maps) verwendet wird. Wird die angegebene Ressource nicht gefunden, wird weiterhin der beim Betriebssystem hinterlegte Standard-Internetbrowser verwendet.

  • Internethilfe=0/1

    • Internethilfe=0
      Beim Betätigen von F1 wird die lokale Hilfe (ke.chm) aufgerufen, STRG+F1 ruft die KE-Internethilfe auf.

    • Internethilfe=1
      Beim Betätigen von F1 wird die KE-Internethilfe aufgerufen, STRG+F1 ruft die lokale Hilfe (ke.chm) auf.

  • InternethilfeUrl=…
    Wird hier eine Internetadresse angeben, wird die HTML-Seite für die Kontexthilfe mit der angegeben URL aufgerufen. Damit ist es möglich, die KE-Internethilfe auf ein alternatives Web umzulenken.

    • <url>/ → ruft die Hilfeseite im Browser auf
      z.B. https://www2.fli.de/hilfe/ke22/was_ist_neu.htm

    • <url>/index.htm? → ruft die Hilfeseite mit geöffnetem Inhaltsverzeichnis auf
      z.B. https://www2.fli.de/hilfe/ke22/index.htm?was_ist_neu.htm

  • Latitudeposition=0/1/2
    Diese Einstellung erlaubt es, das Verhalten vom Karten-Explorer beim Einfügen von geografischen Koordinaten aus der Zwischenablage zu steuern. Da externe Programme wie Google Maps die geografischen Koordinaten in der Regel mit der Latitude (Y) in der ersten Position angeben, kann damit das korrekte Einfügen und Verarbeiten dieser Koordinaten sichergestellt werden.

    • Latitudeposition=0
      54.183793, 13.359263 → Ist der erste Wert (X) größer als der zweite Wert (Y) wird die Reihenfolge Y, X angenommen.

    • Latitudeposition=1
      Die Latitude (Y) wird immer in der ersten Position angenommen.

    • Latitudeposition=2
      Die Latitude (Y) wird immer in der zweiten Position angenommen.

  • Design=0/1
    Diese Einstellung erlaubt es, die Verwendung von Windows-Styles für die Darstellung von Steuerelementen zu steuern.

    • Design=0
      Die Windows-Styles werden nicht verwendet - Steuerelemente (z.B. Schaltflächen) zeigen ein eher klassisches, dreidimensionales Erscheinungsbild.

    • Design=1
      Die Windows-Styles werden verwendet.

  • Info=0/1/2
    Diese Einstellung ruft optional die Hilfe vom KE mit der Seite "Info" oder "Hauptfenster" auf.

    • Info=0
      Keine Anzeige.

    • Info=1
      Die Info-Seite wird angezeigt.

    • Info=2
      Die Info-Seite wird aufgerufen und sofort wieder geschlossen.

    • Info=3
      Die Hilfeseite zum "Hauptfenster" wird angezeigt. Dies forciert das Laden bestimmter DLLs des Internet-Explorers.

    • Info=4

      Die Hilfeseite zum "Hauptfenster" wird angezeigt und sofort wieder geschlossen. Dies forciert das Laden bestimmter DLLs des Internet-Explorers.

Das folgende Beispiel zeigt eine Installation mit Freigaben für Programm und Datenbank:

[Installation]
Datenordner=C:\Karten-Explorer\

Programmordner=C:\Program Files (x86)\Karten-Explorer\
Konfigurationsdatei=C:\Karten-Explorer\config.cfg

    [Optionen]
Internetbrowser= C:\Program Files
    (x86)\Google\Chrome\Application\chrome.exe
Internethilfe=1
InternethilfeUrl=https://www2.fli.de/hilfe/ke22/index.htm?
Latitudeposition=0
Design=0


Polygon erstellen

Polygon-Editor

Bildschirm anzeigen

Der Polygon-Editor erlaubt es, Polygone zu erstellen oder zu bearbeiten, die von TSN als Restriktionszonen (z.B. Sperrbezirke) verarbeitet werden. Polygone werden in einer speziellen Datei (*.plg) abgespeichert. Polygone können völlig neu erstellt, aus Radien generiert oder aus Polygonen vorhandener Shape-Dateien (Layer) importiert/selektiert werden. Durch Mehrfachauswahl und geometrische Operationen können Polygone flexibel verarbeitet werden. Neben dem Speichern als Polygon-Datei ist der Export von Polygonen oder Segmenten (Teilen der Außenlinie) in verschiedenen Formaten als Datei oder in die Zwischenablage möglich.

Aufbau des Polygon-Editors

Menüleiste

Editier-Kontrolle Karten-Element
Layer- Kontrolle
Übersichts-karte
Statusleiste

Der Polygon-Editor verwendet ein Fenster mit Bereichen

Editor-Kontrolle (Steuerung des Zeichnens, Infos zum Polygon und Kontexthilfe)
Layer-Kontrolle (Verwaltung der geladenen Karten)
optionale Übersichtkarte
Kartenelement

Editier-Kontrolle

Die Editier-Kontrolle gibt Hinweise zur Bedienung im aktuellen Kontext, zum geladenen Polygon und markierten Segmenten und steuert den Zeichnen-Modus.
Wurde der Zeichnen-Modus mit der Schaltfläche [image] (Strg + Z) eingeschaltet, fügt jeder Mausklick in die Karte einen Punkt zum Polygon hinzu. Der Zeichnen-Modus wird über die Schaltflächen [image] (Änderungen übernehmen) oder [image] (Änderungen verwerfen) beendet. Das Löschen des zuletzt gezeichneten Punktes, sowie verschiedene Optionen zum Einpassen des Polygons bzw. Endpunktes, sowie die Möglichkeit des Erstellens von Schnappschüssen (Speichern von Zwischenständen) werden hier vorgenommen. Der aktive Zeichnen-Modus wird durch die grüne Linie unterhalb der Tastenleiste visualisiert. Ein Pausieren des Zeichnen-Modus durch erneutes Betätigen von [image] wird durch eine gelbe Linie angezeigt.

OK - Zeichnen-Modus beenden und Änderungen übernehmen
Abbrechen - Zeichnen-Modus beenden und Änderungen verwerfen

letzten Punkt löschen (Rücklöschtaste oder Strg + X) entfernt den gelb markierter Endpunkt

Polygon einpassen zeigt das in Bearbeitung befindliche Polygon komplett an. Ist ein Radius aktiviert wird dieser ebenfalls vollständig im Karten-Element dargestellt. Radius anzeigen
am Endpunkt vergrößern - Karte wird an der Position des gelb markierten Endpunktes vergrößert
am Endpunkt verkleinern - Karte wird an der Position des gelb markierten Endpunktes verkleinert
Die wichtigsten [image] Regeln für das Zeichnen werden angezeigt
Schnappschuss erstellt für das aktuelle Polygon automatisch fortlaufend nummerierte Polygon-Dateien auf der Festplatte. Damit lassen sich Zwischenstände konservieren und per Knopfdruck wiederherstellen. Schnappschuss erstellen

Layer-Kontrolle

Die Layer-Kontrolle erlaubt das Hinzufügen, Entfernen, Einfärben, Ändern der Reihenfolge und Sichtbarkeit von Layern. Erläuterungen zu Symbolik und Bedienung [image] hier

vorhandenen Layer hinzufügen (Shapedatei, Coverage, Rasterkarte | .Hinzufügen (Einfg) lädt existierende Shape-Dateien oder Bilddateien (Rasterkarten) und fügt sie der Layer-Kontrolle zu. Alternativ können Shape-Dateien per Drag&Drop in den Polygon-Editor gezogen werden, um sie zu laden.
 | Entfernen (Entf) beseitigt den markierten Layer aus der Layer-Kontrolle.
Eigenschaften für Einfärbung | Einfärbung (Enter) aktiviert den Dialog zum Einfärben des Layers, mit dem das Erscheinungsbild (Farben, Klassifizierungen, Beschriftungen usw.) des Layers geändert werden können. Eigenschaften für Einfärbung Tipp: Die Funktion kann auch durch Doppelklick auf den jeweilige Layer-Namen in der Layer-Kontrolle aktiviert werden.
Info-Felder | Info-Feld aktiviert bis zu drei beliebiges Felder der Attribut-Datei eines Layers dergestalt, dass für das an der Mausposition befindliche Geo-Objekt die gewählten Informationen als Tooltipp (Quick-Info) angezeigt werden, sofern der Layer in der Layer-Kontrolle markiert ist. Info-Felder auswählen
 | Attribute anzeigen öffnet eine Tabelle mit den Attributen des Layers [image] Anzeigen
Einpassen auf aktiven Layer | Einpassen auf aktiven Layer bewirkt das optimale Einpassen des markierten Layers im Karten-Element.
 | Raster hinterlegen (Strg + R) lädt genau die topografischen Karten, die für den "aktuellen Bildschirmausschnitt" erforderlich sind. Rasterkarten hinterlegen Standardmäßig werden vom Polygon-Editor alle Karten geladen, die unter [image] Einstellungen Standardprojekt angemeldet worden sind.
 | Rasterkartenskalierung aktiviert bzw. deaktiviert die Anzeige von Rasterkarten in Abhängigkeit vom aktuellen Maßstab. Damit werden die Rasterkarten (bei aktivierter Funktion) nur angezeigt, wenn der aktuelle Maßstab größer/gleich 1:50.000 ist. Standardmäßig ist die Rasterkartenskalierung aktiviert!

Übersichtskarte

Die Übersichtskarte erlaubt es, eine beliebige Karte in vollständiger Größe in einem gesonderten Fenster anzuzeigen. Diese korrespondiert mit den geladenen Karten im Karten-Element. Ein rotes Rechteck in der Übersichtskarte zeigt an, welcher Bereich im Karten-Element sichtbar ist. Dies ist insbesondere bei "gezoomter" Darstellung hilfreich.

Um eine Übersichtskarte zu aktivieren, klicken Sie mit der rechten Maustaste auf den gewünschten Layer in der Layer-Kontrolle und wählen Sie die Option "als Übersichtsfenster" aus dem angezeigten Kontext-Menü. Alternativ kann ein Layer per Drag&Drop aus der Layer-Kontrolle in die Übersichtskarte (bzw. bei nicht aktiver Übersichtskarte auf die Statusleiste) gezogen werden, um ihn als Übersichtskarte zu aktivieren. Um die Übersichtskarte zu deaktivieren, ist die rechte Maustaste im Übersichtsfenster zu betätigen und der Menüpunkt "Übersichtsfenster zurücksetzen" aus dem Kontextmenü auszuwählen.

Zoomen und Verschieben

Der sichtbare Kartenausschnitt des Karten-Elements kann über das Übersichtsfenster beliebig gezoomt oder verschoben werden. Zum Zoomen ist mit gedrückter linker Maustaste der gewünschte Bereich im Übersichtsfenster zu markieren.
Um den Kartenausschnitt zu verschieben, ist im Übersichtsfenster das Mausrad an der gewünschten Stelle zu drücken, ein Doppelklick mit der Maus an der gewünschten Stelle zu machen oder die rechte Maustaste (Menüpunkt "Ausschnitt hierher verschieben" im Kontextmenü) zu betätigen. Tipps & Tricks

Karten-Element

Verschiedene Mausfunktionen und das Kontextmenüs unterstützen das Navigieren (Vergrößern, Verkleinern, Verschieben) im Karten-Element.

Mausfunktionen

  • linke Maustaste
    Die Funktion der linken Maustaste hängt vom im Menü Karte eingestellten Modus ab und wird durch folgende Mauskursor symbolisiert:
    Vergrößern, [image] Verschieben, [image] Betrieb identifizieren
    Hinweis: Mit Strg + linke Maustaste kann die Karte jederzeit verschoben werden, auch wenn aktuell ein anderer "Mausmodus" aktiviert ist.

  • Strg + linke Maustaste (auch Alt + linke Maustaste und ↑ + linke Maustaste)
    Diese Kombinationen erlaubt jederzeit das Verschieben der Karte mit gedrückter linker Maustaste.

  • Mausrad drehen

    • nach oben drehen = Karte nach oben verschieben

    • nach unten drehen = Karte nach unten verschieben

  • ↑ + Mausrad drehen

    • nach oben drehen = Karte nach links verschieben

    • nach unten drehen = Karte nach rechts verschieben

  • Strg + Mausrad drehen

    • nach oben drehen = Vergrößern

    • nach unten drehen = Verkleinern

  • Mausrad nach links/rechts (falls unterstützt)

    • nach links drücken = Karte nach links verschieben

    • nach rechts drücken = Karte nach rechts verschieben

  • Mausdoppelklick (außerhalb Zeichnen-Modus) [image] Bearbeiten per Mausdoppelklick

    • Punkt eines Polygons markieren und bearbeiten (Ändern, Löschen, Neuer Punkt)

    • Strg + Doppelklick
      Ändern des angeklickten Punktes

    • Umschalten + Doppelklick
      Einen neuen Punkt hinter dem angeklickten Punkt einfügen.

    • Alt + Doppelklick
      Löschen des angeklickten Punktes

  • rechte Maustaste (Kontextmenü)
    Siehe unten!

Kontextmenü

  • vorheriger Kartenausschnitt (F9) bewirkt die Anzeige des Kartenausschnittes, der vor der letzen Zoom- oder Verschiebeaktion angezeigt wurde.
    nächster Kartenausschnitt (Strg+F9) erlaubt das "Vorwärtsblättern" zum nächsten Kartenausschnitt.

  • Einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Karten-Element.

  • 2 x Vergrößern vergrößert die Karte zweifach an der geklickten Mausposition.

  • 2 x Verkleinern verkleinert die Karte zweifach.

  • 1:50.000, 1:25.000, 1:10.000 etc. zentriert die Karte an Mausposition und zoomt sie auf den gewählten Maßstab; "Maßstab ..." erlaubt die Angabe eines beliebigen Maßstabes.

  • Was ist hier? führt eine [image] Umgebungssuche für Koordinaten an der geklickten Mausposition aus

Menüfunktionen

Datei
Öffnen Polygon lädt eine bestehende Polygon-Datei (*.plg) von der Festplatte/Diskette.
Alternativ kann eine Polygon-Datei (*.plg) per Drag&Drop in den Polygon-Editor gezogen werden.
Importieren Polygon erlaubt es, ein Polygon aus einem momentan geladenen Layer oder einer einer auszuwählenden Shape-Datei zu importieren. Polygon importieren
Speichern Polygon (F2) speichert das aktuelle Polygon als Polygon-Datei (*.plg) auf Festplatte/Diskette.

Schnappschuss erstellen (F3) speichert den aktuellen Zwischenstand des Polygons als Polygon-Datei (*.plg) auf Festplatte/Diskette. Schnappschuss erstellen

Schnappschuss laden (F4) öffnet das Fenster zur Verarbeitung (Laden, Erstellen, Löschen und Anzeigen) von Schnappschüssen. Schnappschuss erstellen

Exportieren gibt die Karte in die Zwischenablage aus:

  1. als Bitmap

  2. als Windows-Metadatei
    Hinweis: Karten können aus der Zwischenablage direkt in Fremdprogramme eingefügt werden
    (z.B. Microsoft Word: Menü "Bearbeiten", Menüpunkt "Inhalte einfügen").
Drucken gibt die Karte auf dem Drucker aus.

Laden
Radius erlaubt es, Radien beliebiger Größe um einen Bestand anzuzeigen bzw. die Anzeige auszuschalten. Der Mittelpunkt kann wahlweise per Mausklick oder durch Auswahl eines georeferenzierten Betriebs aus der Betriebsdatei erfolgen. Radius anzeigen
Rasterkarten hinterlegen (Strg + R) lädt genau die topografischen Karten, die für den "aktuellen Bildschirmausschnitt" erforderlich sind. Rasterkarten hinterlegen

Polygon

Polygon zeichnen (Strg + Z) aktiviert den "Zeichnen-Modus" für Polygone.
Jeder Mausklick in die Karte setzt einen Eckpunkt des Polygons. Der Zeichnen-Modus wird mit einem Maus-Doppelklick beendet. Polygon editieren
Zeichnenmodus unterbrechen (Schaltfläche [image] ein-/ausschalten)
Der Zeichnenmodus kann beliebig oft unterbrochen werden, das heißt, die Tasten [image] Vergrößern, [image] Info, [image] Verschieben können weiterhin genutzt werden. Nach Nutzung der gewünschten Aktion ist der Zeichnenmodus wieder einzuschalten.

Punkt bearbeiten (Strg + B) erlaubt das Ändern und Löschen vorhandener und das Hinzufügen neuer Punkte. Polygon editieren
Rückgängig macht die letzte Änderung des Polygons rückgängig.

Polygon entlang Radius erstellen generiert ein "kreisförmiges" Polygon entlang des angezeigten Radius, der unter dem Menüpunkt "Laden - Radius" aktiviert wurde.

geometrische Operationen (Strg + G) ermöglicht es, das gezeichnete Polygon (Restriktionszone) anhand den Grenzen wählbarer Polygone (z.B. Kreis- und Gemeindegrenzen) zu verarbeiten (zusammenfassen, "zurechtschneiden", ausschneiden). geometrische Operationen [image] Polygon importieren

Exportieren gibt das geladene Polygon (bei nicht aktivem Zeichnen-Modus) als Datei aus:

  1. Layer

    • als Layer - erstellt einen neuen Layer und speichert das Polygon in ihm

    • zu Layer hinzufügen - fügt das Polygon zu einem auszuwählenden vorhandenen Layer hinzu

  2. Shape-Datei

    • als Shape-Datei - erstellt eine neue Shape-Datei und speichert das Polygon in ihr

    • zu Shape-Datei hinzufügen - fügt das Polygon zu einer auszuwählenden vorhandenen Shape-Datei hinzu

  3. KML-Datei

  4. GPX-Datei (es wird der Typ "Route" verwendet)

  5. WKT (Well Known Text)

Zwischenablage gibt das geladene Polygon (bei nicht aktivem Zeichnen-Modus) in verschiedenen Formaten in die Zwischenablage aus:

  1. KML-Datei

  2. GPX-Datei (es wird der Typ "Route" verwendet)

  3. WKT (Well Known Text)

  4. Punkte

Segment
Anfang markieren aktiviert einen Fragezeichen-Kursor zur Auswahl des Startpunktes des Segments in der Karte. (Uhrzeigersinn)
Ende markieren aktiviert einen Fragezeichen-Kursor zur Auswahl des Endpunktes des Segments in der Karte. (Uhrzeigersinn)
Löschen entfernt das markierte Segment aus dem Polygon.

Messen gibt die Länge des markierten Segments aus und kopiert sie bei Bedarf in die Zwischenablage. Die Länge eines Segment wird zusätzlich als Info in der Editier-Kontrolle angezeigt.

Exportieren gibt ein markiertes Segment oder bei aktivem Zeichnen-Modus die gesamte Linie als Datei aus:

  1. Layer
    Wird der Polygon-Editor aus dem Karten-Explorer heraus gestartet, können Linien (im Zeichnen-Modus) bzw. Segmente (Teile eines Polygons) in neuen oder vorhandenen Layern gespeichert werden (z.B. für die Planung von Zäunen).

    • als Layer - erstellt einen neuen Layer und speichert die Linien in ihm

    • zu Layer hinzufügen - fügt die Linie zu einem auszuwählenden vorhandenen Layer hinzu

  2. Shape-Datei

    • als Shape-Datei - erstellt eine neue Shape-Datei und speichert die Linien in ihr

    • zu Shape-Datei hinzufügen - fügt die Linie zu einer auszuwählenden vorhandenen Shape-Datei hinzu

  3. KML-Datei

  4. GPX-Datei (es wird der Typ "Route" verwendet)
    Damit ist es möglich, eine Route an ein GPS-Gerät zu übergeben (z.B. als Suchweg für die Kadaversuche).

  5. WKT (Well Known Text)

Zwischenablage gibt ein markiertes Segment oder bei aktivem Zeichnen-Modus die gesamte Linie in die Zwischenablage aus:

  1. KML-Datei

  2. GPX-Datei (es wird der Typ "Route" verwendet)

  3. WKT (Well Known Text)

  4. Punkte

Hinweis: KML, GPX und Punkte können direkt mit dem Menüpunkt "Erstellen - aus Zwischenablage" (Strg + V) aus der Zwischenablage im Karten-Explorer eingefügt werden.

Karte
Karte einpassen bewirkt die optimale Anpassung der Kartengröße an die Größe des Kartenelements.
Vorheriger Kartenausschnitt (F9) bewirkt die Anzeige des Kartenausschnittes, der vor der letzen Zoom- oder Verschiebeaktion angezeigt wurde (Zurückblättern).
Nächster Kartenausschnitt (Strg+F9) bewirkt die Anzeige des nächsten Kartenausschnittes nach dem "Zurückblättern".
Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.
2x Vergrößern (+ auf Zehnertastatur) vergrößert den Kartenausschnitt zweifach.
2xVerkleinern (- auf Zehnertastatur) reduziert die Größe der Karte zweifach.
Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen.
Tipp: Mit Strg + gedrückter linker Maustaste kann die Karte jederzeit verschoben werden.
Identifizieren (Strg + I) zeigt alle in der Merkmalsdatei vorhandenen Informationen zum mit der linken Maustaste angeklickten Geo-Objekt an. Geo-Objekte identifizieren
Suchen (Strg + S) startet einen Dialog, mit dem Geo-Objekte in den Merkmalsdateien der Layer gesucht und auf der Karte gezeigt werden. Damit ist z.B. die gezielte Suche nach Betrieben möglich. Geo-Objekte suchen
Geokodierung (Alt + G) gestattet es, über Geokodierung von Adressangaben Koordinaten zu ermitteln. Geokodierung
Umgebungssuche (Alt + U) führt eine [image] Umgebungssuche für Koordinaten aus. Mit Alt + W (Was ist hier?) geschieht dies für die aktuelle Mausposition auf der Karte.
Maßstab auswählen (Strg + M) erlaubt es, die Karten in einem frei wählbaren Maßstab anzuzeigen.
Zurücksetzen versetzt den Polygon-Editor in den Ausgangszustand. Eventuell angezeigte Polygone und Radien werden aus der Ansicht entfernt.

Aktualisieren (F5) bewirkt den Neuaufbau der Karten im Karten-Element.

Polygon editieren

Um ein neues Polygon zu erstellen, ist folgendermaßen vorzugehen:

  1. Optional: Mit [image] kann ein Radius wählbarer Größe um einen betroffenen Bestand gezogen werden. Radius anzeigen
    Es stehen dabei folgende Optionen zur Verfügung

    • Radius lediglich anzeigen, um das Zeichnen manuell vorzunehmen ... weiter mit 3.

    • Radius anzeigen und ein Polygon entlang des Kreisbogens automatisch erzeugen ... weiter mit 4.

  2. Mit [image] oder Strg+Z wird der "Zeichnen-Modus" aktiviert.
    Dieser Modus dient insbesondere zum Neuzeichnen eines Polygons. Er kann aber auch zum Weiterzeichnen eines geladenen Polygons verwendet werden (Bsp.: Ein Kreis zeichnet ein Restriktionsgebiet bis zur Kreisgrenze und schickt es zur Vervollständigung an den Nachbarkreis). Jeder Mausklick in die Karte setzt einen Eckpunkt des Polygons. Der Zeichnenmodus wird mit einem Maus-Doppelklick oder Betätigung der Schaltfläche [image] beendet.
    Bitte beachten Sie insbesondere die Regeln zum Erstellen von Polygonen.

  3. Das Polygon kann jetzt (wie weiter unten beschrieben) nachträglich bearbeitet und mit [image] gespeichert werden.

Um ein Polygon zu bearbeiten (ändern), ist folgendermaßen vorzugehen:

  1. Laden, [image] importieren oder [image] erstellen Sie zunächst ein Polygon. Die Eckpunkte des Polygons werden als grüne Punkte angezeigt. Diese Punkte können geändert (versetzt), gelöscht bzw. neue Punkte können hinzugefügt werden.

  2. Verschieben bzw. vergrößern Sie den gewünschten Kartenausschnitt, um den betreffenden Punkt optimal bearbeiten zu können..

  3. Wählen Sie einen Punkt aus, um ihn zu ändern, zu löschen oder hinter ihm einen neuen Punkt einzufügen. Dafür gibt es zwei Herangehensweisen, die zum selben Ergebnis führen. Die unter Punkt a. beschriebene Methode des Markierens per Mausdoppelklick ist im Allgemeinen intuitiver.

    1. Bearbeiten per Mausdoppelklick
      Markieren Sie den gewünschten Punkt per Mausdoppelklick (der daraufhin rot hervorgehoben wird) und wählen Sie danach die gewünschte Option (Ändern Punkt, Neuer Punkt, Löschen Punkt) aus dem angezeigten Kontextmenü aus.

      Hinweis:
      Wird beim Doppelklick auf einen Punkt die Steuerungs-, Umschalt oder Alt-Taste gedrückt gehalten, wird die gewünschte Aktion sofort ausgeführt, ohne das Kontextmenü anzuzeigen.

      Entsprechend der gewählten Option ist wie folgt zu verfahren:
      Ändern Punkt: Der Kursor erscheint als Fadenkreuz. Per Mausklick wird der Punkt auf die angeklickte Position versetzt.
      Neuer Punkt: Der Kursor erscheint als Fadenkreuz. Per Mausklick wird ein neuer Punkt auf die angeklickten Position (im Uhrzeigersinn hinter dem ausgewählten Punkt) eingefügt.

    2. Bearbeiten per Schaltfläche
      Betätigen Sie die Schaltfläche [image] und wählen Sie die gewünschte Option (Ändern Punkt, Neuer Punkt, Löschen Punkt bzw. 'Als Endpunkt festlegen') aus. Es erscheint ein Fragezeichen neben dem Kursor zur Auswahl des Punktes. Entsprechend der gewählten Option ist wie folgt zu verfahren:
      Ändern Punkt: Markieren Sie den zu ändernden Punkt. Der selektierte Punkt wird rot hervorgehoben und der Kursor erscheint als Fadenkreuz. Per Mausklick wird der Punkt auf die angeklickte Position versetzt.
      Neuer Punkt: Markieren Sie den Punkt, hinter dem der neue Punkt in Uhrzeigerrichtung eingefügt werden soll. Der selektierte Punkt wird rot hervorgehoben und der Kursor erscheint als Fadenkreuz. Per Mausklick wird ein neuer Punkt auf die angeklickten Position eingefügt.
      Löschen Punkt: Wählen Sie den zu löschenden Punkt per Mausklick aus.
      Als Endpunkt festlegen: Wählen Sie den Punkt aus, der neuer Endpunkt sein soll aus.

      Was ist der Endpunkt?
      Der Endpunkt wird beim Zeichnen eines Polygons verwendet. Man kann den Endpunkt an eine bestimmte Stelle setzen und ab dort weiterzeichnen. Dies kann hilfreich sein, wenn man eine bestimmte "Stelle" im Polygon nachbearbeiten möchte. Prinzipiell kann man auch einzelne Punkte löschen, ändern und einfügen, aber bei größeren Nacharbeiten ist es oft einfacher, Bereiche von Punkten zu löschen und die Zeichenfunktion [image] zu verwenden und die Option "Polygon vervollständigen" zu wählen.

      Bis Endpunkt im Uhrzeigersinn löschen: Es ist ein Punkt auszuwählen. Alle Punkte vom angeklickten Punkt bis (im Uhrzeigersinn laufend) zum Endpunkt werden gelöscht.

      Anfang Segment markieren und Ende Segment markieren erlaubt es, einen beliebigen Abschnitt des Polygons zu markieren, um ihn mit dem Menü "Segment" zu löschen


Polygon speichern

Bildschirm zeigen

Mit der Schaltfläche [image] wird der Dateiname (*.plg) angegeben, unter dem das Polygon gespeichert werden soll. Optional können Name, die SO-Nummer und die Maßnahme (Sperrgrund) angegeben werden. Diese optionalen Angaben werden in der Polygon-Datei gespeichert.


Radius anzeigen

Bildschirm anzeigen

Diese Programmfunktion wird vom [image] Polygon-Editor aufgerufen und dient der "Erzeugung" von Radien wählbarer Größe, die die Digitalisierung von Polygonen (Restriktionszonen wie Sperrbezirke, Beobachtungsgebiete etc.) erleichtern.

Koordinaten für Kreismittelpunkt

Ist die Option Koordinaten per Mausklick festlegen aktiviert, wird der Kreismittelpunkt (nach Verlassen dieses Fensters) über einen Mausklick in die Karte festgelegt.

Ist die Option Adresse verwenden aktiviert, können die Koordinaten für den Mittelpunkt des Kreises über die Schaltfläche [image] gewählt werden. Geokodierung

Die Option Koordinaten manuell eingeben erlaubt es, die gewünschten Koordinaten direkt einzugeben. Wenn die Koordinaten nicht in der benötigten Projektion vorliegen, kann mit der Schaltfläche [image] eine Programmfunktion aufgerufen werden, die die Eingabe und Umrechnung von Koordinaten aus anderen Koordinatensystemen erlaubt. Koordinaten umrechnen

Radius

Aus der Optionsfeldgruppe Radius ist der gewünschte Radius auszuwählen (0,5 km, 1 km, 3 km oder 10 km). Wird das Optionsfeld ? km selektiert, ist im benachbartem Eingabefeld ein Wert für den Radius zwischen 0,1 und 999,9 km anzugeben.

Das Kontrollkästchen Kreis schraffiert darstellen schaltet die Schraffur des anzuzeigenden Kreises ein/aus.

Das Kontrollkästchen Polygon entlang des Kreisbogens erstellen erlaubt es, neben der Anzeige eines Radius ein Polygon mit 120 Eckpunkten entlang des Radius zu erzeugen.


Polygon-Editor - Geometrische Operationen

Geometrische Operationen

Bildschirm anzeigen

Das im Polygon-Editor gezeichnete Polygon (Restriktionszone) kann mit einem (oder mehreren) Polygonen wie Gemeinden, Kreisen anderen Restriktionszonen manipuliert werden.

Zunächst ist bei der Art der Operation festzulegen, ob ein Polygon mit der Restriktionszone zusammengefasst werden soll (Union), ob die gemeinsame Fläche der Restriktionszone mit einem anderen Polygon ermittelt werden soll (Durchschnitt, ersetzt die frühere Funktion des "Zurechtschneidens") oder ein Polygon von der Restriktionszone abgezogen werden soll.

Im nächsten Schritt erfolgt die Auswahl des Polygons (auch Wunsch über Mehrfachauswahl auch mehrere angrenzende Polygone). Dabei können Polygone aus bereits geladenen Layern (z.B. Gemeindegrenzen) oder beliebige Shape- und Polygondateien verwendet werden.

Die folgende Übersicht zeigt, wie die Restriktionszone (blau) in Verbindung mit einem weiteren selektierten Polygon (gelb) entsprechend der Auswahl der geometrischen Operation manipuliert werden würde:

beteiligte Polygone | geometrische Operation | resultierendes Polygon
 | Union |
 | Durchschnitt |
 | Differenz |


Schnappschuss erstellen (Polygon-Editor)

Schnappschuss erstellen

Bildschirm zeigen

Diese Programmfunktion wird vom Polygon-Editor aufgerufen und dient dem Erstellen eines Zwischenstand beim Zeichnen von Polygonen als Polygon-Datei (*.plg) auf einem Datenträger. Damit ist es möglich, während der Arbeit mehrere Versionen eines Polygons zu erhalten, um sie bei Bedarf wieder zu reaktivieren, was für die Diskussion alternativer Varianten von Restriktionszonen (RZ), aber auch als Sicherheitskopie bei Datenverlust (technische Probleme wie Abstürze und Netzwerkausfall, Bedienfehler oder versehentliches Löschen usw.) sinnvoll ist.

Schnappschuss erstellen

Mit der Schaltfläche [image] oder durch Betätigen von F3 im Polygon-Editor wird ein neuer Schnappschuss, also eine neue Polygon-Datei erstellt. Dabei wird der angegebene Dateiname und das ausgewählte Verzeichnis verwendet. Vor dem Erstellen des ersten Schnappschusses sollten hier die gewünschten Angaben getätigt bzw. ausgewählt werden. Über die Hyperlinks (Eigene Dateien, Temporäre Dateien, Dokumente und Snapshot (wird automatisch unterhalb des Verzeichnis 'Eigene Dateien' des angemeldeten Benutzers erstellt)) kann schnell ein Standardverzeichnis des Systems bzw. von TSN eingestellt werden. Alternativ kann ein beliebiges Verzeichnis mit der Schaltfläche [image] ausgewählt werden.

Die Angabe eines aussagekräftigen Dateinamens für den Schnappschuss kann hilfreich sein, um die Dateien später auf dem Datenträger zuordnen zu können. Vom System wird 'Schnappschuss' vorinitialisiert und dann bei jedem Erstellen eines Schnappschusses weitergezählt, z.B. Schnappschuss(1).plg, Schnappschuss(2).plg usw.

Hinweis: Wird der Polygon-Editor aus dem Krisen-Explorer heraus zum Erstellen bzw. Ändern einer RZ aufgerufen, wird die Kennung der RZ in den Dateinamen integriert wie z.B. Schnppschuss_21-15-00001#01.

Schnappschuss-Liste

Die Schnappschuss-Liste enthält alle während der aktuellen Polygon-Editor-Sitzung erstellten Schnappschüsse. Es können jedoch auch beliebig viele bereits vorhandene Schnappschüsse (bzw. Polygon-Dateien *.plg) per Drag&Drop aus einem Verzeichnis in die Liste gezogen oder mit der Schaltfläche [image] hinzugefügt werden.

Hinweis: Wird der Polygon-Editor aus dem Krisen-Explorer heraus zum Erstellen bzw. Ändern einer Restriktionszone aufgerufen, werden ggf. vorhandene Schnappschüsse mit der Kennung der RZ gesucht und automatisch in die Liste geladen.

Schaltflächen und Kontextmenü
 | Schnappschüsse zur Liste hinzufügen öffnet einen Dateiauswahl-Dialog und erlaubt es, eine oder mehrere bestehende Polygon-Datei (*.plg) von einem Datenträger zu laden.
 | auf Karte anzeigen malt den Umriss und eine Schraffur des markierten Polygons auf die Karte im Polygon-Editor. Alternativ kann die Auswahl dieser Funktion auch über die Eingabetaste oder Mausdoppelklick auf den gewünschten Eintrag erfolgen.
 | in Polygon-Editor laden öffnet die Polygon-Datei zur Weiterverarbeitung im Polygon-Editor. Diese Funktion kann alternativ über STRG + Eingabetaste oder STRG + Mausdoppelklick auf einen Eintrag aufgerufen werden.
 | aus Liste entfernen löscht den markierten Eintrag aus der Liste, jedoch nicht die zugehörige Datei vom Datenträger.
 | alle aus Liste entfernen löscht alle Einträge aus der Liste ohne die zugehörigen Dateien vom Datenträger zu löschen.
 | löschen entfernt den Eintrag aus der Liste und löscht die zugehörige Datei vom Datenträger.
 | alle löschen entfernt alle Einträge aus der Liste und löscht die zugehörigen Dateien vom Datenträger.
 | Schnappschuss von der Karte entfernen löscht die aktive Anzeige eines Schnappschusses von der Karte.

Löschen der Schnappschüsse beim Schließen des Polygon-Editors
Werden während einer Sitzung des Polygon-Editor Schnappschüsse angefertigt. so kann hier vorab eingestellt werden, ob diese beim Schließen des Polygon-Editors erhalten bleiben sollen oder alle gelöscht, alle bis auf den letzen gelöscht oder vom Benutzer auswählbar gelöscht werden sollen.


Georeferenzierung

Bildschirm anzeigen

Dieses Fenster erlaubt die Anzeige und Georeferenzierung von Objekten (Betriebe, Ausbrüche usw.) auf der Grundlage der unter [image] Einstellungen-Standardprojekt "angemeldeten" Karten. Die Koordinaten werden per Mausklick in die Karte ermittelt und in die entsprechenden Eingabemasken übernommen.

Bei der Aktivierung des Fensters wird der Kartenausschnitt nach folgendem Schema positioniert. Sind die Koordinaten des Objektes bekannt, so werden diese in der Karte durch einen Punkt markiert. Die Karte wird auf diesen Punkt zentriert und gezoomt.

Das Fenster ist in zwei Bereiche untergliedert:

Kontrollbereich (rechts)
Kartenbereich (links)

Kontrollbereich

  • Der Mausmodus (Aktion beim Klick der linken Maustaste innerhalb der Karte) wird durch folgende vier Schaltflächen festgelegt:
Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.
Verkleinern reduziert die Größe der Karte.
Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen.
Tipp: Mit Strg + gedrückter linker Maustaste kann die Karte jederzeit verschoben werden.
Koordinate festlegen legt den markierten Punkt auf die angeklickte Position.
Hinweis: Geänderte Koordinaten werden nur nach Betätigen der Schaltfläche Ok in die jeweilige Erfassungsmaske übernommen.
  • Schaltflächen "Zurück", "Vor", "Radius" und "Einpassen":
Vorheriger Kartenausschnitt (F9) bewirkt die Anzeige des Kartenausschnittes, der vor der letzen Zoom- oder Verschiebeaktion angezeigt wurde (Zurückblättern).
Nächster Kartenausschnitt (Strg+F9) bewirkt die Anzeige des nächsten Kartenausschnittes nach dem "Zurückblättern".
Karte einpassen bewirkt die optimale Anpassung der Kartengröße an die Größe des Kartenelements.
markierten Punkt zentrieren bewirkt, dass der markierte Punkt auf dem Bildschirm zentriert und auf eine bestimmte Zielgebietsgröße "gezoomt" wird.
  • Schaltflächen "Geokodierung", "Koordinateneingabe", "Umgebungssuche" und "Suchen":
Geokodierung (Alt + G) gestattet es, über Geokodierung von Adressangaben Koordinaten zu ermitteln. Geokodierung
Koordinaten manuell eingeben erlaubt es, die Koordinaten per Hand einzugeben. Koordinaten eingeben
Umgebungssuche - Was ist hier? (Alt + W) führt eine [image] Umgebungssuche für den markierten Punkt aus.
Suchen (Alt + S) startet einen Dialog, mit dem Geo-Objekte in den Merkmalsdateien der Layer gesucht und auf der Karte gezeigt werden. Damit ist z.B. die gezielte Suche nach Straßen möglich, sofern entsprechende Layer geladen sind. Geo-Objekte suchen
  • Schaltflächen "Restriktionszonen", "Drucken", "Exportieren" und "Einstellungen":
Drucken gibt die Karte auf einem Drucker aus. Karte drucken
Exportieren erlaubt die Ausgabe der Karte in die Zwischenablage.
Hinweis: Karten können aus der Zwischenablage direkt in Fremdprogramme eingefügt werden (z.B. Microsoft Word: Menü "Bearbeiten", Menüpunkt "Inhalte einfügen").
Karteneinstellungen ermöglicht die Änderung der Standardeinstellungen für anzuzeigende Karten. Damit können anzuzeigende Kartenblätter festgelegt werden. Einstellungen-Standardprojekt
  • Symbolgröße festlegen
    Der Schieberegler Symbolgröße ändert die Größe des markierten Punktes.

  • Anzeige von Rasterkarten
    Der Bereich Rasterkarten legt die Anzeige von Rasterkarten (topografischen Karten) fest.

    Standardmäßig werden alle Karten, die unter [image] Einstellungen-Standardprojekt angemeldet worden sind geladen, jedoch werden Rasterkarten erst dann angezeigt, wenn der "Betrachtungsabstand" weniger als 1:50.000 beträgt. Ab dieser Entfernung "verschwimmen" Details auf der Rasterkarte; gleichzeitig benötigt das System bei wachsendem Betrachtungsabstand jedoch mehr Zeit für das Laden der Rasterinformationen. Die Vektorkarten (z.B. Gemeindegrenzen) werden weiterhin angezeigt und ermöglichen die Navigation auf der Karte. Wird die Karte vergrößert (näher als 1:50.000 in die Karte gezoomt), erscheinen die Rasterinformationen wieder.
    Sollte diese Funktionalität nicht erwünscht sein, kann über die drei Optionsfelder festgelegt werden, ob Rasterkarten immer, ab 1:50.000 oder nie angezeigt werden sollen.

    Wenn unter [image] Einstellungen-Standardprojekt keine Rasterkarten angemeldet worden sind (i.d.R. bei Zentralen für Bundesländer, Regierungspräsidien und Krisenzentren), erscheint die Ausschrift "keine Rasterkarten geladen". Mit der Schaltfläche Hinterlegen können die Rasterkarten für den aktuellen Bildschirmausschnitt automatisch geladen und angezeigt werden.

Kartenbereich

Mausfunktionen

  • linke Maustaste
    Die Funktion der linken Maustaste hängt vom im Menü Karte eingestellten Modus ab und wird durch folgende Mauskursor symbolisiert:
    Vergrößern, [image] Verschieben, + Georeferenzieren

  • Strg + linke Maustaste
    Diese Kombination erlaubt jederzeit das Verschieben der Karte mit gedrückter linker Maustaste.

  • Alt + linke Maustaste
    Führt eine Suche nach der Hausadresse (per Web-Service) an der geklickten Position aus und zeigt.

  • Strg + Mausrad drehen

    • nach oben drehen = Vergrößern

    • nach unten drehen = Verkleinern

  • rechte Maustaste (Kontextmenü)
    Siehe unten!

Kontextmenü

  • Was ist hier (Alt + W) führt eine [image] Umgebungssuche an der geklickten Position aus.

  • vorheriger Kartenausschnitt (F9) bzw. nächster Kartenausschnitt (Strg + F9) bewirkt das "Blättern" innerhalb der Kartenausschnitte, die vor den letzen Zoom- oder Verschiebeaktionen angezeigt wurden.

  • Einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Karten-Elements.

  • 2 x Vergrößern vergrößert die Karte zweifach an der geklickten Mausposition.

  • 2 x Verkleinern verkleinert die Karte zweifach.

  • 1:50.000, 1:25.000, 1:10.000 etc. zentriert die Karte an der Mausposition und zoomt sie auf den gewählten Maßstab; "Maßstab ..." erlaubt die Angabe eines beliebigen Maßstabes.

  • Die Koordinaten der mit der rechten Maustaste angeklickten Position oder die Koordinaten des georeferenzierten Punktes können mit den zugehörigen Menüpunkten in die Zwischenablage kopiert und z.B. in Excel eingefügt werden.

Tipp:

  1. rechte Maustaste: Die rechte Maustaste im Karten-Element aktiviert ein Kontextmenü, das verschiedene Optionen zum Vergrößern und Verkleinern bietet.

  2. Zurück zum vorhergehenden Kartenausschnitt: Benutzen Sie die Funktionstaste F9, um zum vor der letzten Zoom- oder Verschiebeaktion aktiven Kartenausschnitt zu wechseln.

  3. Geokodierung: Verwenden Sie Tastenkombination Alt + G um Orte, Straßen und Hauskoordinaten über Geokodierung zu ermitteln.

Statuszeile

  • Name des Betriebs (bei der Georeferenzierung eines Betriebs)
  • Rechtswert (X), Hochwert (Y) des markierten Punktes
  • Rechtswert (X), Hochwert (Y) der Mausposition
  • aktueller Maßstab

Durch Betätigen der Schaltfläche Ok werden die Koordinaten des markierten Punktes in die Erfassungsmaske des aufrufenden Fensters übernommen. Die Schaltfläche Abbrechen bewirkt das Schließen des Fensters ohne die Koordinaten zu übernehmen.


Geokodierung

Bildschirm anzeigen

Dieses Fenster erlaubt in erster Linie die die Ermittlung von Hauskoordinaten aus Adressen, aber auch die Suche nach Postleitzahlen, Orten, Straßen und Hausnummern für die gesamte Bundesrepublik auf Basis eines Web-Services des BKG.

Die Angaben zu PLZ (Alt + P), Ort (Alt + O), Straße (Alt + S) und Hausnummer (Alt + H) sind die die Eingabefelder einzugeben oder können mit der Schaltfläche [image] bzw. Strg + V aus der Zwischenablage eingefügt werden. Mit der Schaltfläche [image] (Strg + H) wird nach einer Hausnummer und damit exakten Adresse gesucht. Wird genau eine (eindeutige) Adresse gefunden, erscheint in der Statuszeile die Ausschrift Treffer, ist die Adresse mehrdeutig, wird eine Vorschlagsliste mit maximal 1000 Einträgen erstellt.

Bei der Geokodierung können auch die Koordinaten von PLZ, Orten und Straßen ermittelt werden. Während eine Haus eine exakte Koordinate einer Adresse darstellt, sind die Koordinaten von PLZ, Orten und Straßen lediglich ein Referenzpunkt/Zentroid des jeweiligen Geo-Objekts.

Die Schaltflächen mit dem Fernglas suchen nach PLZ (Strg + P), Ort (Strg + ) oder Straße (Strg + S)
Haus (Strg + H) sucht nach Hausnummern
Neue Suche (Strg + N) leert alle Eingabefelder und löscht die Ergebnisliste.
Änderungen rückgängig machen stellt die Eingabefelder auf die Werte vor der letzten Suche zurück.
Auf Karte zeigen (Strg + K) zeigt die Position des gewählten Elements durch Blinken auf der Karte an.
Die Anzeige auf der Karte kann auch per Doppelklick mit der Maus oder das Betätigen der Eingabetaste ausgelöst werden.
Layer erstellen (Strg + L) erzeugt einen Layer aus dem Geo-Objekt/den Geo-Objekten der Ergebnisliste.
aus Zwischenablage einfügen (Strg + V) analysiert den Inhalt der Zwischenablage und fügt ihn in die Eingabefelder ein, sofern eine Adresse erkannt wurde. hier
in Zwischenablage kopieren (Strg + C) gibt die Attribute des Geo-Objekts/der Geo-Objekte der Ergebnisliste in die Zwischenablage aus und zeigt sie optional in Excel an.

  • Suche nach Hausnummern

    • Es sind mindestens PLZ und/oder Ort, Straße und Hausnummer anzugeben

    • Wird die Adresse eindeutig gefunden, erfolgt in der Statuszeile die Ausschrift „Treffer“

      • A: Koordinate innerhalb Haus – Haus existiert

      • B: Koordinate innerhalb Flurstück – Haus existiert

    • Beispiel für eine Suche:

    • Ergebnis

      • Die Adresse wird gefunden – Treffer Typ A!

      • Eingabefelder, in denen das Suchergebnis fehlende Werte ergänzt, werden gelb hinterlegt.

  • Weitere Suchmöglichkeiten – unscharfe Suche

    • Es kann nach beliebigen PLZ, Orten, Straßen usw. gesucht werden

      • PLZ: 17039 und Strg + O → findet 28 Orte, die die PLZ 17039 haben

      • Ort: Greifswald und Strg + S → findet 356 Straßen in Greifswald

      • Straße: Netzebander und Strg + H → findet 31 Häuser in einer Straße mit ‚Netzebander‘

    • Es können Fragmente angegeben werden

      • PLZ: 17 und Strg + P → findet 75 PLZ, die mit 17 beginnen

      • PLZ: 17 und Strg + O → findet 226 Orte, deren PLZ mit 17 beginnt

      • Ort: Greifswald, Straße: Karl und Strg + H → findet 110 Häuser in Straßen mit Karl


Umgebungssuche - Was ist hier?

Bildschirm anzeigen

Dieses Fenster erlaubt die Ermittlung von geografischen Objekten (Postleitzahlen, Orte, Straßen, Hausnummern und geografische Namen) in einem wählbaren Radius um eine Koordinate. Es wird ein Web-Service des BKG verwendet.

Koordinaten

Die Umgebungssuche wird auch reverse Geokodierung genannt, weil hier von der Koordinate ausgehend das geografische Objekt ermittelt wird. Beim Aufruf dieser Programmfunktion über den Mechanismus "Was ist hier?" des Karten-Explorers (Alt + W oder Kontextmenü) werden die Koordinaten mit der aktuellen Position auf der Karte initialisiert.

Alternativ können die Koordinaten eingegeben oder aus der Zwischenablage eingefügt werden. Die Koordinaten sind als geografische Koordinaten (in der Reihenfolge X-Wert bzw. Longitude, Y-Wert bzw. Latitude) einzugeben. Beim Einfügen eines Koordinatenpaars über die Zwischenablage sorgt die implementierte Logik dafür, dass die Umrechnung von projizierten Koordinaten (z.B. UTM) in geografische Koordinaten automatisch erfolgt oder dass die Eingabereihenfolge von geografischen Koordinaten automatisch erkannt wird. Detaillierte Hinweise dazu finden Sie [image] hier.

Optionen

Per Vorgabe werden in einem Radius von 500 Metern die maximal 20 nächstgelegenen Objekten gesucht und in der Ergebnisliste angezeigt. Die Entfernung jedes Objektes von der Such-Koordinate (Mittelpunkt des Radius) wird in Klammern angezeigt. Der Radius kann durch Auswahl oder Eingabe beliebig geändert werden, die Anzahl der möglichen Vorschläge in der Ergebnisliste kann durch Auswahl oder Eingabe auf (schnittstellenseitig) maximal 1000 Vorschläge modifiziert erweitert werden.

Der Filter legt fest, ob nach Hausnummern, Orten, Straßen, PLZ oder geografischen Namen gesucht werden soll. Dabei ist zu beachten, dass lediglich Hausnummern eine exakte Position markieren und alle anderen Objekttypen lediglich einen zentralen Referenzpunkt des Objektes (z.B. Zentrum eines Ortes) angeben.

Die Sortierung ist auf die "Entfernung" vom Mittelpunkt voreingestellt, kann alternativ auch auf "Alphabet" geändert werden, um gezielt nach Objekten zu suchen.

Schaltflächen

aus Zwischenablage einfügen (Strg + V) analysiert den Inhalt der Zwischenablage und fügt ihn in die Eingabefelder ein, sofern eine Koordinate erkannt wurde. hier
Objekte suchen (Strg + S) startet die Suche nach den im Filter eingestellten Objekten (PLZ, Ort, Straße, Haus oder Geo-Name)
Auf Karte zeigen (Strg + K) zeigt die Position des gewählten Elements durch Blinken auf der Karte an.
Die Anzeige auf der Karte kann auch per Doppelklick mit der Maus oder das Betätigen der Eingabetaste ausgelöst werden.
Layer erstellen (Strg + L) erzeugt einen Layer aus dem Geo-Objekt/den Geo-Objekten der Ergebnisliste.
in Zwischenablage kopieren (Strg + C) gibt die Attribute des Geo-Objekts/der Geo-Objekte der Ergebnisliste in die Zwischenablage aus und zeigt sie optional in Excel an.


Routenberechnung

Bildschirm anzeigen

Dieses Fenster erlaubt die Ermittlung von Routen zwischen bis zu 50 Wegepunkten über einen Web-Service des BKG. Die Routen können auf der Karte angezeigt und Routenbeschreibungen in Excel ausgegeben werden. Die vom BKG verwendete Kartengrundlage erlaubt die weltweite Berechnung von Routen!

Einfügen von Wegepunkten

Um Wegepunkte in die Liste einzufügen, können folgende Methoden benutzt werden:

  • Ermitteln von Wegepunkten über [image] Geokodierung

  • Einfügen von Wegepunkten aus der Zwischenablage

    • Tabelle mit Koordinaten und/oder Adressen

    • Shape-Datei vom Typ "Punkt"

  • Öffnen einer Shape-Datei vom Typ "Punkt"

  • Drag&Drop von Layern vom Typ "Punkt "aus der Layer-Kontrolle oder Shape-Dateien aus einem Windows-Dateifenster

  • Einfügen von Koordinaten aus einer [image] Umgebungssuche

Wegepunkte bearbeiten

Wegepunkte können per Drag&Drop an die gewünschte Position in der Tabelle gezogen werden. Beachten Sie, dass die Reihenfolge der Wegepunkte der Reihenfolge der Ziele bei der Routenberechnung (Start, Zwischenziele, Ziel) entspricht.

Bei einem Doppelklick auf einen Eintrag öffnet sich (sofern eine Adresse vorhanden ist) die Programmfunktion [image] Geokodierung oder die Programmfunktion [image] Umgebungssuche, sofern keine Adresse, jedoch Koordinaten vorhanden sind.

Um den markierten Eintrag zu löschen, ist die Schaltfläche [image] oder die Tastenkombination Strg + Entf zu verwenden.

Routenoptionen

Verkehrsmittel:

  • Auto

  • Schwerlastverkehr

  • Fahrrad

  • Fußgänger

Route:

  • schnellste

  • kürzeste

Sprache für Navigationsanweisungen:

  • deutsch

  • englisch

  • französisch

Schaltflächen

 | Route berechnen (Strg + B oder Eingabetaste) startet die Berechnung für die angegebenen Wegepunkte entsprechend der eingestellten Routenoptionen.
 | Geokodierung (Strg + G) gestattet es, über Geokodierung von Adressangaben Koordinaten zu ermitteln. Geokodierung
 | aus Zwischenablage einfügen (Strg + V) analysiert den Inhalt der Zwischenablage und fügt Wegepunkte ein, sofern es sich um eine Shape-Datei vom Typ "Punkt" handelt bzw. eine Tabelle mit Koordinaten und/oder Adressen erkannt wurde. hier Tipp: Mit Alt + C kann eine Koordinate (mit ↑ + Alt + C eine Liste von Koordinaten) im Karten-Explorer in die Zwischenablage kopiert und mit dieser Programmfunktion als Wegepunkt zur Routenberechnung eingefügt werden.
Öffnen-Dialog anzeigen | aus Shape-Datei einfügen fügt Wegepunkte aus einer auszuwählenden Shape-Datei vom Typ "Punkt" ein. Alternativ kann ein Layer vom Typ "Punkt" per Drag&Drop aus der Layer-Kontrolle ins Fenster der Routenberechnung gezogen werden.
 | Umgebungssuche (Strg + U) führt eine [image] Umgebungssuche in einem Radius um anzugebende Koordinaten aus, um mögliche Wegepunkte zu ermitteln.
 | Auf Karte zeigen (Strg + K) zeigt den markierten Wegepunkt auf der Karte an.
 | Neue Suche (Strg + N) entfernt alle Wegepunkte aus der Liste.
 | Löschen (Strg + Entf) entfernt den markierten Wegepunkt aus der Liste.
 | Layer erstellen (Strg + L) erzeugt einen Layer vom Typ "Linie" mit der Route und optional einen weiteren Layer vom Typ "Punkt" mit Navigationsanweisungen.
 | in Zwischenablage kopieren (Strg + C) gibt die Navigationsanweisungen in die Zwischenablage aus.
 | in Excel anzeigen (Strg + E) öffnet die Navigationsanweisungen in einer Excel-Tabelle.


Karten mit FLI-Maps

FLI-Maps

Der Karten-Explorer unterstützt die Ausgabe von Karten in "FLI-Maps". Dazu generiert der Karten-Explorer eine so genannte KML-Datei (Keyhole Markup Language) und übergibt diese an einen Server am FLI, der die Karte verarbeitet und in einem Internet-Browser darstellt. Für die Darstellung einer Karte auf "FLI-Maps" ist der Menüpunkt [image] "Export - KML (FLI-Maps)" im Karten-Explorer zu verwenden. KML exportieren

Vorteile:

  • Mit einer Vielzahl von Hintergrund-Karten kombinierbar (BKG, Google, OpenStreetMap usw.)

  • Keine Übertragung von sensiblen Daten auf Server privater Unternehmen

  • Karten können mit einer Lebensdauer versehen werden.

  • Per weitergeleitetem Link kann Dritten Zugriff auf die Karten erlaubt werden.

  • Unhabhängigkeit von Installationen


Karten mit Google Earth und Google Maps

Google Earth und Google Maps

Der [image] Karten-Explorer unterstützt die Darstellung in "Google Earth" und "Google Maps". Dazu wird eine so genannte KML-Datei (Keyhole Markup Language) generiert und diese an die entsprechende Anwendung zur Anzeige auf hoch auflösenden Satellitenbildern übergeben.

Die beiden Google-Applikationen sind in der Lage, Dateien mit den Erweiterungen *.kml oder *.kmz anzuzeigen. Dabei stellt die KMZ-Datei lediglich eine als Zip-Archiv komprimierte KML-Datei dar.

Haftungsausschluss

Die Verwendung von Software der Firma Google erfolgt in Verantwortung der Nutzer des Karten-Explorers, dass heißt, auf deren eigene Gefahr. Die Software Karten-Explorer liefert lediglich ein Werkzeug zur Erstellung der von diesen Anwendungen verarbeiteten Das FLI übernimmt für die Nutzung von "Google Earth" bzw. "Google Maps" keinerlei Haftung, insbesondere für eventuell in der Zukunft geänderte Lizenzbedingungen für die Nutzung der Anwendungen oder für die Verletzung von individuellen Datenschutzbestimmungen der Einrichtungen, die den Karten-Explorer nutzen.

Google Earth

"Google Earth" ist eine Software, die -wie der Karten-Explorer- auf dem PC, Notebook oder WTS (Windows Terminalserver) installiert sein muss, um die Informationen aus TSN anzeigen zu können. "Google Earth" bietet komfortablen Zugriff auf hoch auflösende Satellitenbilder und ermöglicht die individuelle Gestaltung der Karten.

Vorteile

  • Individuelle Einfärbungen
  • Layer-Kontrolle zum Ein- und Ausblenden von Informationen
  • Suchen und Identifizieren
  • Hinzufügen von Objekten (Punkte, Polygone)
  • Routenberechnungen (Wegbeschreibungen) können erstellt werden, Touren können visualisiert werden
  • Messen von Entfernungen
  • Export als KML- oder KMZ-Datei
Darstellungen in Google Earth können folgendermaßen gespeichert werden:

Ausgaben des Karten-Explorers werden in "Google Earth" unter "Temporäre Orte" aufgeführt. Klicken Sie jetzt mit der rechten Maustaste auf den Eintrag "TSN-Lagedarstellung" und wählen Sie aus dem Kontextmenü den Eintrag "Speichern unter". Sie können auswählen, ob Sie eine KMZ- oder KML-Datei erstellen wollen. Diese Dateien können auf jedem PC geöffnet werden, auf dem Google Earth installiert ist.

Nachteile:

  • Software "Google Earth" muss auf der Maschine installiert sein
  • hohe Mindestanforderungen an die Hardware (Hauptspeicher, Grafikkarte)
  • hoher Ressourcenbedarf im Betrieb
  • problematische Multiuserfähigkeiten, die dem Einsatz auf einem WTS entgegenstehen

Google Maps

Im Gegensatz zu "Google Earth" erfordert "Google Maps" keine lokalen Software-Komponenten. Bei Vorhandenensein eines Internet-Browsers und Internetzugangs kann sofort auf "Google Maps" zugegriffen werden. Die Verarbeitung von Karten findet auf einem Server der Firma Google statt, der Internet-Browser zeigt lediglich die fertigen Karten an.

Problematisch ist jedoch, dass darzustellende Informationen zunächst zum Google-Server übertragen werden müssen.

Seit 2015 ist hierzu ein individuelles Nutzer-Konto bei Google notwendig, bei dem sich der Benutzer anmeldet und die als KML-Datei gespeicherte Karte auf einen Server von Google importiert.

Beachten Sie: Die nicht autorisierte Übertragung personenbezogener Daten an Dritte ist generell nicht gestattet.

Vorteile

  • Unhabhängigkeit von Installationen
  • ständige Verfügbarkeit
  • verschiedene Modi (Karte, Satellit, Gelände) vorhanden
  • Routenberechnungen

Nachteile

  • Anmeldung mit einem Konto bei Google erforderlich

  • Übergabe darzustellender Daten an 'Google Maps' erforderlich

  • Einfärbungen müssen in 'Google Maps' angepasst werden


Shapedatei konvertieren

Shape-Dateien konvertieren

Bildschirm anzeigen

Der Shape-Konverter ist ein einheitliches Werkzeug zum Importieren, Duplizieren, Transformieren und Exportieren von Shape-Dateien. Er erlaubt es simultan,

  • die Struktur der Attributs-Datei einer Shape-Datei zu ändern (Felder löschen, umbenennen, hinzufügen; Feldtyp- und Feldlänge ändern)

  • die Shape-Datei zu projizieren, das heißt, das Koordinatensystem, Bezugssystem, Streifen/Zone können geändert werden

  • den Zeichensatz zu ändern

  • Tabellenfilter auf die Shape-Datei anzuwenden, so dass gezielt nach Attributen selektiert werden kann.

Überblick über die Modi

  • Das Importieren versteht sich als das Konvertieren einer externen Shape-Datei für die Nutzung mit dem Karten-Explorer. Dabei wird eine anpassbare Kopie erstellt, die bei Bedarf die Shape-Datei in die momentan eingestellt Projektion überführt, inkompatible Feldnamen und Feldtypen umwandelt, den Zeichensatz von UTF-8 in ANSI konvertiert und nicht unterstützte Shape-Typen ("Null-Shapes", M-Shapes, Z-Shapes) bereinigt. Eine Shape-Datei kann über folgende Aktionen im Karten-Explorer importiert und als neuer Layer hinzugefügt werden:

    • Menüpunkt "Layer - Importieren" (Alt + I) oder

    • eine Shape-Datei wird per Drag & Drop in den Karten-Explorer gezogen und mit gedrückter Strg-Taste fallen gelassen.

  • Das Duplizieren dient im Karten-Explorer dazu, alle Konvertierungsmöglichkeiten des Shape-Konverters auf einen geladenen Layer anzuwenden und einen neuen (temporären) Layer zu generieren. Damit lassen sich zum Beispiel gezielt Layer erzeugen, die nach bestimmten Attributen gefiltert worden sind. Ein Layer kann wie folgt dupliziert werden:

    • Menüpunkt "Layer - Duplizieren - benutzerdefinierte Kopie" (↑ + D),

    • Kontextmenü der Layer-Kontrolle "Duplizieren - benutzerdefinierte Kopie" oder

    • ein Layer wird per Drag & Drop in das Karten-Element gezogen und fallen gelassen.

  • Das Transformieren dient dazu, einen geladenen Layer zu ändern, um zum Beispiel einen inkompatiblen Zeichensatz oder eine abweichende Projektion zu modifizieren. Die mit dem Layer assoziierte Shape-Datei wird dabei überschrieben. Eine Shape-Datei bzw. ein Layer kann wie folgt transformiert werden:

    • Menüpunkt "Layer - Transformieren" (Strg + T) im Karten-Explorer,

    • Kontextmenü der Layer-Kontrolle "Transformieren Layer" im Karten-Explorer,

    • Menüpunkt "Extras - Shape-Datei transformieren" im Hauptfenster der Anwendung.

  • Das Exportieren ermöglicht es, eine mit einem Layer assoziierte Shape-Datei in ein anderes Laufwerk/Verzeichnis zu exportieren und dabei bei Bedarf Projektion, Struktur und Zeichensatz zu modifizieren bzw. Filter anzuwenden. Beim Exportieren ist der Dateiname der zu erstellenden Shape-Datei unter Nutzung der Schaltfläche [image] anzugeben bzw. auszuwählen. Mit der Option [image] kann optional eingestellt werden, dass die Shape-Datei in ein Zip-Archiv komprimiert werden soll. Eine Shape-Datei bzw. ein Layer kann wie folgt exportiert werden:

    • Menüpunkt "Layer - Exportieren" im Karten-Explorer,

    • Kontextmenü der Layer-Kontrolle "Exportieren Layer" im Karten-Explorer,

    • ein Layer wird per Drag & Drop aus der Layer-Kontrolle aus dem Anwendungsfenster heraus gezogen und fallen gelassen oder

    • Menüpunkt "Extras - Shape-Datei exportieren" im Hauptfenster der Anwendung.

Struktur und Zeichensatz

Die Attribut-Datei einer Shape-Datei ist eine dBase-Datei (*.dbf), die jedem Geo-Objekt der Geometriedatei (*.shp) genau eine Zeile mit Attributen zuordnet. Beim Öffnen einer Shape-Datei wird die vorhandenen Struktur eingelesen und in der Tabelle angezeigt. Die Struktur kann auf Wunsch beliebig angepasst werden.

Wichtig: Der Karten-Explorer unterstützt den "normalen" dBase-Standard mit den Feldtypen "Zeichen", "Numerisch", "Datum" und "Logisch" sowie die Zeichensätze "ANSI" und "OEM". Für die Feldnamen gelten strenge Regeln (10 Zeichen, nur Großbuchstaben ohne Umlaute, Ziffern und der Unterstrich sind erlaubt; Feldnamen sind maximal 10 Zeichen lang). Da externe Shape-Dateien nach Aufweichung des ursprünglichen Standards häufig mit inkompatiblen Feldtypen (z.B. Float) und ungültigen Feldnamen (z.B. mit Umlauten) versehen sind, erlaubt der Shape-Konverter das Umwandeln aller inkompatiblen Typen und Schreibweisen. Felder vom Typ "Float" werden per Vorgabe in den Feldtyp "Numerisch" konvertiert. Der Zeichensatz "UTF-8" wird automatisch in "ANSI" konvertiert. Es ist zudem möglich, alle vorhandenen Felder beliebig umzubenennen, ihren Typ zu ändern, sie zu löschen oder die Reihenfolge zu ändern, ohne Datenverlust zu erleiden (außer Felder werden explizit gelöscht).

In der ersten Spalte der Tabelle signalisiert die Spalte "Status" den Änderungszustand durch ein Symbol. Die Ziffern neben dem Symbol geben die Nummer des Feldes in der Ursprungsdatei an, sofern es sich nicht um ein neu hinzugefügtes Feld handelt.

unverändert = ein vorhandenen Feld wurde nicht geändert

geändert = vorhandenes Feld wurde verändert
gelöscht = ein vorhandenes Feld wurde zur Löschung markiert
neu = das Feld wurde zur Struktur hinzugefügt

Folgende Schaltflächen, Tasten- und Mausfunktionen können zur Manipulation der Struktur verwendet werden:

Ein neues Feld wird hinzugefügt und das Fenster "Feld bearbeiten" aufgerufen. (alternativ "Einfg")

Das markierte Feld wird bearbeitet. (alternativ "Enter" oder Doppelklick mit der Maus)
Das markierte Feld wird zur Löschung markiert. Ein neu hinzugefügtes Feld wird sofort aus der Tabelle entfernt. (alternativ "Entf")
Alle vorhandenen Felder werden zur Löschung markiert, eventuell neu hinzugefügte Felder werden aus der Tabelle entfernt.
Bei markierten Feld werden alle Änderungen rückgängig gemacht. (alternativ Strg + Z)
Markiertes Feld an den Anfang der Tabelle bewegen. (alternativ Strg + Pos1)
Markiertes Feld eine Position nach oben bewegen. (alternativ Strg + ↑)
Markiertes Feld eine Position nach unten bewegen. (alternativ Strg + ↓)
Markiertes Feld an das Ende der Tabelle bewegen. (alternativ Strg + Ende)

Mit der Statistik-Funktion wird für jedes Feld entsprechend des Feldtyps folgende Berechnung durchgeführt:

  • Zeichen: die tatsächlich durch Daten verwendete Länge (von - bis)

  • Numerisch: der tatsächlich verwendete Bereich (kleinste bis größte Zahl)
  • Datum: Spanne (kleinstes bis größtes Datum)
  • Logisch: Anzahl "Ja" und "Nein" wird gezählt

Die Statistik-Funktion sollte genutzt werden, um die Länge der Felder zu optimieren. Gerade Felder vom Typ "Zeichen" werden häufig sehr lang gewählt und führen zu unnötig große dBase-Dateien.

Voransicht und Tabellenfilter

Die Voransicht gibt einen komfortablen Ausblick darauf, wie die Attributs-Datei aussehen würde, wenn die aktuellen Einstellungen für Struktur und Zeichensatz angewendet werden. Dazu wird eine größere Anzahl von Zeilen der realen dBase-Datei von der Festplatte in eine virtuelle Tabelle im Speicher eingelesen und entsprechend konvertiert. Um einen Kompromiss zwischen Geschwindigkeit bei der Anzeige und einer guten Nutzbarkeit für Tabellenfilter zu erreichen, wird in Abhängigkeit von Zeilen- und Spaltenanzahl der dBase-Datei ein sinnvoller Wert für die in die Voransicht einzulesenden Zeilen ermittelt, der manuell im entsprechenden Eingabefeld angepasst werden kann. Bitte beachten Sie jedoch, dass sehr große Attributs-Dateien nicht komplett in den Speicher eingelesen werden können und es ggf. zu Performanceeinbußen oder Stabilitätsproblemen kommen kann, wenn hier mehrere 100.000 Zeilen angefordert werden.

Voransicht aktualisieren (alternativ Strg + A)
Spaltenbreite anpassen (Strg + S)

Die Attribute werden entsprechend der gewählten Einstellungen für Struktur und Tabellenfilter in die Zwischenablage kopiert. Es werden alle Zeilen der Datei verarbeitet.

Die Attribute werden entsprechend der gewählten Einstellungen für Struktur und Tabellenfilter in Excel geöffnet. Es werden alle Zeilen der Datei verarbeitet.
Tabellenfilter ein-/ausschalten (Strg + T)

Eine Änderung des Zeichensatzes der Ursprungsdatei wird sofort auf die Voransicht angewendet, um dem Nutzer nach Möglichkeit sofort zu signalisieren, dass mit der gewählten Einstellung Umlaute korrekt verarbeitet werden. Eine Änderung der Struktur, also das Hinzufügen neuer oder Ändern/Löschen bestehender Felder wird nicht sofort auf die Voransicht angewendet, um bei größeren Modifikationen der Struktur nicht durch die Aktualisierung der Voransicht behindert zu werden. Dafür werden die geänderten Spalten in der Voransicht bis zur manuellen Aktualisierung mit der Schaltfläche [image] oder der Tastenkombination Strg + A farblich markiert:

Feld wurde zur Löschung markiert
Feldname und/oder Feldlänge wurde modifiziert
Der Feldtyp wurde geändert

Tabellenfilter

Mit dem Kontrollkästchen [image] wird der so genannte Tabellefilter aktiviert. Wird das Kontrollkästchen aktiviert, erscheint eine Fußzeile zur Eingabe von Bedingungen für Spaltenwerte. Es werden nur noch Einträge (Zeilen) angezeigt, deren Werte mit den Suchwerten in der Fußzeile übereinstimmen.
Tabellenfilter

Hinweis:
Der Filter wird zunächst nur auf die geladenen Zeilen in der Voransicht angewendet. Damit werden ggf. sehr viel weniger "gefilterte" Zeilen in der Voransicht angezeigt, als in der Attributs-Datei vorhanden sind. Bei Bedarf kann die Anzahl der Zeilen der Voransicht erhöht werden. In jedem Falle werden beim Erstellen der Shape-Datei alle Zeilen der Attributs-Datei verarbeitet und somit alle Geo-Objekte berücksichtigt, die der Filterbedingung entsprechen. Beim Modus "Transformieren", der letztendlich die ursprüngliche Shape-Datei überschreibt, gehen alle Einträge verloren, die der Filterbedingung nicht entsprechen.

Projektion von Quelle und Ziel festlegen

Über die zugehörige Schaltfläche [image] kann die Projektion der Quelldatei und die gewünschte Projektion für die konvertierte Shape-Datei eingestellt werden. Projektionsparameter auswählen

Die Projektion der Quelle wird beim Öffnen der Shape-Datei automatisch eingestellt, sofern es sich um eine mit dem Karten-Explorer erstellte Shape-Datei handelt (Parameter sind in der Shape-Datei gespeichert) oder eine externe Shape-Datei über eine PRJ-Datei verfügt, die interpretiert werden konnte. Für die Projektion der Zieldatei werden die aktuellen Einstellungen des Karten-Explorers eingestellt.

Folgende Symbole signalisieren die Zulässigkeit der Umrechnung (und eventuelle Rücktransformation).
 | Die Transformation ist in beide Richtungen möglich (Transformation kann wieder ohne nennenswerte Abweichungen umgekehrt werden).
 | Die Transformation ist möglich, die Transformation kann jedoch nicht mehr umgekehrt werden. Falls der Layer wieder in der jetzigen Projektion benötigt werden sollte, wären er in der Regel nicht mehr brauchbar. In diesem Falle sollte eine Kopie des Layers für die Transformation verwendet bzw. der Original-Layer gesichert werden.
 | Die Transformation des Layers ist nicht möglich.

Voransicht Projektion

Die Voransicht der Projektion kann helfen, die richtigen Parameter für die die Projektion insbesondere der Quelldatei zu finden, wenn diese nicht automatisch ermittelt werden konnte. Dabei wird ein grau hinterlegtes Rechteck angezeigt, welches die Ausdehnung der im Karten-Explorer geladenen Karten repräsentiert. Die Ausdehnung der Zieldatei, wenn sie denn mit den aktuell eingestellten Parametern projiziert werden würde, wird als farbiges Rechteck ebenfalls dargestellt. Dabei signalisiert ein grünes Rechteck, dass die Projektion umkehrbar möglich ist und ein gelbes Rechteck, dass die Projektion zwar möglich ist, die Zieldatei dann jedoch nicht weiter projiziert werden kann. Wenn eine Shape-Datei importiert werden soll, sollte die Zieldatei in der Regel in das graue Rechteck fallen oder dessen Nähe. Bei Exportieren (z.B. wenn achtstellige UTM-Koordinaten in sechsstellige (wie EPSG:25832) für eine externe Einrichtung konvertiert werden sollen), ist zu erwarten, dass die Zieldatei weit außerhalb des grauen Rechtecks liegt.

Hinweis:
Falls im Karten-Explorer, der dem Shape-Konverter zugeordnet ist, ein anderes Projekt geöffnet wird oder Layer hinzugefügt werden, kann die Voransicht (das graue Rechteck für die Ausdehnung im Karten-Explorer) mit der Schaltfläche [image] aktualisiert werden.


Projektionsparameter auswählen

Bildschirm anzeigen

Die gewünschten Einstellungen für [image] Koordinatensystem, Bezugssystem und Streifen sind entweder über die Kombinationsfelder oder direkt in der Tabelle mit den EPSG/ESRI-Codes auszuwählen.

Für die Eingabedaten und Ausgabedaten sind die entsprechenden Parameter anzugeben. Diese können frei kombiniert werden. Folgende Systeme werden unterstützt:

Koordinatensysteme
  • geografisch (dezimal)
  • LAEA
  • UTM8
  • UTM6 (6-stelliger Rechtswert)
  • UTM7 (7-stelliger Rechtswert)

  • Gauß-Krüger 3°-Streifen
Bezugssysteme
  • Potsdam Datum
  • Datum Pulkowo
  • WGS84

  • ETRS89
Streifen
  • UTM:
    29. bis 38. Streifen (Zone)
  • GK 3°-Streifen:
    1. bis 5. Streifen

Tabelle der EPSG/ESRI-Codes

Die Tabelle der EPSG/ESRI-Codes enthält die wichtigsten Projektionen, um mit dem TSN-System für Deutschland und Europa Daten austauschen zu können. Diese Codierungen werden häufig in GIS-Systemen verwendet und erleichtern die Kommunikation beim Austausch von Daten. Insbesondere werden diese Codierungen in den so genannten PRJ-Dateien verwendet, die häufig mit der Shape-Datei verteilt werden, um die Projektion derselben zu beschreiben. Alle in der Liste aufgeführten Projektionen/Codes sollten vom Karten-Explorer damit korrekt erkannt werden, wenn eine PRJ-Datei vorhanden ist.

Beachten Sie dazu folgende Hinweise:

  • das Symbol [image] kennzeichnet die EPSG/ESRI-Codes der im Rahmen des TSN bereitgestellten Rasterkarten

    • EPSG 4647 ist das TSN-Standardsystem der achtstelligen UTM-Koordinaten in der Zone 32

      • ESRI 102329 beschreibt die identische Projektion in einer eigenen ESRI-Codierung

    • EPSG 5650 steht für achtstellige UTM-Koordinaten in der Zone 33, die ggf. in den östlichen Bundesländern verwendet werden

      • ESRI 102360 beschreibt die identische Projektion in einer eigenen ESRI-Codierung

    • EPSG 3035 steht für das LAEA-System, für welches Rasterkarten für ganz Europa verfügbar sind und welches für jegliche Darstellung über die Grenzen Deutschlands hinweg dringend empfohlen wird!

  • das Symbol [image] kennzeichnet die Systeme, die für den Austausch mit externen Einrichtungen (Import/Export von Shape-Dateien) von besonderer Bedeutung sind, da hier in der Regel UTM-Koordinaten mit sechsstelligem Rechtswert zur Anwendung kommen. Werden Daten zwischen TSN und externen Einrichtungen ausgetauscht, sollten beim Import/Export folgende Codes verwendet werden:

    • für die Mehrzahl der Bundesländer in der Zone 32: EPSG 25832

    • für Bundesländer wie BB und SN in der Zone 33: EPSG 25833


Tabellenfilter

Bildschirm anzeigen

Mit der Schaltfläche [image] wird der Tabellenfilter ein- bzw. ausgeschaltet. Bei Aktivierung erscheint eine Fußzeile in der Tabelle, in der alle Zellen, die für die Eingabe von Bedingungen vorgesehen sind, farblich hervorgehoben dargestellt sind. Zeichenkettenfelder, numerische Felder und Datumsfelder werden dabei verschiedenfarbig hinterlegt. Werden in eine oder mehrere Spalten Bedingungen eingegeben, werden die Daten entsprechend dieser Angaben gefiltert.

Klicken Sie auf eine Zelle, in die Sie eine Bedingung eingeben wollen und geben Sie den Suchtext ein. Alternativ kann durch Drücken von Strg+W das Fenster zur Eingabe eines Wertes für die aktuelle Tabellenspalte geöffnet werden. Der Wert wird unabhängig von der Groß- und Kleinschreibung gefunden. Standardmäßig wird ein Wert am Anfang des Feldes gesucht, durch Sonderfunktionen sind jedoch auch andere Optionen möglich. Es können mehrere Spalten gleichzeitig zur Filterung verwendet werden. Diese werden dann mit UND verknüpft, das heißt, es muss jede Bedingung erfüllt sein.

Im folgenden Beispiel ist die Filterbedingung: alle Daten mit der PLZ "16868" und der Straße "Dorfstr." anzeigen, für die der Eintrag Klauentiere größer als Null ist und das Datum der Anmeldung größer als der 31.12.2007.

Schaltflächen "Zurücksetzen", "leer" und "nicht leer"

Beim Betätigen der Schaltfläche Zurücksetzen wird eine vorhandene Filterbedingung für die betreffende Spalte gelöscht und das Fenster geschlossen. Die Schaltfläche leer aktiviert für die Spalte die Suche nach allen Daten, für die in der Spalte kein Wert angegeben ist, die Schaltfläche nicht leer aktiviert die Suche nach Daten, für die in der Spalte Werte vorhanden sind.

Sonderfunktionen

Bestimmte Sonderzeichen dienen als Such- und Vergleichsoperatoren. Abhängig vom Typ der Spalte (Zeichen, Numerisch Logisch, Datum) unterscheidet sich die Funktionsweise. Die für den jeweiligen Spaltentyp verfügbaren Funktionen werden angezeigt und können per Doppelklick mit der Maus in das Eingabefeld übernommen bzw. in einigen Fällen (z.B. aktuelles Tagesdatum bei Datumsfeldern) direkt aktiviert werden.

Zeichenkettenfelder

Symbol | Beispiel | Erläuterung
=... | =1 | Es wird nach exakter Übereinstimmung gesucht. Das heißt, das Feld darf nur diesen Wert und nichts anderes enthalten. Dies ist z.B. bei Hausnummern sinnvoll. Wird das Symbol „=“ weggelassen, würden auch alle anderen Werte die mit „1“ beginnen gefunden werden, also auch „12“ oder „183“. Tipp: Wird das Symbol ohne nachfolgendes Zeichen verwendet, werden alle Daten gesucht, für die für das Feld leer ist.
!... | !Klöß | Es wird nach Daten gesucht, die nicht mit „Klöß“ beginnen. Tipp: Wird das Symbol ohne nachfolgendes Zeichen verwendet, werden alle Daten gesucht, für die das Feld nicht leer ist.
$... | $Schröder | Standardmäßig wird am Anfang des Feldes gesucht. Mit dem Symbol „$“ kann der Suchausdruck an beliebiger Position des Feldes stehen. „Schröder, Ronald“ wird genauso gefunden wie „Ronald Schröder“.
#... | #Müller | Es wird nach Daten gesucht, die kein „Müller“ (an beliebiger Feldposition) enthalten.
@...=... | @8=001 | Es wird nach Daten gesucht, die ab der 8. Position „001“
... | ... | Müller | Meier | Es wird sowohl nach „Müller“ als auch nach „Meier“ gesucht (ODER-Verknüpfung). Mit dem Symbol „|“ können beliebig viele Suchausdrücke verknüpft werden.

numerische Felder

Symbol | Beispiel | Erläuterung
... oder =... | =0 oder 0 | Es wird nach Werten gleich 0 gesucht. Tipp: Das Symbol „=“ ist der Standardvergleich bei numerischen Feldern und kann weggelassen werden.
!... oder #... | !0 oder #0 | Es werden alle Werte ungleich 0 gesucht.
>... | >10 | Es wird nach Werten größer als 10 gesucht.
<... | <1000 | Es wird nach Werten kleiner als 1000 gesucht.
... - ... | 10-100 -10-5 -10--5 | Es wird nach Werten zwischen 10 und 100 gesucht. Es wird nach Werten zwischen -10 und 5 gesucht. Es wird nach Werten zwischen -10 und -5 gesucht.
... | ... | 10 | 20 | 30 | Mit dem Symbol „|“ erfolgt eine ODER-Verknüpfung. Im Beispiel werden Werte 10, 20 oder 30 gesucht.
 | 1-10 | >100 | Es wird nach Werten zwischen 1 und 10 oder Werten größer 100 gesucht.

Tipp: Wird ein Symbol >, !, # oder = ohne weitere Eingabe angegeben, wird automatisch eine Null aufgefüllt. So reicht also die Eingabe „=“ um alle leeren Werte zu finden oder die Eingabe von „!“ bzw. „#“ um alle nicht leeren Werte zu finden.

Logische Felder
Logische Felder sind ein Sonderfall der numerischen Felder, die nur die Werte 0 (nein) oder 1 (ja) annehmen können. Geben Sie dann eine 1 ein, um diese Kontrollkästchen [image] zu filtern bzw. geben Sie eine 0 ein, um diese Kontrollkästchen [image] zu filtern.

Datumsfelder

Symbol | Beispiel | Erläuterung
... oder =... | =1.1.2008 oder 1.1.2008 | Es wird nach Werten gleich 1.1.2008 gesucht. Tipp: Das Symbol „=“ ist der Standardvergleich und kann weggelassen werden. Wird das Symbol "=" ohne folgende Datumsangabe verwendet, werden alle Einträge gefunden, für die kein Datum angegeben worden ist.
!... oder #... | !1.1.2008 | Es werden alle Datumswerte gefunden, die einen Wert enthalten und ungleich dem 1.1.2008 sind. Tipp: Wird das Symbol ohne nachfolgendes Zeichen verwendet, werden alle Daten gesucht, für die das Feld nicht leer, also ein Datum angegeben ist.
>... | >31.12.2010 | Es wird nach Werten größer als 31.12.2010 gesucht, alle Datumswerte ab dem 1.1.2011 werden gefunden.
<... | <1.1.2011 | Es wird nach Werten kleiner als 1.1.2011 gesucht.
... - ... |  |
... | ... | 2010|2011|1.1.2012-31.3.2012 | Mit dem Symbol „|“ erfolgt eine ODER-Verknüpfung. Im Beispiel werden die Jahre 2010, 2011 sowie der Zeitraum vom 1.1.2012 bis 31.3.2012 gesucht.

Bei Datumsfeldern kann entweder ein komplettes Datum in der der Form TT.MM.JJJJ (z.B.1.1.2012-31.12.2012) oder lediglich die Jahreszahl (z.B. 2012) zum Filtern verwendet werden.


Koordinaten umrechnen

Bildschirm anzeigen

Die Programmfunktion "Koordinaten umrechnen" erlaubt es, Koordinaten zwischen verschiedenen Koordinaten-, Bezugs- und Streifensystemen umzurechnen. Neben der manuellen Eingabe können Koordinaten in den Spalten einer dBase-Datei umgerechnet werden.

An folgenden "Stellen" ist diese Programmfunktion verfügbar:

  1. Menüpunkt "Extras - Koordinaten umrechnen" im Hauptfenster,

  2. Menüpunkt "Extras - Koordinaten umrechnen" im Karten-Explorer,

  3. Kontextmenü des Karten-Elements des Karten-Explorers.
    Tipp: Wenn Sie im Karten-Explorer im Karten-Element die rechte Maustaste drücken, können Sie den Menüpunkt "Koordinaten umrechnen" auswählen. Die Koordinaten des geklickten Punktes auf der Karte werden automatisch als Eingabewerte in den "Koordinatenrechner" übernommen!

manuelle Umrechnung

Im Modus der manuellen Umrechnung sind die Koordinaten bei Eingabe (X,Y) einzugeben. In den Feldern Ausgabe (X,Y) erfolgt simultan zur Eingabe die Berechnung der Koordinaten entsprechend der Angaben der Bereiche "Eingabeparameter" bzw. "Ausgabeparameter".

Über die Schaltfläche [image] kann ein Koordinatenpaar aus der Zwischenablage in das Eingabefeld eingefügt werden, wobei ein Tab-Stopp, ein Semikolon oder ein Komma als Trennzeichen fungieren kann. Koordinaten aus GoogleMaps werden automatisch erkannt und korrekt eingefügt.
Mit der Schaltfläche [image] kann das Koordinatenpaar in der Ausgabezeile in die Zwischenablage kopiert (X- und Y-Koordinate werden dabei von einem Tab-Stopp getrennt) und in andere Anwendungen wie Microsoft Excel eingefügt werden (z.B. mit Strg + V).
Die Schaltfläche [image] zeigt die Eingabe- bzw. Ausgabe durch Blinken auf der Karte an, sofern die Funktion aus dem Karten-Explorer aktiviert wurde und die Koordinate zu den aktuell geladenen Karten kompatibel ist.

Datei transformieren

Der Modus Datei transformieren wird mit der Schaltfläche Datei >>> aktiviert. Mit der Schaltfläche [image] ist eine dBase-Datei mit Koordinatenspalten auszuwählen. Die Schaltfläche [image] erlaubt es, diese Datei anzuzeigen bzw. zu bearbeiten. dBase-Datei bearbeiten

Die Kombinationsfelder Eingabe (X,Y) dienen der Auswahl des X- und Y-Wertes der Koordinate aus den vorhandenen Attributen der Datei. Bei Ausgabe (X,Y) sind die Spalten auszuwählen, in die die umgerechneten Koordinaten eingetragen werden sollen. Hier können vorhandene (numerische) Spalten ausgewählt werden, auf Wunsch auch die gleichen, die bei Eingabe gewählt wurden. Zusätzlich stehen die Einträge X_Erzeugt und Y_Erzeugt zur Auswahl. Diese werden bei Bedarf automatisch in die Struktur der dBase-Datei aufgenommen.
Das Kontrollkästchen Nullwerte bei Eingabefeldern ignorieren sollte aktiviert werden, wenn ein Wert 0 in den Eingabefeldern bedeutet, dass keine Koordinaten für diesen Datensatz vorhanden sind.
Das Kontrollkästchen Eingabefelder vom Typ Zeichen verwenden erlaubt alternativ auch die Verwendung von Zeichenfelder als Eingabefelder. Dabei werden die Ziffern in numerische Werte konvertiert. Punkte und Kommata werden als Dezimalpunkt interpretiert. Bei der Auswahl von gradiellen geografischen Koordinaten ist neben der Schreibweise ggg.mmss auch die Schreibweise ggg° mm' ss möglich (mit oder ohne Leerzeichen). So würden Werte wie -13°4'23 oder 14° 34' 43.5 usw. verarbeitet werden.

Mit der Schaltfläche Transformation starten erfolgt die Berechnung der Koordinaten entsprechend der Angaben der Bereiche "Eingabeparameter" bzw. "Ausgabeparameter".

Parameter

In den Bereichen "Eingabeparameter" bzw. "Ausgabeparameter" werden für die Eingabe- und Ausgabekoordinaten die Projektionsparameter festgelegt.

Folgende Parameter sind für die Projektion verantwortlich:

  • Koordinatensystem,
  • Bezugssystem und
  • Streifen

Für die Eingabedaten und Ausgabedaten sind die entsprechenden Parameter anzugeben. Diese können frei kombiniert werden. Folgende Systeme werden unterstützt:

Koordinatensysteme
  • geografisch (dezimal)
  • geografisch (gradiell: ggg,mmss)
  • LAEA
  • UTM8
  • UTM6 (6-stelliger Rechtswert)
  • UTM7 (7-stelliger Rechtswert)
  • Gauß-Krüger 3°-Streifen
Bezugssysteme
  • Potsdam Datum
  • Datum Pulkowo
  • WGS84
  • ETRS89
Streifen
  • UTM:
    29. bis 38. Streifen (Zone)
  • GK 3°-Streifen:
    1. bis 5. Streifen

Für weitere Informationen siehe Koordinatensystem, Bezugssystem und Streifen.


Koordinaten eingeben

Bildschirm anzeigen

Die Programmfunktion "Koordinaten eingeben" erlaubt es, Koordinaten manuell einzugeben. Bei manueller Eingabe sind die Koordinaten dabei exakt in dem im Fenster als Info angezeigten und unter [image] "Einstellungen-Projektion" festgelegten Koordinatensystem und Bezugsdatum einzugeben oder mit der Tastenkombination Strg + V einzufügen. Informationen zum Einfügen von Koordinaten aus der Zwischenablage finden Sie [image] hier

  • Liegen Koordinaten in einer abweichenden Projektion vor, können sie mit der Schaltfläche [image] umgerechnet werden. Koordinaten umrechnen

  • Mit der Schaltfläche [image] ist die Ermittlung von Koordinaten über Geokodierung von Adressen möglich. Geokodierung

  • Mit der Schaltfläche [image] können Koordinaten über eine Umgebungssuche ermittelt werden. Umgebungssuche


Archiv-Manager

Bildschirm zeigen

Um Dateien effizient zu archivieren bzw. über das Internet übertragen zu können, werden diese i.d.R. komprimiert. Dabei stellt das Zip-Format den gebräuchlichsten Standard dar. TSN verwendet Dateikomprimierung an verschiedenen Stellen, u.a. zur Erstellung von Sicherheitskopien für Betriebe, für Online-Projekte des Karten-Explorers und zur Speicherung von Daten im Downloadbereich der ZTSDB.

Zip-Archive können eine oder mehrere Dateien enthalten. Diese Archive können mit dem Archiv-Manager erstellt und verändert werden. Soll lediglich ein Zip-Archiv vollständig entpackt werden, kann alternativ der Menüpunkt "Service - Archiv entpacken" verwendet werden.

Der Archiv-Manager erlaubt es

  • neue Zip-Archive anzulegen,

  • den Inhalt von Zip-Archiven (Verzeichnisse, Komprimierungsgrad) anzuzeigen,

  • Dateien aus Zip-Archiven zu extrahieren (dekomprimieren, entpacken),

  • Dateien zu Zip-Archiven hinzuzufügen (komprimieren, packen) und

  • Dateien aus Zip-Archiven zu löschen.

Menüfunktionen

Datei
neues Archiv | neues Archiv legt ein leeres Archiv an, zu dem im folgenden Dateien hinzugefügt werden können
Archiv öffnen | Archiv öffnen lädt eine bestehende Archiv-Datei (*.zip) bzw. ein Online-Projekt (*.kez) von der Festplatte, zeigt deren Inhalt an und erlaubt im folgenden das Hinzufügen, Extrahieren und Löschen von Dateien zum bzw. aus dem Archiv.
Aktionen
Hinzufügen | Hinzufügen erlaubt es, zum Zip-Archiv eine oder mehrere Dateien in komprimierter Form hinzuzufügen. Das Dateiauswahlfenster erlaubt die Mehrfachauswahl z.B. mit Strg-Mausklick.
Extrahieren | Extrahieren bewirkt, dass alle markierten Dateien des Archivs entpackt und in einem wählbaren Verzeichnis auf der Festplatte gespeichert werden.
Löschen | Löschen entfernt alle markierten Dateien aus dem Archiv.
 | Alles markieren bewirkt die Auswahl aller Dateien des Archivs.
 | Markierung umkehren bewirkt das Umschalten der Markierung der Dateien.


Referenz - Karten-Explorer

Technische Referenz

Der Karten-Explorer bietet Entwicklern die Möglichkeit, Verknüpfungen zu eigenen Projekten herzustellen. Die notwendigen Informationen zur Projektdatei des Karten-Explorers (*.kep - Karten-Explorer-Projekt), zu Online-Projekten (*.kez - Karten-Explorer-Zip) und zum Erzeugen von Shape-Dateien (Typ Punkt) sind in diesem Kapitel dargestellt.

Durch das externe Generieren von KEP-, KEZ- oder Shape-Dateien, können räumlich darzustellende Daten für den Karten-Explorer bereit gestellt werden. Diese Daten können innerhalb des Karten-Explorer manuell geladen werden oder als Aufrufparameter dem Programm Tsn.exe oder Ke.exe übergeben werden. Durch Auswertung der Aufraufparameters kann die Anzeige von Karten per Mausdoppelklick im Ordnerfenster von Windows erfolgen, sofern die entsprechenden Dateitypen mit TSN bzw. KE verknüpft wurden. Des weiteren kann ein Programm diesen Aufruf über ShellExecute() oder WinExec() vornehmen, so dass die Anzeige von Karten ohne jegliche Nutzerinteraktion möglich ist.


Karten-Explorer-Projekt (Referenz)

Karten-Explorer-Projekt (KEP)

Das Karten-Explorer-Projekt (KEP) steuert die Anzeige von beliebig vielen Kartenschichten (Reihenfolge, Sichtbarkeit, Einfärbung), legt den aktuell sichtbaren Kartenausschnitt fest usw.

Durch Schreiben eines individuellen Karten-Explorer-Projektes und Aufrufen von tsn.exe bzw. ke.exe mit dem Parameter *.kep können externe Programme die Visualisierung von Karten automatisieren.

Der Aufbau des Karten-Explorer-Projekts ist weitgehend am "AEP-Format" des ArcExplorers Version 2.0 der Firma ESRI orientiert. Dadurch ist eine Basiskompatibilität zum ArcExplorer gegeben, wenngleich bestimmte Optionen wechselseitig nicht unterstützt werden. Alle grauen Einträge werden vom Karten-Explorer ignoriert und werden nur aus Kompatibilitätsgründen erzeugt. Es wird empfohlen, diese Einträge nicht zu generieren, wenn das Projekt ausschließlich mit dem Karten-Explorer genutzt wird.

Das KEP ist kompatibel zu Ini-Dateien von Windows und besteht aus mehreren Sektionen wobei für jeden Layer (entspricht einer geladenen Karte) eine Sektion [MAPLAYERn] angelegt wird. Bei 3 geladenen Layern wären das die Sektionen [MAPLAYER2], [MAPLAYER1] und [MAPLAYER0] (Siehe Beispiel)

Aufbau KEP

[ARCEXPLORER]
VERSION=2.0.800
DISPLAYOVERVIEW=nModus (1-Übersichtsfenster anzeigen, 0-kein Übersichtsfenster )
DISPLAYSCALEBAR=nModus (1-Maßstabsfenster anzeigen, 0-kein Maßstabsfenster)
DISPLAYEXPLORER=1 (1-Layer-Kontrolle anzeigen, 0-keine Layer-Kontrolle)

[MAP]
EXTENT=nLinks^nRechts^nOben^nUnten
BACKCOLOR=nFarbe (Hintergrundfarbe, siehe Konstanten)
BORDERSTYLE=0 (1-einfache Linie, 0-kein Rahmen)
CANCELACTION=1 (1-ESC bricht Zeichnen ab, 0-kein Abbruch mit ESC)
SCROLLBARS=0 (1-Bildlaufleisten, 0-keine Bildlaufleisten)
3D=0 (1-3D, 0-flach)
SELECTCOLOR=nFarbe (Farbe für Selektion, siehe Konstanten)
LAYERCOUNT=nAnzahl (Anzahl geladener Layer)
MAPUNITS=nEinheit (2-Meter, 1-Fuss, 0-Dezimalgrad)
SCREENUNITS=1 (Bildschirmeinheiten)
SCALEBARUNITS=3 (Maßstabseinheiten)

[SCALEBAR]
MAPUNITS=2 (2-Meter, 1-Fuss, 0-Dezimalgrad)
SCREENUNITS=1 (1-Zentimeter, 0-Inch)
SCALEUNITS=3 (3-Kilometer, 2-Meter, 1-Fuß, 0-Meilen)

[MAPLAYERn] (Layer-Nummer, Achtung:Zählung beginnt mit 0)
* 1. Spezifikation für Shape-Datei (*.shp)
WORKSPACE=cPfad
BASE=0^cDateiname^cNameInLayerKontrolle
VISIBLE=nSichtbarkeit (1-sichtbar, 0-nicht sichtbar)
RENDERERTYPE=nEinfärbungstyp (siehe Renderer)
RENDERERFIELD=cEinfärbungsfeld
RENDERER=cEinfärbungsparameter
RENDEREREX=cZusatzParameter
REMOUTLINE=0 (1-Umrißlinien entfernen, 0-Umrißlinien anzeigen)
MAPTIPFIELD=cQuickInfoFeld
ADDMAPTIPFIELDS=cWeiteresQuickInfoFeld1^cWeiteresQuickInfoFeld2
HYPERLINKFIELD=cHypelinkFeld
SCALELAYER=nAktiv^nAbMaßstab^nBisMaßstab (Anzeigebereich Layer 1-ein, 0-aus)
SCALELABEL=nAktiv^nAbMaßstab^nBisMaßstab (Anzeigebereich Beschriftung 1-ein, 0-aus)
SHOWSYMBOLOGY=nAufgeklappt (Einfärbung in Layer-Kontrolle aufgeklappt anzeigen 1-ja, 0-nein)
SYMBOL=cStandardSymbol (siehe Symbol, verwendet bei RENDERERTYPE=0)

* 2. Spezifikation für ARC/INFO-Datei (pat.adf, aat.adf, *.pat, *.aat, *.nat, *.rat, *.tat)
WORKSPACE=[arc]cPfad
BASE=1^" + cVolständigerPfad^cNameInLayerKontrolle
VISIBLE=nSichtbarkeit (1-sichtbar, 0-nicht sichtbar)
RENDERERTYPE=nEinfärbungstyp (siehe Renderer)
RENDERERFIELD=cEinfärbungsfeld
RENDERER=cEinfärbungsparameter
RENDEREREX=cZusatzParameter
REMOUTLINE=0 (1-Umrißlinien entfernen, 0-Umrißlinien anzeigen)
MAPTIPFIELD=cQuickInfoFeld
ADDMAPTIPFIELDS=cWeiteresQuickInfoFeld1^cWeiteresQuickInfoFeld2
HYPERLINKFIELD=cHypelinkFeld
SCALELAYER=nAktiv^nAbMaßstab^nBisMaßstab (Anzeigebereich Layer 1-ein, 0-aus)
SCALELABEL=nAktiv^nAbMaßstab^nBisMaßstab (Anzeigebereich Beschriftung 1-ein, 0-aus)
SHOWSYMBOLOGY=nAufgeklappt (Einfärbung in Layer-Kontrolle aufgeklappt anzeigen 1-ja, 0-nein)
SYMBOL=cStandardSymbol (siehe Symbol, verwendet bei RENDERERTYPE=0)

* 3. Spezifikation für Bilddateien (*.tif, *.tiff, *.tff, *.sid, *.jpg, *.jpeg, *.bmp, *.bil, *.bip, *.bsq, *.sun, *.ras, *.rlc)
WORKSPACE=cPfad
BASE=3^cDateiname^cNameInLayerKontrolle
VISIBLE=nSichtbarkeit (1-sichtbar, 0-nicht sichtbar)
SCALELAYER=nAktiv^nAbMaßstab^nBisMaßstab (Anzeigebereich Layer 1-ein, 0-aus)

[OVERVIEW]
* Sektion nur erforderlich, wenn DISPLAYOVERVIEW=1
* Dokumentation erfolgt nur für Shape-Dateien im Übersichtsfenster
* ARC/INFO- und Bild-Dateien erfordern komplizierte Notation
BASE=0^cDateiname^cDateiname^cPfad^^cDateiname^^
WORKSPACE=0^cDateiname^cDateiname^cPfad^^cDateiname^^

[KARTENEXPLORER]
Version=1.3
CREATIONTIME=tt.mm.jjjj / hh:mm:ss (Erstellungsdatum- / zeit)
LASTUPDATE=tt.mm.jjjj / hh:mm:ss (Datum / Zeit der letzten Änderung)
ACTIVELAYER=nAktiverLayer
SCALERASTER=nRasterkartenSkalierung (1-Aktiviert, 0-Deaktiviert)

Anmerkung: Aktivierte Rasterkartenskalierung schaltet die Rasterkarten automatisch unsichtbar, wenn der Maßstab außerhalb des festgelegten Bereiches (ScaleRasterMin, ScaleRasterMax) ist

SCALERASTERMIN=nEinblendenAbMaßstab (Default: 5000)
SCALERASTERMAX=nEinblendenBisMaßstab (Default: 50000)
TRANSPARENT=nModus (1-Transparenzmodus ein, 0-aus)
TRANSPARENTCOLOR=nTransparenzFarbe (transparente Farbe, siehe Konstanten)

Anmerkung: Bei Rasterkarten mit Blattschnitt kann eine Farbe transparent (TransparentColor) geschaltet werden, um bei der Anzeige störende Streifen an den Rändern der Kartenblätter zu eliminieren. Bitte nur bei Notwendigkeit aktivieren, da der Ausdruck von transparent geschalteten Rasterkarten nicht unterstützt wird.

IMAGECATALOG=cRasterKatalog
IMAGEFOLDER=cAlternativerSuchpfad

Anmerkung: Ein Rasterkatalog ist eine dBase-Datei, die die Zugriffpfade zu Rasterkarten und deren Ausdehnung enthält (siehe Tipps für Entwickler). Ist ein Raster-Katalog geladen, kann über die Funktionstaste F11 jederzeit der aktuell sichtbare Kartenausschnitt automatisch mit Rasterkarten hinterlegt werden. Werden die angegebenen Rasterkarten nicht gefunden wird (sofern angegeben) in ImageFolder nach ihnen gesucht.

TITLE=cKartenTitel
REMARKS=cAnmerkungen

Hinweis: Titel und Anmerkungen erscheinen unter Projektinformationen (Menü Datei) und beim Ausdruck von Karten. Um Zeilenumbrüche bei den Anmerkungen einzufügen ist das Zeichen 04h zu verwenden.

COORDINATESYSTEM=nKoordinatensystem (siehe Konstanten)
GEODETICSYSTEM=nBezugssystem (siehe Konstanten)
MERIDIAN=nStreifennummer

LEGEND=nAnzeigen (1-Aktiviert, 0-Deaktiviert)
LEGENDSCALEFACTOR=nFaktor (Skalierungsfaktor für Legende, Default: 1, Bereich: 0,25..5,00)
LEGENDLOCATION=nOben^nLinks^nUnten^nRechts
LEGENDBACKGROUND=nAnzeigen (1-Aktiviert, 0-Deaktiviert)

Hinweis zu Zugriffspfaden im KEP:
Der Karten-Explorer sucht beim Öffnen eines KEP die unter BASE=..^cDateiname^.. spezifizierten Karten im unter WORKSPACE=cPfad angegebenen Verzeichnis. Wird die Datei nicht gefunden, erfolgt die Suche im Verzeichnis, in dem sich das KEP befindet.


Renderer - Karten-Explorer-Projekt

Renderer - Einfärbung von Layern

Geo-Objekte eines Layers können vielfältig eingefärbt werden. Über RENDERERTYP=... wird im KEP festgelegt, nach welchem Prinzip die Einfärbung von Geo-Objekten erfolgen soll. Außer beim Einfärben mit einem einheitlichen Symbol für alle Geo-Objekte, legt das Element RENDERERFIELD das Feld (Attribut) fest, das für die Einfärbung verwendet werden soll. Alle benötigten Informationen für zu verwendende Optionen sind dann in RENDERER=... und ggf. RENDEREREX=... gespeichert.

Übersicht

Renderertype | Art der Einfärbung | Rendererfield | Layertyp
0 | einfaches Symbol Alle Geo-Objekte werden einheitlich eingefärbt. Dazu wird der Eintrag SYMBOL=... herangezogen. |  |
1 | Einzelwert Für spezifische Werte (z.B. 'Positiv', 'Negativ', 'Fraglich') eines wählbaren Attributs werden Symbole festgelegt. Des weiteren kann über ein Default-Symbol festgelegt werden, ob und wie weitere (nicht explizit mit Symbol versehene) Feldwerte angezeigt werden sollen. | alle |
2 | Klassen (automatisch) Diese Option ist in erster Linie aus Kompatibilitätsgründen zum ArcExplorer implementiert worden. Für ein wählbares numerisches Attribut werden 2 bis 9 Klassen gebildet, wobei die Klassengrenzen automatisch berechnet werden. Anfangs- und Endfarbe und -größe werden angegeben, der resultierende Farb- und Größenverlauf automatisch berechnet. | numerisch |
6 | Klassen (individuell) Diese Option bietet die Möglichkeit ein numerisches Attribut klassifiziert eingefärbt darzustellen, wobei die volle Kontrolle über Klassengrenzen und den Klassen zugeordnete Symbole besteht. | numerisch |
4 | Beschriftung Geo-Objekte eines Layers können anhand eines wählbaren Attributs beschriftet werden. Ein "intelligenter" Mechanismus versucht dabei, Überlappungen der Schriftzüge zu vermeiden, was ggf. nur unter Auslassung der Beschriftung für einzelne Geo-Objekte möglich ist. | alle |
5 | Punkthäufigkeiten In einem Polygon-Layer kann anhand eines wählbaren numerischen Attributes eine zufällige Verteilung von Punkthäufigkeiten generiert werden. | numerisch |

einfaches Symbol

RENDERERTYPE=0
RENDERERFIELD=
RENDERER=
RENDEREREX=
SYMBOL=cSymbol (siehe Symbol)

Beispiel:
Die Geo-Objekte eines Punkte-Layers werden mit roten Kreisen angezeigt.

RENDERERTYPE=0
RENDERERFIELD=
RENDERER=
RENDEREREX=
SYMBOL=255^Arial^8,25^0^0^0^5^1^53^0

Einzelwert

RENDERERTYPE=1
RENDERERFIELD=cFeldname
RENDERER=cWert1:cSymbol1|cWert2:cSymbol2|...|cWertn:cSymboln
RENDEREREX=nDefaultSymbolVerwenden|cDefaultSymbol

  • in RendererEx wird mit nDefaultSymbolVerwenden (1=ja, 0=nein) angegeben, ob nicht aufgeführte Einzelwerte mit cDefaultSymbol eingefärbt werden sollen.
  • Logische Felder sind über die Einzelwerte 'T' und 'F' zu definieren.
  • Für Datumsfelder sind die Einzelwerte in der Form JJJJMMTT anzugeben.

Beispiel:
Die Bundesländer Hessen und Niedersachen werden mit einem spezifischen Symbol gezeichnet (vgl. Renderer). Die anderen Bundesländer werden einheitlich mit dem Defaultsymbol gezeichnet (vgl. RendererEx)

RENDERERTYPE=1
RENDERERFIELD=BL_NAME
RENDERER=Hessen:38614994^Arial^8^2^0^0^0^0^53^0|Niedersachsen:32768^Arial^8^2^0^0^0^0^53^0
RENDEREREX=1|50331647^Arial^8^2^0^0^0^1^53^0

Klassen (automatisch)

RENDERERTYPE=2
RENDERERFIELD=cFeldname (numerisches Feld)
RENDERER=nAnzahlGrenzen^nStartfarbe^nEndfarbe^nAnfangsSymbolgröße^nEndSymbolgröße
RENDEREREX=

  • nAnzahlGrenzen (2..8) gibt die Anzahl der Klassengrenzen an, und ist demnach um 1 geringer als die Anzahl der gewünschten Klassen
  • Berechnung von Klassengrenzen, Symbolgröße und Symbolfarbe erfolgt automatisch
  • nAnfangsSymbolgröße, nEndSymbolgröße sollten Werte von 2 .. 25 verwenden

Beispiel:
Ein Layer wird mit 9 Klassen (entspricht 8 Klassengrenzen) anhand des numerischen Feldes Rind eingefärbt.

RENDERERTYPE=2
RENDERERFIELD=RIND
RENDERER=8^50331647^33587200^5^15
RENDEREREX=

Klassen (individuell)

RENDERERTYPE=6
RENDERERFIELD=cFeldname (numerisches Feld)
RENDERER=nObereGrenze1:nSymbol1|nObereGrenze2:nSymbol2|...|<END>:nLetztesSymbol
RENDEREREX=

  • Es werden jeweils die oberen Klassengrenzen gefolgt vom zu verwendenden Symbol angegeben. Die letzte Klasse hat keine obere Grenze, was durch den Wert <END> gefolgt vom Symbol signalisiert wird.

Beispiel:
Ein Layer wird mit 5 Klassen anhand des numerischen Feldes Rind eingefärbt. Die oberen Klassengrenzen und die je Klasse zu verwendenden Symbole sind individuell definiert.

RENDERERTYPE=6
RENDERERFIELD=RIND
RENDERER=50,000000:16777215^Arial^8^0^1^0^5^1^53^0|100,000000:15132415^Arial^8^0^1^0^5^1^53^0|185,000000:9211135^Arial^8^0^1^0^5^1^53^0|300,000000:183^Arial^8^0^1^0^5^1^53^0|<END>:88^Arial^8^0^1^0^5^1^53^0
RENDEREREX=

Beschriftung

RENDERERTYPE=4
RENDERERFIELD=cFeldname
RENDERER=1^2^3^4^5^6^7^8^9^10^11^12^13^14^15^16^17^18^19
RENDEREREX=
SYMBOL=cSymbol (siehe
Symbol)

1) Schrift: Name
2) Schrift: Größe (4..25)
3) Schrift: Fett (1=Ja, 0=Nein)
4) Schrift: Kursiv (1=Ja, 0=Nein)
5) Farbe Labelhintergrund (siehe Konstanten)
6) Labelhintergrund verwenden (1=Ja, 0=Nein)

  • Um die Sichtbarkeit von Beschriftungen zu verbessern, kann die Ausgabe der Beschriftung auf einem Hintergrund mit wählbarer Farbe erfolgen.

7) Label unter Punkt/Linie platzieren (1=Ja, 0=Nein)
8) Label über Punkt/Linie platzieren (1=Ja, 0=Nein)
9) Label auf Punkt/Linie platzieren (1=Ja, 0=Nein)
10) Schrift: Farbe (siehe Konstanten)
11) skalierte Schriftgröße

  • Wird an dieser Stelle eine Zahl > 0 angegeben, verwendet der Karten-Explorer diese als Schriftgröße in Karteneinheiten. In der Regel gibt dieser Wert demnach an, wie viele Meter die Schrift auf der Karte hoch ist.
    Hier sollte ein Wert verwendet werden, der zwischen 1/50.000 und 1/50 der Kartenhöhe (Ausdehnung aller geladenen Karten) entspricht. Grund: Der Karten-Explorer verwendet in seinem Einstellungsfenster für Beschriftungen den Schieberegler "Schriftgröße (skaliert)" mit Werte zwischen 1 (1/50.000 Kartenhöhe) und 1000 (1.000/50.000 Kartenhöhe).

12) Abstand der Beschriftung vom Geo-Objekt bei Punkt/Linie (1..30)
13) ignoriert
14) ignoriert
15) ignoriert
16) Hintergrund zeichnen (1=Ja, 0=Nein)

  • 1: Normalerweise sollen neben den Beschriftungen auch die Geo-Objekte angezeigt werden. Die Einfärbung erfolgt dann mit dem unter SYMBOL=... definierten Symbol und mit der Beschriftung.
  • 0: Wir an dieser Stelle eine 0 angegeben, werden nur die Beschriftungen angezeigt. Dies ist z.B. dann sinnvoll, wenn eine Karte mit einer Einfärbung wie Einzelwert, Klassen oder Punkthäufigkeiten eingefärbt und gleichzeitig beschriftet werden soll. Es kann jedoch nur ein Renderer pro Layer definiert werden. Dazu ist die gleiche Karte in zwei (separaten) Layern zu laden. Einer wird z.B. per Einzelwert eingefärbt. Der zweite ist mit Beschriftungen einzufärben und das Zeichnen des Hintergrundes ist zu deaktivieren.

17) Duplikate erlauben (1=Ja, 0=Nein)

  • Dieser Wert steuert die Anzeige gleich lautender Beschriftungen. Ist der Wert auf 0 gesetzt, werden gleich lautende Texte für Polygone und Punkte nur einmal im sichtbaren Kartenausschnitt angezeigt (z.B. Gemeindenamen bei Exklaven). Für Linien ist das Verhalten abweichend: Ist der Wert auf 0 gesetzt, werden Duplikate nur von miteinander verbundenen Linien (z.B. Abschnitte der gleichen Straße) entfernt.

18) ignoriert
19) Schrift: Unterstrichen (1=Ja, 0=Nein)

Beispiel:
Die Gemeinden eines Kreises werden mit schwarzer Farbe in der Schrift Arial (Größe 9 Punkte, Kursiv, Fett) beschriftet. Die Schrift ist mit hellgelbem Hintergrund hinterlegt. Die Gemeinden ('Hintergrund zeichnen' aktiviert) werden mit blauen Linien angezeigt, wie im Symbol spezifiziert.

RENDERERTYPE=4
RENDERERFIELD=GEM_NAME
RENDERER=Arial^9^1^1^13697023^1^0^1^0^0^0,000000^^^^^1^1^^0
RENDEREREX=
SYMBOL=65535^^8,25^2^1^16711680^2^1^0^0

Punkthäufigkeiten

RENDERERTYPE=5
RENDERERFIELD=cFeldname (numerisches Feld)
RENDERER=nPunktfarbe^nPunktwert^nPunktgröße^nHintergrundZeichnen
RENDEREREX=
SYMBOL=cSymbol (siehe Symbol)

  • Diese Einfärbungsoption ist nur für Layer vom Typ Polygon verfügbar
  • nPunktwert gibt an, wie viele Einheiten durch einen Punkt dargestellt werden sollen (z.B. 1: ein Punkt pro Tollwutfall, 1000: 1 Punkt pro 1000 Einwohner etc.)
  • nPunktgröße sollte einen Wert von 1..20 haben
  • nHintergrundZeichnen (1=Ja, 0=Nein) legt fest, ob neben den zufällig verteilten Punkten auch die Polygone mit dem unter SYMBOL=... definierten Symbol angezeigt werden.

Beispiel:
Die Kreise eines Bundeslandes werden mit zufällig verteilten (gelben) Punkten für die Einwohneranzahl eingefärbt, wobei ein Punkt 100 Einwohnern entspricht. Die Grenzen der Bundesländer werden mit blauen Linien angezeigt.

RENDERERTYPE=5
RENDERERFIELD=EINWOHNER
RENDERER=65535^100^4^1
RENDEREREX=
SYMBOL=65535^^8,25^2^1^16711680^2^1^0^0


Symbol - Karten-Explorer-Projekt

Symbol

Geo-Objekte eines Layers können einheitlich oder unterschiedlich (Klassen, Einzelwerte) eingefärbt werden. Zur Definition einer konkreten Einfärbungsvariante wird das so genannte Symbol verwendet. Dementsprechend werden abhängig von der Einfärbungsvariante ein oder mehrere Symbole pro Layer benötigt.

Aufbau

Wenngleich ein Symbol einen einheitlichen Aufbau bestehend aus 10 Elementen besitzt, werden abhängig davon, ob es sich um ein Symbol zur Einfärbung von Punkte-, Linien- oder Polygon-Layern handelt, einzelne Elemente nicht verwendet.

Farbe^Schriftart^Schriftgröße^Symboltyp^Stil^UmrissFarbe^Größe^Umriss^Zeichenindex^Rotation

 | Element | Werte | Symboltyp
1 | Farbe | siehe Konstanten (0..16777215) |
2 | Schriftart | Schriftart für TrueTypeMarker | 1)
3 | Schriftgröße | ignoriert |
4 | Symboltyp | 0=Punkt 1=Linie 2=Polygon |
5 | Stil | siehe Konstanten Punkt: Punktstil (0..4) Linie: Linienstil (0..4) Polygon: Füllstil (0..10) |
6 | Umrissfarbe | Farbe Umrisslinie, siehe Konstanten (0..16777215) |
7 | Größe | Punkt: Größe Markierung (1..30) Linie: Linienstärke (1..30) Polygon: Stärke Umrisslinie (1..30) |
8 | Umriss | 1=Umrisslinien anzeigen, 0=keine Umrisslinien |
9 | Zeichenindex | Index des Zeichens innerhalb der Schriftart (1..256, z.B. 65 für A) | 1)
10 | Rotation | Drehwinkel des Zeichens in Grad (0..259) | 1)

1) Wird bei einem Punkte-Layer die der Stil auf TrueTypeMarker (Symboltyp=0, Stil=4) gesetzt, können die Zeichen beliebiger Truetype-Schriftarten zur Darstellung genutzt werden. In diesem Fall werden die Elemente "Zeichenindex" und "Rotation" verarbeitet.

Anwendung im KEP

Im KEP ist für jeden Layer mit Vektordaten ein Eintrag SYMBOL=... vorhanden. Dieser wird vom Karten-Explorer benutzt, wenn alle Geo-Objekte einheitlich eingefärbt werden sollen bzw. wenn der Hintergrund (Geo-Objekte) bei Beschriftungen oder Punkthäufigkeiten angezeigt werden soll. In folgenden Fällen wird bei der Einfärbung von Geo-Objekten der Eintrag SYMBOL=... verwendet:

  1. einfaches Symbol
    RENDERERTYPE=0
  2. Beschriftung (wenn "Hintergrund zeichnen" aktiviert ist)
    RENDERERTYPE=4
  3. Punkthäufigkeiten (wenn "Hintergrund zeichnen" aktiviert ist)
    RENDERERTYPE=5

Bei Einfärbung mit individuellen Klassen oder Einzelwerten werden mehrer Symbole benötigt, die unter RENDERER=... aufgeführt sind. In folgenden Fällen werden mehrere Symbole benötigt und dem Eintrag RENDERER=... entnommen:

  1. Einzelwerte
    RENDERERTYPE=1
  2. individuelle Klassen
    RENDERERTYPE=6


Beispiel Karten-Explorer-Projekt

Das Beispiel-Projekt enthält 3 Karten.

MapLayer2 KRS99999.SID ist eine Bilddatei, die in der Layer-Kontrolle "unten" liegt. Dir unterste Karte wird zuletzt gezeichnet.

Darüber liegt MapLayer1, die Shape-Datei (Polygon) Gem99999.Shp, die in der Layer-Kontrolle den Namen Gemeinden hat. Die Gemeinden sind mit dem Feld "Gem_Name" beschriftet. Die Beschriftung wird von 1:5.000 bis 1:200.000 eingeblendet.

Der oberste und zuletzt gezeichnete Layer ist MapLayer0, die Shape-Datei (Punkte) Tierhalter.Shp, die in der Layer-Kontrolle als "Tierhalter" angezeigt wird. Renderertype=0 signalisiert, dass alle Geo-Objekte mit einem einheitlichen Symbol (rote Punkte) gezeichnet werden.

Die grauen Einträge können ausgelassen werden.

[ARCEXPLORER]
VERSION=2.0.800
DISPLAYOVERVIEW=0
DISPLAYSCALEBAR=1
DISPLAYEXPLORER=1

[MAP]
EXTENT=3722005,791786^3745428,896072^5895022,675313^5875796,360003
BACKCOLOR=16777215
BORDERSTYLE=0
CANCELACTION=1
SCROLLBARS=0
3D=0
SELECTCOLOR=65535
LAYERCOUNT=3
MAPUNITS=2
SCREENUNITS=1
SCALEBARUNITS=3

[SCALEBAR]
MAPUNITS=2
SCREENUNITS=1
SCALEUNITS=3

[MAPLAYER2]
WORKSPACE=C:\TSN\KARTEN\
BASE=3^KRS99999.SID^KRS99999.SID
VISIBLE=1
SCALELAYER=1^1000^100000

[MAPLAYER1]
WORKSPACE=C:\TSN\STM\
BASE=0^GEM99999.SHP^Gemeinden
VISIBLE=1
RENDERERTYPE=4
RENDERERFIELD=GEM_NAME
RENDERER=Arial^9^0^0^13697023^1^0^1^0^0^0,000000^0^0^9^^1^1^0^0
RENDEREREX=
REMOUTLINE=0
MAPTIPFIELD=GEM_NAME
ADDMAPTIPFIELDS=
SCALELAYER=0^1^100000000
SCALELABEL=1^5000^200000
SYMBOL=65535^^8,25^2^1^16711680^2^1^0^0

[MAPLAYER0]
WORKSPACE=C:\TEMP\TEST-DATEIEN\
BASE=0^TIERHALTER.SHP^Tierhalter
VISIBLE=1
RENDERERTYPE=0
RENDERERFIELD=
RENDERER=
RENDEREREX=
REMOUTLINE=0
MAPTIPFIELD=NAME
ADDMAPTIPFIELDS=STRASSE^RIND
SCALELAYER=0^1^100000000
SCALELABEL=0^1000^100000000
SYMBOL=255^Arial^8,25^0^0^0^5^1^53^0

[KARTENEXPLORER]
Version=1.1
CREATIONTIME=29.11.2002 / 14:54:21
LASTUPDATE=31.01.2003 / 17:59:56
ACTIVELAYER=1
SCALERASTER=0
SCALERASTERMIN=5000,000000
SCALERASTERMAX=50000,000000
TRANSPARENT=0
TRANSPARENTCOLOR=16777215
IMAGECATALOG=
IMAGEFOLDER=
TITLE=Test
REMARKS=Aufbau eines Karten-Explorer-Projekts


Konstanten Karten-Explorer-Projekt

Stil- und Farbkonstanten, Koordinaten- und Bezugssysteme

Punktstil

0 | Kreis
1 | Quadrat
2 | Dreieck
3 | Kreuz
4 | TrueTypeMarker

Linienstil

0 | Linie
1 | Gestrichelt
2 | Gepunktet
3 | Strich-Punkt
4 | Strich-Punkt-Punkt

Füllstil (Flächen)

0 | Vollständig gefüllt
1 | Transparent
2 | Horizontal schraffiert
3 | Vertikal schraffiert
4 | Aufwärts diagonal schraffiert
5 | Abwärts diagonal schraffiert
6 | Kreuzweise schraffiert
7 | Diagonal kreuzweise schraffiert
8 | Hellgrau
9 | Grau
10 | Dunkelgrau

Farben

Farben können mit einem Wert zwischen 0 und 16777215 frei angegeben werden.

0 | Schwarz
255 | Rot
65280 | Grün
16711680 | Blau
16711935 | Magenta
16776960 | Zyan
16777215 | Weiß
12632256 | Hellgrau
8421504 | Grau
4210752 | Dunkelgrau
13697023 | Blassgelb
8454143 | Hellgelb
65535 | Gelb
12639424 | Hellgrün
8421440 | Dunkeltürkis (Teal)
32768 | Dunkelgrün
128 | Rotbraun
8388736 | Purpur
33023 | Orange
7051175 | Khaki
32896 | Olive
4210816 | Braun
8404992 | Marineblau (Navy)

Koordinaten- und Bezugssysteme

Der Karten-Explorer kann ungenutzte Bereiche des Datei-Headers verwenden, um die Angaben zur Projektion mit der Shape-Datei zu speichern.
Aufbau Shape-Datei
Koordinatensystem, Bezugssystem und Streifen

Koordinatensysteme

Nummer | Koordinatensystem |  | Streifen | Intern
1 | GK3 | Gauß-Krüger-Koordinaten (3-Grad-Streifen) | 1-5 | TSN_KS_GK3
2 | GeoK | geografische Koordinaten (dezimal) |  | TSN_KS_GeoK
3 | GK6 | UTM Universale Transversale Mercatorprojektion | 30-35 | TSN_KS_UTM
4 | UTM | Gauß-Krüger-Koordinaten (6-Grad-Streifen) | 1-5 | TSN_KS_GK6
5 | GKÖ | Österreichische Gauß-Krüger-Koordinaten | M28, M31, M34 | TSN_KS_GKÖ
6 | BMN | Österreichisches Bundesmeldenetz | M28, M31, M34 | TSN_KS_BMN
7 | LTM | Luxemburger Transversal-Mercator-Koordinaten) |  | TSN_KS_TML
8 | GeoK° | geografische Koordinaten (Grad, Minute, Sekunde (DMS)) |  | TSN_KS_GeoDMS
9 | UTM7 | UTM mit 7-stelligem Rechtswert | 30-35 | TSN_KS_UTM7
10 | Soldner | Deutsche Soldner-Koordinaten (Müggelberg, neu) |  | TSN_KS_SOLDNER
11 | LKÖ alt | Österreichische Lambertkoordinaten (alt) |  | TSN_KS_LKÖ_ALT
12 | LKÖ neu | Österreichische Lambertkoordinaten (neu) |  | TSN_KS_LKÖ_NEU
13 | EDEN | Lambert Conformal Conic Europe |  | TSN_KS_EDEN
14 | S70 | Rumänische Stereo70 Stereografic Koordinaten |  | TSN_KS_S70
15 | UTM6 | UTM mit 6-stelligem Rechtswert | 30-35 | TSN_KS_UTM6
16 | LAEA | Lambert azimuthal equal-area projection |  | TSN_KS_LAEA

Bezugssysteme (geodätisches Datum)

Nummer | Bezugssystem |  | Intern
1 | PD | Potsdam Datum (DHDN, Rauenberg, Bessel (1941)) | TSN_GD_Potsdam
2 | 42/83 | System 42/83 (Datum Pulkowo, Pulkowo, Krassowski (1940)) | TSN_GD_Pulkowo
3 | WGS84 | WGS1984 (GPS, earth centred, WGS84 (1984)) | TSN_GD_WGS84
4 | ED50 | European Datum 1950 (Potsdam, International (1924)) | TSN_GD_ED50
5 | ETRS89 | ETRS89 (Europäisches Terrestrisches Referenzsystem 1989, earth centred, GRS80 (1980)) | TSN_GD_ETRS89
6 | MGI | MGI (Militärgeografisches Institut, Hermannskogel, Bessel (1941)) | TSN_GD_MGI
7 | LUREF | LUREF( National Datum of Luxemburg, Habay, International (1924)) | TSN_GD_LUREF
8 | WGS72 | WGS1972 (earth centred, WGS72 (1972)) | TSN_GD_WGS72
9 | Stereo70 | Stereo70 (Rumänien, Dealul Piscului, Krassowski) | TSN_GD_S70


Shapefile (Referenz)

Aufbau Shape-Datei

Die detaillierte technische Spezifikation von Shape-Dateien aller Typen (Punkt, Linie, Polygon, Multipoint etc.) kann hier von der ESRI-Homepage als PDF-Datei abgerufen werden. Der Aufbau der Shape-Dateien vom Typ Punkt wird im folgenden erklärt. Dies stellt die einfachste Variante einer Shape-Datei dar und ist für Fremdprogramme, die Daten an den Karten-Explorer übergeben wollen am relevantesten.

Ein Shape-Datei besteht obligatorisch aus 3 Dateien:

  1. *.shp (z.B. rinder.shp) enthält die Geometrie der darzustellenden Objekte und differiert im Aufbau stark mit dem Typ der Shape-Datei. Für den Typ 1=Punkt jedoch ist der Aufbau einfach strukturiert, da ein Punkt hier immer aus 2 Koordinaten besteht.
  2. *.shx (z.B. rinder.shx) ist eine Index-Datei mit festem Aufbau, die einen Zeiger auf jedes Element in der Geometrie-Datei (*.shp) enthält. Da die Geometrie-Datei i.d.R. nicht fest strukturiert ist, Polygone beispielsweise zwischen 3 und ∞ viele Punkte enthalten können, ist diese Datei für den nichtsequentiellen Zugriff auf die Geometriedaten unerlässlich.
  3. *.dbf (z.B. rinder.dbf) stellt eine dBase-Datei dar, die die Attribute, die mit dem Geo-Objekt assoziiert sind, enthält.

Zusätzlich können u.a. Dateien (*.sbn, *.sbx, *.prj, *.avl, *.lyr, *.lyr.xml, *.cpg) mit einer Shape-Datei assoziiert sein, die z.B. Attribute-Indizes, räumliche Indizes, Angaben über Projektion, Legenden, Einfärbungen und Codepages enthalten. Diese Dateien sind fakultativ und werden hier nicht näher erläutert.

Geometrie-Datei (*.shp)

Datei-Header (100 Byte)
Datensatz-Header (8 Byte) | Datensatz-Inhalt (? Byte, bei Punkt 20 Byte)
Datensatz-Header ... | Datensatz-Inhalt ...

Datei-Header

Position | Feld | Wert | Typ | Byte-Order
Byte 0 | Datei-Code | 9994 | Long (Integer) | Big (endian)
Byte 4..23 | nicht benutzt | 0 | Long (Integer) | Big
Byte 24 | Dateilänge | Länge in 16-bit-Words bei Punkt 50+14*Datensätze | Long (Integer) | Big
Byte 28 | Version | 1000 | Long (Integer) | Little
Byte 32 | Shape-Typ | 1=Punkt (3=Linie, 5=Polygon, 8=Multipoint) | Long (Integer) | Little
Byte 36 | Ausdehnung | Xmin | Real8 (Double) | Little
Byte 44 | Ausdehnung | Ymin | Real8 (Double) | Little
Byte 52 | Ausdehnung | Xmax | Real8 (Double) | Little
Byte 60 | Ausdehnung | Ymax | Real8 (Double) | Little
Byte 68..99 | nicht benutzt | 0 | Real8 (Double) | Little

Der Karten-Explorer kann ungenutzte Bereiche des Datei-Headers verwenden, um die Angaben zur Projektion ( [image] Koordinatensystem, Bezugssystem und Streifen) mit der Shape-Datei zu speichern.

Position | Feld | Wert | Typ | Byte-Order
Byte 88 | Koordinatensystem | 0=unbekannt 1..n [image] Konstanten | Long (Integer) | Little
Byte 92 | Bezugssystem | 0=unbekannt 1..n [image] Konstanten | Long (Integer) | Little
Byte 96 | Streifen | 0=unbekannt 1..n [image] Konstanten | Long (Integer) | Little

Datensatz-Header

Position | Feld | Wert | Typ | Byte-Order
Byte 0 | Datensatz | Datensatz-Nummer | Long (Integer) | Big
Byte 4 | Länge | Länge des Datensatzes in 16-bit-Words, beim Typ Punkt immer 10 Byte, bei Polygon usw. ist der Wert von der Anzahl der Punkte abhängig. | Long (Integer) | Big

Datensatz-Inhalt bei Typ Punkt

Position | Feld | Wert | Typ | Byte-Order
Byte 0 | Shape-Typ | 1 | Long (Integer) | Little
Byte 4 | X | X bzw. Rechtswert | Real8 (Double) | Little
Byte 12 | Y | Y bzw. Hochwert | Real8 (Double) | Little

Shape-Dateien verwenden für alle Variablen, die die Dateiorganisation betreffen (Datei- und Datensatzlänge, Offsets) das Mainframe-Format "Big Endian" (Sun, Motorola), für alle datenbezogenen Adressen das Format "Little Endian" (Intel).
Big Endian: Ein Datenformat für die Übertragung oder Speicherung binärer Daten, in denen das höchstwertige Byte an erster Stelle kommt. Intel-basierte Systeme verwenden einen entgegen gesetzte Byte-Reihenfolge, so dass ggf. folgende Konvertierung für Variablen vom Typ Long vorgenommen werden muss:
Byte1Byte2Byte3Byte4 > Byte4Byte3Byte2Byte1

Index-Datei (*.shx)

Index-Datei-Header (100 Byte)
Index-Datensatz (8 Byte)
Index-Datensatz ...

Index-Datei-Header

Der Datei-Header ist identisch mit dem der Geometriedatei, wobei die Dateilänge sich aus 50+4*Anzahl der Datensätze ergibt.

Index-Datensatz

Position | Feld | Wert | Typ | Byte-Order
Byte 0 | Offset | Anzahl der 16-bit-Words vom Dateistart bis zum Beginn des Datensatzes in der Geometrie-Datei bei Punkt: 50*(Datensatz-1)*14 | Long (Integer) | Big
Byte 4 | Länge | Länge des Datensatzes in 16-bit-Words in der Geometrie-Datei (bei Punkt immer 10) | Long (Integer) | Big

dBase-Datei (*.dbf)

Es handelt sich um eine dBase-Datei im Format dBase III oder dBase IV. Jeder Datensatz entspricht einem Geo-Objekt. Anzahl und Reihenfolge der Datensätze in Geometrie-Datei und dBase-Datei stimmen überein.


Online-Projekt (Referenz)

Online-Projekt (KEZ)

Das Online-Projekt (KEZ - Karten-Explorer-Zip-Archiv) ist eine Zip-Archiv. Während eine KEP-Datei (Karten-Explorer-Projekt) lediglich Verweise auf Dateien (Karten) und Informationen zu deren Einfärbung enthält, besteht ein Online-Projekt aus einer oder mehreren Shape-Dateien und in der Regel einer KEP-Datei, die festlegt, wie die Karten angezeigt werden sollen. Wichtigstes Ziel eines Online-Projektes ist der effiziente Datenaustausch von Vektordaten über das Internet, wie der Datenaustausch zwischen Client und Server im TSN-System oder die Übertragung von Kartenmaterial zwischen Krisenzentren. Des weiteren sind Online-Projekte hervorragend zum Archivieren von Vektordaten geeignet. Online-Projekte können mit dem Karten-Explorer erstellt (Export - Online-Projekt) und geöffnet (Datei - Öffnen - Online-Projekt) werden.

Aufbau

Folgende Dateien werden innerhalb von Online-Projekten gespeichert und verarbeitet:

  • KEP-Datei
    Ist eine KEP-Datei (siehe Karten-Explorer-Projekt) vorhanden, legt diese das Erscheinungsbild der Karte fest (Reihenfolge, Einfärbung, Bezeichnung und Infofelder für Layer usw.)
  • Shape-Dateien
    • Die Shape-Datei muss mindestens aus 3 Dateien bestehen (*.shp, *.shx, *.dbf)
    • Sind Index-Dateien (*.shx, *.sbx) vorhanden, werden diese verabeitet
    • Ist eine Layer-Vorlage (*.kel) vorhanden, wird sie zur Einfärbung des Layers herangezogen, sofern keine KEP-Datei vorhanden ist.

Bild-Dateien und ARC/INFO-Dateien werden für Online-Projekte nicht unterstützt.

Verarbeitung von Online-Projekten

  • Ein Online-Projekt (ein verkapptes Zip-Archiv) wird zunächst vollständig in ein temporäres Verzeichnis entpackt.

  • Enthält das Online-Projekt eine KEP-Datei, erfolgt die Abfrage, ob die bereits geladenen Layer jetzt geschlossen werden sollen. Entscheidet sich der Nutzer, bisher geöffnete Layer zu schließen, werden alle Parameter des Online-Projektes aktiviert (Layer, Einfärbungen, Info-Felder, Übersichtsfenster, Anzeige Maßstab, Kartentitel, aktuell sichtbarer Kartenausschnitt usw.). Sollen bisher geladene Layer nicht entfernt werden, so werden lediglich die Layer des Online-Projektes entsprechend der Vorgaben der KEP-Datei (Einfärbungen, Info-Felder) hinzugefügt.

  • Enthält das Online-Projekt keine KEP-Datei, geht der Karten-Explorer davon aus, dass lediglich Shape-Dateien (Layer) zum aktuellen Projekt hinzugefügt werden sollen. Die Layer werden entsprechend eventuell vorhandener Layer-Vorlagen (*.kel) oder mit Standardwerten eingefärbt.


Softwareentwicklung mit Karten-Explorer

Tipps für Entwickler

Windows-Kommandozeile

Tsn.exe bzw. Ke.exe werten die vom Betriebssystem übergebene Kommandozeile aus. Die von verschiedenen Windows-Betriebssystem generierten Kommandozeilen weisen einen variablen Aufbau auf. Folgende Strukturen werden erwartet:

  • "Executable" "Parameter1"
  • Executable "Parameter1"
  • "Executable" Parameter1

Zum Starten bieten sich bei entsprechender Verknüpfung von Dateierweiterungen mit Tsn.exe bzw. Ke.exe ein Mausdoppelklick zum manuellen Öffnen oder ShellExecute() aus einem externen Programm an. In jedem Fall funktioniert der Aufruf aus externen Programmen mit den Windows-API-Funktionen WinExec() und CreateProcess().

Beispiel für WinExec()
pszCommand := '"c:\tsn\bin\tsn.exe" "c:\tsn\projekte\beispiel.kep"'
WinExec( pszCommand, SW_SHOWNORMAL )

Verknüpfbare Dateierweiterungen

Art | Dateierweiterung
Karten-Explorer-Projekt (KEP) | *.kep
Online-Projekt (KEZ) | *.kez
Shape-Datei | *.shp
ARC/Info-Datei | pat.adf, aat.adf, *.pat, *.aat, *.nat, *.rat, *.tat
Bild-Dateien | *.tif, *.tiff, *.tff, *.sid, *.jpg, *.jpeg, *.bmp, *.bil, *.bip, *.bsq, *.sun, *.ras, *.rlc

Standprojekt laden

Beim Öffnen eines Karten-Explorer-Projektes (*.kep) kann der Karten-Explorer zum Laden der unter [image] Einstellungen - Standardprojekt angegebenen Layer veranlasst werden. Damit ist es möglich, aus anderen Anwendungen heraus den Karten-Explorer zu starten und über ein Karten-Explorer-Projekt als Aufrufparameter das Laden individueller Layer zusammen mit dem Standardprojekt zu steuern. Das Standardprojekt wird dabei zuerst geladen, alle weiteren angegebenen Layer werden darüber geladen.

[MAP]
LOADDEFAULT=nStandardProjektLaden (1-ja, 0-nein)

Shape-Dateien automatisch erzeugen (AUTOCREATE)

1. aus dBase-Dateien

Unter Aufbau Shape-Datei wurde erläutert, wie externe Programme Shape-Dateien vom Punkt Typ ggf. selbst generieren können. Als Alternative kann durch ein Kommando in der Sektion eines Layers im Karten-Explorer-Projekt der Karten-Explorer angewiesen werden, die Shape-Datei aus einer dBase-Datei automatisch zu generieren. Voraussetzung ist lediglich, dass die dBase-Datei 2 Spalten (Attribute) enthält, die X- und Y-Koordinaten (X: Rechtswert bzw. Länge - Y: Hochwert bzw. Breite) darstellen. Beim Öffnen des KEP überprüft der Karten-Explorer die Existenz der Shape-Datei und generiert bei Bedarf aus der dBase-Datei die Geometrie-Datei (*.shp) und die Index-Datei (*.shx).

[MAPLAYERn]
WORKSPACE=cPfad
BASE=0^cDateiname^cNameInLayerKontrolle
AUTOCREATE=cAttributX^cAttributY

Beispiel:
Im folgenden Beispiel würde der Karten-Explorer zunächst nach der Datei C:\Karten\Tierhalter.Shp suchen. Ist sie nicht vorhanden, wird die Datei Tierhalter.Shp im Verzeichnis gesucht werden, in dem sich die KEP-Datei befindet (alternativer Suchpfad). Ist auch diese Suche erfolglos, überprüft der Karten-Explorer, ob der Eintrag AUTOCREATE gesetzt ist. Ist dies der Fall, wird die Datei Tierhalter.Dbf gesucht. Wird sie gefunden, dann generiert der Karten-Explorer die fehlenden Dateien Tierhalter.Shp und Tierhalter.Shx unter Verwendung der spezifizierten Attribute (Spalten) für X- und Y-Koordinaten und öffnet die nun existierende Shape-Datei unter dem Namen "Untersuchte Rinderhalter" in der Layer-Kontrolle.

[MAPLAYER0]
WORKSPACE=C:\Karten
BASE=0^Tierhalter.Shp^Untersuchte Rinderhalter
AUTOCREATE=Rechtswert^Hochwert
...

2. aus CSV-Dateien

Eine weitere Möglichkeit zur automatischen Erzeugung von Shape-Dateien stellen CSV-Dateien (*.csv) dar. Aus ihnen kann der Karten-Explorer bei Bedarf Layer generieren.

Spaltendefinition
Dabei ist in der Kopfzeile der CSV-Datei neben der Beschreibung von Spaltennamen auch Typ, Länge und ggf. Anzahl der Nachkommastellen (bei numerischen Felder) anzugeben. Diese Informationen werden benötigt, um die dBase-Datei (als notwendiger Bestandteil der Shape-Datei) generieren zu können. Es sind mindestens Spaltenname und Typ (C, N, D, L) anzugeben. Längenangaben bei Spalten mit Datums- oder logischen Werten sind nicht notwendig. Wird beim Typ Zeichen keine Länge angegeben, wird die Länge 50 Zeichen verwendet. Bei numerischen Spalten würde beim Fehlen der Angaben die Länge 18 mit 6 Nachkommastellen verwendet werden.

Typ | Code | Länge | Nachkommastellen | Bemerkung | Beispiel
Zeichen | C | 1 bis 256 | 0 | Standard ist Länge 50 | NAME,C,20
Numerisch | N | 1 bis18 | 0 bis Länge-1 | Standard ist Länge 18 mit 6 Nachkommastellen | PRAEVALENZ,N,10,6
Datum | D | 8 | 0 |  | GEBURT,D
Logisch | L | 1 | 0 | Folgende Zellinhalte werde als 'wahr' behandelt: 1, Y, J, T, .T., true, wahr, yes, ja | UNTERSUCHT,L

Durch ein Kommando in der Sektion eines Layers im Karten-Explorer-Projekt kann der Karten-Explorer angewiesen werden, die Shape-Datei aus einer CSV-Datei automatisch zu generieren. Voraussetzung ist lediglich, dass die CSV-Datei 2 Spalten (Attribute) enthält, die X- und Y-Koordinaten (X: Rechtswert bzw. Länge - Y: Hochwert bzw. Breite) darstellen. Beim Öffnen des KEP überprüft der Karten-Explorer die Existenz der Shape-Datei und generiert bei Bedarf aus der CSV-Datei die Attribute-Datei (*.dbf) und danach die Geometrie-Datei (*.shp) und die Index-Datei (*.shx).

[MAPLAYERn]
WORKSPACE=cPfad
BASE=0^cDateiname^cNameInLayerKontrolle
AUTOCREATE=cAttributX^cAttributY^nCodierung

AUTOCREATE gibt im ersten und zweiten Parameter die X- und Y-Spalte an, wobei GPS-Koordinaten automatisch erkannt und auf die im Karten-Explorer verwendetet Projektion transformiert werden. Im dritten Parameter ist das Format codiert (0=ANSI, 1=OEM, 2=UTF-8, 3=UTF-7; UTF-8 und UTF-7-BOM werden erkannt und setzten die Codierung automatisch korrekt.)

Beispiel:
PLZ,C,5;ORT,C,30;ORTSTEIL,C,30;STRASSE,C,50;HAUS,C,10;X,N,10,6;Y,N,10,6
16868;Wusterhausen;;Seestraße;55;12,461540;52,907610
17493;Greifswald;Riems;Südufer;10;13,361290;54,182530

[MAPLAYER0]
WORKSPACE=C:\Karten
BASE=0^Adressen.Shp^Standorte FLI
AUTOCREATE=Rechtswert^Hochwert^2
...

Layer-Vorlagen (KEL)

Beim Öffnen von Layern werden die Steuerinformationen der KEP-Datei verwendet, um das Erscheinungsbild des Layers festzulegen. Wird ein Shape-Datei außerhalb eines KEP geöffnet (Laden des "Standardprojektes" beim Georeferenzieren, manuelles Hinzufügen im Karten-Explorer über "Layer - Hinzufügen" oder Aktivierung von Tsn.exe bzw. Ke.exe mit einer Shape-Datei als Aufrufparameter), sucht der Karten-Explorer nach einer so genannten Karten-Explorer-Layer-Vorlage (*.kel), um z.B. Einfärbung, Bezeichnung in der Layer-Kontrolle und Info-Feld festzulegen. Der Aufbau einer KEL-Datei orientiert sich an den entsprechenden Angaben innerhalb einer Sektion für Layer im KEP (siehe Karten-Explorer-Projekt).

1. Vektordaten (Shape-Datei)

[MAPLAYER]
LAYERTYPE=nLayerType
 (1-Shape-Datei)
SYMBOLTYPE=nSymbolTyp
                      (0=Punkt, 1=Linie, 2=Polygon)
LAYERNAME=cNameInLayerKontrolle
RENDERERTYPE=nEinfärbungstyp

(siehe Renderer)
RENDERERFIELD=cEinfärbungsfeld
RENDERER=cEinfärbungsparameter
RENDEREREX=cZusatzParameter
MAPTIPFIELD=cQuickInfoFeld
ADDMAPTIPFIELDS=cWeiteresQuickInfoFeld1^cWeiteresQuickInfoFeld2
SCALELAYER=nAktiv^nAbMaßstab^nBisMaßstab

(Anzeigebereich Layer 1-ein, 0-aus)
SCALELABEL=nAktiv^nAbMaßstab^nBisMaßstab

(Anzeigebereich Beschriftung 1-ein, 0-aus)
SYMBOL=cStandardSymbol
                       (siehe Symbol, verwendet bei RENDERERTYPE=0)

Beispiel Shape-Datei:

[MAPLAYER]
LAYERTYPE=1
SYMBOLTYPE=2
LAYERNAME=Gemeinden
RENDERERTYPE=4
RENDERERFIELD=GEM_NAME
RENDERER=Arial^10^0^0^13697023^1^0^1^0^0^0,000000^0^0^10^^1^1^0^0
RENDEREREX=
MAPTIPFIELD=GEM_NAME
ADDMAPTIPFIELDS=GEM_SCHL^
SCALELAYER=0^1^500000
SCALELABEL=1^1000^100000
SYMBOL=65535^^8,25^2^1^255^2^1^0^0

2. Bild-Dateien (Rasterkarten)

[MAPLAYER]
LAYERTYPE=3
LAYERNAME=cNameInLayerKontrolle
SCALELAYER=nAktiv^nAbMaßstab^nBisMaßstab

(Anzeigebereich Layer 1-ein, 0-aus)

Beispiel:

[MAPLAYER]
LAYERTYPE=3
LAYERNAME=Rasterkarte Testkreis
SCALELAYER=1^1^100000

Raster-Kataloge (Image Catalog)

Raster-Kataloge stellen dBase-Dateien dar, die den Zugriffspfad zu Rasterkarten und deren aktuelle Ausdehnung enthalten. Sie können über den Menüpunkt "Raster - Raster-Katalog" geöffnet, erstellt und bearbeitet werden. Bei geöffnetem Raster-Katalog werden per Funktionstaste F11 genau die Rasterkarten hinterlegt, die den aktuellen Kartenausschnitt ausfüllen. Diese Raster-Kataloge werden auch von ESRITM-Produkten wie ArcView® unterstützt.

Feldname | Typ | Länge | Beschreibung
IMAGE | C | 100 | Datei (*.tif, *.tiff, *.tff, *.sid, *.jpg, *.jpeg, *.bmp, *.bil, *.bip, *.bsq, *.sun, *.ras, *.rlc)
XMIN | N | 19(7) | kleinste X-Koordinate der Kartenausdehnung
YMIN | N | 19(7) | kleinste Y-Koordinate der Kartenausdehnung
XMAX | N | 19(7) | größte X-Koordinate der Kartenausdehnung
YMAX | N | 19(7) | größte Y-Koordinate der Kartenausdehnung


Standardprojekt -Einfärbung

Layer-Optionen festlegen

Bildschirm anzeigen

Mit dieser Programmfunktion werden die Eigenschaften eines Layers festgelegt. Diese werden in einer Layer-Vorlage (*.kel für Karten-Explorer-Layer-Vorlage) gespeichert und beim Laden des Layer aktiviert.

Optionen ändern

Abhängig davon, ob es sich beim Layer um eine Shape-Datei oder Bild-Datei handelt, steht die Änderung folgender Optionen zur Verfügung

Option | Vektorkarten | Rasterkarten
Einfärbung Die Einfärbung eines Layers kann festgelegt werden. | ja | nein
Info-Felder Aus dieser Merkmalsdatei können bis zu 3 Felder ausgewählt werden. Beim Navigieren mit der Maus in diesem Layer werden zum an der Mausposition befindlichen Geo-Objekt diese Informationen als Tooltipp (Quick-Info) angezeigt | ja | nein
Anzeigebereich Für den Layer kann festgelegt werden, ob er nur in einem definierten Maßstabsbereich angezeigt werden soll. | ja | ja
Name in Layer-Kontrolle Der Name des Layers in der Layer-Kontrolle des [image] Karten-Explorers kann festgelegt werden. | ja | ja

Karten-Element

Das Karten-Element wird entsprechend der gewählten Optionen des Layers eingefärbt. Verschiedene Schaltflächen, Mausfunktionen und das Kontextmenüs unterstützen das Navigieren (Vergrößern, Verkleinern, Verschieben) im Karten-Element.

Schaltflächen

Karte einpassen bewirkt die optimale Anpassung der Kartengröße an die Größe des Kartenelements.
Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.

2xVerkleinern reduziert die Größe der Karte zweifach.
Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen.

Kontextmenü

  • vorheriger Kartenausschnitt (F9) bzw. nächster Kartenausschnitt (Strg + F9) bewirkt das "Blättern" innerhalb der Kartenausschnitte, die vor den letzen Zoom- oder Verschiebeaktionen angezeigt wurden.

  • Einpassen bewirkt die optimale Anpassung der Kartengröße (alle Layer) an die Größe des Karten-Elements.

  • 2 x Vergrößern vergrößert die Karte zweifach an der geklickten Mausposition.

  • 2 x Verkleinern verkleinert die Karte zweifach.

  • 1:50.000, 1:25.000, 1:10.000 etc. zentriert die Karte an der Mausposition und zoomt sie auf den gewählten Maßstab; "Maßstab ..." erlaubt die Angabe eines beliebigen Maßstabes.


Karte drucken

Bildschirm anzeigen

Der sichtbare Kartenausschnitt kann mit dieser Programmfunktion auf einen Drucker ausgegeben werden.

Beim Ausdruck von Rasterkarten in hoher Druckqualität ist zu beachten, dass diese Dateien eine enorme Größe besitzen. Die Aufbereitung der Ausgabe kann erhebliche Zeit in Anspruch nehmen. Die konkrete Hardware-Konfiguration (Druckertyp, verfügbarer Druckerspeicher, Übertragungsgeschwindigkeit im Netzwerk usw.) entscheidet i.d.R. über die Praktikabilität. Dies ist ein allgemeines Problem bei GIS-Anwendungen. Siehe auch [image] Hinweise zum Drucken

Standarddrucker

Ist die Option Standarddrucker gewählt, erfolgt die Ausgabe auf den unter Windows als Standard definiertem Druckgerät in maximaler Druckqualität sowie im Querformat.

Drucker auswählen

Ist die Option Drucker auswählen aktiv, ist über [image] der Drucker auszuwählen und einzurichten. Alle verfügbaren Optionen wie Papiergröße, Papierformat (hoch, quer), Papierquelle usw. können entsprechend der Fähigkeiten des gewählten Druckers genutzt werden.

Die Druckqualität kann zwischen hoch, mittel, niedrig und Schnelldruck variiert werden. Diese vier Optionen sind vordefinierte Windows-Optionen und werden ggf. nicht alle mit unterschiedlichen Qualitätsstufen vom jeweils selektierten Drucker unterstützt.


Koordinaten umrechnen

Manuelle Umrechnung von Koordinaten

Koordinaten in einer dBase-Datei umrechnen


Polygon importieren

Bildschirm zeigen

Mit der Importfunktion des Polygon-Editors kann ein Polygon aus einem geladenen Layer, einer Shape-Datei (des Typs Polygon) oder einer Polygon-Datei (*.plg) ausgewählt und importiert werden. Das importierte Polygon kann anschließend mit dem Polygon-Editor geändert und als Polygon-Datei (*.plg) gespeichert werden.

Es ist zunächst mit der Schaltfläche [image] ein geladener Layer, eine Shape-Datei oder Polygon-Datei auszuwählen. Diese Karte wird im Kartenelement angezeigt und kann gezoomt, verschoben und eingepasst werden. Bei aktivem Auswahlmodus (Schaltfläche [image] gedrückt), kann die Auswahl per Mausklick in die Karte erfolgen, worauf das Polygon hervorgehoben dargestellt wird. Wird die Schaltfläche Ok betätigt, wird das selektierte Polygon in den Polygon-Editor importiert. Hinweis: Eine Auswahl per Mausdoppelklick importiert das angeklickte Polygon sofort.

Wird die Schaltfläche [image] aktiviert, können mehrere (angrenzende) Polygone gewählt werden. Diese werden beim Betätigen der Schaltfläche Ok zusammengefasst und in den Polygon-Editor übernommen. Falls mehrere Teilpolygone entstehen, wird das Teilpolygon mit den meisten Punkten verwendet.

Menüfunktionen

Datei
 | Öffnen Shape-Datei lädt eine Shape-Datei (vom Typ Polygon) von der Festplatte/Diskette.
Karte
 | Auswahl Polygon aktiviert den Auswahlmodus. Per Mausklick in die Karte kann jetzt das zu importierende Polygon ausgewählt werden.
 | Mehrfachauswahlmodus aktiviert den Auswahlmodus, bei dem beliebig viele Polygone ausgewählt werden können. Per Mausklick in die Karte können Polygone aus- und abgewählt werden.
 | Einfärbung aktiviert den Dialog zum Einfärben der Geo-Objekte. Es könnte z.B. sehr hilfreich sein, die Geo-Objekte im Auswahlfenster mit einer Beschriftung zu versehen. Eigenschaften für Einfärbung
Info-Felder | Info-Feld (Strg + I) aktiviert bis zu drei beliebige Felder eines Layer dergestalt, dass für das an der Mausposition befindliche Geo-Objekt die gewählte Information als Tooltipp (Quick-Info) angezeigt wird. Info-Felder auswählen
 | Karte einpassen bewirkt die optimale Anpassung der Kartengröße an die Größe des Kartenelements.
 | Vergrößern ermöglicht es, einen Kartenausschnitt beliebig zu "zoomen". Mit gedrückter linker Maustaste wird ein Rechteck über den zu vergrößernden Kartenbereich gezogen.
 | Verkleinern reduziert die Größe der Karte.
 | Verschieben ermöglicht es, bei gedrückter linker Maustaste den Kartenausschnitt beliebig zu bewegen.
 | Identifizieren zeigt alle in der Merkmalsdatei vorhandenen Informationen zum mit der linken Maustaste angeklickten Geo-Objekt an.
 | Suchen (Strg + S) startet einen Dialog, mit dem Geo-Objekte in den Merkmalsdateien der Layer gesucht und auf der Karte gezeigt werden. Damit ist z.B. die gezielte Suche nach Betrieben möglich. Geo-Objekte suchen


neues Polygon zeichnen

Regel für das Erstellen von Polygonen

  1. Richtig: Bitte erstellen Sie die Punkte des Polygons im Uhrzeigersinn!
    Hintergrund: TSN verwendet Polygone häufig in Shape-Dateien. In Shape-Dateien sind äußere Ringe immer im Uhrzeigersinn digitalisiert. Innere Ringe (z.B. Enklaven in Gemeinden sind entgegen der Uhrzeigerrichtung digitalisiert. Bei Flächenberechnungen von Polygonen werden mit diesem Mechanismus die Enklaven korrekt abgezogen...

  2. Falsch: Vermeiden Sie Überlappungen!
    Hintergrund: Einige geometrische Operationen (Zusammenfügen von Polygonen (Union)) funktionieren mit sich kreuzenden Linien nicht!

  3. Richtig: Setzen Sie den letzen Punkt des Polygons nie auf den ersten!
    Häufig wird versucht, das Polygon zu schließen, dass heißt den ersten Punkt zu treffen. Das ist nicht notwendig. Der letzte Punkt wird automatisch durch eine Linie mit dem ersten Punkt verbunden, wenn der Zeichnenmodus beendet wird (Schaltfläche <OK> oder Mausdoppelklick für den letzten Punkt).
    Hintergrund: Wird versucht, den ersten Punkt zu treffen, unterlaufen häufig die unter 2. beschriebenen Überlappungen!

... noch ein Tipp: Die Karte kann auch bei aktivem Zeichnenmodus mit Strg + gedrückt gehaltener linker Maustaste verschoben werden!


Tabellenfilter(Bilder)

Zeichenkettenfelder

numerische Felder

Datumsfelder


Info über Karten-Explorer

Karten-Explorer

© 2003-2022 FLI, Alle Rechte vorbehalten

Der Karten-Explorer wurde am Institut für Epidemiologie des Friedrich-Loeffler-Instituts entwickelt.

Anschrift | Friedrich-Loeffler-Institut, Südufer 10, 17493 Greifswald - Insel Riems
Telefon | +49 (0)38351 7-1500 (TSN, Karten-Explorer)
 | +49 (0)38351 7-0 (Zentrale)
Fax | +49 (0)38351 7-1151
E-Mail | kartenexplorer@fli.bund.de


Anzeigebereich

Bildschirm zeigen

Der Anzeigebereich eines Layer legt fest, in welchem Maßstabsbereich ein Layer eingeblendet werden soll. Ist das Kontrollkästchen "Anzeigebereich für Layer verwenden" aktiviert, wird der Layer entsprechend automatisch ein- und ausgeblendet, wenn die Karte vergrößert bzw. verkleinert wird.
Dieser Status wird durch ein Symbol für den Layer in der Layer-Kontrolle deutlich:

= eingeblendet
= ausgeblendet

Mit dieser Funktionalität können z.B. Detailinformationen wie Straßen nur bei starker Vergrößerung (kleinem Maßstab) angezeigt werden. Sind Rasterkarten verschiedener Auflösung vorhanden (z.B. 1:500.000, 1:50.000 und 1:5.000), so kann man abhängig vom aktuellen Maßstab mit Karten verschiedener Detailliertheit arbeiten, d.h., beim Vergrößern der Karte die groben Rasterkarten aus- und die detaillierten Rasterkarten automatisch einblenden lassen und umgekehrt.

Beachten Sie bitte beim Karten-Explorer, dass Rasterkarten den Anzeigebereich nur verwenden, wenn die [image] Rasterkartenskalierung nicht aktiviert ist.


Ausdruck - Karten-Explorer

Druckausgabe mit Karten-Explorer


Erstellen aus Zwischenablage - Adressen und Koordinaten

Adressen und Koordinaten in Zwischenablage

Eine Reihe von Programmfunktionen analysieren beim Einfügen aus der Zwischenablage den Text auf das eventuelle Vorhandensein von Adressen und Koordinaten und verarbeiten erkannte Inhalte automatisch. Dabei werden benamte Spalten eindeutig erkannt und unbenamte Spalten nach den festgelegten Konventionen behandelt.

Programmfunktionen

Programmfunktion | Bemerkung
Erstellen aus Zwischenablage im Karten-Explorer | Beim Erstellen eines Layer aus der Zwischenablage werden alle Zeilen einer Tabellen mit Koordinaten und Adressen automatisch erkannt und verarbeitet.
Geokodierung | Bei der Geokodierung wird die erste Zeile eine Tabelle mit Adressen verarbeitet.
Umgebungssuche | Bei der Umgebungssuche wird die erste Zeile einer Tabelle mit Koordinaten verarbeitet.
Routenberechnung | Bei der Routenberechnung werden die ersten (max.) 50 Zeilen einer Tabelle mit Koordinaten und/oder Adressen verarbeitet.
Koordinaten umrechnen | Bei Umrechnen von Koordinaten wird die erste Zeile einer Tabelle mit Koordinaten verarbeitet.

Konventionen

Tabellen mit Adressen (Spaltennamen)

  • Folgende Spaltenüberschriften werden erkannt:

    • PLZ: PLZ, S_PLZ, A_PLZ, B_PLZ

    • Ort: ORT, S_ORT, A_ORT, B_ORT

    • Ortsteil: ORTSTEIL, S_ORTSTEIL, A_ORTSTEIL, B_ORTSTEIL

    • Straße: STRASSE, S_STRASSE, A_STRASSE, B_STRASSE

    • Hausnummer: HAUS, HAUSNUMMER, NUMMER, NR, HNR, S_HNR, A_HNR, B_HNR

Beispiel:

PLZ | ORT | ORTSTEIL | STRASSE | HAUS
17489 | Greifswald | Innenstadt | Karl-Marx-Platz | 9
16868 | Wusterhausen |  | Seestraße | 55
17493 | Greifswald | Riems | Südufer | 10

Tabellen mit Koordinaten (Spaltennamen)

  • Folgende Spaltenüberschriften werden erkannt:

    • X: X, X_WERT, X_ERZEUGT, RECHTSWERT, LONG, LONGITUDE

    • Y: Y, Y_WERT, Y_ERZEUGT, HOCHWERT, LAT, LATITUDE

  • Koordinaten können geografisch (dezimal oder in Grad, Minute und Sekunde) oder als Rechts- und Hochwert (projizierte Koordinatensysteme wie UTM, Gauß-Krüger etc.) angegeben werden

Beispiel geografische Koordinaten:

X | Y
13,368130 | 54,095560
12,461540 | 52,907610
13,361290 | 54,182530

Beispiel projizierte Koordinaten:

RECHTSWERT | HOCHWERT
32785586,343850 | 6002978,903528
32732762,273149 | 5867604,475739
32784541,859926 | 6012619,010458

Beispiel Notation in Grad, Minute Sekunde:

LAT | LONG
54°05'43.8"N | 13°22'05.2"E
52°54'27.6"N | 12°27'41.6"E
54°10'57.9"N | 13°21'37.1"E

  • Folgende Notationen sind bei Grad, Minute und Sekunde möglich:

    • 54°05'43.8"N

    • N54°05'43.8"

    • +54°05'43.8" bzw. 54°05'43.8

Tabellen mit Adressen und Koordinaten (Spaltennamen)

PLZ | ORT | ORTSTEIL | STRASSE | HAUS | X | Y
17489 | Greifswald | Innenstadt | Karl-Marx-Platz | 9 | 13,368130 | 54,095560
16868 | Wusterhausen |  | Seestraße | 55 | 12,461540 | 52,907610
17493 | Greifswald | Riems | Südufer | 10 | 13,361290 | 54,182530

Tabellen ohne Spaltennamen

5 Spalten werden als PLZ, Ort, Ortsteil, Straße und Hausnummer verarbeitet

17489 | Greifswald | Innenstadt | Karl-Marx-Platz | 9
16868 | Wusterhausen |  | Seestraße | 55
17493 | Greifswald | Riems | Südufer | 10

4 Spalten werden als PLZ, Ort, Straße und Hausnummer verarbeitet

17489 | Greifswald | Karl-Marx-Platz | 9
16868 | Wusterhausen | Seestraße | 55
17493 | Greifswald | Südufer | 10

2 Spalten mit numerischen Werten werden als Koordinaten (X, Y) verarbeitet

13,368130 | 54,095560
12,461540 | 52,907610
13,361290 | 54,182530

Prinzipiell werden geografische Koordinaten in der Reihenfolge X (Länge), Y (Breite) erwartet. Für Koordinaten innerhalb Deutschlands wird eine umgekehrte Reihenfolge automatisch korrekt erkannt.

54,095560 | 13,368130
52,907610 | 12,461540
54,182530 | 13,361290

Projizierte Koordinaten (UTM, GK) müssen immer in der Reihenfolge X (Rechtswert), Y (Hochwert) angegeben sein.

32785586,34 | 6002978,90
32732762,27 | 5867604,47
32784541,85 | 6012619,01

Koordinaten mit Grad, Minute und Sekunde werden i.d.R. in der Reihenfolge Y (Latitude), Y (Longitude) angegeben.

54°05'43.8"N | 13°22'05.2"E
52°54'27.6"N | 12°27'41.6"E
54°10'57.9"N | 13°21'37.1"E

Eine abweichende Reihenfolge wird automatisch erkannt, wenn N, S, E, W Bestandteil der Angabe ist.

13°22'05.2"E | 54°05'43.8"N
12°27'41.6"E | 52°54'27.6"N
13°21'37.1"E | 54°10'57.9"N


Karten-Explorer - Favoriten verwalten

Favoriten verwalten

Um ein einfaches Positionieren auf Kartenausschnitte zu ermöglichen, können die Koordinaten des momentan sichtbaren Kartenausschnittes unter einem Namen gespeichert werden (Menüpunkt "zu Favoriten hinzufügen" oder Funktionstaste F7) und später über ein Auswahlmenü aktiviert werden (Menüpunkt "Favoriten anzeigen" oder Funktionstaste F8).

Im Fenster "Favoriten verwalten" können Favoriten gelöscht oder umbenannt werden. Zum Löschen ist der gewünschte Eintrag zu markieren und mit der Taste Entf. zu löschen. Zum Umbenennen ist der gewählte Eintrag (Spalte Name) einmal mit der Maus anzuklicken.

Alle Änderungen werden nur übernommen, wenn das Fenster mit Ok verlassen wird.


Flächenanalyse (Bild)

Ergebnis der Berechnung


Georeferenzieren-Editor (Bild) - Karten-Explorer

Modus Liste

Modus Tabelle


Karten-Explorer - Geo-Objekte identifizieren

ein Geo-Objekt an Position identifiziert

mehrere Geo-Objekte an Position

Geo-Objekte in mehreren Layern gleichzeitig identifizieren


Projektion verwalten (Bild) - Karten-Explorer

Beispiel 1.)Projektion von Projekt und Layer stimmen überein, einem Layer ist keine Projektion zugewiesen!

Beispiel 2.) Projektion von Projekt und Layern sind unterschiedlich, Umrechnung ist bei einem Layer nicht möglich!


Raster-Katalog öffnen - Karten-Explorer

Raster-Kataloge öffnen

Bildschirm anzeigen

In einer Liste werden die momentan geladenen Raster-Kataloge angezeigt. Es können beliebig viele Raster-Kataloge mit der Schaltfläche [image] oder durch Betätigen der Taste "Einfg" hinzugefügt werden. Zum Entfernen von Raster-Katalogen aus der Liste kann die Schaltfläche Raster-Katalog entfernen (Entf) oder die Taste "Entf" verwendet werden.

Mit der Schaltfläche [image] oder per Doppelklick können weitere Parametern (Anzeigebereich, alternativer Suchpfad für Rasterkarten) angegeben werden. So können optional individuelle Maßstabsbereiche zugeordnet werden, was insbesondere bei der Verwendung von Kartenwerken unterschiedlicher Auflösung von Vorteil ist, da abhängig vom "Zoombereich" weniger oder mehr detaillierte Karten geladen werden können.
Falls ein alternativer Suchpfad angegeben wird, werden Rasterkarten zusätzlich in diesem Pfad gesucht. Damit werden Rasterkarten auch dann vom System gefunden, wenn im Raster-Katalog ein anderer Zugriffspfad oder lediglich der Dateiname der Rasterkarte angegeben wurde.

Über die Schaltfläche "Bearbeiten" kann der in der Liste markierte Raster-Katalog modifiziert oder ein neuer Raster-Katalog erstellt werden.

Modus bei Verwendung von Anzeigebereichen

Wenn Raster-Katalogen Anzeigebereiche zugeordnet sind, wird über die Optionen statisch und dynamisch festgelegt, wie Rasterkarten geladen werden.
statisch:
Raster-Kataloge, für die ein Anzeigebereich angegeben wurde, werden nur dann verarbeitet, wenn der aktuelle Maßstab der Karten in diesem Anzeigebereich liegt. Rasterkarten, die im aktuellen Kartenausschnitt liegen, werden geladen und permanent sichtbar geschaltet.
dynamisch:
Raster-Kataloge, für die ein Anzeigebereich angegeben wurde, werden in jedem Fall verarbeitet. Die Rasterkarten werden geladen, wenn sie im aktuellen Kartenausschnitt liegen. Sie werden beim Vergrößern/Verkleinern dynamisch sichtbar geschaltet, wenn der Maßstab in ihrem Anzeigebereich liegt.


Rasterkarten hinterlegen DTK25 (Bild)

Rasterkarten gefunden

Rasterkarten nicht gefunden (Downloadoption)


Karten-Explorer - Einfärben (einfaches Symbol)

Dialogfenster für Punkt-Symbole

Dialogfenster für Flächen-Symbole (Polygone)


Symbol einfärben - Karten-Explorer

Symbol einfärben

Bildschirm zeigen

Legen Sie die Eigenschaften des ausgewählten Symbols fest! Abhängig davon, ob Polygone, Punkte oder Linien eingefärbt werden, sind verschiedene Optionen verfügbar.

Flächen-Symbol

  • Farbe (des Füllmusters)
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Farbe der Umrisslinie

  • Umrisslinie anzeigen?

  • Stärke der Umrisslinie

  • Füllstil (vollständig gefüllt, transparent, schraffiert usw.)
    Bei der Verwendung von Rasterkarten ist i.d.R. die Option "transparent" zu wählen.

Punkt-Symbol

  • Farbe
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Farbe der Umrisslinie

  • Umrisslinie anzeigen?

  • Symbolgröße

  • Markierung (Kreis, Quadrat, Dreieck, Kreuz, True-Type-Marker)

Wurde bei Markierung die Option "True-Type-Marker" gewählt, können beliebige Zeichen einer zu wählenden Schriftart als Markierung verwendet werden. Schriftart und Zeichen sind über die Schaltflächen [image] bzw. auszuwählen. Zusätzlich kann das Zeichen in einem beliebigen Winkel gedreht werden.

Linien-Symbol

  • Farbe
    Ändern der Farbe per Mausklick in die farbige Fläche!

  • Linienstärke

  • Linienart (Durchgehend, Gestrichelt, Gepunktet, Strich-Punkt)


Karten-Explorer - Geo-Objekte suchen (Bild)

Standardmodus

SQL-Modus


Karten-Explorer - Geo-Objekte suchen (Beispiel)

Beispiel Suchmodus

  • Folgende Geo-Objekte:
    1. Meier, Sepp
    2. Jochen Meier GmbH
    3. Meier
  • eingegebener Suchtext: Meier
  • Treffer bei Suchmodus
Suchmodus | Treffer
beliebige Feldposition | 1, 2, 3
gesamtes Feld (Genau gleich) | 3
Feldanfang | 1, 2


Karten-Explorer - Überblick

Funktionalitäten Karten-Explorer

Der Karten-Explorer verfügt über folgende Funktionalitäten:

  • Anzeige und Abfrage von ESRI® Shape-Dateien
  • automatisches Erstellen von Shape-Dateien
    • aus CSV-Dateien und Zwischenablage
    • aus KML- und GPX-Dateien
  • Anzeige verschiedener Bilddatei-Formaten (Tiff, Jpeg, Bmp, MrSID usw.)
  • flexibles Einfärben (Klassifizierungen, Symbole, Beschriftungen)
  • Geo-Objekte suchen und identifizieren
  • Geokodierung, Umgebungssuche und Routenberechnung über Web-Services des BKG
  • Drucken und Exportieren von Karten
    • Exportieren in Zwischenablage oder Datei
    • Exportieren in KML (FLI-Maps, Google Earth) und GPX (GPS-Geräte)
  • Layer-Kontrolle (Kontrolle über Reihenfolge, Sichtbarkeit, Einfärbung von Layern)
  • Maßstab, Legende und Übersichtskarte
  • Verwaltung von Projekten - alle Einstellungen können gespeichert und wieder hergestellt werden
  • Selektieren von Geo-Objekten (Mausklick, SQL-Abfrage, räumliche Selektion)
  • Bearbeiten, Berechnen und Exportieren von Attributen
  • Transformieren von Koordinaten, Projizieren von Shape-Dateien
  • Entfernungsmessungen
  • "Zeichnenfunktion"
  • geometrische Funktionen (z.B. Puffer)
  • Verknüpfen von Layern und Daten (dBase, Zwischenablage) über räumliche Beziehungen oder Schlüsselfelder etc.


Verknüpfen mit Zwischenablage

Verknüpfen mit Daten aus der Zwischenablage / Text-Dateien

Bildschirm zeigen

Mit dem Menüpunkten "Extras - Verknüpfen - Join über Schlüsselfeld", "Extras - Verknüpfen - Koordinaten generieren (Punkt)" und "Extras - Verknüpfen - Koordinaten generieren (Multipoint)" des Karten-Explorers ist es möglich, Daten aus der Zwischenablage bzw. aus Textdateien einzufügen und mit einem Layer über ein gemeinsames Schlüsselfeld zu verknüpfen.

Aufbau Dialogfenster

Das Dialogfenster enthält zwei Tabellen:

  • eine Voransicht der ersten Zeilen der in der Zwischenablage bzw. Text-Datei befindlichen Datentabelle und

  • eine Tabelle mit der Struktur, d.h., dem Aufbau der Datentabelle mit Spaltennamen, Typ und Länge der Spalten sowie ein Kennzeichen, ob es sich um eine Spalte mit Koordinaten handelt.

Daten aus der Zwischenablage bzw. Text-Datei einfügen

Die Daten in der Zwischenablage bzw. der Text-Datei müssen tabellenartig aufgebaut sein, die Spalten sind dabei durch ein spezielles Trennzeichen getrennt, das Zeilenende wird durch Zeilenvorschub (CR LF) begrenzt. Als Trennzeichen wird in der 1. Zeile der Zwischenablage (in dieser Reihenfolge) nach Tabulator, Semikolon, | oder Komma gesucht. Das erste erkannte Zeichen wird als Trennzeichen verwendet. Wird eine Excel-Tabelle in die Zwischenablage kopiert, wird automatisch der Tabulator verwendet.

Beispielhaft könnte eine Tabelle wie in der folgenden Abbildung erstellt werden. Dabei enthält die erste Zeile Spaltennamen. Welche Konventionen hier gelten, wird im Abschnitt "Struktur" beschrieben.

GEM_SCHL;GEM_NAME;STRECKE
99991001;Achim;10
99991002;Blender;30
99991003;Dörverden;20
99991004;Emtinghausen;25

Beim Öffnen des Dialogfensters wird der aktuell in der Zwischenablage befindliche Text bzw. der ausgewählten Text-Datei analysiert und die ersten Zeilen und die ermittelte Struktur angezeigt. Mit der Schaltfläche "Daten erneut einlesen" kann der Inhalt der Zwischenablage bzw. einer Textdatei jederzeit erneut eingelesen werden.

Codierung

Es ist möglich, Zeichen mit einer Codierung entsprechend dem Standard von ANSI (Vorgabe bei Zwischenablage), OEM (Vorgabe bei Text-Datei) und UTF einzulesen, um Umlaute korrekt darzustellen. Kontrollieren Sie die in der Voransicht dargestellten Daten und modifizieren Sie ggf. die Einstellung für die Codierung manuell, bis Umlaute und Sonderzeichen korrekt dargestellt werden. Wird ein so genannter BOM (Byte Order Marker) erkannt, wird die Codierung auf UTF gestellt und kann nicht mehr geändert werden.

Struktur

Bei Einlesen der Daten wird der Inhalt nach einem bestimmten Schema analysiert, um den Aufbau der Tabelle zu ermitteln. Diese Angaben zur Struktur werden zum Erzeugen einer dBase- bzw. Attributdatei benötigt.

Zunächst wird versucht zu ermitteln, ob die erste Zeile (Kopfzeile) Spaltennamen oder eine Spaltendefinition (Spaltenname, -typ und -länge) enthält. Wenn die erste Spalte der ersten Zeile keinen gültigen Spaltenname enthält, geht das System davon aus, dass die Tabelle keine Spaltennamen besitzt und nur aus Daten besteht. Die Spalten werden dann mit SPALTE1, SPALTE2 usw. bezeichnet und entsprechend des Inhaltes der ersten Zeile mit dem Typ "Zeichen", "Numerisch" oder "Datum" vorbelegt. Name, Typ und Länge der Spalte kann in der Tabelle des Dialogfensters individuell angepasst werden.

Falls eine Zeile mit Spaltennamen an einer anderen Position als in der ersten Zeile vorhanden ist, ist diese Zeile zu markieren (auszuwählen) und die Struktur mit der Schaltfläche "Struktur erneut ermitteln" zu berechnen. Dabei muss das Kontrollkästchen "markierte Zeile enthält Spaltennamen" aktiviert sein.

Falls das System die erste Zeile fälschlicherweise als Zeile mit Spaltennamen interpretiert hat, ist das Kontrollkästchen "markierte Zeile enthält Spaltennamen" zu deaktivieren und die Struktur erneut zu berechnen.

Was sind gültige Spaltennamen?

Spaltennamen dürfen bis zu 10 Zeichen lang sein und bestehen aus Buchstaben (ohne Umlaute), Ziffern oder einem Unterstrich. Das erste Zeichen muss ein Buchstabe sein.

Spaltendefinition

Eine Spaltendefinition erlaubt es, neben Spaltennamen auch Typ, Länge und ggf. Anzahl der Nachkommastellen (bei numerischen Felder) anzugeben. Dazu sind in der Kopfzeile für jede gewünschte Spalte einfach Name, Typ, Länge und Nachkommastellen mit Komma getrennt anzugeben.

GEM_SCHL,C,8;GEM_NAME,C,40;STRECKE,N,19,3
99991001;Achim;10
99991002;Blender;30
99991003;Dörverden;20
99991004;Emtinghausen;25

Es sind mindestens Spaltenname und Typ (C, N, D, L) anzugeben. Längenangaben bei Spalten mit Datums- oder logischen Werten sind nicht notwendig. Wird beim Typ Zeichen keine Länge angegeben, wird die Länge 50 Zeichen verwendet. Bei numerischen Spalten würde beim Fehlen der Angaben die Länge 18 mit 6 Nachkommastellen verwendet werden.

Typ | Code | Länge | Nachkommastellen | Bemerkung | Beispiel
Zeichen | C | 1 bis 256 | 0 | Standard ist Länge 50 | NAME,C,20
Numerisch | N | 1 bis18 | 0 bis Länge-1 | Standard ist Länge 18 mit 6 Nachkommastellen | PRAEVALENZ,N,10,6
Datum | D | 8 | 0 |  | GEBURT,D
Logisch | L | 1 | 0 | Folgende Zellinhalte werde als 'wahr' behandelt: 1, Y, J, T, .T., true, wahr, yes, ja | UNTERSUCHT,L

Zu importierende Spalten auswählen

Per Voreinstellung werden alle erkannten Spalten zum Erstellen verarbeitet. Über die Kontrollkästchen der Auswahlspalte [image] können die Spalten per Mausklick aus- oder abgewählt werden, alternativ können die Schaltflächen [image] (alle auswählen), [image] (alle abwählen) und [image] (Auswahl umkehren) verwendet werden.